Sending email with Amazon SES and Kentico email queue issue

Chien VH asked on August 30, 2015 10:45

Hi folks,

I have an issue when using Amazon SES service to send the email. I'm appreciated to get any help/suggestion from anybody. After calling the function to send the email I was wait a long time but still not get any email from our system. I'm believed that the email still waiting in Kentico's email queue until I refreshed the email queue. You know, after the queue is refreshed, the email send to SMTP server and I got it immediately. I've also tried to reset the "Send queued e-mails" task in "Scheduled tasks" module to make sure the email queue will be working. However, unfortunately I still unable to get any email from our system until the email queue is refreshed. So, could you guys please let me know what happens with our system? How can I do to solve that issue?


Correct Answer

Chien VH answered on September 11, 2015 12:40

I spent a whole day to investigate the issue and here is my update: At this time the Amazon SES does not worked smoothly with Kentico. So instead of using the current solution by using kentico email queue to handle the emails before sending them to Amazon SMTP server. I have changed the solution to send the email directly to Amazon SMTP, after that it works perfectly. The time to deliver the email to recipients very fast :).

0 votesVote for this answer Unmark Correct answer

Recent Answers

Brian McKeiver answered on August 30, 2015 16:30


That's crazy we had the same issue with 2 clients this week. I think Amazon and Kentico aren't playing nice somehow. The two things we have come up with at BizStream are 1) Contact Amazon and ask them to remove the throttle and 2) Try adding multiple SMTP servers (clones with the same SES info) into the Kentico SMTP server bank (EMS license required). We are hoping that by having multiple connections round robin through to SES helps.

We are still testing to find out the results if either or both tactics above help.

Post back here if you have other ideas or if one of these tactics work for you.

1 votesVote for this answer Mark as a Correct answer

Chien VH answered on August 30, 2015 16:41

Thanks Brian for your quick response. I will try to follow your instruction to solve that issue. I will update you the result.

0 votesVote for this answer Mark as a Correct answer

Matthew Lee answered on May 19, 2016 14:41

Unfortunately, I still found the same issue on Kentico 8.

I finally did not enable email queue and it worked fine.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.