Resource IDs showing instead of string values when deployed to Azure

Tim Norris asked on February 20, 2017 10:36


I deployed a Kentico 10 web application to Azure, using a free license. When I browse to any page that uses localised resources, instead of displayed the resource value, the ID of the resource is displayed instead. Even in the Admin portal.

e.g. On the admin portal login screen, the password field's label is 'LogonForm.Password'.

When I run the web app locally against the same Azure database, all is ok. So it must be a file issue somewhere.

Any ideas would be greatly appreciated!

Thanks, Tim

Correct Answer

Tim Norris answered on February 20, 2017 15:11

I got it sorted.

The Build Action of the .resx files were set to Embedded Content. I changed to Content and it worked fine.

0 votesVote for this answer Unmark Correct answer

Recent Answers

Jan Hermann answered on February 20, 2017 12:58

Those are resource strings from /CMS/CMSResources/CMS.resx file. Please make sure the file is there and restart the application.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.