Permission to link an existing page

Evine Beursken asked on February 20, 2017 09:54

I have made an Editor user with an Editor role. However, when I impersonate this user he is able to add pages and so on, but when I try to link an existing page I get an access denied (both on live-site editing as in the administration interface). Message that is showed: Your UI profile is not granted with permission to access this section. Please contact the administrator.

However, I can not find which permission I missed.

Current settings:

  • Permissions for Module Content: all selected, Permission for Module Design: only 'Design website'.
  • UI Personalization, Administration:

    • CMS/Administration/Content Management: all selected
    • CMS/On-site editing: all selected
    • CMS/Media dialog: only media libraries tab
  • UI Personalization, Editor:

    • all options that were possible are selected

Any idea what I missed here?

Furthermore, I use Kentico 9, have not updated anything, I did a resign signatures but that did not help.

Any ideas?

Correct Answer

Mariia Hrytsai answered on February 20, 2017 10:31

You should also check CMS/Media dialog/ Content tab.

3 votesVote for this answer Unmark Correct answer

Recent Answers


Evine Beursken answered on February 20, 2017 11:00

Can you explain what this exactly is and why this is preventing 'Link existing pages'?

0 votesVote for this answer Mark as a Correct answer

Mariia Hrytsai answered on February 21, 2017 10:31

When creating linked document the dialog with content tree appears to select document that should be linked. So the Content tab under CMS/Media dialog is the UI element that is displayed in the dialog when the document is linking (this Content tab is not only related to some Media selection controls that display dialog to select some media). So Content tab should be selected in UI Personalization module so the editor can see tab with Content tree.

2 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.