Object Selector Error - Cannot Use Custom Document Types

Al LeMay asked on August 14, 2014 19:54

I have a custom table in which one of the fields uses the Object Selector form control. I am able to use the Object Type of "cms.class" and Return Column Name of "ClassName". I replace these items with "CMS.MenuItem" and "DocumentName". When I attempt to enter new data I get an error: Object type "cms.menuitem" not found. I have tried entering macro scripting "{% GlobalObjects.DocumentTypes["CMS.MenuItem"].TypeInfo.ObjectType %}, but still no success. What is worse, is if i attempt to change the macro to something different it fails to save stating I need to enter a value. (I have to type in plain text, save it, then reenter the new macro text; that is a bug in my mind.)

I attempted to find any information on how the Object Selector should be configured, and no success there. Given the attempt to improve the documentation for v8, as a developer I still cannot see why references to these basic items in the UI cannot be found easily with good information. So, please send along some links, pictures, text (anything really) that shows how when creating a custom table how these form controls can be used.


Recent Answers

Joshua Adams answered on August 14, 2014 22:42

What exactly do you want to retrieve? Specific documents of the type menuitem, children of a document, etc? If you want to select actual documents, you could use the uniselector instead... here is an example of the settings for a uniselector


Is this what you are looking for?

1 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.