Not able to select translation service that is enabled

Alistair DeJonge asked on February 23, 2018 17:00

On our Dev site, we want to connect to a sandbox server to test translation workflow. We have Translations enabled under Setting -> Content -> Translation Services. We have the correct info in the Project Director URL, Client user name, Client user password, and Project short code fields. We have the service configured and enabled under Translation Services, but when I enable it I get the message:

This service is not available on current site, please check service settings in Settings -> Content -> Translation services.

When I go to translate a page, the only choice I have is Manual Translation, my other enabled service are not available as options.

On our Beta server, the same configuration is present, except that it points to a production server. Is it something to do with the Settings being incorrect?

Recent Answers

Matt Nield answered on February 24, 2018 09:50

Hi Alistair,

Have a look in the event log application in Kentico. You may see some exceptions logged against the translation service. When you try to configure it for your site, Kentico will try to validate the service. If something goes wrong in that check, then an exception is thrown into the event log and the warning you are seeing is shown.

As an example, i just put nonsenese values in the settings (as i don't have an account) and I se the same warning:

This service is not available on current site, please check service settings in Settings -> Content -> Translation services.

If I look in the event log however, I see this:

The translation service returned the following error: Message: Url '' incorrect or unsupported PD version (needs to be 4.18.0 or higher).

So it looks like - as you noted - the account settings you have need to be absolutely correct in order for the service to ba available. I don't know particularly well, but it's worth checking things like IP whitelisting etc. too to make sure that traffic from your webserver is allowed.

0 votesVote for this answer Mark as a Correct answer

Alistair DeJonge answered on March 6, 2018 15:14

I have contacted the service and they ensure me that the configuration settings are correct. When I look at the Event Log, the description I get is:

The translation service returned the following error:
Message: The content type text/html; charset=UTF-8 of the response message does not match the content type of the binding (multipart/related; type="application/xop+xml"). If using a custom encoder, be sure that the IsContentTypeSupported method is implemented properly. The first 727 bytes of the response were: '<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "">GlobalLink

Exception type: System.ServiceModel.ProtocolException
Stack Trace: 

Server stack trace: 
at System.ServiceModel.Channels.HttpChannelUtilities.ValidateRequestReplyResponse(HttpWebRequest request, HttpWebResponse response, HttpChannelFactory`1 factory, WebException responseException, ChannelBinding channelBinding)
at System.ServiceModel.Channels.HttpChannelFactory`1.HttpRequestChannel.HttpChannelRequest.WaitForReply(TimeSpan timeout)
at System.ServiceModel.Channels.RequestChannel.Request(Message message, TimeSpan timeout)
at System.ServiceModel.Dispatcher.RequestChannelBinder.Request(Message message, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]: 
at GlobalLink.ProjectDirector.WebServices.GLPDWSClient.FindProjectByShortcode(String projectShortCode)
at CMS.TranslationServices.TranslationsComService.get_Project()
at CMS.TranslationServices.TranslationsComService.CheckConnection()

Message: The remote server returned an error: (500) Internal Server Error.

Exception type: System.Net.WebException
Stack Trace: 
at System.Net.HttpWebRequest.GetResponse()
at System.ServiceModel.Channels.HttpChannelFactory`1.HttpRequestChannel.HttpChannelRequest.WaitForReply(TimeSpan timeout)
0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.