New Kentico 10 instance on non-OS volume experiencing "Could not load file or assembly... Access is

Stephen Price asked on March 24, 2017 20:59

We're trying to spin up a fresh instance of Kentico 10 on our new dev server. We are trying to serve our site off of a non-OS drive on the server, in this case, E:. The Kentico instance lives at E:\inetpub\wwwroot\dev

When we try to hit our url, we see this error:

Could not load file or assembly 'Microsoft.CodeDom.Providers.DotNetCompilerPlatform, Version=1.0.2.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. Access is denied.

We've been wracking our brains and google and can't find a coherent answer. We tried installing another Kentico 10 instance on the same server's C:\inetpub\wwwroot directory and everthing worked fine. Moving that instance over to E:\inetpub\wwwroot caused it to stop working as well.

Any ideas?

Correct Answer

Stephen Price answered on March 31, 2017 22:35

So, it turns out we just had to uninstall and reinstall IIS. As far as my team can figure, because the second volume wasn't present when IIS was installed, it didn't register something about it. After that, it was fine.

For posterity, this was on Windows Server 2012, but we have also experienced this on Win 7 as well and were totally stymied in the past.

0 votesVote for this answer Unmark Correct answer

Recent Answers


Zachary Perry answered on March 24, 2017 21:40

Does the account the App Pool is running under have access to the drive?

1 votesVote for this answer Mark as a Correct answer

vasu yerramsetti answered on March 25, 2017 08:00

I am not sure, How did you created inetpub\wwwroot (i.e E:\inetpub\wwwroot\dev) folder in no-OS driver in server. What is the Version of OS and IIS?

Please go through the below, may be it helpful.

https://blogs.iis.net/thomad/moving-the-iis7-inetpub-directory-to-a-different-drive

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.