Multilingual urls language switcher

Dennis Hulsmans asked on October 28, 2016 14:56


I noticed something rather strange with the language switcher. I followed the documentation on . Now when I switch to another language, the url only changes de culture but not the pagename.

For example: I'm on a page, the url is Now when I switch the url becomes The pagename remains in the default culture. I want the pagename to change to "mypagenameinenglish" >>

I've noticed an older Kentico website, which handles this perfectly: >>

Is there a config setting I'm missing? Otherwise the SEO won't be optimal.

KR, D.

Recent Answers

Anton Grekhovodov answered on October 28, 2016 22:00

Hi Dennis,

It's a default behaviour. If you want to change URL for specific culture you should use 'custom URL Path' and populate 'Path or pattern' field: Image Text

If you have a lot of pages with different URL, you can try to create Event Handler and update this field automatically.

3 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.