Kentico 13 - The remote certificate is invalid error when creating new page

Al Burns asked on December 9, 2020 11:12

Hi. I have created a brand new site using Kentico Xperience v13 with the site as .NET Core 5.0. I have created separate sites in IIS for the CMS admin portal and the website, both have HTTPS bindings with self-signed certificates that are in the trusted certificates store on my local development machine. However, when I try to create the very first page (the homepage), I get the following error message in the admin portal:

"An error occurred while attempting to retrieve page templates. Contact your system administrator and check that the page builder feature is registered correctly in the MVC project"

And this error is logged to the event log:

Message: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.

Exception type: System.Net.WebException
Stack trace:
at System.Net.HttpWebRequest.GetResponse()
at CMS.Scheduler.SchedulingHelper.RunSchedulerRequest(String url)

Message: The remote certificate is invalid according to the validation procedure.

Exception type: System.Security.Authentication.AuthenticationException
Stack trace:
at System.Net.Security.SslState.StartSendAuthResetSignal(ProtocolToken message, AsyncProtocolRequest asyncRequest, Exception exception)
at System.Net.Security.SslState.CheckCompletionBeforeNextReceive(ProtocolToken message, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.ProcessReceivedBlob(Byte[] buffer, Int32 count, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.CheckCompletionBeforeNextReceive(ProtocolToken message, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.ProcessReceivedBlob(Byte[] buffer, Int32 count, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.CheckCompletionBeforeNextReceive(ProtocolToken message, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.ProcessReceivedBlob(Byte[] buffer, Int32 count, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.CheckCompletionBeforeNextReceive(ProtocolToken message, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.ForceAuthentication(Boolean receiveFirst, Byte[] buffer, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.ProcessAuthentication(LazyAsyncResult lazyResult)
at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Net.TlsStream.ProcessAuthentication(LazyAsyncResult result)
at System.Net.TlsStream.Write(Byte[] buffer, Int32 offset, Int32 size)
at System.Net.PooledStream.Write(Byte[] buffer, Int32 offset, Int32 size)
at System.Net.ConnectStream.WriteHeaders(Boolean async)

REQUESTED URL: https://cms.MySite.local/CMSPages/Scheduler.ashx

Has anyone encountered this issue and can advise how I can resolve it? Many thanks.

Correct Answer

Al Burns answered on December 10, 2020 11:11

Hi David, thanks for your reply.

I have discovered that if you set the following app setting key in the CMS web.config file then the issue is resolved:

<add key="CMSSchedulerAcceptAllCertificates" value="true" />

0 votesVote for this answer Unmark Correct answer

Recent Answers


David te Kloese answered on December 10, 2020 08:57

Hi,

Do you have a valid license for admin and live site? Are they properly configured in the sites application?

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.