In Kentico 8.1 Smart Search SearchResults SearchSort is not working

swati chavan asked on December 4, 2017 17:09

In Kentico 8.1 Smart Search SearchResults SearchSort is not working. I have kentico 8.1 instance. We have requirement to sort search results by score, custom fields ( which is year and month , this is for custom page type of "Magazine" on fields "IssueYear" and "IssueMonth".

In page type's search field settings i enabled the content , searchable for this field still sorting is not working for this two fields. Only search result getting sort by default score.

Kindly help me if I m doing anything wrong here.

Recent Answers


Mariia Hrytsai answered on December 4, 2017 17:37 (last edited on December 4, 2017 17:37)

Please check whether the fields are set as Searchable in the smart search field configuration of page type. Make sure that index was rebuilt after that. If year and month are integer type try to specify (int)IssueYear, (int)IssueMonth.

2 votesVote for this answer Mark as a Correct answer

Prashant Verma answered on December 5, 2017 07:01

Hi Swati,

I agree with Mariia, hopefully you re-build your index successfully after adding any change in your page type fields. But still it seems their are so many issues with smart search with Kentico 8.1 version you can check the bug-fix log and go with the latest hotfix 8.2.50

Thanks

Happy to help

0 votesVote for this answer Mark as a Correct answer

swati chavan answered on December 6, 2017 11:27

Thank you all for responding. I tried this. If i apply SearchSort, it sort records differently ( means not by ##SCORE## ), but still order is not correct as per IssueYear and IssueMonth. (I already doing cache clear and rebuilding search index after each change i m doing).

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.