Error when selecting Users from uniselector

Jason Grant asked on January 21, 2021 10:23

We are getting the following error after selecting from the list of Users when adding Permissions to a Page (Security tab):

"The selector data is not consistent, please try to refresh the page."

This does not happen when adding a Role, which works fine. The same behaviour occurs under Users > Mass Email: adding roles is ok but adding users fail with the above message.

Searching in the code we found that the message is displayed because the hash is invalid (UniSelector.ascx.cs, ValidationHelper.ValidateHash).

This started happening to us on one of the environments (test), but not on the others (development, staging or production). We have the same Salt in all of them from the beginning, and all the macros and everything else is working fine.

Any ideas?

Recent Answers

Dmitry Bastron answered on January 21, 2021 10:48 (last edited on January 21, 2021 10:48)

Hi Jason,

Try re-signing all macroses, this should help.

1 votesVote for this answer Mark as a Correct answer

Jason Grant answered on January 21, 2021 14:07

Thanks Dmitry, but unfortunately re-signing all macros hasn't made any difference. It still doesn't work and the same message appears.

0 votesVote for this answer Mark as a Correct answer

Dmitry Bastron answered on January 22, 2021 14:41 (last edited on January 22, 2021 14:42)

Hmm, looks like a weird case then. I was convinced it should help based on the error message. I'd recommend you write to support at, probably they could help in your case.

But if this is happening only on one test environment, I would probably have tried to redeploy it completely, making sure no dlls or Temporary ASP.NET Files cache files are left behind.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.