"The worker thread has been aborted" error when importing objects

eSiteful Corporation asked on February 11, 2015 20:21

I spent a few hours debugging the contents of my import file trying to figure this one out, so maybe others will find this useful.

While trying to use the Sites > Import site or objects feature, I kept getting the following error:

The worker thread has been aborted, this might have been caused by the application restart. Please check if the action succeeded and repeat the action if not.

Correct Answer

eSiteful Corporation answered on February 11, 2015 20:23

Thinking it was a problem with the import file's contents, I went through a process of elimination, with no luck. Finally, I fixed it by changing the Start Mode to AlwaysRunning under the application pool's Advanced Settings.

1 votesVote for this answer Unmark Correct answer

Recent Answers

Stephen Rushing answered on March 12, 2015 16:37

I've encountered this several times since, and the above setting made no difference, as well as a blank screen on Import/Export after the error. Deleting the App_Data/CMSTemp/ImportExport folder (not just its contents) has solved this in a few cases.

0 votesVote for this answer Mark as a Correct answer

Andrey Lurye answered on August 12, 2015 17:57

on windows server 2012 r2 this may be resolved by a hotfix as commended by Support


Here is the article from us describing the issue and how it relates to Kentico:


1 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.