ASPX templates
Version 7.x > ASPX templates > Show in navigation option is NOT hiding menu item when I uncheck it View modes: 
User avatar
Member
Member
whiplash - 11/7/2013 4:39:13 AM
   
Show in navigation option is NOT hiding menu item when I uncheck it
Hi Guys

I have a strange issue. Basically I have a form which redirects to another page within my Kentico site but I want to hide the menu item for this new landing page.

CMSDesk > Page > Properties > Navigation > 'Show in navigation'

unchecking this option usually prevents a document from displaying as a menu item. However, it still displays.

Would anyone have any ideas why?

User avatar
Kentico MVP
Kentico MVP
Brenden Kehren - 11/7/2013 7:18:01 AM
   
RE:Show in navigation option is NOT hiding menu item when I uncheck it
What are you using to display the navigation on the page? If you're not using one of the default "menu" webparts, I don't believe this works by default. You'd need to add in your where clause:
DocumentMenuItemHideInNavigation = 1
to exclude those items that are not checked.

User avatar
Kentico Consulting
Kentico Consulting
Kentico_RichardS - 11/7/2013 7:48:29 AM
   
RE:Show in navigation option is NOT hiding menu item when I uncheck it
Hi,

Thank you for your message.

FroggEye is correct, what webpart are you using for your menu?

Also I'm not sure if you want to that particular menu item to be shown and hide only after you submit the form?

Kind regards,
Richard Sustek

User avatar
Member
Member
whiplash - 11/7/2013 9:05:17 AM
   
RE:Show in navigation option is NOT hiding menu item when I uncheck it
Thanks FroggyEye and Richard

The site is set up with a CMSRepeater to spit out the menu items calling a particular transformation.

This menu item will be for a 'Thank you' page which I suppose I want to be hidden at all times.

I'll try FroggyEye's solution and let you know

Thanks