Installation and deployment
Version 7.x > Installation and deployment > CMS Site Manager dashboard page doesn't render View modes: 
User avatar
Member
Member
ks-adaptdev - 1/15/2014 10:59:09 AM
   
CMS Site Manager dashboard page doesn't render
When I click on the "Dashboard" tab in the header of the CMS Site Manager, the following message is displayed:

"Page template for this dashboard was not found."

There are no errors in the event log and I can't seem to find any missing "dashboard"-related files in my installation (I've tried to do some comparisons with another Kentico installation that has a working dashboard page), but I don't know where to look.

How can I troubleshoot this? Does the dashboard page depend on a particular module, one that I may not have installed? Could I have a missing file somewhere? Which file(s) might that be?

Any help would be appreciated. Thanks.

User avatar
Kentico MVP
Kentico MVP
Brenden Kehren - 1/15/2014 11:40:30 AM
   
RE:CMS Site Manager dashboard page doesn't render
What most likely happened is the page template was either deleted or unassigned from your site. You can check this by going to CMS SiteManager>Development>Page Templates>Dashboard pages (category) and look for Administrator dashboard. If its not there then your dashboard won't render. If it is there, assign your site to it.

User avatar
Member
Member
ks-adaptdev - 1/15/2014 11:56:11 AM
   
RE:CMS Site Manager dashboard page doesn't render
Thank you!! That indeed appears to be the problem. I don't have that page template installed at all, whereas I do on another Kentico instance that is operating normally.

What is the proper way to add the out-of-the-box page templates to an existing site? I can't seem to find a way to bring up that "new site" wizard thing for an existing site where you can select/deselect templates.

It appears I could export the templates from another site and import them, but that doesn't seem like the way you should do it for these out-of-the-box templates.

Can you advise? Thanks again.

User avatar
Member
Member
ks-adaptdev - 1/15/2014 12:45:15 PM
   
RE:CMS Site Manager dashboard page doesn't render
I was able to figure it out... I had to find one of the starter websites in my Kentico program files installation folder (eg. ...\webinstaller\templates\corporatesite\template.zip) and import that, then select the dashboard template to import.

User avatar
Kentico MVP
Kentico MVP
Brenden Kehren - 1/15/2014 2:54:13 PM
   
RE:CMS Site Manager dashboard page doesn't render
Find it the site you stated it is in and export it. Then import it into your "new" site that is missing it. Should take all of 60 seconds.