Installation and deployment
Version 7.x > Installation and deployment > "No Internet Connection" error message. View modes: 
User avatar
Member
Member
Jerreck - 1/2/2014 8:49:41 AM
   
"No Internet Connection" error message.
I'm trying to install Kentico CMS 7 on a local machine here in the office to use it as a safe testing environment and programming playground. However, I get the following error message after I have selected which sites to install:
No internet connection available.

There is no internet connection available. Additional software needs to be downloaded for successful installation.

Now before you ask, YES the machine is connected to the internet :D

I downloaded the Kentico CMS 7 installer from this machine, and there is in fact an ethernet cable plugged into both the computer and the ethernet port in the wall.

I'm thinking that this may be a problem with our network, but before I troubleshoot that, I wanted to make sure this error isn't due to some little thing I missed in the install process.

Other than there being no internet connection to the machine (which there is), what could be causing the installer to give this error message?

User avatar
Kentico MVP
Kentico MVP
Brenden Kehren - 1/2/2014 8:53:39 AM
   
RE:"No Internet Connection" error message.
What is your environment? Are you installing this on your local machine or on a server? Do you have IIS installed on your machine? Did you get a free license key installed?

User avatar
Member
Member
Jerreck - 1/2/2014 8:58:02 AM
   
RE:"No Internet Connection" error message.
Installing on a local machine.

IIS is not installed (didn't think to check that).

I was waiting to apply the license key in Site Manager once everything was installed.

User avatar
Member
Member
Jerreck - 1/2/2014 9:08:46 AM
   
RE:"No Internet Connection" error message.
Ok, I just installed IIS.

So now our system specs are:

Windows 7 32-bit
SQL Server 2008 R2
IIS 7.5 Express
.NET 4.5

User avatar
Kentico MVP
Kentico MVP
Brenden Kehren - 1/2/2014 11:17:54 AM
   
RE:"No Internet Connection" error message.
So do you have the same problem yet? Have you reviewed the installation documentation?

If I remember right, the "localhost" license key is already included and is valid for 30 days on a fresh install. So no need to worry about the license until a little later.

User avatar
Member
Member
Jerreck - 1/2/2014 12:40:00 PM
   
RE:"No Internet Connection" error message.
Yep, I've read the installation docs and followed them to a tee. The machine meets all the system requirements now, too. Still getting the same error message.

However, I'm also unable to connect to a database with SQL Server Management Studio on a server that I know I should be able to connect to. I'm thinking there's some problem with this machine connecting to our network that's completely unrelated to Kentico.

User avatar
Kentico MVP
Kentico MVP
Brenden Kehren - 1/2/2014 12:44:35 PM
   
RE:"No Internet Connection" error message.
Since the browser errors are so informational (sarcasm inserted here...) I'd suggest going to the Event log viewer (Windows logs>Application) on the machine you are attempting to run the website on. Look for any warning with "asp.net" in the source. This might help you to get things resolved a bit faster.

User avatar
Kentico Customer Success
Kentico Customer Success
kentico_martind2 - 1/3/2014 7:59:40 AM
   
RE:"No Internet Connection" error message.
Hello Jerreck,

Please try to completely remove the Kentico application after installing the IIS server and then try to install it once again. Are you sure you've got the latest installer for version 7 from our website?

Best regards,
Martin Danko

User avatar
Member
Member
Jerreck - 1/6/2014 8:25:57 AM
   
RE:"No Internet Connection" error message.
I downloaded the Kentico CMS 7 installer from my client portal (using the machine that says it can't connect to the internet :D ).

I have also uninstalled and re-installed Kentico, SQL Server 2008 R2, .NET 4.5 and IIS 7.5 multiple times to no avail.

User avatar
Kentico MVP
Kentico MVP
Brenden Kehren - 1/6/2014 11:13:40 AM
   
RE:"No Internet Connection" error message.
Have you checked the event logs for the server? Before I go through all the effort of uninstalling and reinstalling and reconfiguring that would be an easy check to see what the errors might be vs. just guessing.

User avatar
Member
Member
Jerreck - 1/12/2014 10:48:47 AM
   
RE:"No Internet Connection" error message.
I'm 99% certain the issue is because we don't have SeSecurityPrivileges on any new comps we're getting from IT. Even thought SQL Sever Management Studio was installing properly and running just fine, apparently there were some other SQL Server components that did not install properly.

I'll post again in a couple weeks when I'm 100% certain.