Site structure
Version 5.x > Site structure > Friendly URL extensions not working with .asp View modes: 
User avatar
thecoconutmonkey-hotmail - 8/4/2011 12:38:35 PM
Friendly URL extensions not working with .asp
I have a site that contains the following pages:


If I go into "Site Manager > Settings > URLS and SEO" and clear out the values from "Friendly URL extensions", option 1 and 2 both work, but option 3 returns a 404. If I include .asp in the friendly url extensions, option 2 and 3 works but option 1 does not.

There doesn't seem to be a way to have my pages return through all 3 options.

This is creating a problem were google has indexed many of our old pages as .asp. If we set .asp in the friendly url extensions, the urls with no extension stop working. While it is possible to go into each page and in 'custom extensions' specify .asp, it would be impossible to do this on every page of the website.

Any thoughts? Is this a bug?

User avatar
Kentico Developer
Kentico Developer
kentico_ondrejv - 8/5/2011 5:09:36 AM
RE:Friendly URL extensions not working with .asp

It is just about setting multiple extensions as shown in our Developer's Guide:

In particular, your field definition can look like this:


This will enforce you can have your 3 ways of accessing the page1 document.

Best regards
Ondrej Vasil