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1.1

Personal Site Guide

Overview

Kentico CMS Personal Site allows you to easily run your own personal website. It comes with several
design templates and you can easily change the graphics.

The Personal Site is built with Kentico CMS and it comes with following features out-of-the box:
e Content editing

e Blogs

e Forums

e Photo Galleries

You can also use other Kentico CMS modules (such as newsletter, polls or forms) as you need.

To learn about other features and capabilities of Kentico CMS, please refer to other Kentico
documentation, such as Kentico CMS Tutorial (http://www.kentico.com/devnet/documentation.aspx).

You can contact our technical support at http://www.kentico.com/Support.aspx.
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Getting Started

Editing content
In this chapter, you will learn how to change the About text on your website.

1. Go to CMS Desk -> Content -> Personal Site -> About me.

Live Site  Site Manager  [PersonallSitélld L Global Administrator » v6.0.4237 @  Sign Out

Content s Administration  E-commerce  On-line marketing 'EnternrlseMarketIngSo\uticn

S copy i Up
/O D
New Delete o Move J} Down Preview Live site List Search
Content management View mode Other —
) Personal site Page | Design Form  Properties Analytics 7
'\Sj My Blog -
[) About Me E Save ;-“fa Spell check
|| Forums A
[} Photo Gallery E] source | FEll W S e @ | B I U x x| i=E EM ow | = = = =
i) Special pages o =
o e e BaP | EDEC Bow8E
& Images
Styles ~ Format ~ Font v Size v | A~ A- | R
=
Sign in to CM5 Desk. Sign in to CM5 Site Manager. The default account is administrator with blank password.

Current user: Global Administrator| My details | Sign out

Photo Gallery

 Left column text

‘What can you find on my web :
isite? There isn't much stuff on it
:50 far, still working on it. What !
iyou might be interested inis my
*blog from 2 trip around Europe

2. Make sure you are on the Page tab and click into the Main text text box. Erase the text from the
text box and enter This is the new About me text. Then click Save at the top-left.
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Page Design Form Properties  Analytics

[ sae Il Spell check

The changes were saved.

Left column text
‘What can you find on my web
:site? There isn't much stuff on it
:5o far, still working on it. What
you might be interested in is my
‘blog from a trip around Europe
‘that we took with my friend PJ
:this summer. Hope to upload
more photos in near future.

A

My latest blog posts

7/5/2008 | Saying goodbye
Europe

Paris, our final destination.
Because there's no upcoming
hitchhiking trip, the tension
between PJ and me is all gone. I
have a friend here, so the last
night we spend in his place,
drinking wine and using his
computer to look at pictures
we've taken during our month in

Size

Bk @ | B I U = X x| i =

ini
b
=
S
i
Il
(il

E] Source | FERE e -
& Pl EREEEO| BOx 8 B
Styles ~ Format ~ fFont -

3. Now switch to the Preview viewing mode. You can see that the About me text has been updated.
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2.2

Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password.

Current user: Global Administrator| My detzils | Sign out

"Tllusion is the first of all plea

My Blog Photo Gallery

What can you find on my web site? About Me
There isn't much stuff on it so far, e i

still working on it. What you might This is the new About me text.
be interested in is my blog from a

trip around Europe that we took .

with my friend P this summer. PN o

Hope to upload more photos in near

future.

My latest blog posts

6/29/2008 | Sweetness of
loneliness

Since I went to Budapest on my
own, I didn't have to pretend I
enjoy hitchhiking and T took a
train. I wouldn't dare to hitchhike
on my own anyway. Finally had a
little ime to read that book I
bought in Ljubljana.

Adding a blog post

In this chapter, you will learn how to add a new post to your blog.

1. Go to CMS Desk -> Content -> Personal Site -> My Blog and click New in the document action
toolbar.

© 2014 Kentico Software



Getting Started 9

Live Site  Site Manager  [PersonalSteElld L Global Administrator * v6.0.4237 @  Sign Out

Content Administration ~ E-commerce  On-line marketing ! Enterprise Marketing Solution

5 Copy it Up
A 7
New Delete o Move @ Down Preview Live site List Search
Content management View mode Other —
) Personal site Page | Design Form Properties  Analytics ?
T] My Blog
[] About Me E Save Spell check
] Forums i
[2) photo Gallery E] Souree | FER W I 2 Bad e | B I U=xx| == = G T
i Spedial pages = .
ED pag & Pl EEBR=E O BO #E
<y Images
Styles ~ Format ~  Font v Size v | A~ A- | =
=
Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password.

Current user: Global Administrator| My details | Sign out

Forums Photo Gallery

airport Austria bus cuisine Czech
Republic France Germany —

hitchhiking hostel raly [ Saying goodbye Europe
luggage sacher torte Slovenia Spain =
subway tourism traffic train

I~ 2 Paris, our final destination. Because there's no upcoming hitchhiking
=—— trip, the tension between P] and me is all gone. I have a friend here,
L =R 50 the last night we spend in his place, drinking wine and using his
~ ko, computer to look at pictures we've taken during our month in Europe.

2. Choose Blog post as a new document type.

Mo o 2= |
e Kentico

#1N  CMS Desk Wl My desk  Tools  Administration  E-commerce  On-line markating
5 co ir u
# Copy W UP L4 | [d = A
Mew Delete | Move &b Down Edit Preview Live site List Search
Content management View mode Other
':_,J Personal site 2 New document
\S] My Blog
.__i About Me Please select new document type:
|| Forums
[ Photo Gallery [H Blog month
i) Special pages Y Blog post
& Images
#] Link an existing document

3. Next, enter information for your new blog post.
e Post title: My new blog post
e Post Summary: Summary of the blog post.
e Post text: The entire text of the blog post.

Then click Save at the top.
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' E Save ' E‘ Save and create another @ Spell check

] Source | E W e A | e B @ | B I U = X x? = =
& P EEEE 0| B ol E

Styles + MNormal - Font ~ Size w | v AT | @

Post title: My new blog post

Post date: G/9/2011 10:47:06 AM @M

Summary of the blog post.

Post summary:

The entire text of the blog post.

Post text:

Your new blog post has been added to My Blog.

LIS
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Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password.

Current user: Global Administrator| My details | Sign out

"Tllusion is the first of all pleasures.” - Oscar Wilde.

My Blog About Me Photo Gallery
airport Austria bus cuisine Czech
Republic France Germany —

hitchhiking hostel raiy | | My new blog post
luggage sacher torte Slovenia Spain e
subway tourism traffic train

Summary of the blog post.

[ Recent posts

Posted: 8/8/2011 4:47:51 PM by Global Admini

Mo recent posts

£ Syndication ~

Saying good| Europe
e | 53ving 9 bye p

L=

Paris, our final dgstination. Because H'ler__e’s no up!:uming_hitch_h_iking

2.3 Adding a photo gallery

In this chapter, you will learn how to add the new photo gallery and upload some photos.

1. Go to CMS Desk -> Content -> Personal Site -> Photo Gallery and click New in the document

action toolbar.

2. Choose Image gallery as a new document type.
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| New document

Please select new document type:
[ Page (menu item

= Article

) Blog

3 Cell phone

P Event

| Event (booking system)
[2 Jile)

= Ele

) Folder

i Job opening

& Knowledge base article

& Laptop
8, Office
& roa

(i3 Press release

55 Product
| Simple article
|} Smartphene

B Wireframe

&) Link an existing document

3. Enter New gallery into the Name text box and click Browse ... . Choose some Teaser image. Then
click Save at the top.
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E Save F‘ Save and create another Spell check
El source | B W ®m BE o | B I U+ x x| EE
& Pl EEEE O BOx 8 E
Styles ~ Format ~ Font - Size | - A~ | @
Name: New gallery
Description:
Actions Update Name
Teaser image: -
7R [ 3 =] testimage.ipg
Publish from: @ Now
Publish to: P pow

LLITYY

Size

548 kB

4. Now, go to Properties -> Template and click Select to choose template to use. Choose Personal
Site\Personal Site - Photo Gallery. Click Save at the top.

Page Design Form Properties | Analytics

General

URLs

Template »

Mztadata
Categories
Menu
Workflow
Versions
Related docs
Linked docs
Security

Attachments

[ sare

Template

Personal Site - Photo Gallery

=

/== .
(= Save as new template
*z Inherit template

ey :
& Clone template as ad-hoc

E Edit template properties

Inherit content
@ Wse page template settings
() Do not inherit any content
() Inherit only master page
() Select inherited levels

5. Your new gallery is ready. All you have to do is to add some pictures into your new created gallery.
Make sure New gallery is selected in the content tree and click New in the document action toolbar.
Choose File as the new document type.
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| New document

Please select new document type:

|] Page (menu item

&) Link an existing document

6. Click the Upload file ('#) icon and choose a picture to upload.

E Save F Save and create another @ Spell check

Upload file: [ | 4 Upload file

File description:

Then enter The description of the first picture. into the File description text box and click Save at the

top.

l E Save 'E‘ Save and create another % Spell check

i

Actions  Update  Name
Upload file: :
e . SR = Penauins.ipg

The description of the first picture.

File description:

Size

760 kB

Congratulations, you've just learned how to create a new gallery and add some pictures into it.

© 2014 Kentico Software



Getting Started 15

Current user: Global Administrator | My details | Sign out

"Tlusion is the first of 3 7 : ar Wilde.

My Blog About Me Forums Photo Gallery
About my photos List of galleries
Alright, let’s be clear on this. In these galleries, you can find pictures I took in past few months. I'm planning to upload

maore pictures in near future.
I'm far from being a professional
photagrapher, Therefore, if you're
looking for mesmerizing pictures, I European Trip
advise you to search somewhere
else.

Set of pictures, we've taken on our hitchhiking trip around
Europe with my friend P). Additional pictures are to come.

New gallery

Sweet Home Arizona

Mothing compares to smell of desert after moonson rain.
Nothing compares to sound of coyote howling at the Moon.
Nothing compares to view of blossoming saguaro.

Nothing compares to Arizona.

Please note that you can take advantage of the File Import module to upload more images and files.
The File Import module can be found at CMS Desk -> Tools -> File import.

2.4 Adding aforum

In this chapter you will learn how to create a new forum, create new thread and post a message.

1. Go to CMS Desk -> Tools -> Forums and click Edit next to the My Forums group.
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¢ Kentico
SN CMS Desk Content My desk Administraion ~ E-commerce  On-line marketing
= Polls Custom tables Forums| [5] Message boards
Srois g )
Forms  Media ®§ Staging [[3 File import Blogs fa Groups || Abuse report Projects
Content Community Collab

&l Forum groups

&4 New forum group

- Actions Group name

@ T &~ My Forums

2. In the Forum group properties, click Add forum (&2).
3. Add the following information for the new forum:

e Forum display name: New forum

e Forum code name: newForum

e Description: The description of the new forum.

Then click OK.

ﬂ Forum group properties

» Forum groups » My Forums

Forums | General  View

» Forums » Mew forum

Forum display name: New forum
Forum code name: newForum

The descripticn of the new forum. =

Description:
Forum base URL: ~[Forums aspx Inherit from forum group
Forum unsubscription URL: ~[/Special-pages/ForumUnsubscribe. aspx Inherit from forum group

Require e-mail addresses: [=] inkerit from forum group

Dizplay e-mail addresses: [T inherit from forum qgroup
Enable WYSIWYG editor- [Tl inherit from forum group
Use security code (CAPTCHA): [T inkerit from forum group
Forum is open:

Forum is locked:

Forum is moderated:

%DDHDDDD

4. The forum has been added as you can see in the following screenshot.
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Current user: Global Administrator| My details | Sign out

"Tllusion is th t of all p r Wilde.

My Blog About Me Forums Photo Gallery

Forums

Welcome to my forums. You ca use these forums to discuss different topics. If you want to add new post or reply to a post you have to be signed
in. You can use the sign in link in the top right corner.

Search forums:
Forum Threads Posts Last post
My Forums
New forum
The description of the new forum. 0 0 (1/1/0001 12:00:00 AM)
Lock
Where to go in Europe
9 5 Kate
Lock (5/22/2008 8:16:15 PM)
Goodbye party 3
9 g Abi

(5/28/2008 3:57:25 PM)

Lock
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3 Adjusting Design

3.1 Changing website theme

The sample Personal Site comes with several predefined CSS stylesheets. In this chapter, you will learn
which stylesheets are available and how you can choose the CSS stylesheet you want to use on your
website.

To choose the CSS stylesheet for your website, go to CMS Site Manager -> Sites and click Edit site
next to the Personal Site.

'. Kentico

1™ Site Manager Administration ~ Settings

&) Sites

@ New site wizard [E. Import site or objects [3 Export objects

~ Actions Site name -~

@ i@ B MW & @ Personal site

In the Site Properties, choose your CSS stylesheet from the Site CSS stylesheet drop-down list.

(«_) Site properties

» Sites » Personal site

General | Domain aliases  Cuftures  Off-line mode

Site display name: Personal site

Site code name: PersonalSite

Site domain name: localhost

Default content culture: English - United States
Default visitor culture:  (Automatic) |Z|

Ok

The following CSS stylesheets are available in the sample Personal Site:

Personal Site
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Current user: Global Administrator| My details | Sign out

My Blog About Me Forums Photo Gallery
Tags &
My new blog post

airport  Austria bus cuisine -

Czech Republic France Germany

hitch hlklllg hostel Summary of the blog post.

Italy luggage sacher torte

Slovenia 5Spain  subway

tourism traffic  train Posted: 2/16/2010 10:02:43 AM by Global Administrator | with 0 comments
D Recent posts Saying goodbye Europe

—
} Saying goodbye Europe

» Wir sind Berliners

} Disappointment in Prague Paris, our final destination. Because there's ne upcoming hitchhiking
} Sweetness of loneliness trip, the tension between PJ and me is all gone. I have a friend here,
» Sacher torte and Austrian so0 the last night we spend in his place, drinking wine and using his

capital computer to look at pictures we've taken during our month in
Europe.
Today, P] went to do some shopping and we've promised each
=1 syndication other go out have dinner tonight.

Personal Site - Blue

© 2014 Kentico Software



Adjusting Design 21

| My details

Personal starter site

Tags

» airport ¥ Austria ¥ bus ¥ cuisine
¥ Czech Republic ¥ France

F Germany b h itCl'Ih iki“g

rhostel » Italy ¥ luggage P sacher
torte  Slovenia * 5pain » subway
F tourism F traffic ¥ train

] Recent posts

» Saying goodbye Europe
Wit sind Berliners

k Disappointment in Prague
» Sweetness of loneliness

k Sacher torte and Austrian
capital

Syndication

Personal Site - Green

My Blog | About Me | Forums | Photo Gallery

a Saying goodbye Europe

Paris, our final destination. Because there’s no upcoming hitchhiking
trip, the tension between PJ and me is all gone. I have a friend here,
5o the last night we spend in his place, drinking wine and using his
computer to look at pictures we've taken during our month in
Europe.

Today, P11 went to do some shopping and we've promised each
other go out have dinner tonight.

Posted: 7/5/2005 1:56:04 PM by Abigail Woodwarth | with 3 comments

a Wir sind Berliners

5 Berlin, after a long time the city we both wanted to see. And as we're
- A - almost done with our trip, we're getting much more relaxed in
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| My details

&

I:I .7 MyBlog w7 About Me wr Forums w Photo Gallery

Tags

Saying goodbye Europe
F airport * Austria ¥ bus * cuisine
¥ Czech Republic ¥ France
F Germany D hItCh hlkl“g
rhostel » Italy * luggage * sacher
torte * Slovenia * 5pain b subway
F tourism * traffic ¥ train

Paris, our final destination. Because there’s no upcoming hitchhiking
trip, the tension between P1 and me is all gone. I have a friend here,
s0 the last night we spend in his place, drinking wine and using his
computer to look at pictures we've taken during our month in
Europe.

Today, P1 went to do some shopping and we've promised each
other go out have dinner tonight.

[3 Recent posts Pasted: 7/5{200% 1:56:04 PM by Abigail Woodwarth | with 3 comments

¥ Saying goodbye Europe

» Wir sind Berliners

+ Disappointment in Prague

+ Sweetness of loneliness

» Sacher torte and Austrian

capital U Wir sind Berliners

Eﬂ svndicati Berlin, after a long time the city we both wanted to see. And as we're
yndication & ﬁ - almost done with our trip, we're getting much more relaxed in

Personal Site - Red
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3.2

Personal starter site

"llusion is the first of all pleasures.” - Oscar Wide.

Tags

F airport * Austria * bus ¥ cuisine
F Czech Republic * France

»eermany " hitchhiking
rhostel » Italy * luggage P sacher

torte P Slovenia ' Spain » subway
F tourism F traffic P train

] Recent posts

» Saying goodbye Europe

» Wir sind Berliners

k Disappointment in Prague
F Sweetness of loneliness

» Sacher torte and Austrian
capital

£ syndication

Search # MyBlog

| My details

¥ About Me ¥ Forums ¥ Photo Gallery

-~
k_,| Saying goodbye Europe

Paris, our final destination. Because there’s no upcoming hitchhiking
trip, the tension between PJ and me is all gone. I have a friend here,
s0 the last night we spend in his place, drinking wine and using his
computer to look at pictures we’ve taken during our month in
Europe.

Today, P] went to do some shopping and we've promised each
other go out have dinner tonight.

Posted: 7/5/2005 1:56:04 PM by Abigail Woodwarth | with 3 comments

—
| Wir sind Betliners
I

Berlin, after a long time the city we both wanted to see. And as we'te
almost done with our trip, we're getting much more relaxed in

adih oo

Editing CSS stylesheets

In this chapter, you will learn how to change the design of your website by modifying the CSS
stylesheets.

Changing the header picture

1. Go to CMS Site Manager -> Development -> CSS stylesheets and click Edit (#) next to the
Personal Site stylesheet. On the General tab, click on the Main styles -> Master page bookmark in
the listbox on the right side of the code editor. This will navigate to the corresponding block of CSS

code.
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E l(enl:co

#1% Site Manager Sites  Administration  Settings [EUNGLLNNE Tools Dashboard  Llicenses  Support
Development (j CSS stylesheet properties [2]
@ Countries
d S5 stylesheets » CSS stylesheeis » Personal Site
© cuttures Genersl | Theme Sites  Versions
47 Custom settings =
£} Custom tables Hsave & checkouttofile || [ Preview
8 Device profiles
[ Document types Stylesheet display name: Personal Site @
& Form controls Stylesheet code name:  PersonalSite @
Inline controls | Abuse report
[E| Macro rules /*#Main styles/Master page#*/ Blogs
B Modules -mainDiv Breadcrumbs
. i Buttons
/] Notifications width: 796px; __| Content rating
IR page layous e S
[@ Page templates s 9: Lpk Tex Dpx TR/ Attachments

background-color: #££f;
=F Relationship names } Global

= 3 B
[@ Search engines . oxes
.zoneTop ogon page
E System tables 1 Main styles
«# Tag groups height: 23%px; Left menu
@ Time zones width: 725px; Master page
1 . . o background-color: #££f; Membership top zone
0
Translation services | background: #££f url(../App_Themes/PersonalSite/Images/bg_head.jpg) no-repe Search box
e UI cultures H 1 Top meny
{0 Web part containers X Modal popup
.zoneTopMembership
# web parts { My profile
[@] Web templates width: 795px: ';":’t“’lga”et“’ .
. : eight: . ortal context menu
Widgets Stylesheet text: height: 15px; . \
padding: 3px 0 3px 0; earch page
« Workflows 1 Tags
Tooltip

.Gecko .zoneTopMembership, .Opera .zoneTopMembership, .Safari .zoneTcpMembers:
{

padding: 3px 0 3px 0;

height: 15px;
1

.DesignMode .zoneTopMembership
1

height: 110px:
!

.zoneTopMenmbership a

or: #3a5a5a;
font-weight: normal:
< i | 5

EEEl>calad&d| o F

2. In the .zoneTop class, change the url of the background image to ../App_Themes/
PersonalSiteGreen/Images/bg_head.jpg and modify its styles according to the following:

. zoneTop
{

hei ght : 239px;

wi dt h: 795px;

background-col or: #fff;

paddi ng: Opx Opx 7px;

mar gi n: Opx Opx Opx;

background: #fff url(../App_Thenes/ Personal SiteG een/| mages/ bg_head. j pg)
no-repeat top left;

}

Then click the kd Save action in the tab's header to confirm the change.

3. Now click the & Preview button, which will allow you to view the site's pages while editing the CSS
stylesheet. Enter /My-Blog into the path textbox on the preview toolbar and Refresh () the page
section. You will be able to see that the header image has been changed. Of course, the modified style
will also be applied to the live site.
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()’ CSS3 stylesheet properties

» CSS stylesheets ¥ Personal Site

General | Theme  Sites  Versions

E Save (5 Check out to file

= | Abuse report

f*Main styles/Master pagef*/ Blogs
-mainDiv Breadcrumbs
{ _ ‘&l Buttons
ﬂldJ_'l- T9EpH: Content rating
margin: 35px auto: Forums
ding: Opx 7px Opx 7Dx; Attachments
packground-color: $#£££;
} Global
Boxes
.zoneTop Logon page
I Main styles
height: Z39px: Left menu
width: 795px; L MESEErPAge
ground-color: $£££: Membership top zone

padding: Opx Opx Tpx: Search box
margin: Opx Opx Opx: Top menu
background: #£ff url(../BEpp_Themes/PerscnalSiteGreen/Images/bg head.jpg) no-repeat top left: Modal popup
' My profile
-zoneTopMembership Photogallery
{ Portal context menu
width: 795px; -~ | Search page
4| 1 b Tags
Tooltip

= Al > al & &)
[ ] D 1] | My-Blog English - United States (en-US)[»] @

Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password.

Current user: Global Administrator| My details | Sign out

Photo Gallery

Changing the top menu

1. Continue editing the same stylesheet as in the previous section. Under the Main styles -> Master
page bookmark, scroll down until you find the .zoneTopMenu CSS class.
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(f C3SS3 stylesheet properties

» CSS stylesheets » Personal Site

General | Theme  Sites  Versions

{{3 Check out to file

E Save
i

font-weight: normal;
font-size: 3Zpx;
margin-top:0px;

}

- zoneTopMenu

{

height: 43px;

width: 795px:

I kground: #££f url{.. /REpp_Themes/PerscnalSite/Images/bg_topmenu.gif) repeat-x top CENter;
padding: Opx:

margin: Opx:

}

.DesignMcde .zoneTopMenu
{

height: 1Z0px:
}

4| 1 |

= | Abuse report
Blegs
Breadcrumbs
1 Buttons
Content rating
Forums
Attachments
Global
Boxes
Logon page
Main styles
Left menu
Master page
Membership top zone
Search box
Top menu
Modal popup
- My profile

il

+ Photogallery

2. Change the background color to #BOC4DE and erase the image URL from the style, so that the

class definition reads as follows:

.zoneTopMenu
{
hei ght : 43px;
wi dt h: 795px;
backgr ound: #BOCADE;
paddi ng: Opx;
mar gi n: 0px;
}

This will change the background of the site's main navigation menu to a dark blue color.

3. Now, switch to the Main styles -> Top menu bookmark and find the .CMSListMenulLl a:hover
class. This style modifies the appearance of menu items that are currently selected or have the user's

mouse placed over them.
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(; CSS stylesheet properties

» CSS stylesheets » Personal Site

General | Theme  Sites  Versions

E Save r'Sj Check out to file

color: £#000: = | Abuse report
text-decoration: none; Blogs
'ji'iil‘:“‘ff glcsgg . Breadcrumbs
padding: Upx px; _| Buttons
margin-right: 2px; = .
} Content rating
Forums
.CMSListMenuLI a:hover, .CMSListMenulinkHighlighted, .CMSListMenuLIlast a:hover, .CMSLiscMenuHighl Attachments
1 Global
color: #000; Boxes
background: url(. .f_lxpp_:l'hemest'erscnals1:efImagesfbg_:cpmenu_hcver.qif} repeat-x top left: Logon page
text-decoraticn: nene; Main styles
¥ Left menu
) ) ) Master page
UnigridicticnButton Membership top zone
{ o o Search box
) margin-right: Spx; Top menu
Meodal popup
oTT TTr G rewed ATt 5 mm B s = mm 7| My profile
< | n > Photogallery
= . = Portal context menu
CSEEI >a @8 | e e e

4. Change the color to #fff and replace the image url in the background style with #87CEFA. The
entire class should read as follows:

. CMBLi st MenuLl a: hover, . QVBLi st MenuLi nkH ghl i ghted, .CVBLi st MenuLl| ast a: hover,
. OVBLi st MenuH ghl i ght edLI | ast a, . CWVBLi st MenuH ghl i ght edLl a
{

color: #fff;

backgr ound: #87CEFA;

t ext -decorati on: none;

This will change the background of highlighted menu items to light blue and their text color to white.

5. Click kd Save to confirm the modification and the result will automatically be shown in the page
preview section.
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E] m | /My-Blog ﬁ English - United States [en-US}E e

Current user: Global Administrator| My details | Sign out

Tags

J Saying goodbye Europe

airport Austria bus cuisine
Czech Republic France Germany
hitch hi ki ng hostel e Paris, our final destination. Because there’s no upcoming hitchhiking

. trip, the tension between PJ and me is all gone. I have a friend here,
_ q 2l so the last night we spend in his place, drinking wine and using his
Slosma Spain subway computer to look at pictures we've taken during our month in Europe.
tourism  traffic train s

Italy luggage sacher torte

Today, P] went to do some shopping and we've p ised each
other go out have dinner tonight.

Posted: 7/5/2008 1:56:04 PM by Abigail Wood th | with 1 c

['] Recent posts
Mo recent posts

You have learned how to modify the CSS stylesheets to change design of your website.
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4.1

Adding web parts

Adding text

In this chapter, you will learn how to add a new editable text region into your website.

1. Go to CMS Desk -> Content -> About Me and switch to the Design tab. Click Add web partin

zoneRight.

Content

S copy 4 Up

Live Site  Site Manacer  |PersonalSElEd L Global Administrator v v6.04245 4 SignOut

Administration  E-commerce  On'line marketing ! Enterprise Marketing Solution

£ 4
New Delete | Move b Down Preview Live site List Search ‘ -
Content management View mode Other —

) Personal site Page | Design | Form Properties  Analytics ?

T] My Blog — - . - — -

Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password.
|| About Me
] Forums

|| Photo Gallery
&) Special pages

‘S Images

Current user: Global Administrator| My details | Sign out

"Tllusion

Photo Gallery

- | IAbout Me - page template: Personal Site - About Me

v zoneleft o = zoneRight

v LefiText &4 on my web site? = | TitleRegion | {3

2. Select the Text & Images -> Editable text web part.
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#. Select web part

Filters 1 Web part name: m [7] Search in description

Forms
Forums
Full-text search = E 'E
General Eﬁ Tar ‘%
Intranet portal E 1
Layouts
Listings and viewers Editable image Editable text Link / Button Paged text QR Code
Localization
Maps
Media |
Media library
Membership =] 1] ——

= - —— T
Message board - — —

— I
Messaging - = _—
Microsoft SharePoint . . -
Static HTML Static text Text highlighter

MNavigation

News

Newsletters
Notifications

Polls

Project management
Reporting

Silverlight

Social networks
Syndication

Tagging & categories
Text & Images

User contributions
Web analytics Editable text
Web services

mn

Creates an editable text region in CMS Desk -» Content - Edit -> Page that can be used by website editors to enter page content
Widgets using the WYSIWYG editor. When saved, this content is displayed on the live site.

& Wireframes

HLLOLHLBOLHLLLLHLLLLGLLLLLHL6DLLHLLLEH

oK™= cancer|
3. Inthe Web part properties dialog, enter the following information for the new web part.
e Editable region title: AboutWebPageTitle
e Content before: <h1>
e Content after: </h1>
Then click OK.

4. Click Add web part again and select the same EditableText web part.

5. In the Web part properties dialog, enter AboutWebPageText into the Editable region title textbox.
Then click OK.

6. Now you have the new web parts ready and you can enter some new text. Switch to the Page tab
and click into the AboutWebPageTitle editable region. Enter About my web page. Click Save at the
top.

7. Click into the AboutWebPage editable region and enter This is a short text about my web page.
Click Save again.

© 2014 Kentico Software



Kentico CMS 7.0 Personal Site Guide

Page Design Form Properties  Analytics
E Save

The changes were saved.

Spell check

Bl Source | B m Y% e B @ | B I U = X x2 = = = e i = = =
& P EEEE 0| O § E
Styles + MNomali... = Font - Size - | o A | &)

finished reading two weeks ago i e ,

and whose story was set to Graz. ]

‘About my web page.

AboutWebPageText

This is a short text about my web page.

That is how you add a new editable region into your website.

Current user:  Global Administrator | My details | Sign out

"Ilusion is

My Blog Photo Gallery

What can you find on my web site? About Me

There isn't much stuff on it so far, e i

still working on it. What you might Thisis the new About me text.

be interested in is my blog from a

trip around Europe that we took . About my webpage

with my friend PJ this summer.

Hope to upload more photos in near This is a short text about my webpage.
future.

My latest blog posts

Have d iy e e, DU uie dghl
night we spend in his place,
drinking wine and using his
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4.2 Adding a poll

In this chapter, you will learn how to create a new poll and add it to your web page.

1. First of all we need to create a new poll. Go to CMS Desk -> Tools -> Polls and click New poll (&).

Kentico
CM5 Desk Content My desk Administration
Igl (& Polls | fjl Custom tables &4 Forums
Forms  Media #§ staging ([ Fileimport Blogs  fla Groups
Content Comm
& Polls
Site: Community site |Z|
@ Newe poll

No data found.
2. Enter the following information for the new poll.
e Display name: My poll
e Code name: MyPoll

e Question: How do you like my pictures?

Then click OK.

3. Now we need to defined some questions for your new poll. In the poll properties, switch to Answers
tab and click New answer (“#). Into the Text text box, enter | love them! and click OK.

& Poll properties

» Polls » My poll

General | Answers Security View

» Answers » New answer

['qa New answer

Text | love them!

—

4. Click New answer again and enter Not bad. as Text. The Enabled check box should be checked.
Then click OK.

5. Click New answer again and enter Waste of time! into the text box provided. Click OK.

6. Now we are ready to add your new poll to website. Go to CMS Desk -> Content -> Personal Site ->
Photo Gallery and switch to the Design tab. Click Add web part in zonelLeft.
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istrator ¥ v6.0.4241 @ | Signout

Content Administration  E-commerce i ! Enterprise Marketing Solution
5 Copy 4t Up
New Delete & Move J} Down Preview Live site List Search ?
Content management View mode Other —
) Personal site Page | Design | Form  Properties Analytics Display web pari content | 7

'\Sj My Blog

|] About Me

|| Forums

|| Photo Gallery
) Special pages

&) Images

Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password.

Current user: Global Administrator| My details | Sign out

Photo Gallery

~ | [Photo Gallery - page template: Personal Site - List of galleries

- zoneleft

o |' zoneRight

— I

7. In the Select web part dialog, select Polls\Poll web part.
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r
2 Select web part - Windows Internet Explorer

&% Recently used web parts
i) All web parts

Abuse report
Articles
Attachments

Blogs

Community
Community services
Content rating
Custom tables

Data sources
Document library
E-commerce

Events & booking
Filters

Forms

Forums

Full-text search
General

Google services
Intranet portal
Layouts

Listings and viewers
Localization

Maps

Media

Media library
Membership
Message board
Messaging
Microsoft SharePoint
Mavigation

News

Newsletters
Notifications
On-line marketing
Polls

Project management
Reporting

oy oyoycyoycycycycysycyoysycy ey oy oy oy oy oy oy oy oy ol oy oy o Gy sy ey oy sy oy ey oy e

mn

Web part name:

Poll

Poll

The Poll web part allows you to insert your own Poll on the page.

Search in description

=5 [ |

Select web part

8. In the Web part properties dialog, make sure My poll is selected as Poll name and click OK.

Congratulations, you've just learned how to add a new poll to your website.
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About my photos

Alright, let’s be clear on this.

I'm far from being a professional
photographer. Therefore, if you're
looking for mesmerizing pictures, I

advise you to search somewhere
else.

How do you like my pictures?
21 love them!

© Not bad.

) waste of time!

Current user: Global Administrator| My details | Sign out

"Tllusion is the fi fall p wilde.

My Blog Photo Gallery

List of galleries

In these galleries, you can find pictures T took in past few months. I'm planning to upload
more pictures in near future.

European Trip

Set of pictures, we've taken on our hitchhiking trip around
Europe with my friend PJ. Additional pictures are to come.

Sweet Home Arizona

Nothing compares to smell of desert after moonson rain.
Nothing compares to sound of coyote howling at the Moon.
Nothing compares to view of blossoming saguaro.

Nothing compares to Arizona.
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Further reading

This guide has provided you only with a short introduction to some of the aspects of the Kentico CMS.
For more detailed information about Kentico CMS please consult the following resources:

e Kentico CMS Tutorial
e Kentico CMS Developer's Guide

e Kentico DevNet at http://www.kentico.com/DeviNet.aspx

Should you need any further assistance, please do not hesitate to contact us at http://

www.kentico.com/Support.aspx.
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