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1 Introduction

1.1 About this guide

This guide contains information about on-line marketing features of Kentico Enterprise Marketing
Solution, the full-featured on-line marketing tool based on Kentico CMS. It will guide you through the
basics of all the on-line marketing features and explain how your website can benefit from using them. It
will also navigate you through the related sections of the user interface and provide step-by-step
examples that can be tried out in order to get hands-on experience and see how they behave in
real-world scenarios.

To be able to understand the content of this guide, it is highly recommended to be already familiar with
the basics of Kentico CMS. If you are completely new to Kentico CMS and have no previous experience
with it, we recommend you to go through Kentico CMS Tutorial before proceeding further in this guide.

In the On-line marketing features topic, individual features are listed with links leading to their dedicated
chapters. Before going through the related step-by-step examples and trying out their functionality on
your Kentico CMS instance, it is recommended to install the sample Corporate Site and adjust on-line
marketing settings to make the features are enabled. It is also recommended to see the First sight topic
in order to get familiar with the sections of the user interface where the on-line marketing features are
located.

Built-in Context Help

Basic documentation of particular sections of the system's user interface can be found
in Kentico CMS Context Help. It is useful in case that you need a quick explanation of
the currently used functionality.

If you click the  icon in the top right corner of each UI screen, you get redirected to
the appropriate Context Help page which describes the current UI screen. The Context
Help is embedded in the web project, so you don't even need to have Internet
connection to view it.

http://devnet.kentico.com/docs/6_0/tutorial/index.html
http://devnet.kentico.com/docs/6_0/contexthelp/index.html
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1.2 On-line marketing features

Kentico Enterprise Marketing Solution provides the following features related to on-line marketing:

Web analytics - measure and analyze key metrics of your website such as visits, page views, file
downloads, traffic sources, etc.

Conversions - track actions performed by your website's visitors (e.g. user registration, product
order, etc.) and record them as conversions.
Campaigns - accurately monitor traffic generated by individual on-line marketing campaigns (e.g.
banners, marketing e-mails, etc.).
Reporting - view analytics data presented in highly flexible reports that contain various kinds of
charts and tables.

Contact management - centralized overview of all users who visit your website, used to gather
information about them and their activities on the website.

Contacts - individuals who visit the website and about whom information is gathered.
Accounts - companies or other commercial or non-commercial bodies where contacts operate.
Contact groups - organizational units that can be used to group contacts or accounts based on
various criteria.
Merging - merge contacts or accounts into one in order to avoid duplicities.
Activities - analyze behavior and actions that contacts perform on the website.

Scoring - numerically evaluate individual contacts on multiple scales based on their properties and
activities.

Website optimization - create different versions of pages and evaluate them according to the behavior
of the website visitors.

A/B testing - create one or more modified versions of a given page, diversify traffic to them and
track how individual versions affect behavior of website visitors.
Multivariate testing - create different versions of elements on a page and track which versions
produce the best results when displayed to website visitors.

Content personalization - create pages that display different content depending on the circumstances
in which they are viewed.
E-mail marketing - attract new customers to your website or keep in touch with existing clients by
sending marketing e-mails.
Security - allow access to user interfaces of on-line marketing features only to certain users.
Internals and API - modify or enhance the out-of-the-box functionality by your custom code using
Kentico CMS API.
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2 Getting started

2.1 Installing the sample Corporate Site

Examples in this guide are based on the sample Corporate Site. It is therefore recommended to have
this website installed in order to try out the examples in practice. This topic provides information on how
to get the website installed and is divided into two parts, depending on if you already have Kentico CMS
installed (but without the Corporate Site), or if you are performing a completely new installation.

New Kentico CMS installation

Installation of Kentico CMS is fully described in Developer's Guide -> Installation and deployment. The
following points sum up which steps need to be taken in order to perform the installation and provide
links to the relevant topics in that chapter of the Developer's Guide:

1. Launch KenticoCMS_<version>.exe and follow the instruction in Installation procedure -> Setup
(KenticoCMS.exe).

2. Once the setup finishes, launch Kentico CMS Web Installer and follow the instructions in Installation
procedure -> Web installer.

3. When the Web Installer is finished, access the URL of the new website. The first step of the
Database Setup will be displayed. Follow the instructions in Installation procedure -> Database setup,
until you reach the Starter Site step (the number of the step may vary). In this step, select the Choose
starter site option and choose the Corporate Site sample site. Click Next to continue.

http://devnet.kentico.com/docs/6_0/devguide/installation_overview.htm
http://devnet.kentico.com/docs/6_0/devguide/setup_kenticocms_exe.htm
http://devnet.kentico.com/docs/6_0/devguide/setup_kenticocms_exe.htm
http://devnet.kentico.com/docs/6_0/devguide/web_installer.htm
http://devnet.kentico.com/docs/6_0/devguide/web_installer.htm
http://devnet.kentico.com/docs/6_0/devguide/database_setup.htm
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4. Wait until the Database Setup finishes importing the site. Once finished, the Finished step will be
displayed. Click the Continue to the new website link highlighted in the screenshot below.

5. You will be redirected to the Home page of the website.
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Existing Kentico CMS installation

If you already have Kentico CMS installed, but without the sample Corporate Site, you can add it using
the New site wizard.

1. Log on to Site Manager and on the Sites tab, click the  New site wizard link.

2. In the first step of the wizard, choose the Use web site template option and click Next.

http://devnet.kentico.com/docs/6_0/devguide/new_site_wizard.htm
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3. In Step 2, choose Corporate Site from the list of available website templates and click Next.
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4. Go through the rest of the wizard as described in Developer's Guide -> ... -> New site wizard ->
Website template. It is recommended to leave the default settings unless you really need to change
them according to your specific requirements. Once the wizard finishes, you should see the website
present in the list of websites in Site Manager -> Sites.

5. Sign out of the administration interface (use the Sign out button at the top right corner of the UI). You
will be redirected to the Home page of the website.

2.2 Enabling On-line marketing

This topic explains the configuration required to enable the on-line marketing features of Kentico CMS. It
only mentions the most important settings necessary to get the examples in the following chapters
working and produce meaningful results. Detailed information about all the available settings can be
found in the respective chapters of this guide.

1. Go to Site Manager -> Settings. In the Site drop-down list, you can either leave the (global) option

http://devnet.kentico.com/docs/6_0/devguide/website_template.htm
http://devnet.kentico.com/docs/6_0/devguide/website_template.htm
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selected and let the global settings be inherited by the Corporate Site, or you can choose Corporate
Site and adjust the settings only for it in case that you do not want other websites running in the system
to be affected. Then choose the On-line marketing category in the tree on the left and make sure to
enable the following settings:

Enable on-line marketing: enabled
Enable A/B testing: enabled
Enable multivariate testing: enabled
Enable content personalization: enabled

Leave the rest of the settings at their default values and click Save.

2. Switch to the On-line marketing -> Activities category. Here, make sure that the Log activities
option is enabled and that logging of all possible types of activities is also enabled by the check-boxes
below.

3. Finally, switch to the On-line marketing -> Newsletters category and configure the options as
described in E-mail marketing -> Monitoring bounced e-mails -> Configuration.

Immediate logging of activities

It is also recommended to add the following key to the appSettings section of your projects's web.config
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file:

<add key="CMSLogActivityImmediatelyToDB" value="true" />

This key ensures that activities are logged directly into the system database instead of being logged into
a file and periodically batch-processed by a scheduled task. This may generate additional load on the
system database, but results in minimal delays in displaying of activity-related data (e.g. activity-based
rules in Scoring). It is therefore recommended to use the key when going through the examples in this
guide in order to see activity-related results in the user interface immediately.

2.3 First sight

Once you have Kentico CMS and the sample Corporate Site installed, it is a good idea to get familiar
with the parts of Kentico CMS user interface where the on-line marketing features are located. 

1. To get started, log on to CMS Desk. This can be done either by clicking the CMS Desk link in the
header of the sample Corporate Site ...

... or by directly entering an address in the following format into your browser's address bar: http://
<website domain>/cmsdesk

2. Once in CMS Desk, navigate to the On-line marketing tab. This is the main on-line marketing user
interface which encapsulates user interfaces of the most of the on-line marketing features. You can
access the individual features using the ribbon toolbar at the top of the screen.

3. The Web analytics, Conversions, Campaigns and Newsletters features have duplicate user
interfaces also on the Tools tab in CMS Desk. These user interfaces are identical to the ones on the
On-line marketing tab, they provide the same options and display the same data. Please note that
Conversions and Campaigns are embedded under Web analytics interface on the Tools tab.

4. The above mentioned interfaces are site-specific, which means that they provide functionality related
only to the website currently edited in CMS Desk. In Site Manager -> Tools -> Contact management
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, there is a global user interface which enables management of Contact management objects and
configuration for all websites running in the system. Depending on the selection made in the Site drop-
down list, you can choose if you want the UI to be related to a specific site, to global objects shared by
all websites running in the system, or to all websites running in the system.

5. Finally, there is a number of settings that can modify behavior of the on-line marketing features of
Kentico CMS. These settings can be adjusted in Site Manager -> Settings and are located under the
On-line marketing settings category highlighted in the screenshot below. You can learn more about
them in the Enabling On-line marketing topic.
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3 Web analytics

3.1 Overview

The web analytics module provides a way to measure and later analyze key metrics of your website
such as visits, page views, file downloads, traffic sources and much more. Monitoring is only done on
the live site, so actions that take place on the pages belonging to the Kentico CMS administration
interface (CMS Desk and Site Manager) are not included in the statistics.

The web analytics interface can be accessed in CMS Desk -> On-line marketing -> Web Analytics.
As you can see in the screenshot below, there are various types of statistics available that keep track of
certain events that occur on the website. When you select a statistic, the corresponding data is
displayed in a report.

In addition to measuring various statistics for the website and its pages, web analytics are also used by
several other on-line marketing features, including Conversions, Campaigns and Website optimization
(A/B or multivariate testing).

To learn about all available features of the web analytics module, its internal mechanics and advanced
configuration or customization options, please refer to the full documentation that can be found in the 
Modules -> Web analytics chapter of the Kentico CMS Developer's Guide.

http://devnet.kentico.com/docs/6_0/devguide/web_analytics_overview.htm
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3.2 Using web analytics reports

The data logged for web analytics statistics is presented in highly flexible reports that contain various
kinds of charts and tables. The same type of reports are also used to display the results of other related
on-line marketing features, such as campaigns and website optimization tests.

When viewing a web analytics report, the From and To fields on the right can be used to enter a time
period. Only hits that were logged for the statistic during the specified interval will be included in the
displayed data.

The following options allow you to choose which unit of time should be used in the report:

 Hour
 Day
 Week
 Month
 Year

This selection determines the length of time which is represented by individual units in the report's
graphs (if there are any) and the precision that can be specified in the From and To fields.

The following actions may also be performed for every report:



Web analytics 21

© 2012 Kentico Software

 Save - saves the report in its current state (according to the selected time interval). To view saved
reports at a later time, go to CMS Desk -> Tools -> Reporting, select the matching report under the
appropriate category and switch to the Saved reports tab.

 Print - allows the report to be printed. The available options depend on the used browser.
 Delete data - may be used to clear the data measured for the given statistic. Please note that

this permanently removes the data from the database. This action is only available for users who
have the Manage data permission for the Web analytics module.

The data displayed in the reports may also be exported into external files using various formats. This can
be done by right clicking on a graph or table in the given report, which will open a context menu offering
the following options:

 Export to Excel - exports the data displayed by the given object to an XLSX spreadsheet.
 Export to CSV - exports data to a CSV file.
 Export to XML - exports data to an XML file.

After you select an action from the menu, your browser's standard file download dialog will pop up,
letting you open or save the file with the exported data just like when downloading any other type of file.
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4 Conversions

4.1 Overview

The Web analytics module provides a way to track actions performed by your website's visitors and
record them as conversions. This is typically done for desired events that somehow benefit the website,
such as the registration of a new user, a product order, subscription to a newsletter or similar.
Conversions are represented in the system by corresponding tracking objects, which are described in
more detail in Managing conversions.

Once an action is defined as a conversion, a conversion hit is logged whenever it occurs. Additionally, a
numerical value may be stored along with each hit to indicate its importance. To learn how you can
assign conversions to individual types of actions and ensure that they are logged correctly, please refer
to the Logging actions as conversions topic.

Once you start tracking conversions on the live site, you can compare the recorded data with the values
of other statistics, such as the total amount of visitors. This allows you to evaluate the website and
adjust it as necessary.

While simply tracking all conversions that occur on the website can be useful, in many cases you may
also require additional information about the context in which the given actions occurred. For this reason,
conversion tracking is integrated with several other on-line marketing features. When used together with 
Campaign tracking, conversions allow you to record actions only for visitors who arrive on the website in
a specific way (e.g. as a result of a marketing campaign).

If you wish to optimize your site to increase its conversion rate (i.e. make it more user friendly to get
better results), you may utilize A/B or Multivariate testing. These features allow you to accurately
measure how changes made to the content or structure of your website's pages affect the behavior of
users.

Conversions only record the total statistics of an action and do not store information about the specific
users who performed it, or any other details. This advanced type of tracking can however be achieved by
using the Contact Management module. It provides a way to log specific actions as Activities, including
various information about the context in which the given action occurred.

4.2 Managing conversions

To access the management interface dedicated to conversions, go to CMS Desk -> On-line marketing
-> Web analytics, expand the Campaigns & conversions category in the tree on the left and select
Conversions. This section of the UI may alternatively be reached by selecting the Conversions option
directly from the main on-line marketing menu.

The Overview contains a web analytics report displaying the number of conversions that were logged on
the website over the specified time period. 
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This report only provides a general summary of the total conversion statistics. Additional reports with
more detailed data for conversions that were logged under special circumstances are available under the 
Campaigns and Optimization -> A/B tests or MVT tests categories.

If you switch to the Conversions tab, you can view a list of all conversions defined for the current site
and manage them as necessary. 

To define a new conversion, click the  New conversion link and fill in the following properties in the
displayed dialog:

Conversion display name - the name of the conversion displayed in the administration interface
and in reports.
Conversion code name - sets a code name that serves as a unique identifier for the conversion.
Conversion description - can be used to enter text describing the conversion's purpose.
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The entered data may be modified at any time by editing ( ) the given conversion object on the
General tab. 

The Campaigns tab allows you to configure which campaigns should track the currently edited
conversion as part of their statistics. By default, campaigns log all possible conversions, so it is only
necessary to assign campaigns that are configured to work with a limited set of conversions. This type
of configuration is not available for A/B or multivariate tests, which automatically keep track of all
conversions performed on the website.

As you can see, the objects representing conversions are very simple and do not require any advanced
configuration. It is however necessary to assign the conversions to the appropriate actions to ensure that
they are logged correctly. This can be done through various other parts of the Kentico CMS
administration interface as described in the Logging actions as conversions topic.

4.3 Logging actions as conversions

This topic describes the possible options that may be used to ensure that the system logs specific
events as conversions. When assigning a conversion through the user interface, two separate fields are
provided.

The first is a standard conversion selector. You can either enter the code name of a conversion into the
text box or click the Select button to choose from a list of conversions defined for the current site. If you
enter a name that does not match any conversion in the system, a conversion with this name will
automatically be added. The New and Edit buttons allow you to create a new conversion or modify the
properties of the selected one directly from the given part of the user interface.

The second field is optional and provides a way to set a number that will be recorded along with the
conversion when the tracked action is performed. This may be used to indicate the relative importance of
the conversion, the profit generated by a single conversion hit or similar. The values are cumulative, i.e.
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when a conversion hit is logged, the specified value will be added to the total sum previously recorded for
the conversion. You may insert a Macro expression into this field to dynamically retrieve a value from the
current site context. For examples of conversion value macros, please see the sections below dedicated
to individual types of actions.

Web part and widget actions

Many of the default Kentico CMS Web parts and Widgets that allow users to perform important actions
come with built-in support for conversion tracking. To configure a specific web part or widget instance to
log actions as conversions, open its properties dialog and enter the appropriate values into the Track
conversion name and Conversion value properties.

Below you can find a list of all types of actions that can be tracked as conversions through web parts:

Action Web part(s)

User registration In this case, the conversion will be logged when a visitor successfully
completes their registration using the given web part. There are multiple
web parts that allow users to register on the website:

Registration form
Custom registration form
Facebook Connect logon and Facebook Connect required data
LinkedIn logon and LinkedIn required data
Windows LiveID and LiveID required data

http://devnet.kentico.com/docs/6_0/devguide/macro_expressions_overview.htm
http://devnet.kentico.com/docs/6_0/devguide/web_part_development_overview.htm
http://devnet.kentico.com/docs/6_0/devguide/widgets_overview.htm
http://devnet.kentico.com/docs/6_0/webparts/registrationform_overview.htm
http://devnet.kentico.com/docs/6_0/webparts/CustomRegistrationForm_overview.htm
http://devnet.kentico.com/docs/6_0/webparts/FacebookConnectLogon_overview.htm
http://devnet.kentico.com/docs/6_0/webparts/FacebookUsersRequiredData_overview.htm
http://devnet.kentico.com/docs/6_0/webparts/LinkedInLogon_overview.htm
http://devnet.kentico.com/docs/6_0/webparts/LinkedInUsersRequiredData_overview.htm
http://devnet.kentico.com/docs/6_0/webparts/WindowsLiveID_overview.htm
http://devnet.kentico.com/docs/6_0/webparts/LiveIDUsersRequiredData_overview.htm
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OpenID logon and OpenID required data

Newsletter subscription Newsletter subscriptions may be tracked as conversions through the 
Newsletter subscription web part. This can also be done for the widget
based on this web part.

Shopping cart actions The Shopping cart web part can be used to track three types of events:

Registration - occurs when a customer registers on the website
through the shopping cart.
Order - logged when a customer successfully completes an order
through the shopping cart.
Add to shopping cart - occurs when a user adds a product to the
shopping cart.

You can assign a different conversion and value to each of these actions
through the appropriate conversion name and conversion value
properties.

The conversion value properties support macro expressions, for
example:

Order conversion value: {%EcommerceContext.CurrentShoppingCart.
TotalPrice%}

This macro is resolved into the total price of all items contained in the
order, including tax and shipping. With this configuration, each Order
conversion will automatically store the price of the given order as its
value.

Add to shopping cart conversion value: {%ShoppingCartItemInfo.
UnitTotalPrice%}

With this macro as the conversion value, the Add to shopping cart
conversion will log the price (including tax) of the specific product that
was added to the shopping cart.

Filling in an on-line form A conversion can be logged when a user submits a form displayed by
the On-line form web part.

Voting in a poll The Poll web part may be used to log a conversion whenever a user
votes in the displayed poll.

Page views of specific documents

You can also use conversions to keep track of the amount of hits received by individual pages. To
configure this behaviour for a page, go to CMS Desk -> Content -> Edit, select the document
representing the given page from the content tree and switch to its Analytics -> Settings tab. To assign
a conversion and associated value, fill in the Track conversion name and Conversion value fields as
described above.

http://devnet.kentico.com/docs/6_0/webparts/OpenIDlogon_overview.htm
http://devnet.kentico.com/docs/6_0/webparts/OpenIDUserRequiredData_overview.htm
http://devnet.kentico.com/docs/6_0/webparts/NewsletterSubscription_overview.htm
http://devnet.kentico.com/docs/6_0/webparts/ShoppingCart_overview.htm
http://devnet.kentico.com/docs/6_0/webparts/BizForm_overview.htm
http://devnet.kentico.com/docs/6_0/webparts/poll_overview.htm
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The specified conversion will be logged every time the given page is opened by the website's users. You
can find an example of such a page on the sample Corporate Site under the Examples sections as
shown in the image above.

E-commerce product orders

The Shopping cart web part allows you to track entire orders, but in some cases you may wish to log a
separate conversion hit every time a product of a specific type is purchased. This can be done by
navigating to the product list in CMS Desk -> E-commerce -> Products and editing ( ) the particular
product (or by selecting a product document in the content tree and editing it on the Product ->
General tab).
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Here you can assign a conversion through the Conversion name property at the bottom of the product's
editing page. 

The Conversion value field can be used to enter an appropriate value that will be recorded for each
conversion hit. You may enter a macro expression here, for example: {%ShoppingCartItemInfo.
UnitTotalPrice%}. This macro allows the conversion to log the price of the given product as its value. The
advantage of a macro is that it retrieves the price dynamically, including tax and any potential discounts
applied by the given customer.

Please note that these properties are not available for global products, since each site has its own
separate set of conversions.

You can also use the same approach to configure different conversion settings for individual product
options (via E-commerce -> Product options -> edit Category -> Options).
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5 Campaigns

5.1 Overview

One of the most common techniques used to bring new traffic to a website are on-line marketing
campaigns. When attempting to determine if a campaign was cost-effective or when measuring its exact
results, simply tracking referring sites or URLs may not always provide sufficient data. 

In these cases, the campaign tracking support provided by the Web analytics module of Kentico CMS
may be used, which allows you to accurately monitor traffic generated by individual campaigns. This can
include banners, marketing e-mails or any other method used to present links to your website. In
addition to logging the amount of visits, this feature lets you keep records of any important actions
performed on the website by users who arrive as a result of a campaign.

How the tracking works

There are several ways to identify visitors who come to your site through a campaign link (further details
can be found in the Managing campaigns (Example) topic). When this happens, the system updates the
visit statistics and stores a cookie named Campaign in the user's browser, which saves the name of
the corresponding campaign tracking object as its value. Only one campaign may be assigned to a user
at a given time and the current value is overwritten if the user returns to the site through a different
campaign.

Until the cookie expires (its duration is 24 hours), any actions performed by the visitor that are defined
as conversions will be logged as part of the statistics kept for the campaign. Please refer to the 
Conversions chapter for information about how the tracking of individual actions can be configured. 

The currently active campaign will also be stored among the details of any Activities that are logged by
the Contact management module.

If the visitor registers on the website while the cookie is still valid, the name of the currently active
campaign will be permanently stored in their user settings (administrators may view the value in 
Administration -> edit ( ) user -> Settings -> Campaign). This data field only serves to provide
information about users and is not used to track activity on the website.

Campaign statistics and results can be viewed using special reports available in the web analytics
interface, which are described in the Evaluating campaigns topic.

5.2 Managing campaigns (Example)

Each marketing campaign is represented in the system by a corresponding object. To configure these
objects, go to CMS Desk -> On-line marketing and select Campaigns from the menu. Then, switch to
the Campaigns tab, where you can view a list of all campaigns defined for the current website and
manage them as needed.

By default, the Corporate Site contains a single campaign called Sample campaign.
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To better demonstrate the functionality of campaigns, we will need two additional ones. Click the 
New campaign link to create a new campaign and fill in the following properties:

Campaign display name: Banner campaign; the name of the campaign displayed in the
administration interface (in campaign lists and reports).
Campaign name: Banner1; sets a code name that serves as a unique identifier for the campaign. It
is also stored as the value of the Campaign browser cookie used to identify visitors who came to the
website through the given campaign.
Campaign description - can be used to enter a text description for the campaign in order to give
information about its purpose, goals etc. You may leave this empty.
Open from/to - sets the time interval during which the campaign should be active. The Calendar
button ( ) can be used to select an exact date and time. Leave these empty for this example.
Enabled - this property may be used to manually start or stop the campaign. Visitor statistics and
actions will not be logged for disabled campaigns. Leave the box checked.

Click OK to add the campaign. The General tab of the campaign's editing interface will now be
displayed, where you can modify the fields listed above at any time. Several additional properties are
also available, but these are described later in this chapter.

Return to the campaign list and add a third campaign with the following names:

Campaign display name: E-mail marketing
Campaign name: Emails
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Now that some campaign tracking objects are prepared, it is necessary to ensure that visitors who
access the website through marketing campaigns are correctly identified and assigned to the
appropriate object. There are three different ways how this can be done.

1. URL parameter

This method utilizes a URL query string parameter to indicate that the traffic source is a campaign. All
you need to do is enter the name of the parameter that you wish to use into the Site Manager ->
Settings -> On-line marketing -> Web analytics -> Campaign tracking URL parameter setting.

For now, leave the setting with its default value (campaign).

Open a new tab in your browser and enter the URL of your site's Home page into the address bar.
Include the campaign tracking parameter and set its value to samplecampaign (the name of the default
campaign):

http://localhost/KenticoCMS/Home.aspx?campaign=samplecampaign

You will have to adjust the URL according to the domain of your website. You may also need to Close
the preview mode of the page to get to the actual live site. The Home page will be opened as usual, but
the system will recognize that you have arrived via a campaign. Scroll down to the bottom of the page
and click the Examples link under the Where to learn more? section. On this page, use the menu on
the left to reach On-line marketing -> Optimization -> Conversion page, which will cause a sample
conversion to be logged.
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Because the Sample campaign is currently active in your browser, the conversion will also be recorded
in the campaign statistics. You can try reloading the page several times to log multiple conversions.

In a real-world scenario, you would need to ensure that all links to your website placed in the given
campaign's marketing materials contain the tracking parameter with the name of the appropriate
campaign object as the value. This type of campaign tracking is not limited to a specific document and
may be used when linking to any page on the website.

2. Document-specific campaigns

Alternatively, you can configure a document to behave as a campaign landing page. When this type of
page is viewed by a user, a specified campaign will automatically be assigned.

To ensure accurate campaign tracking, it is recommended to create a special page that will not be
available in the website's standard navigation, since the campaign will be assigned to all users who view
this page (and repeated views by the same user will also be logged as campaign visits). When using this
approach, all of the campaign's links need to be directed at this special landing page.

Log back in to CMS Desk, select the Special Pages folder in the content tree and create a New page
under it named Landing page. You can choose the Create a blank page option in the template
selection dialog, since the content of the page is not important for the purposes of this example. 

Select the new document and switch to its Analytics -> Settings tab. Here, click the Select button
next to the Track campaign field and choose Banner campaign in the displayed dialog. Then click
the Save button.
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Now open this new page on the live site (you can access it through its URL: <domain>/SpecialPages/
Landing-Page.aspx). The Banner campaign will become active, replacing the previously assigned
campaign. Navigate to Examples -> On-line marketing -> Optimization -> Conversion page again,
so that a conversion is logged for this campaign as well.

3. Campaigns for document aliases

You can also define campaign tracking for a page's specific Document alias. This approach is useful if
you wish for the campaign to link visitors to an easily accessible page, but want to avoid using a query
string parameter. The campaign will only be assigned to users who access the document through this
alias. 

Select the Home page from the content tree in CMS Desk and go to Properties -> URLs. Here, click
the  Add new alias link and configure the alias's settings as shown below:

Path type: Standard URL or wildcard
Path or pattern: /EmailCampaign/Home
Track campaign: select the E-mail marketing campaign

http://devnet.kentico.com/docs/6_0/devguide/Multiple_document_aliases.htm
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Click OK and the alias will be created.

To activate the campaign, open the Home page of the site through the URL of this alias (<domain>/
EmailCampaign/Home.aspx). This will override the previous campaign and you can visit the sample
Conversion page again.

The campaign tracking methods are listed in the order of their priority. So if a campaign is specified for a
document via Settings -> Analytics, but the page is also accessed via a URL containing a tracking
parameter, the campaign specified via the parameter will be assigned to the given visitor.

Continue in the Evaluating campaigns topic to see how you can view the results of these steps. Keep in
mind that this sample scenario only serves to quickly demonstrate the functionality of campaigns. In the
case of a real campaign, visitors would not need to enter URLs manually, but would simply follow the
appropriate links and the system would keep track of more practically defined conversions.

Advanced campaign settings

As you may have noticed, there are some additional configuration options that may be specified when
editing campaigns in the CMS Desk -> On-line marketing interface.

On the General tab, the Campaign impressions and Total cost values may be used to help evaluate
the campaign and calculate its goals. An important property is the Campaign condition, which allows
you to set a macro condition that must be fulfilled in order for the campaign to be assigned to visitors.



Campaigns 37

© 2012 Kentico Software

For example: Cook ies.Campaign != "Banner1"

This sample condition checks the value of the Campaign cookie and prevents the edited campaign
(E-mail marketing) from being assigned to visitors who are already being tracked by the Banner1
campaign. In practice, this would mean that if a visitor was brought to the site through a banner and then
later clicked on a link in a marketing e-mail, the banner campaign would remain active instead of being
overwritten.

You can write any other type of condition according to your specific requirements. Through the edit icon
( ), you can open the Macro condition editor, which provides a graphical interface that makes it easier
to build complex conditions. For more information about the available macro options, please refer to 
Internals and API -> On-line marketing macros.

If you switch to the Conversions tab, you can configure which Conversions should be tracked by the
campaign. There are two possible options:

All conversions will be tracked for the campaign - if chosen, any conversion hit logged on the
entire website will be included in the campaign's statistics.
Only the selected conversions will be tracked for the campaign - this option allows you to limit
which conversions should be tracked. Specific conversions may be assigned to the campaign by

http://devnet.kentico.com/docs/6_0/devguide/index.html?entering_macro_expressions.htm#conditioneditor
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clicking the Add conversions button and choosing from the list in the displayed dialog.

In both cases, only conversions performed by visitors who arrive on the website as a result of the given
campaign will be logged.

Automatic campaign creation

When a visitor comes to the website through an undefined campaign (typically specified
via the tracking URL parameter), it will be ignored by default and no campaign tracking
will be performed. 

If you wish to change this behaviour, edit your application's web.config file and add the
following key to the /configuration/appSettings section:

<add key="CMSEnableAutomaticCampaignCreate" value="true" />

Once this is done, unknown campaigns will automatically be added to the list of
campaign objects for the given website.

Campaigns created this way will be enabled by default and active for an unlimited time
interval, but they can be configured using the same approach as mentioned above at
any time.

5.3 Evaluating campaigns

The statistics logged for campaigns may be viewed using various types of web analytics reports. To
access these reports, go to CMS Desk -> On-line marketing -> Web analytics and expand the
Campaigns & conversions -> Campaigns category.
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Here you can check the results of the sample campaigns created according to the instructions in the 
Managing campaigns (Example) topic. Because of the way the analytics log is processed, you may
have to wait approximately one minute before conversion hits or campaign visits are reflected in the
reports.

Campaign reports use the same basic format as all other web analytics reports, so please refer to Web
analytics -> Using web analytics reports for details about the actions that can be used to filter or
otherwise manage the displayed data. The following types of reports are available for campaigns:

Overview Displays the amount of hits that the website received as a result of the
selected campaign(s). It contains a line chart that shows the number of
visits recorded over time and a table with the total amount of page views
generated by the given campaigns during the entire time period.

Conversions count Displays the number of conversion hits that were performed by users
who arrived on the website through the selected campaign. 

This report includes two types of charts, one that shows the progress of
the amount of conversion hits recorded during the specified time period
and another with detailed statistics for individual units of time according
to the selected report type (hours, days, months etc.).

Conversions value Displays the sum of the conversion values generated by users who
arrived on the website through the selected campaign.

This report includes two types of charts, one that shows the progress of
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the conversion values recorded during the specified time period and
another with detailed statistics for individual units of time according to
the selected report type.

Campaign details Displays the values of the following campaign metrics:

Visits - the amount of hits that the website received as a result of the
given campaign.
Conversions - the number of conversions that were performed by
users who arrived on the site through the campaign.
Conversions rate - the percentage of visitors that performed a
conversion. This can be higher than 100% if the average visitor
generated more than one conversion.
Conversions value - the total sum of the values recorded for all of
the campaign's conversions.
Conversions value per visit - the average conversion value
contributed by the campaign's visitors.
Total cost - shows the total cost that was specified for the given
campaign.
ROI - the rate of investment, calculated as the sum of the
campaign's conversion values divided by the total cost. This statistic
is accurate only if your conversion values are set to reflect the
income generated by the matching conversions.

You can either choose to view all campaigns defined for the website and
compare their values, or select a specific campaign and analyze the
statistics logged for individual types of conversions.

Server campaigns May be used to compare the results of campaigns created for different
sites in the system. You can choose to display the Views, Conversion
count or Conversion value statistics for the campaigns belonging under
the selected site.

Campaign goals

In addition to the data provided by the reports listed above, you can optionally specify goals that should
be achieved by each campaign and then compare them with the actual results.

To enter a campaign's goals, select one of the reports and switch to the Campaigns tab, which
contains the campaign management interface (the same one that is available under the Campaigns
item in the main on-line marketing menu). Next, edit ( ) a campaign. On the General tab, the following
two properties are available among the advanced settings:

Campaign impressions - this field can be used to specify how many people were targeted by the
given marketing campaign. For example, if you sent marketing e-mails containing a link to the
website to ten thousand people, the amount of impressions would be 10000. 
Total cost - allows you to manually enter the total cost of the given marketing campaign. This can be
used to determine whether the campaign was a success and when calculating the campaign's goals.

Now switch to the Goals tab, where you can configure the following types of target values for the
campaign:
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Number of visitors - sets how many visitors should be brought to the website by the campaign. It
can either be specified directly as an Absolute number, or as a percentage of the campaign's
Impressions according to the value set on the General tab.
Number of conversions - specifies the expected amount of conversions performed by users who
visit the website as a result of the campaign. It can either be specified directly as an Absolute
number, or as a percentage of the campaign's Impressions.
Total value of conversions - sets a target number for the sum of all conversion values logged as a
result of the campaign. It can either be specified directly as an Absolute number, or as a percentage
of the campaign's Total cost.
Value per visitor - this indicator allows you to specify the average conversion value that should be
generated by a single campaign visitor. It is calculated as the campaign's Total value of conversions
divided by its Number of visitors. The value can either be specified directly as an Absolute number,
or as a percentage of the campaign's Cost per visitor (i.e. the Total cost divided by the Number of
Visitors).

Each goal may have two values. The Red flag may be used to set a number that must be reached in
order for the campaign to be at least partially successful (campaigns below this value are considered to
have failed). The Goal value sets a target that should ideally be achieved by the campaign. The progress
that individual campaigns make towards their goals can then be followed using the corresponding reports
under the Goals sub-category in the web analytics tree.
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The red flag and goal values configured for the selected statistic are displayed in the reports as red and
green lines, so you can easily see the current status of the specified campaign.

Reports for individual campaigns

Any of the reports described above may also be viewed when editing a campaign in CMS Desk ->
On-line marketing -> Campaigns on the Reports tab. You can choose a specific report via the radio
buttons at the top of the page.
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Only the data logged for the given campaign is displayed here.
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6 Contact management

6.1 Overview

The Contact management module is an on-line marketing tool which provides a centralized overview of all
users who visit your website. It can be used to gather information about them and about the activities
that they perform on the website. The data gathered by the module can be used to track campaign
results, analyze client behavior, optimize content, identify potential buyers and perform other
marketing-related actions.

To get started with the module, it is important to get familiar with the following basic terms represented
by objects of the module. Click the links to learn more about the particular objects, their management,
use and configuration.

Contact - a single person who visits the website and about whom information is gathered by the
module.
Account - a company or other commercial or non-commercial body where a contact operates.
Individual contacts can belong to multiple accounts and an account can be a subsidiary of another
account.
Contact role - the role which a contact has in an account. It is typically a job position or a type of
competence which the contact has within the account. One contact can have only one role in one
account.
Contact status - individual contacts can be labeled with pre-defined statuses. One contact can be
labeled with only one status at a time.
Account status - individual accounts can be labeled with pre-defined statuses, similarly as contacts,
while there are separate sets of statuses for contacts and accounts. One account can be labeled
with only one status at a time.
Contact group - taxonomy units which enable you to sort contacts into groups. Contacts can be
added to groups either manually, or automatically based on dynamically evaluated macro conditions.
It is also possible to add an account to a contact group, which makes all contacts belonging to the
account belong to the contact group as well.

The sample diagram below depicts how relationships between the objects may look in a real world
scenario. It shows three contacts who operate as different roles in three accounts. They are grouped in
two contact groups and both contacts and accounts are labeled with statuses.
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In certain situations, it may happen that you have multiple contacts or accounts in the system and get
to the conclusion that they actually represent one object. In the Merging contacts and accounts sub-
chapter, you can learn how to get rid of such duplicate contacts or accounts by merging them into a
single object.

Another important part of the Contact management module are Activities. Activities are actions that a
contact performs on the website, e.g. visit a page, vote in a poll, add a product to their shopping cart or
wishlist, etc. These activities can be tracked and logged so that you can view a log of all activities that
individual contacts performed. You can deduce conclusions about the contacts from the activities that
they performed and the logged activities can also be used for contact evaluation by the Scoring module.

In the end of this chapter, you can find the Configuration sub-chapter. In it, you can learn how to enable
the use of global objects in this module, and how to define account statuses, contact statuses and
contact roles.

6.2 Contacts

6.2.1 Overview

A contact in Kentico CMS is an object representing a single person who visits the website and about
who the Contact management module gathers information. It can thus stand behind an anonymous
visitor identified by IP or cookie or a regular user identified by username or e-mail. A contact can have its
website activities tracked and analyzed, it can be grouped together with other contacts, assigned with a
contact status (e.g a V.I.P. contact) or contact role (e.g. Designer) and it can be associated with
accounts, i.e. companies and other commercial and non-commercial bodies, in which it operates.
Besides, stored as a system table, a contact supports custom fields.

Further in this chapter, you will learn how to manage contacts and you will also see an example of
adding a new contact to your Contact management.
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6.2.2 Managing contacts

In this topic you will learn how to manage contacts. Contacts can be managed in:

CMS Desk -> On-line marketing -> Contacts
Site Manager -> Tools -> Contact management -> Contacts

The user interface in CMS Desk allows management of contacts that belong to the currently edited
website. The one in Site Manager allows management of contacts belonging to all websites running in
the system. If global contacts are enabled, they can be managed in both sections.

On the initial page of the user interface, you can see a list of contacts available on the current site. You
may need to display only contacts matching certain search criteria (e.g. first name, last name, e-mail
etc.). To do so, choose either the simplified or advanced filter, enter the required values and click 
Search.

Individual contacts can be Edited ( ) or Deleted ( ) and you can also perform  Other actions such
as  Export,  Backup or  Restore. New contacts can be added after clicking the  New contact
link.

Using the pair of drop-down lists below the list, you can perform certain contact management tasks with
multiple contacts at once, specifically adding contacts to a contact group, deleting and merging
contacts or changing their status. To do this, choose either Selected contacts or All contacts from the
first drop-down list, the required action from the second one and click OK.

If editing a contact, the following tabs are available:

General tab
Custom fields tab
Accounts tab
Membership tab
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Activities tab
IPs tab
Contact groups tab
Scoring tab
Merge tab

General tab

On this tab you can edit properties of a selected contact. When you have modified the values, click 
Save to save the contact.

General
First name - the first name of the contact.
Middle name - the middle name of the contact.
Title before - allows to define a contact title used before the name.
Last name - the last name of the contact.
Salutation - allows to define a contact salutation.
Title after - allows to define a contact title used after the name.

Personal info
Birthday - the birthday of the contact. Enter the value manually, use the Calendar ( ) or use the
Now link.
Gender - the gender of the contact.
Job title - the job title of the contact.
Created - indicates when the contact was created.

Contact settings
Contact status - allows to select a contact status. If defined, the contact can be labeled with a
contact status, e.g. a V.I.P. contact.
Track activities - if enabled, allows to track contact activities.
Contact owner - allows to define a contact owner, i.e. a user responsible for management of the
given contact.
Campaign - allows to choose a Campaign to be associated with the current contact.

Address
Address 1 - the first line of the contact's address.
Address 2 - the second line of the contact's address.
City - allows to define the city where the contact has their address.
Zip code - allows to define the zip code of the area where the contact has their address.
Country - allows to define the country where the contact has their address.
Mobile phone - the mobile phone number of the contact.
Home phone - the home phone number of the contact.
Business phone - the business phone number of the contact.
E-mail - the e-mail address of the contact.
Web URL - the web URL of the contact.

Notes - you can leave contact notes either as plain text or as text with basic formatting, and you can
also add your stamp by clicking the Add stamp button.

Please note that if you are viewing properties of a merged contact, the  Split from parent link is
available on the page, enabling you to split the current contact from the parent one.
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Custom fields tab

On this tab you can enter custom field values of the current contact, as defined in Site manager ->
Development -> System tables -> Edit ( ) Contact management - Contact on the Fields tab. When
you have entered the values, click OK to save the changes.
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Accounts tab

On this tab you can see a list of accounts assigned to the current contact and you can also assign
accounts by clicking the  Add accounts link. If you decide to do so, the Select account dialog
opens, enabling you to assign selected accounts to the current contact; optionally, a contact role may
be selected (if defined). Please note that if you edit a global contact, only global accounts are offered.
Similarly, if you edit a site contact, only current site accounts are offered.

You can View account details ( ) of individual accounts and you can also Select contact role ( )
or Remove ( ) an account. The displayed list can be sorted by account name, contact role, account
status and country.

Using the pair of drop-down lists below the list, you can perform certain management tasks with multiple
accounts at once, specifically Selecting contact role or Removing accounts. To do this, choose either
Selected accounts or All accounts from the first drop-down list, the required action from the second one
and click OK.

Membership tab

On this tab you can manage the current contact's memberships, i.e. users, e-commerce customers and
newsletter subscribers that should be associated with the currently edited contact. 

The following tabs are available under the Membership tab:

Users - here you can see a list of users under the current contact and you can also manually add
users using the  Add users link. Please note that the usual scenario is that a contact acts as one
registered user. However, more users can be assigned to a contact.
Customers - here you can see a list of customers under the current contact and you can also
manually add customers using the  Add customers link.
Subscribers - here you can see a list of subscribers under the current contact and you can also
manually add subscribers using the  Add subscribers link.

On each tab, the listed items can be Deleted ( ) and the list can be sorted e.g. by name and e-mail.

You may need to display only items matching certain search criteria (e.g. first name, last name, e-mail)
on the respective tabs. To do so, enter the required values and click Search.

Detailed information on memberships in Kentico CMS can be found in the Memberships chapter in the
same section of the Developer's Guide.

http://devnet.kentico.com/docs/6_0/devguide/membership_overview.htm
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Activities tab

On this tab you can see a list of the current contact's activities, e.g. user registration, blog post
subscription, poll voting etc. However, activities are logged only if the Enable on-line marketing setting
is enabled in Site Manager -> Settings -> On-line marketing and the Log activities setting is
enabled in Site Manager -> Settings -> On-line marketing -> Activities.

Individual activities can be Viewed ( ) or Deleted ( ). The displayed list can be sorted by title, type,
IP address and activity time.

You may need to display only activities matching certain search criteria (e.g. activity type, title etc.). To
do so, fill in the fields as required and click Search.
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IPs tab

On this tab you can see a list of IP addresses from which the current contact accessed the website. The
listed items can be Deleted ( ) and you can also Export (  -> ) the items. The displayed list can
be sorted by IP address and activity time. 

You may need to display only IP addresses matching certain search criteria (IP address, time period).
To do so, fill in the respective fields as required and click Search.

Contact groups tab

On this tab you can see a list of contacts groups to which the current contact is assigned. You can also
add the contact to other contact groups by clicking the  Add to contact groups link. Individual items
can be Removed ( ) from the list, which results in the current contact being removed from the



Contact management 53

© 2012 Kentico Software

respective contact group. 

Scoring tab

On this tab you can see a list of scores in which the current contact achieved some points, together with
the actual score point values. By clicking the View ( ) icon, the respective score's management
interface is opened in a pop-up window. The interface is identical to the one displayed when editing ( )
a score in CMS Desk -> On-line marketing -> Scoring.

Merge tab

On this tab you can merge other contacts with the currently edited contact so that only the currently
edited contact remains. This is useful in cases when you come to the conclusion that multiple contacts
actually represent a single real-world person. On the tab, you can also view a list of contact that have
been merged with it and split them back into separate contacts if needed. Detailed information on
merging in Kentico CMS can be found in the Merging contacts and accounts chapter.

6.2.3 Contact statuses

Contacts can be labeled with statuses in order to reflect their relationship to your organization or to
indicate how they are perceived from the marketing point of view. Statuses can be assigned to individual
contacts in the Contact status field on the General tab of each contact's editing interface. One contact
can be labeled with only one status at a time. 
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There is a pre-defines set of contact statuses for each website. The sets of statuses can be managed in
the following sections of the user interface:

CMS Desk -> On-line marketing -> Configuration -> Contact status
Site Manager -> Tools -> Contact management -> Configuration -> Contact status

The user interface in CMS Desk allows management of contact statuses pre-defined for the currently
edited website. The one in Site Manager allows management of contact statuses for all websites running
in the system. If global contact statuses are enabled, they can be managed in both sections.

Properties of contact statuses listed in the mentioned sections of the user interface can be edited after
clicking the Edit ( ) icon in a respective contact role's row. By clicking the Delete ( ) icon, you can
delete the contact status so that it is no longer present and available in the system. The Export ( )
action available in the drop-down menu ( ) in each row enables you to export the respective status into
a file and subsequently import it on another Kentico CMS instance.

Creating a new contact status
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If you want to add a new contact status to the set of listed statuses, click the  New contact status
link above the list. After doing so, you need to specify the following properties in the New contact status
dialog:

Display name - name of the contact status used in the system's user interface.
Code name - name of the contact status used in web project code.
Description - text describing the contact status.

Once you have the properties specified, click OK for the new status to be created.

6.2.4 Contact roles

Contact roles enable you to specify the role of a contact in an account. It is typically a job position or a
type of competence which a person has in the organization, e.g. CEO, CFO, Decision maker, etc. The
role of a contact in an account can be specified after clicking the Select contact role ( ) icon on the
Contacts tab of each account's editing interface. One contact can only have one role in one account.

There is a pre-defined set of contact roles for each website. The sets of roles can be managed in the
following sections of the system's user interface:

CMS Desk -> On-line marketing -> Configuration -> Contact role
Site Manger -> Tools -> Contact management -> Configuration -> Contact role

The user interface in CMS Desk allows management of contact roles pre-defined for the currently edited
website. The one in Site Manager allows management of contact roles for all websites running in the
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system. If global contact roles are enabled, they can be managed in both sections.

Properties of contact roles listed in the mentioned sections of the user interface can be edited after
clicking the Edit ( ) icon in a respective contact role's row. By clicking the Delete ( ) icon, you can
delete the contact role so that it is no longer present and available in the system. The Export ( ) action
available in the drop-down menu ( ) in each row enables you to export the respective status into a file
and subsequently import it on another Kentico CMS instance.

Creating a new contact role

If you want to add a new contact role to the set of listed roles, click the  New contact role link above
the list. After doing so, you need to specify the following properties in the New contact role dialog:

Display name - name of the contact role used in the system's user interface.
Code name - name of the contact role used in web project code.
Description - text describing the contact role.

Once you have the properties specified, click OK for the new contact role to be created. 

6.2.5 Example: Creating a sample contact

Here you will learn how to create a new contact.

A new contact can be created automatically on the live site, e.g. if an anonymous visitor browses the
website for some content or if a new user registers there, and manually in the administration interface.
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On the live site

When an anonymous website visitor comes to the website for the first time, a contact is created for
them automatically. When the same visitor registers on the live site as a new user, a new contact An
example of creating a new contact on the live site can be found in the Activities -> Example topic in the
Contact management section of this guide.

In the administration interface

1. Sign in as an administrator, go to CMS Desk -> On-line marketing -> Contacts (alternatively, you
can navigate to the Contacts tab in Site Manager -> Tools -> Contact management) and click the 
 New contact link.

2. In the New contact dialog, enter the following properties:

First name: James
Last name: Watson
Contact status: select a contact status, if no statuses were defined yet, please refer here to see
how to do it
Gender: Male
Job title: Marketing specialist
Address 1: 55 Hawthorn Drive
City: Bristol
ZIP code: BS3 7WJ
Country: United Kingdom
E-mail: james.watson@localhost.local

Once entered, click Save ( ) for the contact to be created.
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3. Optionally, switch to the Accounts tab, click the  Add accounts link and in the Select account
dialog select accounts which should be assigned to the contact. Click OK. Please note that at least one
account must be defined to be able to perform this step. If no accounts were defined yet, please refer
here to see how to do it.

4. Optionally, switch to the Membership tab and on the respective tabs add users, customers or
subscribers that should be associated with the new contact.
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5. Optionally, switch to the Contact groups tab, click the  Add to contact groups link and in the
Select contact groups dialog select contact groups to which the contact should be added. Click OK.
Please note that at least one contact group must be defined to be able to perform this step. If no contact
groups were defined yet, please refer here to see how to do it.

6. If you now view the list of contacts, you can see that the new contact is listed among other contacts.
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6.3 Accounts

6.3.1 Overview

An account in Kentico CMS is an object representing a single organization, i.e. a company or other
commercial or non-commercial body. The object can be site-specific or shared across more websites (
global account). It contains multiple contacts, can have subsidiaries and can be assigned with an
account status. Besides, stored as a system table, an account supports custom fields.

Further in this chapter, you will learn how to manage accounts and you will also see an example of
adding a new account to your Contact management.

6.3.2 Managing accounts

In this topic you will learn how to manage accounts. Accounts can be managed in:

CMS Desk -> On-line marketing -> Accounts
Site Manager -> Tools -> Contact management -> Accounts

Here you can see a list of accounts available on the current site and you can also create new accounts 
by clicking the  New account link. Please note that you can always create site-specific accounts
and, if the use of global accounts is allowed, also accounts shared across more websites.

You may need to display only accounts matching certain search criteria (e.g. account name, account
status, e-mail etc.). To do so, choose either the simplified or advanced filter, enter the required values
and click Search.

Individual accounts can be Edited ( ) or Deleted ( ) and you can also perform  Other actions such
as  Export,  Backup or  Restore. The displayed list can be sorted by account name, account
status, primary contact and country.

Using the pair of drop-down lists below the list, you can perform certain contact management tasks with
multiple accounts at once, specifically adding accounts to a contact group, deleting and merging
accounts or changing the account status. To do this, choose either Selected contacts or All contacts
from the first drop-down list, the required action from the second one and click OK.
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If editing an account, the following tabs are available:

General tab
Custom fields tab
Contacts tab
Subsidiaries tab
Merge tab

General tab

On this tab you can edit properties of a selected account. When you have modified the values, click 
Save to save the account.

General
Account name - the name of the account. Accounts usually represent companies or other
commercial or non-commercial bodies.
Account status - allows to select an account status. If defined, the account can be labeled with an
account status, e.g. a V.I.P. account.
Subsidiary of - allows to select an account, i.e. company or other commercial or non-commercial
body, of which the current account is a subsidiary.
Account owner - allows to define an account owner, i.e. user responsible for management of the
current account.

Address
Address line 1 - the first line of the account's address.
Address line 2 - the second line of the account's address.
City - allows to define the city where the account has its address.
Zip code - allows to define the zip code of the area where the account has its address.
Country - allows to define the country where the account has its address.
Phone - the phone number of the account.
Fax - the fax number of the account.
E-mail - the e-mail address of the account.
Website URL - the website URL of the account.
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Contacts
Primary contact - the most important contact assigned to the current account; e.g. a company's
CEO. Please note that you can select a primary contact only if at least one contact is assigned to
the current account.
Role - if defined, allows to assign the primary contact with a contact role, e.g. CEO.
Secondary contact - the second most important contact assigned to the current account; e.g. a
company's CFO. Please note that you can select a secondary contact only if at least one contact is
assigned to the current account.
Role - if defined, allows to assign the secondary contact with a contact role, e.g. CFO.

Notes - you can leave account notes either as plain text or as text with basic formatting, and you can
also add your stamp by clicking the Add stamp button.

Please note that if you are viewing properties of a merged account, the  Split from parent link is
available on the page, enabling you to split the current account from the parent one.

Custom fields tab
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On this tab you can enter custom field values of the current account, as defined in Site manager ->
Development -> System tables -> Edit ( ) Contact management - Account on the Fields tab.
When you have entered the values, click OK to save the changes.

Contacts tab

On this tab you can see a list of contacts assigned to the current account and you can also add
contacts by clicking the  Add contacts link. If you decide to do so, the Select contact dialog opens,
enabling you to assign selected contacts to the current account; optionally also with a selected role (if
defined). Please note that if you edit a global account, only global contacts are offered. Similarly, if you
edit a site account, only current site contacts are offered.

You can View contact details ( ) of individual contacts and you can also Select contact role ( ) or
Remove ( ) a contact. The displayed list can be sorted by contact first name, last name, e-mail,
contact role, contact status and country.

Using the pair of drop-down lists below the list, you can perform certain management tasks with multiple
contacts at once, specifically Selecting contact role or Removing contacts. To do this, choose either
Selected contacts or All contacts from the first drop-down list, the required action from the second one
and click OK.

Subsidiaries tab

On this tab you can see a list of accounts which are subsidiaries of the current account. You can also
add accounts to be recognized as subsidiaries of the current account by clicking the  Add accounts
link. If you decide to do so, the Select account dialog opens, enabling you to assign these accounts.
Please note that if you edit a global account, only global accounts are offered; similarly, if you edit a site
account, only current site accounts are offered.
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You can View details ( ) of individual accounts or Remove ( ) them. The displayed list can be sorted
by account name, account status, primary contact and country.

Using the pair of drop-down lists below the list, you can perform the Remove action for multiple accounts
at once. To do this, choose either Selected accounts or All accounts from the first drop-down list, the
action from the second one and click OK.

Merge tab

On this tab you can merge other accounts with the currently edited account so that only the currently
edited account remains. This is useful in cases when you come to the conclusion that multiple accounts
actually represent a single real-world organization. On the tab, you can also view a list of accounts that
have been merged with it and split them back into separate accounts if needed. Detailed information on
merging in Kentico CMS can be found in the Merging contacts and accounts chapter.

6.3.3 Account statuses

Accounts can be labeled with account statuses in order to reflect their relationship to your organization
or to indicate how the account is perceived from the marketing point of view. Statuses can be assigned
to accounts in the Account status field on the General tab of each account's editing interface. One
account can be labeled with only one status at a time. 
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There is a pre-defined set of account statuses for each website. The sets of statuses can be managed in
the following sections of the user interface:

CMS Desk -> On-line marketing -> Configuration -> Account status
Site Manager -> Tools -> Contact management -> Configuration -> Account status

The user interface in CMS Desk allows management of account statuses pre-defined for the currently
edited website. The one in Site Manager allows management of account statuses for all websites
running in the system. If global account statuses are enabled, they can be managed in both sections.

Properties of account statuses listed in the mentioned sections of the user interface can be edited after
clicking the Edit ( ) icon in a respective account status's row. By clicking the Delete ( ) icon, you can
delete the account status so that it is no longer present and available in the system. The Export ( )
action available in the drop-down menu ( ) in each row enables you to export the respective status into
a file and subsequently import it on another Kentico CMS instance.

Creating a new account status

If you need to add a new account status to the set of listed statuses, click the  New account status
link above the list. After doing so, you need to specify the following properties in the New account
status dialog:

Display name - the name of the account status used in Kentico CMS user interface.
Code name - the name of the account status used in the code.
Description - the description of the account status.
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Once you have the properties specified, click OK for the new status to be created.

6.3.4 Example: Creating a sample account

Here you will learn how to create a new account.

1. Sign in as an administrator and go to CMS Desk -> On-line marketing -> Accounts and click the 
 New account link.

2. In the New account dialog, enter for example the following properties:

Account name: Kentico Software
Account status: select an account status, if no statuses were defined yet, please refer here to see
how to do it
Account owner: Luke Hillman (LukeH)
Address line 1: AXA Centrum
City: Brno
Zip code: 60200
Country: Czech Republic
Phone: +420-511-180-800
E-mail: info@localhost.local

Once entered, click  Save for the new account to be created.
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3. The account is now created and you are redirected to the General tab of its editing interface. If you
want to add contacts to it, switch to the Contacts tab and click the  Add contacts link. In the Select
contact dialog which pops up, select contacts who should belong to the account, e.g. James Watson
defined in Contacts -> Example: Creating a sample contact, and click OK.

4. Optionally, switch to the Subsidiaries tab, click the  Add accounts link and in the Select
account dialog select accounts which should be recognized as subsidiaries of the current account.
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Click OK.

6. If you now view the list of accounts in CMS Desk -> On-line marketing -> Accounts, you can see
that the new account is listed among other accounts. 

6.4 Contact groups

6.4.1 Overview

Contact groups in Kentico CMS are objects enabling you to group contacts according to the required
criteria. One contact can be contained in several different contact groups. Assignment to more contact
groups at a time applies also to accounts. However, if a particular account is contained in a contact
group, all its contacts belong to this group, too. Besides, contact groups can be site-specific or shared
across more websites (global contact group). They are thus convenient for various marketing activities,
e.g. for e-mail marketing.

Further in this chapter, you will learn how to manage contact groups and you will also see an example of
creating a new contact group.

6.4.2 Managing contact groups

In this topic you will learn how to manage contact groups. Contact groups can be managed in:
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CMS Desk -> On-line marketing -> Contact groups
Site Manager -> Tools -> Contact management -> Contact groups

Here you can see a list of contact groups available on the current site and you can also create new
contact groups by clicking the  New contact group link. Please note that you can always create
site-specific contact groups and, if the use of global contact groups is allowed, also contact groups
shared across more websites.

Individual contact groups can be Edited ( ) or Deleted ( ) and you can also perform  Other actions
such as  Export,  Backup or  Restore. The displayed list can be sorted by contact group name
and, optionally, site.

If editing a contact group, the following tabs are available:

General tab
Contacts tab
Accounts tab

General tab

On this tab you can edit properties of a selected contact group. When you have modified the values,
click  Save to save the contact group.

Display name - the name of the contact group used in Kentico CMS user interface.
Code name - the name of the contact group used in the code.
Description - the description of the contact group.
Dynamic condition - allows to define a macro condition. If defined, a contact which fulfills the given
condition is assigned to the current contact group.
Macro condition - use the text area to define a macro condition, e.g. contact's city is London.
Alternatively, you can click Edit ( ) to edit the macro condition in the Edit macro condition dialog
window. For more details on using macros in Kentico CMS, please refer to the Macro expressions
chapter in the Development section of the Developer's Guide.
Schedule rebuild - if enabled, the current contact group is automatically rebuilt in accordance with
the defined macro condition.

You can also manually rebuild the contact group according to a macro condition (if defined) by clicking
the  Rebuild contact group link or view Contact group info containing information on the number of
contacts in the current contact group, its status and last rebuild time.

http://devnet.kentico.com/docs/6_0/devguide/macro_expressions_Overview.htm
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Contacts tab

On this tab you can see a list of contacts assigned to the current contact group and you can also add
contacts to the group by clicking the  Add contacts link. If you decide to do so, the Select contact
dialog opens, enabling you to assign selected contacts to the current contact group. Please note that if
you edit a global contact group, current site contacts and optionally global contacts are offered; however,
if you edit a site contact group, only current site contacts are offered.

You can View contact details ( ) of individual contacts and you can Remove ( ) contacts. The
displayed list can be sorted by contact first name, last name, e-mail, contact status, country etc.
Besides, the list provides information on how a particular contact was added to the contact group:

Dynamic - indicates if the contact was added based on a dynamic condition.
From account - indicates if the contact was added together with an account with which it is
associated.
Manual - indicates if the contact was added manually, using the Select contact dialog window.

Using the pair of drop-down lists below the list, you can perform the Remove action for multiple contacts
at once. To do this, choose either Selected contacts or All contacts from the first drop-down list, the
action from the second one and click OK.

Please note

Contacts added to the current contact group otherwise than by assigning an associated
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account, i.e. either dynamically based on a condition or manually, remain in the
contact group after removing the respective account from it.

Similarly, this holds true also to contacts added to the group dynamically providing the
respective dynamic condition ceased to apply.

Accounts tab

On this tab you can see a list of accounts assigned to the current contact group and you can also add
accounts to the group by clicking the  Add accounts link. Please note that adding an account to a
contact group results in adding all contacts associated with this account to the group. If you decide to
add accounts, the Select account dialog opens, enabling you to assign selected accounts to the
current contact group. Please note that if you edit a global contact group, current site accounts and
optionally global accounts are offered; however, if you edit a site contact group, only current site
accounts are offered.

You can View account details ( ) of individual accounts and you can Remove ( ) accounts. The
displayed list can be sorted by account name, account status, country etc.

Using the pair of drop-down lists below the list, you can perform the Remove action for multiple accounts
at once. To do this, choose either Selected accounts or All accounts from the first drop-down list, the
action from the second one and click OK.
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6.4.3 Example: Creating a sample contact group

In Part 1 of this example, you will learn how to create a new contact group with a dynamic condition. In
Part 2, you will learn how contacts can be added to the group based on a dynamic condition, as
members of an account and manually.

Part 1: Creating the sample contact group

1. Sign in as an administrator and go to CMS Desk -> On-line marketing -> Contact groups. Click the
 New contact group link.

2. In the New contact group dialog, enter the following properties: 

Display name: UK residents
Code name: UKResidents
Description: Contacts who live in the United Kingdom should belong to this group.

Click  Save once entered.

3. You will be redirected to the General tab of the newly created contact group's editing interface. Here,
specify a dynamic condition which will ensure that all contacts who have United Kingdom specified in
the Country field of their properties will be added to the contact group automatically:

Dynamic condition: enabled
Macro condition: Contact.ContactCountry == "United Kingdom"

Click  Save to save the condition.
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The group is now created. To try out the three different ways how contacts can be added to the group,
please proceed to the second part of this example.

Part 2: Adding contacts to the contact group

4. To try out adding of contacts based on the dynamic condition, make sure that you have at least one
contact with United Kingdom specified in the Country field (see Contacts -> Example: Creating a
sample contact to learn how to create one). Then click the  Rebuild contact group link which
appeared next to  Save. This ensures that all contacts that match the condition will be added to the
contact group automatically. 

5. Now switch to the Contacts tab. You should see that the matching contacts were added to the
contact group. The Yes value in the Dynamic column indicates that they were added to the contact
group based on a dynamic condition.

6. Now let's try adding an account to the contact group, which makes all contacts that belong to the
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account members of the contact group as well. Before proceeding, please make sure that you have at
least two contacts assigned to one account (see Accounts -> Example: Creating a sample account to
learn how to do it). Then switch to the Accounts tab and click  Add accounts. In the Select account
pop-up dialog, select the account and click OK.

7. If you switch back to the Contacts tab, you can see that all contacts associated with the previously
added account are listed. The Yes value in the From account column indicates that the contacts were
added automatically because they belong to the added account.

7. The last way how contacts can be added to contact groups is to add them manually. To do this, click
the  Add contacts link above the list of contacts. In the Select contact pop-up dialog, choose a
random account which has not been added to the contact group yet and click OK. 
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8. Switch back to the Contacts tab, you should see the last contact listed with the Yes value in the
Manual column, indicating that it was added to the contact group manually manually.

6.5 Merging contacts and accounts

6.5.1 Overview

It may happen that multiple contacts in the system actually represent the same real-world person, or
that you have more than one account in the system that represents a single real-world organization. The
merging functionality allows you to get rid of such duplicities by merging multiple contacts or accounts
into a single object. 

There are two ways how merging can be performed:

Manual merging - available for both contacts and accounts. It can be performed on the Merge tab of
individual contacts' and accounts' editing interfaces by selecting contacts or accounts to be merged
with the currently edited one. A merge suggestion functionality is available here, offering to merge
contacts with identical parameters.
Automatic merging - available only for contacts. It can be performed automatically when multiple
contacts are associated with the same E-commerce customer or newsletter subscriber, depending
on settings made in Site Manager -> Settings -> On-line marketing.
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After merging, only the single object (so-called parent) into which multiple ones have been merged is
displayed in the user interface. However, the ones merged with it are still stored in the database. On the 
Merge -> Split tab of each contact's or account's editing interface, you can see a list of contacts or
accounts that have been merged with it. It is possible to split these contacts or accounts from the parent
back into separate objects. More information on how this can be achieved is available in the Splitting
topic.

6.5.2 Manual merging

Manual merging of contacts or accounts can be performed on the Merge tab of their editing interfaces.
Here, you can either let the system suggest you which contacts/accounts appear to be duplicate to the
currently edited one, or choose the contacts/accounts to be merged with it manually from a list of all
contacts/accounts that are available.

Suggested merges

On the Suggested merges sub-tab, you can let the system suggest you which contacts/accounts have
identical values of certain properties. To get the suggestions, select the parameters to be compared
using the Suggest by check-boxes and clicking Show. A list of contacts/accounts that have values of
the selected properties identical to the currently edited one is displayed below.

To merge all suggested contacts/accounts into the currently edited one, click the Merge all button. If
you want only some of them to be merged, select them using the check-boxes in their rows and click
the Merge selected button. In both cases, the Merge collisions dialog window will be opened, enabling
you to specify values of individual properties and resolve potential value conflicts.

Choose contact/account

On the Choose contact/account sub-tab, you can choose contacts/accounts to be merged with the
currently edited one manually. By default, a list of all available contacts/accounts is displayed, while you
can display only those that match specified criteria using the filter above the list.

To merge all displayed objects into the currently edited one, click the Merge all button. If you want only
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some of them to be merged, select them using the check-boxes in their rows and click the Merge
selected button. In both cases, the Merge collisions dialog window will be opened, enabling you to
specify values of individual properties and resolve potential value conflicts.

Merge collisions

In the Merge collisions dialog window, you can adjust property values that the contact/account will
have after merging. Properties whose values are not empty in at least one of the merged contacts/
accounts are pre-filled, while the following icons are displayed next to them:

 - indicates that the system didn't detect any collision of this field's values.
 - indicates a detected collision, while the pre-filled value is is taken from the parent. If collisions

are detected only between child contact properties while the parent has the property value empty, the
pre-filled value taken from the colliding contact that is retrieved from the database first. By clicking
the  icon next the fields, you can choose the colliding value from a different contact.

You can adjust values of all the properties according to your needs. Once finished, click Merge to
perform the merging.
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6.5.3 Automatic merging

When multiple contacts are associated with the same registered user, the system merges the two
contacts automatically. It is also possible to configure automatic merging when identical E-commerce
customer or Newsletter subscriber is associated with multiple contacts. To configure automatic merging,
adjust the following settings in Site Manager -> Settings -> On-line marketing:

Merge contacts for identical E-commerce customers - if enabled, contacts associated with the
same E-commerce customer will be merged automatically.
Merge contacts for identical Newsletter subscribers - if enabled, contacts associated with the
same newsletter subscriber will be merged automatically.
When a visitor has more contacts, use - indicates which contact should be used as the parent
contact when merging multiple contacts automatically.

Last logged contact - a contact which has the last logged activity will be selected as parent.
Most active contact - a contact which has the highest number of logged activities will be selected
as parent.
Create a new contact - a new contact will be created and the contacts will be merged into it.

In cases when collisions are detected, the system uses property values of the parent contact. If
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collisions are detected only between child contact properties while the parent has the property value
empty, value of the property is taken from the colliding contact that is retrieved from the database first.

6.5.4 Splitting

On the Merge -> Split tab of each contact's or account's editing interface, you can see a list of all
objects which were merged into the currently edited one. It is possible to split these objects from the
parent and make them separate objects again.

To split some of the merged objects back into separate objects, select them using the check-boxes and
click the Split selected button. Before splitting, you may enable the following options in the Split
settings section for additional actions to be performed when splitting:

The following options are available when splitting merged contacts:

Copy activities created after merge to split contacts - indicates if activities of the current contact
logged after merge should be copied to the split contacts.
Fill in empty fields in split contacts - indicates if originally empty fields of the split contacts should
be filled in with values from the current contact.
Remove accounts from current contact which are also in relation with split contacts -
indicates if accounts originally associated with the split contacts should be removed from the current
contact.
Remove current contact from contact groups which are also in relation with split contacts -
indicates if the current contact should be removed from contact groups into which the split contacts
belong.

The following options are available when splitting merged accounts:

Fill in empty fields in split accounts - indicates if originally empty fields of the split accounts
should be filled in with values from the current contact.
Remove contacts from current account which are also in relation with split accounts -
indicates if contacts associated with the split accounts should be removed from the current account.
Remove current account from contact groups which are also in relation with split accounts -
indicates if the current account should be removed from contact groups associated with the split
accounts.
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6.6 Activities

6.6.1 Overview

Kentico CMS allows you to track and log activities (i.e. actions such as visiting a page, making a
purchase, subscribing to an event etc.) performed by a contact on the website, and thus gather data
needed for evaluating contact's behaviour for various marketing purposes (more details can be found in
the Scoring chapter in the same section of this guide).

Further in this chapter, you will learn how to manage activities and activity types and you will also see
an example of activity logging.

6.6.2 Managing activities

In this topic you will learn how to manage activities performed by a contact on the website. Activities can
be managed in:

Site Manager -> Tools -> Contact management on the Activities -> Activities tab
CMS Desk -> On-line marketing -> Activities on the Activities tab

Here you can see a list of activities which the users performed on the website, e.g. user registration,
blog post subscription, poll voting etc., and you can also create a new custom activity by clicking the 
New custom activity link. However, activities are logged only if On-line marketing is enabled, same as
the Log activities setting in Site Manager -> Settings -> On-line marketing -> Activities.

Individual activities can be Viewed ( ) in detail or Deleted ( ). The displayed list can be sorted by title,
type, contact name, IP address and the time of when the activity happened.

You may need to display only activities matching certain search criteria (e.g. activity type, title, contact
name etc.). To do so, fill in the fields as required and click Search.
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Creating a new custom activity

If you need to create a new custom activity, click the  New custom activity link, fill in the fields as
required and click OK. 

Contact - a contact related to the activity. Used e.g. to permanently associate a particular contact
with the activity. Click Select to choose a contact from a contact list.
Activity type - the type of the activity.
Activity title - the title of the activity.
Activity value - the value of the activity. Used e.g. in Content rating, E-commerce etc.
Activity URL - the URL associated with the activity. Used e.g. if you need to permanently relate the
activity to a particular URL.
Campaign - a campaign associated with the activity. Used e.g. if you need to monitor the behavior of
the visitors of your website.
Created - indicates the time of creating the activity.
Comment - allows to leave an activity comment.

http://devnet.kentico.com/docs/6_0/devguide/content_rating_module_overview.htm
http://devnet.kentico.com/docs/6_0/ecommerceguide/ecommerce_module_overview.htm
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Viewing activity details

If you need to view the details of a particular activity, click the View ( ) link beside it. A dialog window
pops up, giving you the details of the given activity and allowing you to leave an activity comment. 
Besides, some activity details can be edited, e.g. the title of the activity etc. The following activity details
are available:

General information
Activity type - the type of the activity.
Activity title - the title of the activity.
Contact name - the name of the contact associated with the activity. Click the  icon to view and
edit contact details.
Activity date - the date and time of performing the activity.
Activity URL - the URL of the activity. Click the  icon to view the web page on the live site.
Activity URL referrer - the URI from which the web page where the activity was performed had been
visited.
Activity site - the website where the activity was performed.

Activity comment
Comment - you can leave an activity comment, either as plain text or as text with basic formatting,
and you can also add your stamp by clicking the Add stamp button. To save the comment, click
Save.

If you have modified any value, click Save. To view the details of another activity in the list, click Next.
Or click Back to view the details of the previous activity.
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6.6.3 Managing activity types

In this topic you will learn how to manage activity types on which activities performed by contacts on the
website are based. Activity types can be managed in:

Site Manager -> Tools -> Contact management on the Activities -> Activity types tab
CMS Desk -> On-line marketing -> Activities on the Activities tab

Here you can see a list of activity types and you can also create new types by clicking the  New
activity type link.

The existing activity types can be Edited ( ) or Exported (  -> ). Besides, custom activity types
can be Deleted ( ). The displayed list can be sorted by activity type name, availability (Enabled) and
status (Is custom).

You may need to display only activity types matching certain search criteria (activity type name, activity
type status). To do so, fill in the fields as required and click Show.
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Creating a new activity type

If you need to create a new activity type, click the  New activity type link, fill in the fields as required
and click OK.

Display name - the name of the activity type used in Kentico CMS user interface.
Code name - the name of the activity type used in the code.
Description - the description of the activity type.
Is custom - indicates whether the activity type is custom.
Allow manual creation - indicates whether manual creation is allowed.
Enabled - indicates whether the activity type is enabled.

Scoring rule configuration

Activity item control - indicates which Activity item control should be used when defining a scoring
rule.
Activity detail control - indicates which Activity detail control should be used when defining a
scoring rule.
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Activity types

The following activity types come shipped with Kentico CMS:

Abuse report - the visitor reported an abuse using the Abuse report module (see Modules -> Abuse
report in the Developer's Guide).
Blog comment - the visitor commented on a blog post (see Modules -> Blogs in the same guide).
Blog post subscription - the visitor subscribed to blog post comments.
Clicked newsletter link - the subscriber clicked a tracked link in a newsletter (see Newsletters).
Content rating - the visitor rated some content (see Content rating).
Customer registration - the customer registered during the checkout process.
Event booking - the visitor signed up for an event using the Booking system.
External search - the visitor came to the website after searching on a search engine, such as
Google.
Form submission - the visitor submitted an on-line form (see Forms).
Forum post - the visitor posted on the forum (see Forum).
Forum post subscription - the visitor subscribed to a forum post.
Internal search - the visitor searched for text using the on-site search.
Joining a group - the visitor joined a community group or a workgroup (see Groups).
Landing page - the visitor came to this page as the first page.
Leaving a group - the visitor left a community group or a workgroup.
Message board comment - the visitor posted a comment on a message board (see Message
boards).
Message board subscription - the visitor subscribed to a message board.
Newsletter subscription - the visitor subscribed to a newsletter.
Newsletter unsubscription - the visitor unsubscribed from a newsletter.
Opened newsletter e-mail - the subscriber opened a tracked newsletter.
Page visit - the visitor visited a page.
Poll voting - the visitor voted in a poll (see Polls).
Product added to shopping cart - the visitor added a product to the shopping cart.
Product added to wishlist - the visitor added a product to the wishlist.
Product removed from shopping cart - the visitor removed a product from the shoppingcart.

http://devnet.kentico.com/docs/6_0/devguide/Abuse_report_module_overview.htm
http://devnet.kentico.com/docs/6_0/devguide/Abuse_report_module_overview.htm
http://devnet.kentico.com/docs/6_0/devguide/module_Blogs_overview.htm
http://devnet.kentico.com/docs/6_0/devguide/Newsletter_module_overview.htm
http://devnet.kentico.com/docs/6_0/devguide/content_rating_module_overview.htm
http://devnet.kentico.com/docs/6_0/devguide/BizForms_module_overview.htm
http://devnet.kentico.com/docs/6_0/devguide/Forum_module_overview.htm
http://devnet.kentico.com/docs/6_0/devguide/groups_module_overview.htm
http://devnet.kentico.com/docs/6_0/devguide/message_boards_overview.htm
http://devnet.kentico.com/docs/6_0/devguide/message_boards_overview.htm
http://devnet.kentico.com/docs/6_0/devguide/polls_overview.htm
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Purchase - the visitor made a purchase.
Purchased product - the visitor bought a product.
User contribution - content created - the visitor created new content using the User contributions
module (see User contributions (Wiki)).
User contribution - content deleted - the visitor deleted content using the User contributions
module.
User contribution - content updated - the visitor updated content using the User contribution
module.
User login - the visitor logged in to a site.
User registration - the visitor registered as a member of the site.

6.6.4 Example

Here you will see how website users' activities are logged. The example is demonstrated both on an
anonymous and a registered user.

1. Visit the live website as an anonymous visitor and perform some actions, e.g. view the Home page
and vote in the poll.

2. Sign in as an administrator and navigate to CMS Desk -> On-line marketing -> Contacts
(alternatively, you can navigate to the Contacts tab in Site Manager -> Tools -> Contact
management). As you can see, an anonymous contact is listed.

3. If you now Edit ( ) this contact and switch to the Activities tab, you can see that the poll voting
activity was logged, same as the Home page visit.

http://devnet.kentico.com/docs/6_0/devguide/User_contributions_overview.htm
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4. Go to the live site again, sign out from the administration account and on the My account page
register as a new user, e.g. Peter Chelmsford. Perform actions like in Step 1., i.e. view the Home page
and vote in the poll.

5. If you now view the list of contacts in the administration interface, you can see that a new contact,
Peter Chelmsford, is listed among other contacts.

6. And if you Edit ( ) this contact and switch to its Activities tab, you can see that the poll voting
activity was logged, same as the Home page visit.
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6.7 Settings

6.7.1 Overview

In this sub-chapter, you will learn about settings which influence and modify the behavior of the Contact
management module. These settings can be adjusted in the Site Manager -> Settings section of the
system's user interface. Here, they are located in the On-line marketing settings category and its
sub-categories.

The following topics in this sub-chapter contain explanations of settings with related functionality:

General contact management settings - explains general settings related to the Contact
management module.
Enabling tracking of activities - explains which settings need to be adjusted in order for activity
tracking to be functional.
Allowing the use of global objects - explains what global Contact management objects are, how their
use can be enabled and what changes to the user interface their enabling brings.
Automatic deleting of contacts - explains which settings may be used to configure the system to
periodically delete unnecessary contacts and their activities.

Depending on your selection in the Site drop-down list, you can either adjust the settings for a particular
website, or globally if the (global) option is selected. Global settings can be inherited by individual sites
if the Inherit from global settings check-box next to a site-specific setting is enabled. 
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As you can notice if you browse the settings categories, there is a number of other settings not listed in
this sub-chapter. These settings have no direct relation to the Contact management features and are
explained in respective chapters of this guide dedicated to the features which they influence. 

6.7.2 General contact management settings

General settings related to the Contact management module can be adjusted in the On-line marketing
category in Site Manager -> Settings. The following of the settings in the category are related to the
Contact management module:

Enable on-line marketing - enables on-line marketing features, among others including tracking of
live site users as contacts and logging of activities.

Notes stamp format - format of the stamp added to the Notes field after clicking the Add stamp
button when editing contacts or accounts.
Log IP address - indicates if logging of contacts' IP addresses should be allowed.
Remember contacts permanently - indicates how long contacts should be remembered. If
checked, a contact is kept until cookies are deleted or another contact is determined. If unchecked,
a contact is kept until the current session expires.
Automatically recognize visitors by user agent - indicates if a visitor's browser user agent
information should be used to determine what contact should be assigned to the current anonymous
visitor.
Automatically recognize visitors by IP address - indicates if visitor's IP address should be used to
determine what contact should be assigned to the current anonymous visitor.
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6.7.3 Enabling tracking of activities

For tracking of activities to be functional, you need to:

1. Enable the Enable on-line marketing option in the On-line marketing category in Site Manager -
> Settings. 

2. Enable the Log activities option in the On-line marketing -> Activities category in Site Manger ->
Settings. 

3. Still in the On-line marketing -> Activities category in Site Manger -> Settings, enable or disable
the rest of the settings below Log activities. These settings have self-explanatory names according to
the type of activity whose logging they enable.
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6.7.4 Allowing the use of global objects

The following objects can either be site-specific, i.e. available only for a single website, or global, which
means that they are shared across all websites running in the system:

Contacts 
Accounts
Contact groups
Account statuses
Contacts statuses
Contact roles

The use of global objects is disabled by default. To enabled it, go to Site Manager -> Settings -> On-
line marketing and adjust the following settings in the Global data section:

Allow global contacts - enables the use of global contacts.
Automatically create global contact for user on multiple sites - if enabled and the system
detects that there are multiple contacts associated with a user registered to multiple websites
running in the system, a new global contact is created and the detected ones are merged into it. If
one of the detected contacts is already global, the others are merged into it instead of a new one. If
more of them are global, no action is performed as it would not be possible to determine which of
them should be used as the parent.
Allow global accounts - enables the use of global accounts.
Allow global contact groups - enables the use of global contact groups.
Allow global configuration - enables the use of global contact statuses, account statuses and
contact roles.
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User interface differences when global objects are enabled

If global objects are allowed, the Site drop-down list is visible above the list of objects in the respective
sections of CMS Desk (e.g. CMS Desk -> On-line marketing -> Contacts). The Site drop-down list
offers you the following options:

(global and this site) - both global and current site objects are listed. 
(global) - only global objects are listed. 
current site - only current site objects are listed. 

When the (global and this site) options is selected, the Site column is added to the grid, indicating if
the object is site-specific or global. It is also not possible to create new objects in this case since it
would not be clear whether the new object should be global or site-specific. To create a new object, you
either need to have a particular website selected in the Site drop-down list, in which case you create an
object specific for the website, or you need to select the (global) option, in which case you create a
global object.
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If you manage contact management objects in Site Manager -> Tools -> Contact management, the
Site drop-down list is always present and allows you to manage both global objects and objects of all
websites in the system. The same conditions as described above apply here as well.

6.7.5 Automatic deleting of contacts

Hotfix required

The functionality described in this topic is only available if hotfix 6.0.7 or newer is
applied to your installation of Kentico CMS. 

You may download the appropriate hotfix package from http://devnet.kentico.com/
Bugtracker/Hotfixes.aspx.

The contact management module generates a very large amount of data, especially in the case of
high-traffic websites. Contacts are created and activities logged for every visitor, which may be
overwhelming for your marketers. For this reason, the system can be configured to regularly remove
contacts that meet certain conditions (and the activities logged by these contacts). This way, you can
filter out inactive, outdated or otherwise unnecessary contacts without having to remove them
individually.

This functionality is provided by a global Scheduled task named Delete inactive contacts, which is
executed once per week by default. If you wish, you can change this interval (and other properties) by
editing the task in Site Manager -> Administration -> Scheduled tasks. It is also possible to run the
task manually at any time.

The task runs in a separate thread by default and the deleting itself is done by the database server, so it
should not have a negative impact on the performance of your website, even when removing a large
number of contacts.

http://devnet.kentico.com/Bugtracker/Hotfixes.aspx
http://devnet.kentico.com/Bugtracker/Hotfixes.aspx
http://devnet.kentico.com/docs/6_0/devguide/Scheduler_overview.htm
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When this task is executed, it starts a deleting process for each site according to the rules defined by
the settings in the Site Manager -> Settings -> On-line marketing category. Please note that the
task does not delete global contacts.

The Delete inactive contacts setting determines whether the contacts associated with the given site
should be affected by the scheduled task. If disabled, the site's contacts will only be removed if they are
deleted manually. Additionally, the Enable on-line marketing setting must also be enabled for every
site where you wish to use this task.

The remaining settings in the section are used to set the conditions that specify which contacts should
be deleted. At least one condition must be entered in order for any contacts to be deleted. If multiple
conditions are set, only those contacts that fulfill all of them will be removed. The following are available:

Last activity older than (days) - can be used to delete contacts that do not have any recent
activities logged. Contacts whose latest activity is older than the specified number of days will be
removed. For example, entering 14 would mean that contacts which do not have any activities logged
within the last two weeks would be removed.
Contact created before (days) - can be used to clear out old contacts. All contacts that are older
than the specified number of days will be removed. For example, setting the value to 365 would mean
that all contacts created more than a year ago would be removed.
Contact last logon before (days) - this condition is only applied to contacts that are not
anonymous (i.e. only those that are associated with a specific user account). It can be used to
delete contacts who have not logged into the website recently. For example, entering 31 would mean
that all contacts who have not logged in within the last month would be removed.
Contact last modified before (days) - can be used to remove contacts that were not edited
recently (e.g. had their contact address changed). Contacts whose latest modification is older than
the specified number of days will be deleted. For example, entering 31 would mean that all contacts
which were not modified within the last month would be removed.
Contact merged before (days) - can be used to delete contacts that were merged into another
contact a certain number of days ago. A merged contact is one that was combined into another
contact, not the contact which is the actual result of a merge operation. For example, entering 7
would mean that all contacts which were merged more than one week ago would be removed.
Merged into site contact - determines whether the task should delete all contacts that were
merged into another contact associated with the given site.
Merged into global contact - determines whether the task should delete all contacts that were
merged into a global contact.
Contact is anonymous - can be used to choose whether the task should remove all contacts that
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are anonymous, or the opposite (those that are related to a specific user account). Contacts that are
only related to a customer or subscriber are still considered as anonymous. The Doesn't matter
option is the equivalent of an empty value in this condition. (i.e. if selected, the task will not delete
any contacts unless at least one other condition is specified).

It is recommended to be very careful when configuring these conditions. Make sure that the system only
deletes those contacts that are no longer necessary, otherwise you may lose valuable marketing data.
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7 Scoring

7.1 Overview

Scoring (also referred to as lead scoring or engagement scoring) is an on-line marketing method based
on assigning numeric values to individual contacts based on their properties and activities that they
perform on the website. The purpose of this method is to numerically evaluate contacts based on various
criteria, deduce conclusions about them from the scores and perform appropriate marketing actions.

You can define multiple scores, each with a separate set of rules based on which score points are
assigned to individual contacts within the particular score. If a contact matches a rule, score points can
either be added to or subtracted from its total score points within a particular score. 

User interface of the Scoring module is located in CMS Desk -> On-line marketing -> Scoring. The
user interface is generally described in the Managing scores topic. In the Example: Creating a sample
score topic, you can see a step-by-step example of how a sample score with several rules can be
defined and how score points are added to multiple contacts when they match the defined rules.

7.2 Managing scores

User interface of the Scoring module is located in CMS Desk -> On-line marketing -> Scoring. On the
initial screen of the interface, you can see a list of defined scores. New scores can be added using the 

 New score link. Existing scores have the following actions available in the Actions column:

 Edit - opens the score's editing interface where properties of the score can be modified, score
rules defined and score points that individual contacts received within the score can be viewed.

 Delete - deletes the score.

It is also possible to  Export,  Backup and  Restore listed scores by choosing the respective
action from the  Other actions drop-down menu.

The editing interface of each score, displayed after clicking the Edit ( ) icon, is split into three tabs —
General, Rules and Contacts.

General tab
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On the General tab, you can edit general properties of the score. The following of them are also
available when creating a new score after clicking the  New score link mentioned above:

Display name - name of the score used in the system's administration interface.
Code name - name of the score used in web project code.
Description - text describing the score.
Enabled - indicates if the score is enabled, i.e. if contacts are evaluated with score points within the
score.

Other properties are only available when editing an already existing contact:

E-mail notifications

The two properties listed below enable you to set up e-mail notifications about contacts reaching a
certain number of score points: 

Send notification at score - number of score points that a contact has to reach in order for the e-
mail notification to be sent.
Notification e-mail address - e-mail addresses to which the notification e-mails will be sent. You
can enter multiple addresses separated by semicolons (;).

The e-mail notifications are based on the Scoring - Notification e-mail e-mail template.

Score recalculation

When rules within the score are added or modified, it is necessary to recalculate score points previously
reached by individual contacts with regards to the new rules. This can either be done manually by
clicking the  Recalculate link, or automatically by means of a dedicated scheduled task. 

A scheduled task named Score '<score display name>' recalculation is created automatically in
Site Manager -> Administration -> Scheduled tasks for every created score. It is disabled by default
and can be enabled by the Schedule rebuild check-box. After doing so, a set of controls is displayed
below the check-box, letting you specify the period after which recalculation will be regularly performed.

In the Score info box on the right, two values related to score recalculation are displayed:

Status - when rules within the score were added or modified, the Recalculation needed status is
displayed here. When the current score points reflect the currently defined rules, you should see the 
Ready status.
Last recalculation time - date and time of last score points recalculation.
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Rules tab

On the Rules tab, you can see a list of defined rules based on which score points are added to contacts
within the current score. New rules can be defined after clicking the  New rule link above the list.
Listed rules can be Edited ( ) or Deleted ( ) by clicking the respective icons in the Actions column.

When defining a new rule or editing an existing one, the following properties can be specified:

Display name - name of the rule used in the system's administration interface.
Code name - name of the rule used in web project code.
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Value - number of score points that will be added to a contact for matching the rule.
Rule type - you can choose from the following types of rules:

Attribute - score points are added to contacts whose properties match a specified value.
Activity - score points are added to contacts who perform a specified activity.

If you select the Attribute type, the following two fields can to used to define the rule:

Attribute - contact property that has to match the condition specified below in order for contacts to
receive the score points.
Condition - condition that the attribute must match in order for contacts to receive the score points.

If you select the Activity type, the following fields can be used to specify the required activity:

Activity - type of activity that the contact needs to perform in order to receive the score points.
Activity time - time period within which contacts receive score points for performing the activity.
Page - path to a page where the activity needs to be performed.
Activity URL - URL where the activity needs to be performed.
Activity title - title of the activity.
Activity comment - text entered as comment of the activity.
Campaign - web analytics campaign through which the user came to the website.
Culture - cultural version of the website in which the activity needs to be performed.
IP address - IP address from which the activity needs to be performed.
URL referrer - URL from which the user needs to come to the page where they perform the activity.
Recurring rule - indicates if score points can be added to contacts for performing the activity
repeatedly. If disabled, score points are added only for the first time it is performed by each contact.
Max. rule points - maximum number of points that can be added to a single contact for performing
the activity
Validity - indicates how long the score points will be added to a contact after performing the activity.
After the specified time period, the score points will be subtracted from the user's total score points.

Depending on the selected type of activity, other specific properties can be displayed along with the
ones listed above.
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Contacts tab

On the Contacts tab, you can see a list of contacts who received points within the current score and the
actual numbers of score points that they received (the Score column). Please note that points received
for matching activity rules are added about one minute after the activity is performed, unless the 
CMSLogActivityImmediatelyToDB key is added to the appSettings section of the project's web.config file
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and set to true. In this case, score points for activity rules are added almost immediately.

When large numbers of contacts are displayed, you can filter them by their score points value using the 
Score filter above the list. By clicking the View contact details ( ) icon next to a contact, the
contact's editing interface identical to the one available in CMS Desk -> On-line marketing -> Contacts
is displayed in a new pop-up window.

7.3 Example: Creating a sample score

In Part 1 of the following example, we will create a sample score with two attribute rules and one activity
rule. In Part 2, we will browse the website as two new contacts and see how score points are assigned
to them when they match the defined rules.

Part 1: Creating a sample score

1. Go to CMS Desk -> On-line marketing -> Scoring and click the  New score link. 

2. In the New score dialog, enter the following details:

Display name: Interested in smartphones
Code name: InterestedInSmartphones
Description: enter some text describing the score
Enabled: checked

Click Save when you have all values entered. 



Scoring 103

© 2012 Kentico Software

3. The new score is now created and some new fields appear in the form you have just filled in. Let's
omit these for now and create some rules based on which score points will be added to contacts within
this score. As you may have noticed, three tabs have appeared after clicking Save, while you are now
on the General tab of the score's editing interface. Switch to the Rules tab. The tab is empty since no
rules are created yet, so let's click the  New rule link to create our first rule.

4. The first rule will be based on contact activities. It will add one point when a contact views a page in
the /Products/Smartphones section of the website (i.e. the list of offered smartphones and particular
smartphone detail pages). The rule will be recurring, which means that points will be added even for
repeated visits of these pages. In the New rule dialog, such a rule can be specified by the following
configuration:

Display name: Browsed smartphones
Code name: BrowsedSmartphones
Value: 1
Rule type: Activity
Activity: Page visit
Activity URL: Starts with /Products/Smartphones
Recurring rule: enabled

Leave the rest of the properties blank or at default values and click Save.
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5. Now let's create an attribute rule which will add 5 score points to contacts who have the word 
manager in their job title, as these are likely to need smartphones to do their job. Switch back to the list
of rules (click the Rules tab header) and click the  New rule link again. This time, enter the following
properties:

Display name: Works as manager
Code name: WorksAsManager
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Value: 5
Rule type: Attribute
Attribute: Job title
Condition: LIKE manager

Click Save to save the rule.

6. Repeat the procedure for the last time to create one more attribute rule, this one adding 5 points to
contacts that have a business phone number, as these can also be considered as potential smartphone
buyers:

Display name: Has business phone
Code name: HasBusinessPhone
Value: 5
Rule type: Attribute
Attribute: Business phone
Condition: Not empty

Click Save to save the rule.
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7. If you switch back to the list of rules, you should see the three defined rules listed.

Part 2: Trying out the functionality

With the rules defined, let's try how score points are added to contacts when they match the rules. For
the purpose of this example, we will use brand new contacts created by accessing the website as
anonymous users from two different browsers. If you already have some contacts created this way (e.g.
after going through Example: Creating a sample contact), these contacts will be used instead of the new
ones, but the demonstrated functionality will be the same.

Points for activity rules

Please note that points received for matching activity rules are added about one minute
after the activity is performed, unless the CMSLogActivityImmediatelyToDB key is
added to the appSettings section of the project's web.config file and set to true. In this
case, score points for activity rules are added almost immediately.
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It is therefore recommended to add the key to the web.config file in order to see the
results in steps 9 and 10 immediately.

8. Sign out of the administration interface, navigate to the /Products/Smartphones section of the
Corporate Site and view the product detail pages of at least 4 smartphones.

9. Then, log back on to CMS Desk, go to On-line marketing -> Scoring, edit ( ) the previously
created Interested in smartphones score and view the Contacts tab. You should see that a new
contact is listed there. It should have as many score points in the Score column as the number of
pages in the /Products/Smartphones section you have viewed.

10. Now open a different web browser and access the /Products/Smartphones section as an
anonymous visitor again. This time, view only the list of smartphones. After doing so, switch to the first
browser and view the Contacts tab. You should see another contact, but with only one point added for
viewing the list of smartphones.

11. Now click the View contact details ( ) icon next to the second contact. A new pop-up window
where you can edit properties of the contact appears. The user interface provided in the pop-up window
is identical to the contact editing interface in CMS Desk -> On-line marketing -> Contacts (see
Contact management -> Contacts for more details). 

On the General tab, fill in some sample details including a Business phone number and a Job title
containing the word manager. Click Save once finished.
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12. Close the window. Back on the Contacts tab, you should see that the second contact now has 11
points. This results from the fact that 5 were added due to having a business phone and another 5 due to
having the word manager in their job title, just as defined by the two previously created attribute rules.



Part
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8 Website optimization

8.1 Overview

Making improvements on a website can be a difficult process, since it is often not possible to know
ahead of time whether a change will have a positive effect, or which modification out of several options
will bring the best results. A possible solution for these issues is optimization testing of pages.

Optimization testing allows you to create different versions of a page (or specific parts of a page) and
evaluate them according to the behavior of the website's visitors. This way you can confirm which
changes are actually beneficial and use the content that works best for the users who visit your website.
The entire process is completely transparent for the site's visitors and does not require them to give any
feedback manually. Testing is typically done for key sections of the website that receive the most traffic,
such as the default home page (landing page).

There are two different techniques that you can use to optimize pages in Kentico CMS:

A/B testing - divides incoming traffic between two or more different variants of a page. Each variant is
defined as a separate document in the content tree. Results are tracked for each page variant as a
whole, meaning that the combined effect of all changes made to the given page is measured.
Multivariate testing (MVT) - allows you to make multiple modifications to the content of a single page
and monitor the effect that specific changes have on the behavior of visitors.

Each type of testing has its advantages and disadvantages and is intended for different scenarios. A/B
testing is usually more straightforward and easier to set up and use. It is most suitable for situations
where you need to test a single variable element or a full redesign that changes the entire appearance of
a page. In cases where you need to evaluate multiple variables on a single page or monitor the effect of
individual modifications with a greater degree of detail, multivariate testing is the better option. Because
MVT usually involves more tested variants, it may require more time (or site traffic) than A/B testing to
get meaningful results.

For both types of optimization testing, results are measured by tracking the activity of users after they
access the tested page and view one of the different content versions. Actions that are desired from
visitors are represented in the system as Conversions. Typical examples of conversions are product
orders, registrations, newsletter subscriptions, views of special pages etc. When a user performs the
specific action tracked by a conversion, it is referred to as a Conversion hit. To learn more about
conversions and how they can be implemented on your website, please read the Conversions chapter.

8.2 A/B testing

8.2.1 A/B testing overview

A/B testing is an on-line marketing technique used to optimize the pages of a website according to the
reactions of visitors. This is achieved by creating one or more modified versions of a given page and
running them all at the same time during a designated testing period. The system then divides traffic
between individual page versions and tracks how the changes affect the user experience and activity of
visitors.

The following images show two versions of a sample home page — the original and an alternative page
with the position of the left and right content columns reversed.
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Some visitors will be assigned to the second version and will see the following when they view the home
page:

There are no limitations placed on the modifications that can be made to different page options. They
may include anything from subtle changes to using a completely different page.

In Kentico CMS, the basic objects that provide this functionality are A/B tests, which can be created for
specific website pages. The page options defined for a test are called Page variants. Each variant is
linked to a document in the content tree of the website that can be designed and configured using the
standard web development process. Usually, the Original page for which the test was created will be
included as one of the variants, so that potential improvements can be compared with the baseline
statistics (those of the unmodified page).

For a practical scenario, imagine that you have an e-commerce page on your website where visitors can
purchase products and you wish to fine-tune it to be more user friendly in order to increase the amount
of sales. By utilizing A/B testing, you can create multiple versions of this page with any type of
modifications such as a slightly altered layout, graphical design or text content. These alternative pages
will then serve as variants of the A/B test. While the test is running, it will automatically display different
page variants to different visitors and keep track of all product purchases as conversions. When the test
is completed after a certain amount of time, you can evaluate which page variant encouraged more users
to make purchases on the website and set the most successful one as the permanent page.

Please see the Managing A/B tests topic for detailed information about how an A/B test can be defined
for a page. If you wish to try out a live A/B testing scenario, you can do so on the sample Corporate Site
according to the instructions in the Example: Sample A/B test topic. The data gathered by A/B tests is
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displayed using reports that allow you to view and analyze several types of conversion metrics, as
described in Analyzing A/B test results.

With A/B testing, results are tracked for entire page variants, which means that the measured statistics
reflect the combined effect of all changes made to each variant. If you wish to monitor how individual
page modifications affect the behaviour visitors, you may use Multivariate testing, which is another
website optimization feature provided by Kentico CMS.

How it works

When a visitor navigates to a page that has a running A/B test defined, one of the page variants
configured for the given test will be displayed to them. The variant is chosen randomly for every user.
With a large enough visit sample size, each page variant should receive roughly the same amount of
traffic during the course of the test.

A persistent cookie is stored in the visitor's browser, used to identify which variant was assigned by the
given A/B test. The name of the cookie uses the following format: CMSAB<A/B test code name>. It
saves the code name of the assigned page variant as its value. This cookie expires either within 30 days
after the last visit on the tested page, or on the date when the test is configured to end.

Any conversions performed on the website by users who have passed through an A/B test page will be
logged under the assigned page variant, which is taken from the value of the A/B testing cookie. The
logging of conversion hits is provided by the Web analytics module. In addition to monitoring
conversions, the cookie also ensures that returning visitors are always shown the page variant that was
previously assigned to them, which helps avoid confusion by maintaining a consistent appearance of the
tested page.

It is possible to run multiple A/B tests concurrently for different pages on the same website. Conversions
will be logged for all tests defined for pages visited by a given user, according to the cookies present in
the browser.

8.2.2 Managing A/B tests

The sections below describe the general steps that need to be taken in order to successfully set up an
A/B test on your website.

Enabling A/B testing

Before you can start creating A/B tests for pages, it is first necessary to enable the module by going to 
Site Manager -> Settings -> On-line marketing and checking the Enable A/B testing field.
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Since web analytics are used to log conversion statistics for individual page variants, the Enable web
analytics and Track conversions fields must additionally be enabled in the On-line marketing ->
Web analytics sub-category of the settings. All other requirements for the correct functioning of the web
analytics module also need to be fulfilled.

Defining an A/B test for a page

To start optimizing a page via A/B testing, create and configure an A/B test object for it. This can be
done in the Content -> Edit mode of CMS Desk by selecting the appropriate document from the content
tree and switching to its Analytics -> A/B tests tab. Here you can find a list of all A/B tests assigned to
the current document and manage them as required. The  New test link may be used to add an A/B
test. 

When creating or editing A/B tests, the properties described in the table below are available:

Display name The name of the A/B test displayed in the administration
interface.

Code name Sets a code name that serves as an identifier for the test. It
is also used in the name of the browser cookie used to store
which of the test's page variants was assigned to a visitor.

Test description Can be used to enter a text description for the test in order to
give information about its purpose, goals etc.

Test culture Used to selects which culture version(s) of the document
should be included in the test.

Target number of conversions Sets the number of conversion hits that must be logged to
complete the test. Once this number is reached, the A/B test
will automatically stop working and switch to the Finished
status.

If the total option is selected, then the number will be
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compared with the total sum of the conversion hits logged for
all test page variants. If any variant is chosen, then the test
will be concluded when the specified number is reached by
one variant (the one with the most conversion hits).

Leaving this property empty or setting it to 0 means that
there will be no conversion hit limit for the test.

Test from/to Sets the time interval during which the test should occur.
The Calendar button ( ) can be used to select the exact
date and time.

Test enabled This property may be used to manually start or stop the test.

Status Displays the current status of the A/B test. The following
statuses are possible:

Disabled - indicates that the test is not active. The original
tested page will always be displayed to visitors and
conversions will not be logged for the test's variants.
Not running - indicates that the test is not active yet.
Used when the test is enabled, but the Test from date is
still in the future.
Running - indicates that the test is currently active.
Finished - this status is automatically assigned after the
Test to date passes or when the current number of
conversions reaches the Target number of conversions.
Tests with this status are no longer active.

Each page may have only one A/B test running at a given
time. It is however possible to have multiple finished or
inactive (disabled) tests assigned to a page, which can be
used to archive data from previous tests or when preparing
future tests. Different culture versions of a page may each
have a different test running at the same time.
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Managing A/B tests through the Web analytics interface

If you wish to manage all tests assigned to different pages from a single location, go to 
CMS Desk -> On-line marketing (or Tools) -> Web analytics. Then expand the
Optimization -> A/B tests category, select any of the contained items (reports) and
switch to the A/B tests tab.

Here, all A/B tests defined on the current website and their page variants may be
managed in the same way as described for individual documents. The only difference is
that the Original page property is additionally available when editing a test, which can
be used to assign tests to specific pages.

Adding page variants to an A/B test

Test variants are created the same way as any other pages, since each variant is represented by a
separate document in the website's content tree and can be managed in CMS Desk -> Content.
Because of this, you can utilize all page configuration and design options provided by Kentico CMS.
Please refer to the Development -> Web development overview chapter of the Developer's Guide if you
require basic information about page development.

Usually, the page variants of an A/B test will all use the same basic concept, but have one key
difference that sets them apart from the original page, such as:

The position of an important page element.

http://devnet.kentico.com/docs/6_0/devguide/what_is_a_page_template.htm
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A different color scheme intended to highlight a part of the page.
Alternative text content of headings or descriptions that could potentially be more interesting for
visitors.

These are only basic examples of ideas that can be tested by individual variants. You can implement
any other type of modifications according to your specific requirements.

You may also leverage existing functionality to help present all variants defined for an A/B test as a
single page. The following two properties are available on the Properties -> Menu tab when editing any
document:

Show in navigation - indicates if the page variant should be displayed by navigation controls and
web parts (i.e. in the website's menus).
Show in site map - indicates if the page variant should be displayed by the Site map web part and
included in the website's Google Sitemap.

In most cases, it is recommended to have these properties disabled for page variants in order to prevent
users from encountering multiple pages with nearly identical content. The appropriate variant will
automatically be displayed to users when they view the test's original page, so standard navigation is not
necessary.

Additionally, the Exclude from search flag can be enabled for page variants on the Properties ->
General tab. This will ensure that the given variant will not be returned in the results of searches
performed on the website.

Once the modified versions of the original document are added to the content tree, they must be
registered as variants of the given A/B test. To do this, select the original document, go to Analytics ->
A/B tests, edit ( ) the test and switch to its Variants tab. Click the  New variant link and enter the
following properties: 

Variant display name - the name of the variant displayed in the administration interface.
Variant code name - sets a code name that serves as an identifier for the page variant. It is also
used as the value of the A/B testing cookie stored for visitors assigned to this variant.
Test page - must contain the path of the associated page (document). When users assigned to the

http://devnet.kentico.com/docs/6_0/webparts/cmssitemap_overview.htm
http://devnet.kentico.com/docs/6_0/devguide/google_site_map.htm
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variant access the original page of the given A/B test, they will see the page specified here instead.
The Select button may be used to choose an existing page from the website's content tree.

Repeat this process for all documents that should be included as possible page options for the A/B test.
The original document is automatically added as a variant when the A/B test is created, and highlighted
in the list by a yellow background.

Important!
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When editing a running A/B test, it is necessary to always keep the variant Test page
paths up-to-date and ensure that the target documents actually exist in the content
tree. Otherwise visitors may encounter a Page not found error if the path of their variant
is not valid.

To preserve conversion statistics, variants remain in the system even if their associated
document is deleted.

It is possible to save time when defining page variants by using an action that combines the two steps
described above. Simply select the A/B test's original page in CMS Desk -> Content and click the New
button in the menu above the content tree. Instead of selecting a document type, choose the A/B test
page variant option below the list.

This can also be done by right-clicking the document in the content tree and selecting the New -> A/B
test page variant item from the context menu. A dialog with the following options will be opened:

Document name - sets the name of the new document that will be associated with the page variant.
Save under location - sets the path of the document under which the page variant will be placed.
The Select button may be used to choose a parent page directly.
Assign to A/B test - selects the A/B test to which the variant will be added.
Show in navigation, Show in site map, Exclude from search - these options may be used to
directly set the corresponding properties of the new document. The default values will hide the page
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variant from all standard website navigation.

This will create a copy of the selected document and automatically add it as a page variant of the
specified A/B test. Now you can implement the required modifications that will distinguish the variant
from the original page. Please keep in mind that this copy will use the same page template as the
original document, so the template must be Cloned as ad-hoc on the document's Properties ->
Template tab if you wish to make any changes to the design or layout of the page.

Configuring conversions

Conversions allow you to track the behaviour and actions of the website's visitors, so they must be used
in order to get A/B testing results. They work on a site-wide level and do not need to be assigned to
individual A/B tests in any way. All that needs to be done is define conversion objects and link them with
the actions that you wish to log for the test. There are many ways to specify that an action should be
logged as a conversion. You can find information about conversion management in the Conversions
chapter of this guide.

When an action designated as a conversion is performed anywhere on the website, the system checks if
the given user has passed through a page with an A/B test (according to the presence of a cookie). If
this is the case, the conversion hit will be logged for the page variant assigned to the user.

Once the A/B test starts running on the live website, you can monitor the conversion statistics for
individual page variants using pre-defined reports, as described in the Analyzing A/B test results topic.

8.2.3 Example: Sample A/B test

The following example demonstrates how the sample A/B test included on the Corporate Site works. The
first part shows how the test looks from the live site perspective once it is started. In Part 2, you can
learn how to create a new page variant and add it to the test.

Part 1: Live testing example

1. Go to CMS Desk -> Content -> Edit and select the A/B test document, which can be found under
Examples -> On-line marketing -> Optimization. This document already has an A/B test defined and
one page variant added as a child document. The testing scenario is very basic, with the page being
composed of a text column on one side and a link on the other. The layout is reversed on the page
variant and the goal of the test is to find out which version gets more link clicks from visitors.
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2. To start the test, switch to the Analytics -> A/B tests tab of this document, edit ( ) the Sample AB
Test, check the Test enabled box on the General tab and click OK.
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3. Now try viewing the page on the live site. To access it, sign out of CMS Desk, open the Home page
of the Corporate Site, scroll down to the bottom and click the Examples link under the Where to learn
more? section. Then, use the menu on the left to navigate to On-line marketing -> Optimization ->
A/B test. When you view the tested page, one of the two possible variants will be randomly selected and
displayed.

4. Click on the Download here link, and a conversion will be logged for the given page variant by the
sample Conversion page. If you return to the A/B test page, the same variant that was assigned during
the first visit will always be displayed.

5. Now open the same page using a different browser. Again, one of the page variants will automatically
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be chosen and assigned. Please note that it may be the same variant as before, since the selection
process is entirely random. You can simulate visits from multiple users by clearing the cookies from
your browser between views of the tested page. Try to use this approach to log several conversions for
each variant.

Please continue reading in the Analyzing A/B test results topic to see how you can view the results
measured for the sample test performed in the previous steps.

Part 2: Creating an A/B testing page variant

This part of the example demonstrates how you can add another variant to the test used in the section
above. Please note that it is generally not recommended to add, remove or otherwise modify the variants
of a running test, since this may affect the accuracy of the results (this is not a concern in the case of
this example).

6. Log in to CMS Desk -> Content -> Edit and select the A/B test document again (under Examples ->
On-line marketing -> Optimization). Then click the New action located in the menu above the content
tree and choose the A/B test page variant option below the list of possible document types.
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7. A dialog will appear, where you can specify the settings of the page variant. Enter Second variant into
the Document name field and leave the default values for the remaining properties.

Click the  Save button and the variant will be created as a child under the currently selected
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document. Additionally, it will automatically be assigned to the Sample AB Test.

8. By default, new variants added this way use the same page template as the parent document, so you
need to assign a unique template before you can start modifying the design of the page variant. To do
this, select the Second variant document, go to the Properties -> Template tab and click on the 
Clone template as ad-hoc action.

9. Now that the document no longer shares its template with the original page, switch to the Design tab.
In this example, the new variant will test a single column layout where the "Download link" is placed
directly below the text. To achieve this, simply drag the web parts from the zoneLeft and zoneRight
zones into zoneTop as shown below:
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You can also make any necessary changes to the text content on the Page tab.

The variant will now serve as a third possible option when the tested page is viewed. If you wish, you can
use the approach described in the first part of this example to try out the functionality of the A/B test
now that it has an additional page variant.

8.2.4 Analyzing A/B test results

The data gathered during the course of A/B testing may be viewed in reports that display various types of
conversion metrics. To access the main interface containing these reports, go to CMS Desk -> On-line
marketing -> Web analytics and expand the Optimization -> A/B tests category.
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Here you can check the results of the A/B testing actions performed according to the instructions in the 
Example: Sample A/B test topic. Because of the way the analytics log is processed, you may have to
wait approximately one minute before conversion hits are reflected in the reports.

A/B testing reports use the same basic format as all other web analytics reports, so please refer to Web
analytics -> Using web analytics reports for details about the actions that can be used to filter or
otherwise manage the displayed data.

The Conversions drop-down list may be used to select which conversion's statistics should be
displayed. Please note that the system logs all conversion hits generated by visitors who have passed
through a page where an A/B test is running. If there are many conversions defined on your website, only
those that can somehow be affected by the differences in the A/B test's page variants will contain
relevant data.

Data in the reports is represented by two possible types of graphs. The line charts show the progress of
a certain conversion statistic over time and display combined data for all of the A/B test's variants. The
bar graphs contain details for individual units of time according to the selected report type (hours, days,
months etc.). You may also view the conversion data in a table located between the graphs. Each row in
the table shows the data logged for a specific page variant, both for the time period currently displayed
by the report and the entire duration of the test.

The following reports are available for A/B testing:
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Overview This report can be used to view the progress of the primary metrics
measured for the site's A/B tests from a single location.

Conversions count Displays the number of conversion hits logged for the selected A/B test
during the specified time interval.

In the bar graph, the number of conversion hits is divided into categories
that represent individual page variants. This allows you to compare the
A/B test's variants and determine which one generated the most
conversions (in absolute terms).

Conversions value Displays the sum of the conversion values logged for the selected A/B
test during the specified time interval.

In the bar graph, the conversion values are divided into categories that
represent individual page variants, which allows you to determine which
variant generated the highest total conversion value. This way you can
easily evaluate an A/B test's variants when using weighted conversions
that have a different level of importance.

Conversions rate Used to indicate how many visitors who access the tested page perform
a conversion. The conversion rate is calculated as the amount of logged
conversion hits divided by the total number of visitors on the variants of
the tested page.

If you select the (all) option from the Conversions drop-down list, then
the rate will be measured for all possible conversions, i.e. as the
percentage of visitors who generated at least one conversion hit of any
type.

The conversion rate in the bar graph is displayed for individual page
variants. This allows you to compare the A/B test's variants and
determine which one encouraged the highest share of its visitors to
perform a conversion.

Conversions source pages Displays hit statistics for individual conversions that were logged as part
of the selected A/B test during the specified time interval.

The data logged for the chosen conversion is categorized according to
the page variants defined for the given A/B test. This allows you to
easily determine which variant generated the most conversion hits of the
selected type.

Conversions by variants Displays details of the number of hits logged for each conversion by
individual page variants defined for the selected A/B test. You can
select the variant that you wish to evaluate from the Variants drop-down
list.

The hits logged for the chosen variant are divided into categories that
match individual conversions. This allows you to easily measure which
conversions are performed most commonly by visitors assigned to the
selected page variant.
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Reports for individual A/B tests

These reports can also be viewed when editing the original page of an A/B test in CMS
Desk -> Content -> Edit -> Analytics -> A/B testing -> Reports.

The same options are available as described for the web analytics interface, but
statistics are only displayed for the currently edited A/B test.

8.3 Multivariate testing

8.3.1 Multivariate testing overview

Multivariate testing (MVT) provides a way to optimize a website's pages based on the behaviour of its
visitors. It allows you to define any number of elements on a page as variables and create different
versions for each one. Once the test is started, users who view the page will see one of the possible
versions of its content and their subsequent activity will then be tracked to determine which
modifications produce the best results.

The basic objects used to manage this functionality are MVT tests, which can be created for specific
documents (pages) on the website. You can implement the changes that you wish to test by creating 
Variants of the standard design objects that make up the content of the given page. This includes Web
parts, entire web part zones and Widgets in the page's editor zones.

Testing is not done for individual variants, but rather for Combinations of the variants on the page.
Because scenarios with multiple object variables can lead to a very large amount of possible
combinations, you can limit the scope of the test by disabling those that you are not considering as
options. The default page is also available as a combination, so you can compare potential
improvements with the baseline statistics (those of the page with its original, unmodified content).

The image below shows how a page with a defined multivariate test could look in the design interface.
There are two different versions of the top zone's content and three possible variants of the web part that
displays the download button in the bottom zone. That makes six total combinations of the page's
content which can be included in the MVT test.

http://devnet.kentico.com/docs/6_0/devguide/web_part_development_overview.htm
http://devnet.kentico.com/docs/6_0/devguide/web_part_development_overview.htm
http://devnet.kentico.com/docs/6_0/devguide/widgets_overview.htm
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To learn how you can define an MVT test for a page and create different testing variants of its content,
please see the Managing MVT tests topic. If you wish to try out a live multivariate testing scenario, you
can do so on the sample Corporate Site according to the instructions in the Example: Sample MVT test
topic. The data gathered by MVT tests can be viewed in various reports that allow you to analyze several
types of conversion metrics, as described in Analyzing MVT test results.

With multivariate testing, results are tracked for specific combinations of the variants defined on a single
page, which represent individual modifications. If you wish to monitor the aggregate effect of all changes
made to an entire page as a single variable, you may use A/B testing, which is another optimization
feature provided by Kentico CMS.

How it works

When a visitor navigates to a page that has a running MVT test on the live site, one of the enabled
content combinations will be displayed. The combination is chosen randomly for every user. With a large
enough visit sample size, each active combination should receive roughly the same amount of traffic
during the course of the test.

A persistent cookie is stored in the visitor's browser, used to identify which combination was assigned to
the user by the given MVT test. The name of the cookie uses the following format: CMSMVT<MVT test
code name>. It saves the internal code name of the assigned combination as its value. This cookie
expires either within 30 days after the last visit on the tested page, or on the date when the test is
configured to end.

Any conversions performed on the website by users who have passed through a page where an MVT
test is running will be logged for the given test under the assigned combination, which is taken from the
value of the MVT testing cookie. The logging of conversion hits is provided by the Web analytics module.
In addition to monitoring conversions, the cookie also ensures that returning visitors are always shown
the same content combination that was previously assigned to them, which helps avoid confusion by
maintaining a consistent appearance of the tested page.

It is possible to run multiple MVT tests concurrently for different pages on the same website.
Conversions will be logged for all tests defined on the pages visited by a given user, according to the
cookies present in the browser.



Kentico CMS 6.0 On-line Marketing Guide130

© 2012 Kentico Software

8.3.2 Managing MVT tests

The sections below describe the general steps that need to be taken in order to successfully set up a
multivariate test on your website.

Enabling multivariate testing

Before you can start creating MVT tests for pages, it is first necessary to enable the module by going to 
Site Manager -> Settings -> On-line marketing and checking the Enable multivariate testing field.

Since web analytics are used to log conversion statistics for individual versions of tested pages, the 
Enable web analytics and Track conversions fields must additionally be enabled in the On-line
marketing -> Web analytics sub-category of the settings. All other requirements for the correct
functioning of the web analytics module also need to be fulfilled.

Defining an MVT test

To start optimizing a page on your website via multivariate testing, create and configure an MVT test
object for it. This can be done in the Content -> Edit mode of CMS Desk by selecting the appropriate
document from the content tree and switching to its Analytics -> MVT tests tab. Here you can find a list
of all MVT tests assigned to the current document and manage them as required. The  New MVT test
link may be used to add an MVT test.

When creating or editing MVT tests, the properties described in the table below are available:

Display name The name of the MVT test displayed in the administration
interface.

Test code name Sets a code name that serves as an identifier for the test. It
is also used in the name of the browser cookie used to store
which of the test's variant combinations was assigned to a
visitor.
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Description Can be used to enter a text description for the test in order to
give information about its purpose, goals etc.

Culture Used to select which culture version(s) of the document
should be included in the test.

Target number of conversions Sets the number of conversion hits that must be logged to
complete the test. Once this number is reached, the MVT
test will automatically stop working and switch to the 
Finished status.

If the total option is selected, then the number will be
compared with the total amount of conversion hits logged for
all of the test's combinations. If any combination is chosen,
then the test will be concluded when the specified number is
reached by one combination (the one with the most
conversion hits).

Leaving this property empty or setting it to 0 means that
there will be no conversion hit limit for the test.

Test from/to Sets the time interval during which the test should occur.
The Calendar button ( ) can be used to select the exact
date and time.

Enabled This property may be used to manually start or stop the test.

Status Displays the current status of the MVT test. The following
statuses are possible:

Disabled - indicates that the test is not active. The default
content of the tested page will always be displayed to
visitors and conversions will not be logged for the test's
combinations.
Not running - indicates that the test is not active. Used
when the test is enabled, but the Test from date is still in
the future.
Running - indicates that the test is currently active.
Finished - this status is automatically assigned after the
Test to date passes or when the Current number of
conversions reaches the Target number of conversions.
Tests with this status are no longer active.

Each page may have only one MVT test running at a given
time. It is however possible to have multiple finished or
disabled tests assigned to a page, which can be used to
archive data from previous tests or when preparing future
tests. Different culture versions of a page may each have a
different test running at the same time.
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Managing MVT tests through the Web analytics interface

If you wish to manage all tests assigned to different pages from a single location, go to 
CMS Desk -> On-line marketing (or Tools) -> Web analytics. Then expand the
Optimization -> MVT tests category, select one of the contained items (reports) and
switch to the MVT tests tab.

Here, all MVT tests defined on the current website may be managed in the same way
as described for individual documents. The only difference is that the Page property is
additionally available when editing a test, which can be used to assign tests to specific
pages.

Creating testing variants on the page

Once a page contains an MVT test, you can start creating the content options that you wish to evaluate.
This is done by defining variants for the elements that make up the content of the page. It is possible to
use the following objects as variables:

Web parts - these variants are separate instances of the original web part. Each variant's properties
may be configured differently and an alternative Web part layout can be specified.
Web part zones - in this case, variants are added as entire web part zones. A zone variant may
contain any type or number of child web parts as required. The basic properties of the zone may also
be set differently. When a new variant is added to a zone, the content of the original is automatically
copied into it, so you do not have to rebuild the zone from scratch if you only need to make small

http://devnet.kentico.com/docs/6_0/devguide/customizing_web_part_layout.htm
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modifications. Please note that creating variants for individual web parts inside zone variants is not
supported.
Editor widgets - like with web parts, each variant is a widget of the same type as the original that
provides the option to set different values for its properties.

If you are not familiar with the basics of page development in Kentico CMS, it is recommended to read
through the Development -> Web parts and Widgets chapters in the Kentico CMS Developer's Guide
before you continue.

To add an MVT variant to a web part or zone, open the page on the Design tab, expand the context
menu of the given object by right clicking its header (or through the  icon), hover over the MVT variants
option and select Add <object type> variant from the second level of the menu. 

Then, fill in the following properties in the displayed dialog:

Display name - the name used in lists of MVT variants in the administration interface.
Code name - sets a code name that serves as an identifier of the variant.
Description - can be used to enter a text description of the variant.
Enabled - indicates if the variant should be considered as a possible testing option. If you disable an
MVT variant, all testing combinations that include this variant will also be disabled.

After you enter and confirm these basic values for the new variant, a configuration dialog will be opened,
just like when creating a standard web part or widget. Here, you can set up the available properties
(according to the type of the given object) so that the variant generates the content that you wish to test.
By default, the values set for the original will be loaded into the properties, so you only have to change
the parts of the configuration that are unique for the given variant.

Each object for which testing variants are created will have a slider available in its header as shown
below:

This slider can be used to switch between individual variants as needed (including the original). The
content specified by the current selection on the page's variant sliders will be displayed in CMS Desk on
the Design and Page tabs, and in Preview mode. You can also switch between different versions of
the page's content by using the combination panel, which is described below in the next section. If you
wish to view the content of variants while cycling through the slider on the Design tab, make sure that
the Display web part content checkbox on the right side of the Edit mode header is checked.

http://devnet.kentico.com/docs/6_0/devguide/web_part_development_overview.htm
http://devnet.kentico.com/docs/6_0/devguide/widgets_overview.htm
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The buttons on the right of the slider allow you to add new variants ( ), remove the currently selected
one ( ) or open a list ( ) of all variants that the given object currently has. At any time, you can
Configure ( ) the properties of the variant currently chosen on the slider.

When editing a variant like this, you can access the properties that affect the content on the General
tab. The specific settings related to the MVT testing functionality of the specific variant (the same
options that were offered when creating a new variant) can be changed on the additional Variant
properties tab.

In the case of editor widgets, multivariate testing variants are handled using a very similar approach. The
only difference is that editing is done on the Page tab of CMS Desk and the slider and actions for variant
management are located on the pop-up menu of individual widgets.

You can access a list of all multivariate testing variants defined on a given document (page), by selecting
it from the content tree in CMS Desk -> Content -> Edit and going to Analytics -> MVT variants. The
variants of all three object types are included here, and they can be removed or edited as necessary.

There are some general rules that apply to all MVT variants:

If you delete an object from the page, any variants that it might have will be removed along with it.
Variants are not linked to a specific MVT test. Instead, they are either stored on the page template

http://devnet.kentico.com/docs/6_0/devguide/portal_engine_overview.htm


Website optimization 135

© 2012 Kentico Software

used by the given document (in the case of web parts and zones) or bound to the document itself
(editor widget variants). This means that existing variants may be used by other MVT tests performed
on the given page at another time. Also keep this in mind if you wish to Export a multivariate testing
scenario to another website. Variants will be transferred along with documents or page templates,
not MVT test objects.

Multivariate testing and Content personalization

Please note that it is not possible to create multivariate testing variants of web parts,
zones or widgets that already have variants defined for Content personalization.

Setting up testing combinations

Individual testing scenarios are represented by combinations of the MVT variants created on the page.
By default, all possible combinations of the page's content will be included in a multivariate test, but you
may perform some additional configuration to fine-tune your test as required.

Combinations can be managed for documents that have an MVT test defined via a panel located at the
top of the page editing interface in CMS Desk. This panel is available on both the Page and Design
tabs, and in Preview mode.

You can choose any of the available combinations through the Combination selector. Doing so will
cause the page to display the content defined by the variants that make up the given combination. The
selection made through the combination panel is linked with the positions set on the MVT sliders of
variable objects on the page. If you switch to a different variant through an object's slider, the current
combination will also change accordingly and vice versa.

Pages where there are several variants for multiple objects will have a large amount of possible
combinations. For this reason, it is recommended to carefully choose which combinations should be
included in the page's MVT test. You can include or exclude a combination by toggling the Enabled
checkbox located on the panel next to the selector. There is a close relationship between the status of a
combination and its variants. If an individual variant is disabled through its properties, all combinations
that include it will also be disabled. If a disabled combination is enabled at a later point, all of its variants
will be enabled automatically.

A good way to evaluate potential combinations is to check them in the Preview mode of CMS Desk,
and disable those where the variants clash visually, have conflicting logic or are otherwise incompatible.
We recommend leaving the Default page combination enabled, so you can compare any improvements
with the baseline statistics of the original page.

Another best practice is to set a descriptive custom name for each active combination, so that you can
easily differentiate between combinations in the editing interface and identify them in the test's result
reports. To do this, simply select a combination through the panel, enter the appropriate text into the 
Custom name field and click the Change button. The default names assigned to new combinations are
composed of a number indicating their order, followed by a list of the display names of all variants that
are included in the given combination.

http://devnet.kentico.com/docs/6_0/devguide/export_and_import_overview.htm
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Once the page's variants and combinations are all configured as needed, you can enable your MVT test
on the Analytics -> MVT tests tab of the document. Making further modifications on the page while an
MVT test is running is not recommended, since this may affect the accuracy and relevance of the
measured statistics. A warning will be displayed below the combination panel on pages where a test is
running.

The Set as result action should only be used after the conclusion of the test, once you have analyzed
the logged conversion data and identified the combination that provides the best results. The action
allows you to easily set the winning combination as the permanent content of the page. Simply select
the given combination via the combination panel, then click the button and confirm the action. This will
replace the original web parts, zones and widgets with the variants included in the currently selected
combination and remove all other MVT variants from the page.

Configuring conversions

Conversions allow you to track the behaviour and actions of the website's visitors, so they must be used
in order to get MVT testing results. They work on a site-wide level and do not need to be assigned to
individual MVT tests in any way. All that needs to be done is define conversion objects and link them
with the actions that you wish to log for the test. There are many ways to specify that an action should
be logged as a conversion. You can find information about conversion management in the Conversions
chapter of this guide.

When an action designated as a conversion is performed anywhere on the website, the system checks if
the given user has passed through a page with a running MVT test (according to the presence of a
cookie). If this is the case, the conversion hit will be logged for the content combination that was
assigned to the user.

Once you enable the MVT test and it starts running on the live site, the conversion statistics for
individual combinations can be monitored using pre-defined reports, as described in the Analyzing MVT
test results topic.

8.3.3 Example: Sample MVT test

This example demonstrates the functionality of the sample multivariate test included on the Corporate
Site and shows how you can expand it by adding another testing variant.

1. Go to CMS Desk -> Content -> Edit and select the MVT test document, which can be found under
Examples -> On-line marketing -> Optimization. This document already has a pre-defined MVT test.
The page is composed of a header, content text and a link at the bottom. If you switch to the Design
tab, you can see that there are three versions of the Editable text web part that displays the link (the
original and two MVT variants). Each one uses a different background color. The goal of the test is to find
out which variant gets more link clicks from visitors.
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Try switching between the content of individual variants using the slider in the web part's header. Also
notice the combination panel at the top of the page. It shows which combination of variants is currently
being viewed and may also be used to switch between individual combinations or configure their
behavior. Since the default test page only contains variants of a single web part, each "combination"
represents the same page with a different link color.

2. To better demonstrate how MVT combinations work, we will need to add a variant to another element
on the page. Right click the HeaderText web part, hover over the MVT variants option in the context
menu and select Add web part variant from the second level.
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3. Enter the following values for the variant's properties in the displayed dialog:

Display name: Header text - Red
Code name: RedLinkHeader
Enabled: Yes (leave it checked)

Click OK.

4. A configuration dialog will appear for the Editable text web part used to display the page's header.
Enter Red link  header variant into the Web part title property. Setting an appropriate title is
recommended, since this allows you to identify which variant you are working with on the Design tab
straight from the description in the web part header. You can then confirm the dialog by clicking OK
again and the variant will be added to the page.



Website optimization 139

© 2012 Kentico Software

5. Now that there are two different variants of the page's header text, the number of possible
combinations will double to a total of six. Switch to the Page tab and make sure that one of the new
combinations that contains the Header text - Red variant is selected. The editable region at the top of the
page will be empty, so type in the following text: MVT Test - Red Download Link . Click  Save.

6. In this sample testing scenario, the second variant of the page's header is only intended for the red
version of the download link, so we will disable the combinations where the header text does not match
the link color. Select the fourth combination using the panel and uncheck the Enabled box next to the
drop-down list. Repeat this for the sixth combination. This ensures that versions of the page where the
new "red" header is combined with a blue or green link will not be included in the MVT test, which leaves
only four active combinations: all of the variants with the original header and a new combination that
contains the red link together with the second header.

7. The testing combinations are now prepared and you can start the MVT test. Switch to the Analytics -
> MVT tests tab of the document, edit ( ) the Sample MVT Test, check the Enabled box on the
General tab and click OK.
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8. Now try viewing the page on the live site. To access it, sign out of CMS Desk, open the Home page
of the Corporate Site, scroll down to the bottom and click the Examples link under the Where to learn
more? section. Then, use the menu on the left to navigate to On-line marketing -> Optimization ->
MVT test. When you view the tested page, one of the possible combinations will be randomly selected
and displayed.
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9. Click on the Download here link, and a conversion will be logged for the given combination by the
sample Conversion page. If you return to the MVT test page, the same combination that was assigned
during the first visit will always be displayed.

10. Now open the same page in a different browser. Again, one of the combinations will automatically be
chosen and assigned. Please note that it may be the same combination as before, since the selection
process is entirely random. You can simulate visits from multiple users by clearing the cookies from
your browser between views of the tested page. Try to use this approach to log several conversions for
each combination.

Please continue reading in the Analyzing MVT test results topic to see how you can view the results
measured for the sample test performed in the previous steps.

8.3.4 Analyzing MVT test results

The data gathered during the course of MVT testing may be viewed in reports that display various types
of conversion metrics. To access the main interface containing these reports, go to CMS Desk -> On-
line marketing -> Web analytics and expand the Optimization -> MVT tests category.
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Here you can check the results of the MVT testing actions performed according to the instructions in
the Example: Sample MVT test topic. Because of the way the analytics log is processed, you may have
to wait approximately one minute before conversion hits are reflected in the reports.

MVT testing reports use the same basic format as all other web analytics reports, so please refer to 
Web analytics -> Using web analytics reports for details about the actions that can be used to filter or
otherwise manage the displayed data.

The Conversions drop-down list may be used to select which conversion's statistics should be
displayed. Please note that the system logs all conversion hits generated by visitors who have passed
through a page where an MVT test is running. If there are many conversions defined on your website,
only those that can somehow be affected by the differences between the tested content combinations
will have relevant data.

Data in the reports is represented by two possible types of graphs. The line charts show the progress of
a certain conversion statistic over time and display combined data for all of the tested combinations. The
bar graphs contain details for individual units of time according to the selected report type (hours, days,
months etc.). You may also view the conversion data in a table located between the graphs. Each row in
the table shows the data logged for a specific combination, both for the time period currently displayed
by the report and the entire duration of the test.

The following reports are available for MVT testing:
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Overview This report can be used to view the progress of the primary metrics
measured for the site's MVT tests from a single location.

Conversions count Displays the number of conversion hits logged for the selected MVT test
during the specified time interval.

In the bar graph, the number of conversion hits is divided into categories
that represent individual content combinations. This allows you to
compare the tested combinations and determine which one generated
the most conversions (in absolute terms).

Conversions value Displays the sum of the conversion values logged for the selected MVT
test during the specified time interval.

In the bar graph, the conversion values are divided into categories that
represent individual content combinations, which allows you to
determine which one generated the highest total conversion value. This
way you can easily evaluate the results of the MVT test when using
weighted conversions that have a different level of importance.

Conversions rate Used to indicate how many visitors who access the tested page perform
a conversion. The conversion rate is calculated as the amount of logged
conversion hits divided by the total number of visitors on the given page.

If you select the (all) option from the Conversions drop-down list, then
the rate will be measured for all possible conversions, i.e. as the
percentage of visitors who generated at least one conversion hit of any
type.

The conversion rate in the bar graph is displayed for individual content
combinations. This allows you to compare the tested combinations and
determine which one encouraged the highest share of its visitors to
perform a conversion.

Conversions by
combinations

Displays details about the number of conversion hits logged for
individual content combinations defined on the page associated with the
selected MVT test. 

You can select the combination that you wish to evaluate from the 
Combinations drop-down list. If the MVT test is used for multiple
culture versions of the page, you can also specify the culture.

The hits logged for the chosen combination are divided into categories
that match individual conversions. This allows you to easily measure
which conversions are performed most commonly by visitors assigned
to the selected content combination.

Reports for individual MVT tests

These reports can also be viewed when working with the tested page in CMS Desk ->
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Content -> Edit by editing the given MVT test in Analytics -> MVT tests and switching
to its Reports tab.

The same options are available as described for the web analytics interface, but
statistics are only displayed for the currently edited MVT test.



Part
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9 Content personalization

9.1 Content personalization overview

Content personalization is an on-line marketing feature that can significantly increase the flexibility of a
website. It allows you to create pages that display different content depending on the circumstances in
which they are viewed. This way, pages can be custom-built for different types of visitors, dynamically
reflect previous actions performed on the website by a given user or have their content determined by
any other site variables.

Personalization is applied through the basic components that form the content of pages, which includes 
Web parts, entire web part zones and Widgets added into page editor zones. The first necessary step is
to define different versions of these objects called variants. The details of how personalization variants
can be created and configured for objects are described in Managing personalization variants.

Each variant is dedicated to a particular scenario, which is specified through a macro-based condition.
The condition determines in which situations the variant should be displayed. When a visitor selects the
page on the live site, the variants of all personalized objects will have their conditions dynamically
resolved according to the current context and the appropriate variant will be displayed for each object.

Some of the most effective content personalization can be achieved by using the data provided by other
on-line marketing features, such as Contact management, Scoring or Campaigns. An example of this
type of scenario can be found in the Example: Creating a personalized page topic, which demonstrates
how you can perform the personalization process step-by-step.

9.2 Managing personalization variants

To start using content personalization on a website, go to Site Manager -> Settings -> On-line
marketing and check Enable content personalization. This will allow users with the appropriate
permissions to start creating variants of objects, which will then be processed and displayed accordingly
on the live site.

http://devnet.kentico.com/docs/6_0/devguide/web_part_development_overview.htm
http://devnet.kentico.com/docs/6_0/devguide/widgets_overview.htm
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If you disable content personalization at a later time, existing variants on your website will not be
deleted, but it will not be possible to manage them or define new ones, and the original objects will
always be shown on the live site.

Once content personalization is enabled, variants of objects can be created through the CMS Desk ->
Content -> Edit interface, which you would normally use to define standard page content. There are
three possible types of objects that you can personalize:

Web parts

To add the first content personalization variant to a web part, open its context menu by right clicking its
header (or through the  icon), hover over the Personalization variants option and then select Add
web part variant from the second level of the menu.

A dialog will be displayed where you can set the properties of the variant:

Display name - this name will be displayed in lists of content personalization variants in the
administration interface.
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Code name - sets a code name that serves as an identifier of the variant.
Description - can be used to enter a text description for the variant. To make the variant easier to
use and maintain, you can add an explanation about the scenario for which the variant is intended,
describe the differences from the original object etc.
Enabled - indicates if the variant should be considered as a possible content option. When an
object's variants are processed to determine which one should be displayed, disabled variants are
skipped (even if the requirements set by their condition are met).
Display condition - enter the condition that must be fulfilled in order for the variant to be displayed.

When the values are confirmed, a standard web part configuration dialog will be displayed. The variant is
simply another instance of the original web part. By default, it will have the same values in its properties
as are set for the original, but you can change them as required. 

After the first variant is created, a slider will be added to the header of the given web part as shown
below:

This slider can be used to switch between individual variants as needed (including the original). The
content specified by the currently selected variant will be displayed on the Design and Page tabs, as
well as in Preview mode. The conditions are only resolved on the actual live site. This means that you
can easily check how the page will look with different active variants without having to fulfill the required
conditions. Simply set the slider(s) to the appropriate variants. If you wish to view the content of variants
while cycling through the slider on the Design tab, make sure that the Display web part content
checkbox on the Edit mode header is checked.

The buttons on the side of the slider allow you to add new variants ( ), remove the currently selected
one ( ) or open a list of all variants defined for the given web part ( ). At any time, you can Configure (

) the properties of the variant currently chosen on the slider.
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A variant may be edited just like any other web part. Notice that there is an additional tab available in the
configuration dialog called Variant properties, which contains the same options that were offered when
creating a new variant (as described above). It is also possible to specify a unique Web part layout for
each variant. You only need to switch to the Layout tab, select or create the required layout and it will
be applied to the currently edited variant.

If you need to enter content into a variant of a web part that provides an editable region (Editable text or
Editable image), you can do so on the Page tab as usual. To quickly switch between different variants
on this tab, hover over the given personalized section of the page and a menu icon ( ) will appear. If you
expand the menu, a list of all available variants will be shown and you can select the one that you wish
to edit or view.

http://devnet.kentico.com/docs/6_0/devguide/customizing_web_part_layout.htm
http://devnet.kentico.com/docs/6_0/webparts/editabletext_overview.htm
http://devnet.kentico.com/docs/6_0/webparts/EditableImage_overview.htm
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When one of the menu options is clicked, the page will be reloaded with the content of the chosen
variant.

The variants of a personalized web part are stored on the given document's page template, so they will
be present on all pages that use the same template. If you delete ( ) a web part, all of its variants will
be removed along with it. These same principles also apply to web part zone variants.

Web part zones

If you wish to define personalized content that uses a completely different type of web part or multiple
web part instances, you can add variants of an entire web part zone. This allows you to set the
properties of the zone in a specific way for each variant, and more importantly add (or remove) any child
web parts that you need. Each zone variant may contain any type or amount of web parts, regardless of
what is placed inside other variants or the original zone.

Variants of zones can be created and managed on the Design tab in the same way as web parts (the
buttons on the slider use different icons for zones). The only difference is that you need to work with
zone objects rather than specific web parts. When a new zone variant is added, the content of the
original is automatically copied into it, so you do not have to rebuild the zone from scratch if you only
need to make small modifications.

The zone variant currently selected on the slider may be edited by double clicking the header of the zone
or through the  Properties option in the zone's context menu. To add content into a variant, use the
Add web part ( ) button in the top-right corner of the zone as usual. Most of the functionality
described above for web part personalization is also available for zones.

Creating variants for individual web parts inside a personalized zone is not supported. The same also
applies in the opposite direction: it is not possible to personalize a zone that already contains
personalized web parts. Moreover, personalization is only available for standard web part zones, and
cannot be done for widget zones.

Widgets

Content personalization can also be leveraged by editors, who do not have access to the Design tab, via
widgets. If the feature is enabled, variants can be added and managed through buttons on the pop-up
menu of individual widgets on the Page tab. When at least one variant is created for a widget, a slider
will become available just like for web parts or zones.

http://devnet.kentico.com/docs/6_0/devguide/portal_engine_overview.htm
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The following actions can be used:

 Add new variant - creates a new variant for the given widget. When creating the first variant for a
widget on a page that also has a multivariate test defined, this action will open a menu where you
can choose which type of variant should be created.

 Remove variant - removes the variant currently selected on the slider (not available for the
original).

 Variant list - opens a dialog that contains a list of all variants defined for the widget and allows
their management.

Personalization of editor widgets works the same way as for web parts. Each variant is a widget of the
same type as the original, but its properties may be configured differently. This functionality is only
available for widgets placed into zones set for Customization by page editors and cannot be done for
group administrator or user widgets.

Since editor widgets are categorized as page content, their variants are bound to the specific document
and are not included on the page template. Like with web parts, removing a widget ( ) also deletes all of
its variants. Please note that using the Reset to default action provided by a Widget actions web part
will also cause all widget variants to be deleted from the page.

Variant overview

You can access a list of all content personalization variants defined on a given
document (page), by selecting it from the content tree in CMS Desk -> Content -> Edit
and going to Properties -> Variants. The variants of all three object types are included
here.

Multivariate testing and Content personalization

Please note that it is not possible to create personalization variants of web parts, zones
or widgets that are already included in a Multivariate test.

http://devnet.kentico.com/docs/6_0/webparts/WidgetActions_overview.htm
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Variant display conditions

When setting up a personalized page, the most important part of the process is to properly define the
conditions that indicate when individual variants should be displayed. By utilizing macro expressions,
you can write conditions for virtually any type of scenario according to your specific requirements. Keep
in mind that the final result of a condition's expression must be a logical (boolean) value in order for it to
work correctly. For more information about the available macro options, please refer to Internals and API
-> On-line marketing macros.

A variant's condition is specified in its Display condition property.

Through the edit icon ( ), you can use the Macro condition editor, which provides a graphical interface
that makes it easier to build complex conditions.

On the live site, each personalized object will only have one of its variants displayed at any given
moment. Variants are processed in the order of their priority and the first enabled variant whose
condition is fulfilled in the current context will be selected. The original object is displayed in cases
where the conditions of all variants are resolved as false.

By default, the priority of variants depends on the order in which they were created, as can be seen on
the personalization slider. Apart from the original object, which is always first, variants with a higher
priority can be found further on the left of the slider.

If you wish to change the order in which an object's variants should be processed, click the Variant list
button among the actions on the slider. A dialog containing a list of the variants will be opened as shown
below.

http://devnet.kentico.com/docs/6_0/devguide/index.html?entering_macro_expressions.htm#conditioneditor
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Here, you can reorganize the variants as necessary through the Up ( ) or Down ( ) actions.

9.3 Example: Creating a personalized page

This topic contains a step-by-step tutorial which describes how to create a relatively advanced
personalized page that leverages Contact management features in order to display different content to
each user according to the actions they previously performed on the website. Specifically, the example
demonstrates how you can modify the default Products page on the sample Corporate Site to display a
list of products based on the keywords that a visitor has entered into the website's search function.

1. Begin by opening the Corporate Site in CMS Desk and then select the Products document from the
content tree. Switch to the Design tab in Edit mode and you will be able to see the zones and web
parts that make up the content of the page. For the purposes of this example, we will create
personalization variants for the Random products web part located in the Main zone (its default title on
this page is Featured products). To add the first variant, open the context menu of the web part by right
clicking its header (or through the  icon), hover over the Personalization variants option and then
click Add web part variant in the second level of the menu.
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2. Enter the following values for the variant's properties in the displayed dialog:

Display name: Featured products - Smartphones
Code name: Products_smartphones
Enabled: Yes (leave it checked)
Display condition:

OnlineMarketingContext.CurrentContact.LastActivityOfType("internalsearch").
ActivityTitle.ToLower().Contains("phone")
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This condition ensures that the variant will only be displayed if the latest keyword searched by the
current user contains the word phone, e.g. smartphone, iPhone etc. It is composed of several macro
methods and expressions.

The LastActivityOfType method is used to retrieve the current contact's most recently logged Activity of
the Internal search type. The exact text of the search phrase is stored as part of the activity object's
Title, which is accessed through the corresponding property. Then, the title is converted to lower case to
make sure that the condition correctly recognizes search keywords with capital letters. Finally, the 
Contains method simply checks if the second parameter (i.e. the word phone) is located somewhere
within the text of the first one and returns the result.

When writing your own conditions, you can refer to the Internals and API -> On-line marketing macros
topic for a description of all available macro methods and context values related to on-line marketing
features.

Click OK.

3. Next, the configuration dialog for the variant's web part properties will appear, where you can define
which products should be displayed on the page. The properties will automatically have the same values
as are set for the original, so you only need to make the changes listed below:

Default -> Web part title: Featured products - Smartphones; setting a different title for each variant
is recommended, so that you can identify which variant you are working with on the Design tab
straight from the header text.
Content filter -> Product public status: (all)
Content filter -> Document types: CMS.Smartphone; this means that the web part will only load
and display documents of the appropriate type (smartphone products in this case).
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Once the changes are made, click OK.

4. Now add another variant to the same web part by clicking the Add content personalization variant
button ( ) next to the slider.

Set the following properties for the variant:

Display name: Featured products - MS Windows
Code name: Products_MS
Enabled: Yes (leave it checked)

Then click the edit icon ( ) next to the Display condition field to open the macro condition editor. On
the Designer tab, use the Add expression ( ) button to create three expressions and copy the
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following macro code into the text areas on the left:

searchText=OnlineMarketingContext.CurrentContact.LastActivityOfType(
"internalsearch").ActivityTitle.ToLower();

searchText.Contains("windows")

searchText.Contains("microsoft")

searchText.Contains("office")

Select the OR radio button between the expressions. The Contains function already returns a logical
value, so choose the (no operation) option from the selector for each expression.

Since this condition is composed of multiple parts, it only loads the latest search keyword once (just
like the first variant) and stores the value in a variable named searchText. This avoids unnecessary
repetition and improves performance. The variable is then checked for three different words. Because the 
OR option was selected between individual expressions, the condition will be fulfilled if at least one of the
keywords is found in the search text.

Once everything is set up properly, click OK to close the dialog and the macro output generated by the
condition editor will automatically be placed into the Display condition field. You can now confirm the
variant's properties.

For this variant, make the following changes to the web part's properties:

Default -> Web part title: Featured products - MS Windows
Content filter -> Product public status: (all)
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Content filter -> WHERE condition: SKUManufacturerID = 6; this causes the web part to load only
those products that have Microsoft Corporation set as their manufacturer (specified through the
manufacturer ID).

Click OK again to create the second variant. There are now three different versions of the product list on
the page.

5. To try out how the personalization works, sign out of CMS Desk to view the live site. Enter phone or
some other text containing this word into the search bar on any of the website's pages (it is located in
the header under the navigation menu).

Then select the Products page from the menu and you will see that only smartphone products are
included under the Featured products section.

You can test other possible search expressions and check how the content of the page changes. If the
searched text does not match the conditions of either one of the created variants, the default list
containing a random selection of featured products will be shown. If you log on to the site as a different
registered user (e.g. user name Andy with a blank password), this will change the current contact and
the default version of the page will be displayed until you search for an expression that matches one of
the personalization variant conditions.



Content personalization 159

© 2012 Kentico Software

As you can see, the result of the example is a personalized page that dynamically offers those products
that the visitor has shown interest in (by searching for related terms), rather than a random selection of
products from the entire catalog. When setting up this type of personalization on your own website, you
can create any number of variants with appropriate conditions according to your specific requirements
and product catalog.
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10 E-mail marketing

10.1 Overview

E-mail marketing can be one of the most effective ways to attract new customers to your website or
keep in touch with existing clients. In Kentico CMS, you have the option to prepare and send out mass
e-mails via newsletters, which ensure delivery to the addresses of all subscribers. Subscriber
management can either be done by importing a mailing list manually or by allowing visitors to opt-in
individually. Additionally, you may include any existing users registered on your site, or even subscribe
entire Contact groups to a newsletter.

For detailed information about the functionality of the newsletter module and its configuration options,
please see the Modules -> Newsletters chapter of the Kentico CMS Developer's Guide.

When using newsletters to carry out an e-mail marketing campaign, it is important to determine its
overall effectiveness. This can be achieved by tracking the sent e-mails and monitoring the reactions of
recipients. For this purpose, you may utilize several features that provide feedback and statistics about
how successful your newsletters are and which actions subscribers take when reading issues, including
the following:

E-mail tracking - measures how many newsletter issues were actually opened by subscribers and
the clickthrough rate of any links placed into the content of the e-mails.
Bounced e-mail monitoring - allows you to identify and block subscribers with invalid e-mail
addresses to which newsletter issues cannot be delivered.

Please note that the on-line marketing features of newsletters are only available if the Enable on-line
marketing setting is enabled for the given website in Site Manager -> Settings -> On-line marketing.

10.2 E-mail tracking

Two types of tracking can be used for the e-mails that deliver newsletter issues to subscribers. This
functionality may be enabled for individual newsletters through the CMS Desk -> On-line marketing ->
Newsletters interface by editing the selected newsletter on the Configuration tab: 

Track opened e-mails - if enabled, the e-mails used to send out the issues of the newsletter will be
tracked and statistics will be kept about the amount of e-mails that are opened by subscribers.
Track clicked links - if enabled, the system will maintain records of how many times subscribers
click the hyperlinks placed in the issues of the newsletter.

http://devnet.kentico.com/docs/6_0/devguide/newsletter_module_overview.htm
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Please note that tracking cannot be done retroactively for e-mails that have already been sent before the
appropriate settings were enabled. Also, since draft e-mails are intended only for testing purposes, they
are not included in tracking statistics (only the e-mails sent to actual subscribers are measured).

Logging newsletter actions as activities

You can also decide if you want the actions related to a specific newsletter to be
included in the site's on-line marketing Activity statistics. 

This is done by setting the Log newsletter actions as on-line marketing activities
property on the Configuration tab.

Newsletter activities include the following types of events: 

Subscription
Unsubscription
E-mail opening
Link clickthrough

Opened e-mails

This feature allows you to monitor how many newsletter e-mails are actually opened by subscribers.
Open rate is one of the key metrics for judging an e-mail campaign's success.

Tracking of this type is achieved by embedding a small, invisible image into the content of e-mails.
When this image is requested from the server for the first time, the system marks the e-mail as received
and opened for the given subscriber. As a result, mails will only be counted as opened if the e-mail client
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of the subscriber allows the loading of images. Alternatively, if the recipient clicks on a link contained in
the e-mail and Track clicked links is enabled for the newsletter, the e-mail will be recognized as
opened even if images are blocked. Because of these factors, the indicated number of opened e-mails
may be slightly lower than the actual amount.

If tracking is enabled, the statistics of newsletter issues can be viewed when editing a specific
newsletter on the Issues tab. The amount of e-mails that were received and opened by subscribers can
be compared side-by-side with the total number of sent e-mails.

If the number is greater than zero, it can be clicked to display a dialog containing a detailed list of all
subscribers who opened the e-mail.

The subscribers can be filtered according to their name, e-mail address or the time interval during which
they opened the e-mail.

Clicked links

Another way to measure the effectiveness of an e-mail campaign is to track which links are clicked by
the recipients and how many times, also known as the click through rate. If this type of tracking is
enabled, all links in newsletter issues are converted to tracking links when they are sent out. This
applies to both template based and dynamic newsletters. When a tracking link is clicked by a
subscriber, the system stores a record of the event.

Link statistics of individual newsletter issues can be viewed when editing a specific newsletter on the 
Issues tab. The View tracking statistics ( ) action is available for all issues that contain tracked
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hyperlinks.

When clicked, this action opens a modal dialog that lists all links in the given issue and displays the
following information about them:

Unique clicks - shows how many different subscribers clicked on the link.
Total clicks - indicates how many times the link was clicked, including multiple clicks from the
same user.
Click rate (%) - displays the clickthrough rate of the link as a percentage. Calculated as the number
of unique clicks divided by the total amount of sent e-mails.

Further details can be displayed for each link by using the View participating subscribers ( ) action.
The action opens another dialog containing the names and addresses of the subscribers that used the
given link and their respective click count.
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Excluding links from tracking

Tracking may be manually disabled for any link in a newsletter issue by editing the
source and inserting the tracking="false" attribute into the <a> tag of the given
hyperlink, for example:

<a href="http://www.kentico.com/home.aspx" tracking="false">Kentico CMS</a>

When editing the content of a newsletter issue, you can easily switch to its source
using the Source button on the toolbar of the WYSIWYG editor.

In addition, please keep in mind that newsletter unsubscription links generated by the 
{%UnsubscribeLink%} expression are not tracked by this feature (unsubscription
statistics are kept for each newsletter by default). Links to local anchors within the
content of an e-mail are also excluded.

10.3 Monitoring bounced e-mails

When an e-mail cannot be delivered successfully for some reason, an automatic reply informing about
the problem is returned (bounced) back to the sender. Tracking bounced mails allows the system to
identify addresses that do not correctly receive newsletter issues. Removing invalid addresses from your
mailing lists saves bandwidth and improves the accuracy of your subscription statistics, leading to a
better delivery rate.

Once this feature is enabled and properly configured (please see the Configuration section below for
more information), the mailbox where the bounced e-mails are stored is periodically checked. All
contained e-mails are analyzed and the bounce counter of subscribers is increased as necessary. After
a bounced e-mail is processed, it is deleted from the mailbox. This functionality is ensured by the 
Check bounced e-mails scheduled task, which is executed once per hour by default.

If the number of bounces received from a subscriber reaches a specified limit, the system will
automatically block the corresponding address from receiving any further newsletter issues.

http://devnet.kentico.com/docs/6_0/devguide/scheduler_overview.htm


Kentico CMS 6.0 On-line Marketing Guide166

© 2012 Kentico Software

Bounce statistics can be viewed in various parts of the CMS Desk -> On-line marketing ->
Newsletters interface. On the main Subscribers tab, the amount of bounces associated with individual
subscribers is displayed.

The Blocked field in the filter above the list may be used to display only blocked or active subscribers.
The Block ( ) or Unblock ( ) actions allow you to manually change the status of subscribers. When a
subscriber is unblocked, their bounce counter is reset to zero. To perform these actions for individual
subscribers assigned through a role or contact group, edit ( ) the given role or contact group subscriber
and switch to the Users or Contacts tab respectively.

The same options are also available when viewing the subscribers of a specific newsletter in 
Newsletters -> edit ( ) newsletter -> Subscribers. The bounce count of a subscriber is shared for all
newsletters on the given site.

On the Issues tab of a newsletter, the total amount of bounces is shown for each issue. This way, you
can view the amount of sent e-mails and compare it with the number of bounces.

Configuration

To enable this feature, go to Site Manager -> Settings -> On-line marketing -> Newsletters and
check the Monitor bounced e-mails box. It is also necessary to properly fill in the remaining settings
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in the Bounced e-mails and POP3 settings categories.

Keep in mind that it is possible to enter different values for each site to override the global settings (you
can use the Site selector above the settings tree for this purpose). The following options are available:

Bounced e-mails

Monitor bounced e-mails - indicates if bounced e-mails should be counted for newsletter
subscribers.
Bounced e-mail address - sets the e-mail address to which bounced e-mails are sent when the
delivery of a newsletter issue to a subscriber fails. If set, this address is used in the From field of
newsletter issue e-mails.
Bounced e-mail limit - sets the amount of bounced e-mails that can be recorded for a subscriber
before the system blocks them from receiving further newsletter issues. This limit is set for all
newsletters under the selected site. If 0 is entered, subscribers will never be blocked automatically,
but their bounced e-mail count will still be tracked and displayed in the CMS Desk -> On-line
marketing -> Newsletters interface.
Block subscribers globally - if checked, bounces will be added to all subscribers that have the
same e-mail address. This is applied across all sites in the system. Please note that this setting
does not ensure consistency between the bounce counts of all subscribers with a shared address,
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only that new bounces will be added to all of them.

POP3 settings

Server name - sets the domain name or IP address of the mail server where the bounced e-mails
should be stored. The POP3 protocol is used to check the server and monitor bounced e-mails.
Server port - specifies the number of the port used to connect to the mail server.
User name - sets the user name used for authentication against the mail server.
Password - sets the password used for authentication against the mail server.
Use SSL - indicates whether the connection to the mail server should be secured using SSL.
Authentication method - selects the authentication method used for the connection to the mail
server. Options include basic user name and password authentication and several
challenge-response mechanisms. The Auto option uses APOP if the server supports it and plain text
user name and password authentication otherwise.

Some mail servers may be configured to store e-mails even after they are downloaded, which causes
bounces to be counted multiple times (every time the mailbox is checked), so please adjust the settings
of the e-mail server if you experience issues of this type. 

Monitoring bounced e-mails under medium trust

If your website is hosted in a medium trust environment, the bounced e-mails feature
will not be functional by default.

To be able to check bounced e-mails, the newsletter module makes use of a
component that creates outgoing network connections via POP3, a standard e-mail
protocol for receiving maildrops from an e-mail server. This component requires the 
SocketPermission for its operation, otherwise it fails when attempting to connect to
the server. This permission is denied for applications under medium trust.

If you cannot raise the trust level yourself or create a custom security policy that
includes this permission, the only solution is to attempt to convince your hosting
administrators to grant the SocketPermission to your application. If you are unable to
do so, the bounced e-mail monitoring feature will unfortunately not be available.
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11 Security

11.1 Overview

The security options of the on-line marketing features described in this guide can be configured in the
same way as for all Kentico CMS modules. Access to various types of data and the ability to perform
specific actions is only allowed for users who belong to roles that have the appropriate Permissions for
individual on-line marketing modules.

Additionally, the user interface is composed of separate elements and each user may only view those
parts that are included in the UI personalization profile configured for their roles.

Default accounts and roles for on-line marketing

Security restrictions do not apply to users who are designated as global administrators,
since such accounts override any permission requirements and automatically have
access to all UI elements.

You may also assign users to the Marketing manager default role, which is imported
along with the sample Corporate Site. By default, this role may perform any on-line
marketing actions, since it has all the necessary permissions and UI elements
pre-assigned.

11.2 Permissions

Setting up the authorization options for on-line marketing features can be done by assigning the
appropriate permissions to your site's roles. This can be done in the Site Manager/CMS Desk ->
Administration -> Permissions interface. First, you need to select the appropriate Module and then fill
in its permission matrix as needed.

Web analytics (including conversions and campaigns)

The following permissions can be given for the Web analytics module:

Read - allows members of the specified roles to view web analytics reports and other parts of the
CMS Desk -> Tools -> Web analytics interface. It is also required to access the analytics reports
anywhere else in the UI, e.g. in CMS Desk -> Content -> Analytics -> Reports.
Save reports - allows members of the specified roles to save web analytics reports. The saved
reports can be viewed in the CMS Desk -> Tools -> Reporting interface.
Manage data - allows members of the specified roles to manage the data logged for various
statistics (i.e. delete or generate sample data for statistics).
Manage campaigns - allows members of the specified roles to create or delete campaign tracking
objects and edit their properties, including goals.
Manage conversions - allows members of the specified roles to create or delete conversions and
edit their properties.
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Contact management

There are four basic types of permissions for the Contact management module:

Read - allows members of the specified roles to access the appropriate part of the on-line marketing
interface and view any data there.
Read global - allows members of the specified roles to view global objects of the appropriate type.
Please note that global data is only available in CMS Desk if this is allowed by the site's settings (
Site Manager -> Settings -> On-line marketing -> Global data).
Modify - allows members of the specified roles to create, edit or delete objects of the given type.
Modify global - allows members of the specified roles to create, edit or delete global objects of the
given type in CMS Desk.

Specific permissions of these types are then available for the following contact management objects:

Contacts - these permissions allow users to view or manage contacts and their settings.
Accounts - affect the viewing or management of accounts.
Contact groups - affect the viewing or management of contact groups.
Configuration - these permissions affect the viewing or management of account statuses, contact
statuses and contact roles.
Activities - allow users to view or manage the activity log in CMS Desk. There are no global
permissions for activities, since activities are always logged for a specific site.

Please note that the Read global and Modify global type permissions may only be configured by global
administrators.
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Scoring

The security options of scoring are determined by the permissions of the Scoring module. The following
can be assigned:

Read - allows members of the selected roles to view the settings of scores and their rules, as well as
the score points of individual contacts. This applies to the CMS Desk -> On-line marketing ->
Scoring interface.
Manage - allows members of the selected roles to create, edit or delete scores and their rules. This
also includes the recalculate action.
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A/B and MVT testing

To configure the permissions for optimization testing, select the A/B testing or MVT testing module
respectively. The following two permissions can be assigned for either one of the modules:

Read - allows members of the selected roles to view all parts of the A/B or MVT testing management
interface and the corresponding reports.
Manage - allows members of the selected roles to create, edit and delete tests and manage their
variants. In this case of A/B testing, this means page variants. For MVT testing, this affects
management of object (web part, zone or widget) variants on pages that have a test defined.
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Additionally, permissions for the Web analytics module (as described above) are required to access A/B
or MVT testing reports in the web analytics interface and in CMS Desk -> Content -> Analytics -> A/B
tests / MVT tests -> Reports. 

Editing A/B testing page variant documents

Because every page variant is represented by a document in the content tree, the
standard document permissions apply. 

All permissions that can be configured for the Content module are checked, such as for
creating, modifying or deleting documents. Also, the Design web site permission for
the Design module is needed to edit page variants on the Design tab of CMS Desk.

Managing MVT object variants

The Design web site permission for the Design module is also needed for users to be
able to manage the variants of web parts and zones on the Design tab of CMS Desk.

To work with variants of editor widgets on the Page tab, the Modify permission for the
Content module is required. Also, the security settings defined for specific widgets are
checked, as described in the Development -> Widgets -> Security chapter of the
Developer's Guide.

Content personalization

To configure the permissions for content personalization, select the Content personalization module. The
following can be assigned:

Read - allows members of the selected roles to view the content of personalization variants, their
properties and variant lists in the CMS Desk  administration interface. No special permissions are
required to view personalized content on the live site.
Manage - allows members of the selected roles to create, edit and delete personalization variants of
objects.

http://devnet.kentico.com/docs/6_0/devguide/widgets_security.htm
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Additionally, the Design web site permission for the Design module is needed for users to be able to
manage the variants of web parts and zones on the Design tab of CMS Desk. To work with variants of
editor widgets on the Page tab, the Modify permission for the Content module is required. Also, the
security settings defined for specific widgets are checked.

E-mail marketing

E-mail marketing actions require the appropriate permissions for the Newsletters module:

Read - allows members of the selected roles to view all data in the CMS Desk -> On-line marketing -
> Newsletters interface.
Configure newsletters - allows members of the selected roles to configure the settings of individual
newsletter, including on-line marketing tracking.
Author newsletter issues - allows members of the selected roles to create, edit and send out
newsletter issues.
Manage subscribers - allows members of the selected roles to add, manage and remove newsletter
subscribers. This includes blocking and unblocking subscribers.
Manage templates - allows members of the selected roles to create, edit and delete newsletter
templates.
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Additionally, the Read contact groups permission for the Contact management module is required to
be able to subscribe contact groups to a newsletter.

11.3 UI personalization

UI personalization can be applied to CMS Desk only. Site Manager cannot be personalized as it is
typically used by administrators and developers who need the full rather than a simplified UI. Further in
the topic you will thus learn how to personalize the UI of On-line marketing, specifically the Ribbon and
Configuration tab, in CMS Desk.

Ribbon

You can hide individual items or entire item groups in the top ribbon menu of On-line marketing. 

In the screenshot below, you can see the UI elements of the Online marketing module. Their names
match the names of the ribbon menu items on the screenshot above.
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Configuration tab

You can also hide the tabs of the Configuration section of On-line marketing. 

In the screenshot below, you can see the UI elements of the respective section. Their names match the
names of the tabs on the screenshot above.
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Detailed information on UI personalization in Kentico CMS can be found in the Membership, permissions
and security -> UI personalization chapter in the Development section of the Developer's Guide.

http://devnet.kentico.com/docs/6_0/devguide/UI_personalization_overview.htm
http://devnet.kentico.com/docs/6_0/devguide/UI_personalization_overview.htm
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12 Internals and API

12.1 Overview

The content of this chapter is mainly intended for developers who wish to customize the behaviour of the
on-line marketing features, or for those interested in the internal workings. The information is divided into
the following sub-chapters, which are dedicated to the corresponding modules:

Web analytics (including campaigns and conversions)
Contact management
A/B testing
MVT testing
Content personalization
Newsletters (E-mail marketing)

Each section contains an overview of the database structure for the given module and a list of classes
that you can use when working with the API. If you are not familiar with database table data
management through Info and Provider classes, we strongly recommend that you read the Database
table API topic in the Kentico CMS Developer's Guide before you continue. For detailed API
documentation, such as a list of all methods from the module classes, please refer to Kentico CMS API
Reference.

The on-line marketing features are also supported by the macro engine, which can be extremely useful
when creating dynamic website content. You can learn more in the On-line marketing macros topic.

12.2 Web analytics

12.2.1 Database tables

There are six important database tables used by the web analytics module to keep track of statistics
and their values. The Analytics_Statistics table stores records that represent the statistics of a tracked
event within a certain context, i.e. related to a specific object, site and culture. 

Five other tables are used to store the exact number of hits for the statistics in the Analytics_Statistics
table:

Analytics_HourHits
Analytics_DayHits
Analytics_WeekHits
Analytics_MonthHits
Analytics_YearHits

When a hit for a tracked statistic occurs, it is logged into all of these tables. The difference between
them is in the unit of time used to separate hits into individual records. For example, a record in the 
Analytics_HoursHits table would contain the number of hits that were logged for a given statistic during
one hour, while a single record in Analytics_MonthHits would count all hits that occurred over an entire
month.

The Analytics_ExitPages table is used to temporarily store exit page candidates for the Top exit pages
statistic. The latest candidate recorded for a visitor when their session expires is then stored as the final
exit page.

http://devnet.kentico.com/docs/6_0/devguide/database_table_API.htm
http://devnet.kentico.com/docs/6_0/devguide/database_table_API.htm
http://devnet.kentico.com/docs/6_0/kenticocms_api.zip
http://devnet.kentico.com/docs/6_0/kenticocms_api.zip
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Additionally, the tables listed below are used to store campaign and conversion tracking objects:

Analytics_Campaign - contains records representing campaigns and their settings.
Analytics_Conversion - contains records representing conversions.
Analytics_ConversionCampaign - stores relationships between campaigns and conversions. Each
entry in this table indicates that a conversion should be included in the statistics of a certain
campaign. Only campaigns that are restricted to a limited set of conversions have these
relationships.

Campaign and conversion statistic storage

The data logged for campaigns and conversions is stored like all other web analytics
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statistics. The main records are kept in the Analytics_Statistics table and the
corresponding amount of hits for individual units of time are saved in the appropriate Hits
table.

Page view statistics for campaigns always use the campaign StatisticsCode with the
name of the given campaign stored in the StatisticsObjectName column.

The following code names are used for conversion statistics:

conversion - general statistic used to store the overall conversion records. This
statistic is always logged when a conversion is performed on the website.
campconversion;<campaign name> - logged when a conversion is performed by a
user associated with the particular campaign.
abconversion;<A/B test code name>;<Variant code name> - logged when a
conversion is performed by a user who viewed the given page variant of an A/B test.
mvtconversion;<MVT test code name>;<Combination name> - logged when a
conversion is performed by a user who viewed the given content combination on a
page with a defined multivariate test.

All types of conversions use the StatisticsObjectName column to store the code name
of the logged conversion.

12.2.2 API classes

The following classes are used to manage the web analytics module. They can be found in the CMS.
WebAnalytics namespace.

Analytics_Statistics table API:

StatisticsInfo - represents the statistics of a certain event within a specific context.
StatisticsInfoProvider - provides management functionality for statistic records.

Analytics_<time interval>Hits table API:

HitsInfo - represents the hits of a statistic during a specific time interval.
HitsInfoProvider - provides management functionality for statistic hits.

Analytics_Campaign table API:

CampaignInfo - represents one campaign tracking object.
CampaignInfoProvider - provides management functionality for campaigns.

Analytics_Conversion table API:

ConversionInfo - represents one conversion tracking object.
ConversionInfoProvider - provides management functionality for conversions.

Analytics_ConversionCampaign table API:

ConversionCampaignInfo - represents a relationship between a campaign and a conversion.
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ConversionCampaignInfoProvider - provides management functionality for campaign-conversion
relationships.

Other classes:

AnalyticsHelper - provides general web analytics functionality and data.
HitLogProvider - contains methods used to create the analytics log files for statistics.
HitLogProcessor - this class implements the scheduled task used to periodically process the
analytics log, which transfers the information to the database.

12.2.3 Logging conversions using the API

If you need to track a type of action that is not supported by default (as described in Logging actions as
conversions), you can write your own custom code and use the API to log conversions. This allows you
to monitor any type of activity performed by users on your website and view the results using the various
conversion reports available in the web analytics interface.

To log a conversion via the API, you can use code similar to the following:

[C#]

using CMS.WebAnalytics;
using CMS.CMSHelper;

...

string siteName = CMSContext.CurrentSiteName;
string aliasPath = CMSContext.CurrentAliasPath;

// Checks that web analytics and conversion tracking are enabled in the site's
settings.
// Also confirms that the current IP address, alias path and URL extension are not
excluded from web analytics tracking.
if (AnalyticsHelper.IsLoggingEnabled(siteName, aliasPath)
    && AnalyticsHelper.TrackConversionsEnabled(siteName))
{
    // Logs the conversion according to the specified parameters.
    HitLogProvider.LogConversions(siteName, CMSContext.PreferredCultureCode,
ConversionName, 0, 1, ConversionValue);
}

There are several possible ways to include this type of code in your website's functionality. When
tracking activity on a specific page, you may use a custom user control or web part to ensure that the
code is executed as required. If you wish to log actions that may occur anywhere on the website, you
may utilize global event handlers.

As shown above, conversions can be logged using the HitLogProvider class from the CMS.
WebAnalytics namespace, specifically the following method:

LogConversions(string siteName, string culture, string objectName, int objectId, int count, double value)

http://devnet.kentico.com/docs/6_0/devguide/adding_custom_code_to_the_portal_page_template.htm
http://devnet.kentico.com/docs/6_0/devguide/developing_web_parts.htm
http://devnet.kentico.com/docs/6_0/devguide/event_handler_library.htm
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siteName - sets the code name of the site for which the conversion should be logged.
culture - sets the culture code under which the conversion should be logged.
objectName - used to specify the code name of the conversion that should be logged.
objectId - used to specify the ID of the conversion. This parameter may be set to 0 if a valid code
name is passed via the objectName.
count - sets the amount of conversion hits that should logged. This parameter is optional and the
default value (1) is used if it is not specified.
value - specifies the value that will be logged for the conversion.

In addition to logging a general conversion, this method checks if the current user has passed through a
page with a running A/B or Multivariate test, or has arrived on the website through a Campaign. If this is
the case, then the conversion is also automatically logged within the appropriate context and included in
the statistics of the given test or campaign.

12.3 Contact management

12.3.1 Database tables

The following database tables are used to store contact management and scoring data:

OM_Contact - contains records representing contacts and their settings.
OM_ContactStatus - contains records representing possible contact statuses.
OM_ContactRole - stores the possible roles that contacts can have within accounts.
OM_Membership - this table is used to bind users, subscribers and customers to contacts. Each
entry has a member type, which determines whether the related object is a user, subscriber or
customer. The given object is then connected through its ID (RelatedID). Please note that the
relationships with the CMS_User, Newsletter_Subscriber and COM_Customer tables are not
indicated in the diagram below.
OM_IP - used to store the IP addresses associated with contacts.
OM_UserAgent - stores the browser user agents of contacts.

OM_Account - contains records representing accounts and their settings.
OM_AccountContact - stores relationships between contacts and accounts. Each record indicates
that a contact belongs to a specific account. If the contact has a certain role within the account, the
information is also stored in this relationship.
OM_AccountStatus - contains records representing possible account statuses.

OM_ContactGroup - contains records representing contact groups.
OM_ContactGroupMember - this table is used to bind contacts and accounts to contact groups.
Each entry has a member type, which determines whether the related object is a contact or account.
The given object is then connected through its ID (ContactGroupMemberRelatedID). Please note that
the relationships with the OM_Contact and OM_Account tables are not indicated in the diagram
below.

OM_Activity - contains records representing the logged activities.
OM_ActivityType - contains records of all possible activity types.
OM_PageVisit - used to store the additional details, which are logged along with Page visit
activities.
OM_Search - used to store additional details for Search activities.

OM_Score - contains records representing and their configuration.
OM_Rule - contains records representing scoring rules.
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OM_ScoreContactRule - contains relationships between contacts, scores and rules. Each record
stores the value that a specific contact has according to a certain scoring rule. The total score points
of a contact are calculated as the sum of all values for the rules that belong to the given score.

The diagram below shows the relationships between these tables. For a full-size diagram including table
columns, please click here.

12.3.2 API classes

The following contact management classes can be used in the API. Unless specified otherwise, they
may be found in the CMS.OnlineMarketing namespace.

OM_Contact table:

ContactInfo - represents one contact object.
ContactInfoProvider - provides management functionality for contacts.

OM_ContactStatus table:

ContactStatusInfo - represents one contact status.
ContactStatusInfoProvider - provides management functionality for contact statuses.

OM_ContactRole table:

ContactRoleInfo - represents one contact role.
ContactRoleInfoProvider - provides management functionality for contact roles.

OM_Membership table:

http://devnet.kentico.com/docs/6_0/onlinemarketingguide/cm_db_diagram.png
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MembershipInfo - represents a binding object between a contact and a user, subscriber or
customer.
MembershipInfoProvider - provides management functionality for contact binding objects.

OM_IP table:

IPInfo - represents one IP address associated with a contact.
IPInfoProvider - provides management functionality for contact IP addresses.

OM_UserAgent table:

UserAgentInfo - represents one browser user agent object associated with a contact.
UserAgentInfoProvider - provides management functionality for contact user agents.

OM_Account table:

AccountInfo - represents one account object.
AccountInfoProvider - provides management functionality for accounts.

OM_AccountContact table:

AccountContactInfo - represents a relationship between a contact and an account.
AccountContactInfoProvider - provides management functionality for account-contact
relationships.

OM_AccountStatus table:

AccountStatusInfo - represents one account status.
AccountStatusInfoProvider - provides management functionality for account statuses.

OM_ContactGroup table:

ContactGroupInfo - represents one contact group object.
ContactGroupInfoProvider - provides management functionality for contact groups.

OM_ContactGroupMember table:

ContactGroupMemberInfo - represents a binding object between a contact group and contact or
account.
ContactGroupMemberInfoProvider - provides management functionality for contact group binding
objects.

OM_Activity table:

ActivityInfo - represents one activity object.
ActivityInfoProvider - provides management functionality for activities.

OM_ActivityType table:

CMS.WebAnalytics.ActivityTypeInfo - represents an activity type object.
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CMS.WebAnalytics.ActivityTypeInfoProvider - provides management functionality for activity
types.

OM_PageVisit table:

PageVisitInfo - represents an object used to store additional data for Page visit activities.
PageVisitInfoProvider - provides management functionality for PageVisitInfo objects.

OM_Search table:

SearchInfo - represents an object used to store additional data for Search activities.
SearchInfoProvider - provides management functionality for SearchInfo objects.

OM_Score table:

ScoreInfo - represents one score object.
ScoreInfoProvider - provides management functionality for scores.

OM_Rule table:

RuleInfo - represents one scoring rule.
RuleInfoProvider - provides management functionality for scoring rules.

OM_ScoreContactRule table:

ContactScoreListInfo - represents a binding object between a contact, score and specific scoring
rule.

Other classes:

CMS.WebAnalytics.ActivityLogProvider - contains methods used to create activity log files.
CMS.WebAnalytics.ActivityLogProcessor - this class implements the scheduled task used to
periodically process the activities log, which transfers the information to the database.

12.3.3 API examples

12.3.3.1 Overview

The topics listed below contain examples that demonstrate how the contact management API can be
used:

Managing contacts
Managing contact groups
Managing contact roles
Managing contact statuses
Managing accounts
Managing account statuses
Managing activities
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Please note

All of the API examples can be simulated in the API examples user interface. Please
refer to the API examples chapter in the Developer's Guide for more details.

If you would like to check the code of the examples, please refer to <web project
folder>\CMSAPIExamples\Code\OnlineMarketing\ContactManagement\Default.
aspx.cs.

The contact management API examples use the following namespaces:

using System;
using System.Data;

using CMS.GlobalHelper;
using CMS.CMSHelper;
using CMS.SiteProvider;
using CMS.DataEngine;
using CMS.OnlineMarketing;
using CMS.SettingsProvider;

12.3.3.2 Managing contacts

The following example creates a new contact.

private bool CreateContact()
{
    // Create new contact object
    ContactInfo newContact = new ContactInfo()
        {
            ContactLastName = "My New Contact",
            ContactFirstName = "My New Firstname",
            ContactSiteID = CMSContext.CurrentSiteID,
            ContactIsAnonymous = true
        };

    // Save the contact
    ContactInfoProvider.SetContactInfo(newContact);

    return true;
}

The following example gets and updates the contact created by the example above.

private bool GetAndUpdateContact()
{
    // Get dataset of contacts

http://devnet.kentico.com/docs/6_0/devguide/API_examples_overview.htm
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    string where = "ContactLastName LIKE N'My New Contact%'";
    InfoDataSet<ContactInfo> contacts = ContactInfoProvider.GetContacts(where,
null, 1, null);

    if (!DataHelper.DataSourceIsEmpty(contacts))
    {
        // Get the contact from dataset
        ContactInfo contact = contacts.First<ContactInfo>();

        // Update a property
        contact.ContactLastName = contact.ContactLastName.ToLower();

        // Save the changes
        ContactInfoProvider.SetContactInfo(contact);

        return true;
    }

    return false;
}

The following example gets and bulk updates multiple contacts specified by a WHERE condition.

private bool GetAndBulkUpdateContacts()
{
    // Get dataset of contacts
    string where = "ContactLastName LIKE N'My New Contact%'";
    InfoDataSet<ContactInfo> contacts = ContactInfoProvider.GetContacts(where,
null);

    if (!DataHelper.DataSourceIsEmpty(contacts))
    {
        foreach (ContactInfo contact in contacts)
        {
            // Update a property of each contact
            contact.ContactLastName = contact.ContactLastName.ToUpper();

            // And save them
            ContactInfoProvider.SetContactInfo(contact);
        }

        return true;
    }

    return false;
}

The following example adds a contact status to the contact created by the first example in this topic.

private bool AddContactStatusToContact()
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{
    // Get dataset of contacts
    string where = "ContactLastName LIKE N'My New Contact%'";
    InfoDataSet<ContactInfo> contacts = ContactInfoProvider.GetContacts(where,
null, 1, null);

    // Get the contact status
    ContactStatusInfo contactStatus = ContactStatusInfoProvider.
GetContactStatusInfo("MyNewStatus", CMSContext.CurrentSiteName);

    if (!DataHelper.DataSourceIsEmpty(contacts) && (contactStatus != null))
    {
        // Get the contact from dataset
        ContactInfo contact = contacts.First<ContactInfo>();

        // If relationship doesn't already exist
        if (contact.ContactStatusID != contactStatus.ContactStatusID)
        {
            // Add contact status to contact
            contact.ContactStatusID = contactStatus.ContactStatusID;

            // Save the changes
            ContactInfoProvider.SetContactInfo(contact);

            return true;
        }
    }

    return false;
}

The following example removes the contact status added by the example above from the contact.

private bool RemoveContactStatusFromContact()
{
    // Get dataset of contacts
    string where = "ContactLastName LIKE N'My New Contact%'";
    InfoDataSet<ContactInfo> contacts = ContactInfoProvider.GetContacts(where,
null, 1, null);

    // Get the contact status
    ContactStatusInfo contactStatus = ContactStatusInfoProvider.
GetContactStatusInfo("MyNewStatus", CMSContext.CurrentSiteName);

    if (!DataHelper.DataSourceIsEmpty(contacts) && (contactStatus != null))
    {
        // Get the contact from dataset
        ContactInfo contact = contacts.First<ContactInfo>();

        // If relationship exists
        if (contact.ContactStatusID == contactStatus.ContactStatusID)
        {
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            // Remove the status
            contact.ContactStatusID = 0;

            // Save the changes
            ContactInfoProvider.SetContactInfo(contact);

            return true;
        }
    }

    return false;
}

The following example adds a membership (user) to the contact created by the first example in this
topic.

private bool AddMembership()
{
    // Get dataset of contacts
    string where = "ContactLastName LIKE N'My New Contact%'";
    InfoDataSet<ContactInfo> contacts = ContactInfoProvider.GetContacts(where,
null, 1, null);

    if (!DataHelper.DataSourceIsEmpty(contacts))
    {
        // Get the contact from dataset
        ContactInfo contact = contacts.First<ContactInfo>();

        // Set relationship to user
        CMS.OnlineMarketing.MembershipInfoProvider.SetRelationship(
            CMSContext.CurrentUser.UserID,
            MemberTypeEnum.CmsUser,
            contact.ContactID,
            contact.ContactID,
            false);

        return true;
    }

    return false;
}

The following example removes the membership (user) added by the previous example from the contact.

private bool RemoveMembership()
{
    // Get dataset of contacts
    string where = "ContactLastName LIKE N'My New Contact%'";
    InfoDataSet<ContactInfo> contacts = ContactInfoProvider.GetContacts(where,
null, 1, null);
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    if (!DataHelper.DataSourceIsEmpty(contacts))
    {
        // Get the contact from dataset
        ContactInfo contact = contacts.First<ContactInfo>();

        // Get the membership
        CMS.OnlineMarketing.MembershipInfo membership = CMS.OnlineMarketing.
MembershipInfoProvider.GetMembershipInfo(contact.ContactID, contact.ContactID,
CMSContext.CurrentUser.UserID, MemberTypeEnum.CmsUser);

        // Delete the membership
        CMS.OnlineMarketing.MembershipInfoProvider.DeleteRelationship(membership.
MembershipID);

        return (membership != null);
    }

    return false;
}

The following example adds an IP address to the contact created by the first example in this topic.

private bool AddIPAddress()
{
    // Get dataset of contacts
    string where = "ContactLastName LIKE N'My New Contact%'";
    InfoDataSet<ContactInfo> contacts = ContactInfoProvider.GetContacts(where,
null, 1, null);

    if (!DataHelper.DataSourceIsEmpty(contacts))
    {
        // Get the contact from dataset
        ContactInfo contact = contacts.First<ContactInfo>();

        // Create new IP address
        IPInfo newIP = new IPInfo()
            {
                IPAddress = "127.0.0.1",
                IPOriginalContactID = contact.ContactID,
                IPActiveContactID = contact.ContactID
            };

        // Save the IP info
        IPInfoProvider.SetIPInfo(newIP);

        return true;
    }

    return false;
}
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The following example removes the IP address added by the previous example from the contact.

private bool RemoveIPAddress()
{
    // Get dataset of contacts
    string where = "ContactLastName LIKE N'My New Contact%'";
    InfoDataSet<ContactInfo> contacts = ContactInfoProvider.GetContacts(where,
null, 1, null);

    if (!DataHelper.DataSourceIsEmpty(contacts))
    {
        // Get the contact from dataset
        ContactInfo contact = contacts.First<ContactInfo>();

        // Get contact's IP
        where = String.Format("IPOriginalContactID = '{0}' AND IPAddress = '{1}'",
contact.ContactID, "127.0.0.1");
        InfoDataSet<IPInfo> deleteIPs = IPInfoProvider.GetIps(where, null, 1,
"IPID");

        if (!DataHelper.DataSourceIsEmpty(deleteIPs))
        {
            // Delete IP
            IPInfoProvider.DeleteIPInfo(deleteIPs.First<IPInfo>());

            return true;
        }
    }

    return false;
}

The following example adds user agent information to the contact created by the first example in this
topic.

private bool AddUserAgent()
{
    // Get dataset of contacts
    string where = "ContactLastName LIKE N'My New Contact%'";
    InfoDataSet<ContactInfo> contacts = ContactInfoProvider.GetContacts(where,
null, 1, null);

    if (!DataHelper.DataSourceIsEmpty(contacts))
    {
        // Get the contact from dataset
        ContactInfo contact = contacts.First<ContactInfo>();

        // Create new agent info
        UserAgentInfo agentInfo = new UserAgentInfo()
            {
                UserAgentActiveContactID = contact.ContactID,
                UserAgentOriginalContactID = contact.ContactID,
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                UserAgentString = "My User Agent"
            };

        // Save the agent info
        UserAgentInfoProvider.SetUserAgentInfo(agentInfo);

        return true;
    }

    return false;
}

The following example removes the user agent information added by the previous example from the
contact.

private bool RemoveUserAgent()
{
    // Get dataset of contacts
    string where = "ContactLastName LIKE N'My New Contact%'";
    InfoDataSet<ContactInfo> contacts = ContactInfoProvider.GetContacts(where,
null, 1, null);

    if (!DataHelper.DataSourceIsEmpty(contacts))
    {
        // Get the contact from dataset
        ContactInfo contact = contacts.First<ContactInfo>();

        // Get the user agent info
        where = String.Format("UserAgentOriginalContactID = '{0}' AND
UserAgentString = '{1}'", contact.ContactID, "My User Agent");
        InfoDataSet<UserAgentInfo> deleteAgents = UserAgentInfoProvider.
GetUserAgents(where, null, 1, null);

        if (!DataHelper.DataSourceIsEmpty(deleteAgents))
        {
            // Delete the user agent info
            UserAgentInfoProvider.DeleteUserAgentInfo(deleteAgents.First<
UserAgentInfo>());

            return true;
        }
    }

    return false;
}

The following example deletes the contact created by the first example in this topic.

private bool DeleteContact()
{



Internals and API 195

© 2012 Kentico Software

    // Get dataset of contacts
    string where = "ContactLastName LIKE N'My New Contact%'";
    InfoDataSet<ContactInfo> contacts = ContactInfoProvider.GetContacts(where,
null, 1, null);

    if (!DataHelper.DataSourceIsEmpty(contacts))
    {
        // Get the contact from dataset
        ContactInfo contact = contacts.First<ContactInfo>();

        // Delete the contact
        ContactInfoProvider.DeleteContactInfo(contact);

        return true;
    }

    return false;
}

12.3.3.3 Managing contact groups

The following example creates a new contact group.

private bool CreateContactGroup()
{
    // Create new contact group object
    ContactGroupInfo newGroup = new ContactGroupInfo()
        {
            ContactGroupDisplayName = "My new group",
            ContactGroupName = "MyNewGroup",
            ContactGroupSiteID = CMSContext.CurrentSiteID,
            ContactGroupDynamicCondition = "{%Contact.ContactLastName.Contains
(\"My new\")%}"
        };

    // Save the contact group to database
    ContactGroupInfoProvider.SetContactGroupInfo(newGroup);

    return true;
}

The following example gets and updates the contact group created by the example above.

private bool GetAndUpdateContactGroup()
{
    // Get the contact group
    ContactGroupInfo updateGroup = ContactGroupInfoProvider.GetContactGroupInfo(
"MyNewGroup", CMSContext.CurrentSiteName);
    if (updateGroup != null)
    {
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        // Update contact group's properties
        updateGroup.ContactGroupDisplayName = updateGroup.ContactGroupDisplayName.
ToLower();

        // Save the contact group
        ContactGroupInfoProvider.SetContactGroupInfo(updateGroup);

        return true;
    }

    return false;
}

The following example gets and bulk updates multiple contact groups specified by a WHERE condition.

private bool GetAndBulkUpdateContactGroups()
{
    // Get the contact groups
    string where = "ContactGroupName LIKE N'MyNewGroup%'";
    InfoDataSet<ContactGroupInfo> groups = ContactGroupInfoProvider.
GetContactGroups(where, null);

    if (!DataHelper.DataSourceIsEmpty(groups))
    {
        foreach (ContactGroupInfo group in groups)
        {
            // Update a property
            group.ContactGroupDisplayName = group.ContactGroupDisplayName.ToUpper
();

            // Save the contact group
            ContactGroupInfoProvider.SetContactGroupInfo(group);
        }

        return true;
    }

    return false;
}

The following example adds a contact to the contact group created by the first example in this topic.

private bool AddContactToGroup()
{
    // Get dataset of contacts
    string where = "ContactLastName LIKE N'My New Contact%'";
    InfoDataSet<ContactInfo> contacts = ContactInfoProvider.GetContacts(where,
null, 1, null);

    // Get the contact group
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    ContactGroupInfo group = ContactGroupInfoProvider.GetContactGroupInfo(
"MyNewGroup", CMSContext.CurrentSiteName);

    if (!DataHelper.DataSourceIsEmpty(contacts) && (group != null))
    {
        // Get the contact from dataset
        ContactInfo contact = contacts.First<ContactInfo>();

        // Create the contact - contactgroup relationship
        ContactGroupMemberInfo newContactGroupMember = new ContactGroupMemberInfo
()
            {
                ContactGroupMemberContactGroupID = group.ContactGroupID,
                ContactGroupMemberType = ContactGroupMemberTypeEnum.Contact,
                ContactGroupMemberRelatedID = contact.ContactID,
                ContactGroupMemberFromManual = true
            };

        // Save the contact group
        ContactGroupMemberInfoProvider.SetContactGroupMemberInfo
(newContactGroupMember);

        return true;
    }

    return false;
}

The following example removes the contact added by the the previous example from the group.

private bool RemoveContactFromGroup()
{
    // Get dataset of contacts
    string where = "ContactLastName LIKE N'My New Contact%'";
    InfoDataSet<ContactInfo> contacts = ContactInfoProvider.GetContacts(where,
null, 1, null);

    // Get the contact group
    ContactGroupInfo group = ContactGroupInfoProvider.GetContactGroupInfo(
"MyNewGroup", CMSContext.CurrentSiteName);

    if (!DataHelper.DataSourceIsEmpty(contacts) && (group != null))
    {
        // Get the contact from dataset
        ContactInfo contact = contacts.First<ContactInfo>();

        // Get the contact - contactgroup relationship
        ContactGroupMemberInfo deleteContactGroupMember =
ContactGroupMemberInfoProvider.GetContactGroupMemberInfoByData(group.
ContactGroupID, contact.ContactID, ContactGroupMemberTypeEnum.Contact);

        if (deleteContactGroupMember != null)
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        {
            // Delete the info
            ContactGroupMemberInfoProvider.DeleteContactGroupMemberInfo
(deleteContactGroupMember);

            return true;
        }
    }

    return false;
}

The following example adds an account to the contact group created by the first example in this topic.

private bool AddAccountToGroup()
{
    // Get the account
    AccountInfo account = AccountInfoProvider.GetAccountInfo("My New Account",
CMSContext.CurrentSiteName);

    // Get the contact group
    ContactGroupInfo group = ContactGroupInfoProvider.GetContactGroupInfo(
"MyNewGroup", CMSContext.CurrentSiteName);

    if ((account != null) && (group != null))
    {
        // Create new account - contact group relationship
        ContactGroupMemberInfo newContactGroupMember = new ContactGroupMemberInfo
()
            {
                ContactGroupMemberContactGroupID = group.ContactGroupID,
                ContactGroupMemberType = ContactGroupMemberTypeEnum.Account,
                ContactGroupMemberRelatedID = account.AccountID
            };

        // Save the object
        ContactGroupMemberInfoProvider.SetContactGroupMemberInfo
(newContactGroupMember);

        return true;
    }

    return false;
}

The following example removes the account added by the the previous example from the group.

private bool RemoveAccountFromGroup()
{
    // Get the account
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    AccountInfo account = AccountInfoProvider.GetAccountInfo("My New Account",
CMSContext.CurrentSiteName);

    // Get the contact group
    ContactGroupInfo group = ContactGroupInfoProvider.GetContactGroupInfo(
"MyNewGroup", CMSContext.CurrentSiteName);

    if ((account != null) && (group != null))
    {
        // Get the account - contactgroup relationship
        ContactGroupMemberInfo deleteContactGroupMember =
ContactGroupMemberInfoProvider.GetContactGroupMemberInfoByData(group.
ContactGroupID, account.AccountID, ContactGroupMemberTypeEnum.Account);

        if (deleteContactGroupMember != null)
        {
            // Delete the info
            ContactGroupMemberInfoProvider.DeleteContactGroupMemberInfo
(deleteContactGroupMember);

            return true;
        }
    }

    return false;
}

The following example deletes the contact group created by the first example in this topic.

private bool DeleteContactGroup()
{
    // Get the contact group
    ContactGroupInfo deleteGroup = ContactGroupInfoProvider.GetContactGroupInfo(
"MyNewGroup", CMSContext.CurrentSiteName);

    if (deleteGroup != null)
    {
        // Delete the contact group
        ContactGroupInfoProvider.DeleteContactGroupInfo(deleteGroup);

        return true;
    }

    return false;
}

12.3.3.4 Managing contact roles

The following example creates a contact role.



Kentico CMS 6.0 On-line Marketing Guide200

© 2012 Kentico Software

private bool CreateContactRole()
{
    // Create new contact role object
    ContactRoleInfo newRole = new ContactRoleInfo()
        {
            ContactRoleDisplayName = "My new role",
            ContactRoleName = "MyNewRole",
            ContactRoleSiteID = CMSContext.CurrentSiteID
        };

    // Save the contact role
    ContactRoleInfoProvider.SetContactRoleInfo(newRole);

    return true;
}

The following example gets and updates the contact role created by the example above.

private bool GetAndUpdateContactRole()
{
    // Get the contact role
    ContactRoleInfo updateRole = ContactRoleInfoProvider.GetContactRoleInfo(
"MyNewRole", CMSContext.CurrentSiteName);
    if (updateRole != null)
    {
        // Update a property
        updateRole.ContactRoleDisplayName = updateRole.ContactRoleDisplayName.
ToLower();

        // Save the changes
        ContactRoleInfoProvider.SetContactRoleInfo(updateRole);

        return true;
    }

    return false;
}

The following example gets and bulk updates multiple contact roles specified by a WHERE condition.

private bool GetAndBulkUpdateContactRoles()
{
    // Get the contact roles dataset
    string where = "ContactRoleName LIKE N'MyNewRole%'";
    InfoDataSet<ContactRoleInfo> roles = ContactRoleInfoProvider.GetContactRoles
(where, null);

    if (!DataHelper.DataSourceIsEmpty(roles))
    {
        foreach (ContactRoleInfo role in roles)
        {
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            // Update the properties
            role.ContactRoleDisplayName = role.ContactRoleDisplayName.ToUpper();

            // Save the changes
            ContactRoleInfoProvider.SetContactRoleInfo(role);
        }

        return true;
    }

    return false;
}

The following example deletes the contact role created by the first example in this topic.

private bool DeleteContactRole()
{
    // Get the contact role
    ContactRoleInfo deleteRole = ContactRoleInfoProvider.GetContactRoleInfo(
"MyNewRole", CMSContext.CurrentSiteName);

    if (deleteRole != null)
    {
        // Delete the contact role
        ContactRoleInfoProvider.DeleteContactRoleInfo(deleteRole);

        return true;
    }

    return false;
}

12.3.3.5 Managing contact statuses

The following example creates a contact status.

private bool CreateContactStatus()
{
    // Create new contact status object
    ContactStatusInfo newStatus = new ContactStatusInfo()
        {
            ContactStatusDisplayName = "My new status",
            ContactStatusName = "MyNewStatus",
            ContactStatusSiteID = CMSContext.CurrentSiteID
        };

    // Save the contact status
    ContactStatusInfoProvider.SetContactStatusInfo(newStatus);

    return true;
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}

The following example gets and updates the contact status created by the example above.

private bool GetAndUpdateContactStatus()
{
    // Get the contact status
    ContactStatusInfo updateStatus = ContactStatusInfoProvider.
GetContactStatusInfo("MyNewStatus", CMSContext.CurrentSiteName);
    if (updateStatus != null)
    {
        // Update a property
        updateStatus.ContactStatusDisplayName = updateStatus.
ContactStatusDisplayName.ToLower();

        // Save the changes
        ContactStatusInfoProvider.SetContactStatusInfo(updateStatus);

        return true;
    }

    return false;
}

The following example gets and bulk updates multiple contact statuses specified by a WHERE
condition.

private bool GetAndBulkUpdateContactStatuses()
{
    // Get the contact statuses dataset
    string where = "ContactStatusName LIKE N'MyNewStatus%'";
    InfoDataSet<ContactStatusInfo> statuses = ContactStatusInfoProvider.
GetContactStatuses(where, null);

    if (!DataHelper.DataSourceIsEmpty(statuses))
    {
        foreach (ContactStatusInfo contactStatus in statuses)
        {
            // Update a property
            contactStatus.ContactStatusDisplayName = contactStatus.
ContactStatusDisplayName.ToUpper();

            // Save the changes
            ContactStatusInfoProvider.SetContactStatusInfo(contactStatus);
        }

        return true;
    }

    return false;
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}

The following example deletes the contact status created by the first example in this topic.

private bool DeleteContactStatus()
{
    // Get the contact status
    ContactStatusInfo deleteStatus = ContactStatusInfoProvider.
GetContactStatusInfo("MyNewStatus", CMSContext.CurrentSiteName);

    if (deleteStatus != null)
    {
        // Delete the contact status
        ContactStatusInfoProvider.DeleteContactStatusInfo(deleteStatus);

        return true;
    }

    return false;
}

12.3.3.6 Managing accounts

The following example creates a new account.

private bool CreateAccount()
{
    // Create new account object
    AccountInfo newAccount = new AccountInfo()
        {
            AccountName = "My New Account",
            AccountSiteID = CMSContext.CurrentSiteID
        };

    // Save the account
    AccountInfoProvider.SetAccountInfo(newAccount);

    return true;
}

The following example gets and updates the account created by the example above.

private bool GetAndUpdateAccount()
{
    // Get the account
    AccountInfo updateAccount = AccountInfoProvider.GetAccountInfo("My New
Account", CMSContext.CurrentSiteName);
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    if (updateAccount != null)
    {
        // Update a property
        updateAccount.AccountName = updateAccount.AccountName.ToLower();

        // And save it
        AccountInfoProvider.SetAccountInfo(updateAccount);

        return true;
    }

    return false;
}

The following example gets and bulk updates multiple accounts specified by a WHERE condition.

private bool GetAndBulkUpdateAccounts()
{
    // Get dataset of accounts
    string where = "AccountName LIKE N'My New Account%'";
    InfoDataSet<AccountInfo> accounts = AccountInfoProvider.GetAccounts(where,
null);

    if (!DataHelper.DataSourceIsEmpty(accounts))
    {
        foreach (AccountInfo account in accounts)
        {
            // Update each one's property
            account.AccountName = account.AccountName.ToUpper();

            // And save it
            AccountInfoProvider.SetAccountInfo(account);
        }

        return true;
    }

    return false;
}

The following example adds an account status to the account created by the first example in this topic.

private bool AddAccountStatusToAccount()
{
    // Get the account
    AccountInfo account = AccountInfoProvider.GetAccountInfo("My New Account",
CMSContext.CurrentSiteName);

    // Get the account status
    AccountStatusInfo accountStatus = AccountStatusInfoProvider.



Internals and API 205

© 2012 Kentico Software

GetAccountStatusInfo("MyNewStatus", CMSContext.CurrentSiteName);

    if ((account != null) && (accountStatus != null))
    {
        // Check that account doesn't have this status 
        if (account.AccountStatusID != accountStatus.AccountStatusID)
        {
            // Set new status
            account.AccountStatusID = accountStatus.AccountStatusID;

            // Save changes to the object
            AccountInfoProvider.SetAccountInfo(account);

            return true;
        }
    }

    return false;
}

The following example removes the account status added by the previous example from the account.

private bool RemoveAccountStatusFromAccount()
{
    // Get the account
    AccountInfo account = AccountInfoProvider.GetAccountInfo("My New Account",
CMSContext.CurrentSiteName);

    // Get the account status
    AccountStatusInfo accountStatus = AccountStatusInfoProvider.
GetAccountStatusInfo("MyNewStatus", CMSContext.CurrentSiteName);

    if ((account != null) && (accountStatus != null))
    {
        // Check if account has this status set
        if (account.AccountStatusID == accountStatus.AccountStatusID)
        {
            // Remove the status from account
            account.AccountStatusID = 0;

            // Save the object
            AccountInfoProvider.SetAccountInfo(account);

            return true;
        }
    }

    return false;
}

The following example adds a contact to the account created by the first example in this topic.
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private bool AddContactToAccount()
{
    // Get dataset of contacts
    string where = "ContactLastName LIKE N'My New Contact%'";
    InfoDataSet<ContactInfo> contacts = ContactInfoProvider.GetContacts(where,
null, 1, null);

    // Get the account
    AccountInfo account = AccountInfoProvider.GetAccountInfo("My New Account",
CMSContext.CurrentSiteName);

    // Get the role
    ContactRoleInfo role = ContactRoleInfoProvider.GetContactRoleInfo("MyNewRole",
CMSContext.CurrentSiteName);

    if (!DataHelper.DataSourceIsEmpty(contacts) && (account != null) && (role !=
null))
    {
        // Get the contact from dataset
        ContactInfo contact = contacts.First<ContactInfo>();

        // Create new account - contact relationship
        AccountContactInfo accountContact = new AccountContactInfo()
            {
                AccountID = account.AccountID,
                ContactID = contact.ContactID,
                ContactRoleID = role.ContactRoleID
            };

        // And save it
        AccountContactInfoProvider.SetAccountContactInfo(accountContact);

        return true;
    }

    return false;
}

The following example removes the contact added by the previous example from the account.

private bool RemoveContactFromAccount()
{
    // Get dataset of contacts
    string where = "ContactLastName LIKE N'My New Contact%'";
    InfoDataSet<ContactInfo> contacts = ContactInfoProvider.GetContacts(where,
null, 1, null);

    // Get the account
    AccountInfo account = AccountInfoProvider.GetAccountInfo("My New Account",
CMSContext.CurrentSiteName);

    if (!DataHelper.DataSourceIsEmpty(contacts) && (account != null))
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    {
        // Get the contact from dataset
        ContactInfo contact = contacts.First<ContactInfo>();

        // Find account - contact relationship
        AccountContactInfo accountContact = AccountContactInfoProvider.
GetAccountContactInfo(account.AccountID, contact.ContactID);

        if (accountContact != null)
        {
            // Delete the object
            AccountContactInfoProvider.DeleteAccountContactInfo(accountContact);

            return true;
        }
    }

    return false;
}

The following example deletes the account created by the first example in this topic.

private bool DeleteAccount()
{
    // Get the account
    AccountInfo deleteAccount = AccountInfoProvider.GetAccountInfo("My New
Account", CMSContext.CurrentSiteName);

    if (deleteAccount != null)
    {
        // Delete the account
        AccountInfoProvider.DeleteAccountInfo(deleteAccount);

        return true;
    }

    return false;
}

12.3.3.7 Managing account statuses

The following example creates an account status.

private bool CreateAccountStatus()
{
    // Create new account status object
    AccountStatusInfo newStatus = new AccountStatusInfo()
        {
            AccountStatusDisplayName = "My new status",
            AccountStatusName = "MyNewStatus",
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            AccountStatusSiteID = CMSContext.CurrentSiteID
        };

    // Save the account status
    AccountStatusInfoProvider.SetAccountStatusInfo(newStatus);

    return true;
}

The following example gets and updates the account status created by the example above.

private bool GetAndUpdateAccountStatus()
{
    // Get the account status
    AccountStatusInfo updateStatus = AccountStatusInfoProvider.
GetAccountStatusInfo("MyNewStatus", CMSContext.CurrentSiteName);
    if (updateStatus != null)
    {
        // Update a property
        updateStatus.AccountStatusDisplayName = updateStatus.
AccountStatusDisplayName.ToLower();

        // Save the changes
        AccountStatusInfoProvider.SetAccountStatusInfo(updateStatus);

        return true;
    }

    return false;
}

The following example gets and bulk updates multiple account statuses specified by a WHERE
condition.

private bool GetAndBulkUpdateAccountStatuses()
{
    // Get the account status dataset
    string where = "AccountStatusName LIKE N'MyNewStatus%'";
    InfoDataSet<AccountStatusInfo> statuses = AccountStatusInfoProvider.
GetAccountStatuses(where, null);

    if (!DataHelper.DataSourceIsEmpty(statuses))
    {
        foreach (AccountStatusInfo accountStatus in statuses)
        {
            // Update a property
            accountStatus.AccountStatusDisplayName = accountStatus.
AccountStatusDisplayName.ToUpper();

            // Save the changes
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            AccountStatusInfoProvider.SetAccountStatusInfo(accountStatus);
        }

        return true;
    }

    return false;
}

The following example deletes the account status created by the first example in this topic.

private bool DeleteAccountStatus()
{
    // Get the account status
    AccountStatusInfo deleteStatus = AccountStatusInfoProvider.
GetAccountStatusInfo("MyNewStatus", CMSContext.CurrentSiteName);

    if (deleteStatus != null)
    {
        // Delete the account status
        AccountStatusInfoProvider.DeleteAccountStatusInfo(deleteStatus);

        return true;
    }

    return false;
}

12.3.3.8 Managing activities

The following example logs an activity.

private bool CreateActivity()
{
    // Get dataset of contacts
    string where = "ContactLastName LIKE N'My New Contact%'";
    InfoDataSet<ContactInfo> contacts = ContactInfoProvider.GetContacts(where,
null, 1, null);

    if (!DataHelper.DataSourceIsEmpty(contacts))
    {
        // Get the contact from dataset
        ContactInfo contact = contacts.First<ContactInfo>();

        // Get an activity type
        ActivityTypeInfo activityType = ActivityTypeInfoProvider.GetActivityTypes(
null, null, 1, null).First<ActivityTypeInfo>();

        // Create new activity object
        ActivityInfo newActivity = new ActivityInfo()
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            {
                ActivityType = activityType.ActivityTypeName,
                ActivityTitle = "My new activity",
                ActivitySiteID = CMSContext.CurrentSiteID,
                ActivityOriginalContactID = contact.ContactID,
                ActivityActiveContactID = contact.ContactID
            };

        // Save the activity
        ActivityInfoProvider.SetActivityInfo(newActivity);

        return true;
    }

    return false;
}

The following example gets and updates a the activity logged by the example above.

private bool GetAndUpdateActivity()
{
    // Get dataset of contacts
    string where = "ContactLastName LIKE N'My New Contact%'";
    InfoDataSet<ContactInfo> contacts = ContactInfoProvider.GetContacts(where,
null, 1, null);

    if (!DataHelper.DataSourceIsEmpty(contacts))
    {
        // Get the contact from dataset
        ContactInfo contact = contacts.First<ContactInfo>();

        // Get all activities associated with user
        where = String.Format("ActivityActiveContactID = '{0}'", contact.
ContactID);
        InfoDataSet<ActivityInfo> updateActivities = ActivityInfoProvider.
GetActivities(where, null);

        if (!DataHelper.DataSourceIsEmpty(updateActivities))
        {
            // Get just the first activity
            ActivityInfo activity = updateActivities.First<ActivityInfo>();

            // Update the activity
            activity.ActivityTitle = activity.ActivityTitle.ToLower();

            // Save the activity
            ActivityInfoProvider.SetActivityInfo(activity);

            return true;
        }
    }
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    return false;
}

The following example gets and bulk updates multiple activities specified by a WHERE condition.

private bool GetAndBulkUpdateActivities()
{
    // Get dataset of contacts
    string where = "ContactLastName LIKE N'My New Contact%'";
    InfoDataSet<ContactInfo> contacts = ContactInfoProvider.GetContacts(where,
null, 1, null);

    if (!DataHelper.DataSourceIsEmpty(contacts))
    {
        // Get the contact from dataset
        ContactInfo contact = contacts.First<ContactInfo>();

        // Get all activities associated with contact
        where = String.Format("ActivityActiveContactID = '{0}'", contact.
ContactID);
        InfoDataSet<ActivityInfo> updateActivities = ActivityInfoProvider.
GetActivities(where, null);

        if (!DataHelper.DataSourceIsEmpty(updateActivities))
        {

            foreach (ActivityInfo activity in updateActivities)
            {
                // Update activity content
                activity.ActivityTitle = activity.ActivityTitle.ToLower();

                // Save the activity
                ActivityInfoProvider.SetActivityInfo(activity);
            }

            return true;
        }
    }

    return false;
}

The following example deletes the activity logged by the first example in this topic.

private bool DeleteActivity()
{
    // Get dataset of contacts
    string where = "ContactLastName LIKE N'My New Contact%'";
    InfoDataSet<ContactInfo> contacts = ContactInfoProvider.GetContacts(where,
null, 1, null);
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    if (!DataHelper.DataSourceIsEmpty(contacts))
    {
        // Get the contact from dataset
        ContactInfo contact = contacts.First<ContactInfo>();

        // Get all activities associated with contact
        where = String.Format("ActivityOriginalContactID = '{0}'", contact.
ContactID);
        InfoDataSet<ActivityInfo> activities = ActivityInfoProvider.GetActivities
(where, null);

        if (!DataHelper.DataSourceIsEmpty(activities))
        {
            foreach (ActivityInfo activity in activities)
            {
                // Delete the object
                ActivityInfoProvider.DeleteActivityInfo(activity);
            }

            return true;
        }
    }

    return false;
}

12.4 A/B testing

12.4.1 Database tables

The following database tables are used to store A/B testing data:

OM_ABTest - contains records representing A/B tests and their settings.
OM_ABVariant - contains records representing individual A/B testing page variants. Each variant
record contains the path to the corresponding document in the content tree, which will be displayed
when the given variant is selected during the test.
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The results of A/B tests (i.e. conversion statistics) are stored among the data of the web analytics
module. Please see Web analytics -> Database tables to learn more.

12.4.2 API classes

The following classes are used to manage the A/B testing module. They may be found in the CMS.
OnlineMarketing namespace.

OM_ABTest table API:

ABTestInfo - represents one A/B test object.
ABTestInfoProvider - provides management functionality for A/B tests.

OM_ABVariant table API:

ABVariantInfo - represents one A/B testing page variant.
ABVariantInfoProvider - provides management functionality for page variants.

12.5 MVT testing

12.5.1 Database tables

The following database tables are used to store multivariate testing data:

OM_MVTest - contains records representing MVT tests and their settings. Each test record contains
the path to the corresponding document in the content tree. When the test is running, possible MVT
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combinations will be loaded through their connection to the given document's page template or
content.
OM_MVTVariant - contains records representing MVT testing variants. As you can see, variants are
not linked to specific MVT tests. Instead, they are either stored on the page template used by the
given document (in the case of web parts and zones) or as part of the document's content (editor
widget variants).
OM_MVTCombination - this table is used to store MVT combinations and their configuration.
OM_MVTCombinationVariation - stores relationships between MVT variants and combinations.
Each entry in this table indicates that a variant is included in a specific combination.

The results of MVT tests (i.e. conversion statistics) are stored among the data of the web analytics
module. Please see Web analytics -> Database tables to learn more.

12.5.2 API classes

The following classes are used to manage the MVT testing module. They may be found in the CMS.
OnlineMarketing namespace.
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OM_MVTest table API:

MVTestInfo - represents one MVT test object.
MVTestInfoProvider - provides management functionality for MVT tests.

OM_MVTVariant table API:

MVTVariantInfo - represents one MVT variant.
MVTVariantInfoProvider - provides management functionality for MVT variants.

OM_MVTCombination table API:

MVTCombinationInfo - represents one MVT combination.
MVTCombinationInfoProvider - provides management functionality for combinations.

OM_MVTCombinationVariation table API:

MVTCombinationVariationInfo - represents a relationship between an MVT variant and a
combination.
MVTCombinationVariationInfoProvider - provides management functionality for
variant-combination relationships.

12.6 Content personalization

12.6.1 Database tables

Content personalization data is stored in a single database table:

OM_PersonalizationVariant - contains records representing personalization variants of web parts,
zones and widgets. Web part and zone variants are bound to a specific page template. Widget
variants are additionally connected to individual documents.

All variant records contain the ID of the zone where they are located. Web part and widget variants
additionally have bindings to the specific web part/widget instance for which they are defined.
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12.6.2 API classes

The following classes are used to manage content personalization. They may be found in the CMS.
OnlineMarketing namespace.

OM_PersonalizationVariant table API:

ContentPersonalizationVariantInfo - represents one personalization variant.
ContentPersonalizationVariantInfoProvider - provides management functionality for content
personalization variants.

12.7 Newsletters

12.7.1 Database tables

The following database tables are used in the newsletters module:

Newsletter_Newsletter - contains records representing newsletters and their configuration.
Newsletter_NewsletterIssue - used to store individual newsletter issues, including their content.
Newsletter_Subscriber - contains records representing newsletter subscribers.
Newsletter_SubscriberNewsletter - stores relationships between subscribers and newsletters. This
table also contains data that determines whether the subscriber is approved for the given newsletter.
Newsletter_EmailTemplate - used to store the templates on which newsletter issues and
notification messages are based (all types).
Newsletter_Emails - this table stores newsletter e-mails could not be sent out successfully (i.e. the
newsletter queue). This allows them to be resent at a later time.
Newsletter_OpenedEmail - stores relationships between subscribers and newsletter issues. Each
record indicates that a subscriber has opened a specific issue.
Newsletter_Link - contains records representing links inside the content of newsletter issues.
Newsletter_SubscriberLink - stores relationships between subscribers and newsletter links. Each
record indicates that a subscriber has clicked on a specific link.
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12.7.2 API classes

The following classes are used to manage the newsletters module. They may be found in the CMS.
Newsletter namespace.

Newsletter_Newsletter table API:

Newsletter - represents on newsletter object.
NewsletterProvider - provides management functionality for newsletters.

Newsletter_NewsletterIssue table API:

Issue - represents one newsletter issue.
IssueProvider - provides management functionality for newsletter issues.

Newsletter_Subscriber table API:

Subscriber - represents one newsletter subscriber.
SubscriberProvider - provides management functionality for subscribers.

Newsletter_SubscriberNewsletter table API:

SubscriberNewsletterInfo - represents a relationship between a subscriber and a newsletter.
SubscriberNewsletterInfoProvider - provides management functionality for subscriber-newsletter
relationships.

Newsletter_EmailTemplate table API:

EmailTemplate - represents one newsletter e-mail template.
EmailTemplateProvider - provides management functionality for newsletter templates.

Newsletter_Emails table API:

EmailQueueItem - represents an issue e-mail in the newsletter e-mail queue.
EmailQueueManager - provides management functionality for the newsletter queue.

Newsletter_OpenedEmail table API:

OpenedEmailInfo - represents a relationship which indicates that a subscriber has opened a
newsletter issue.
OpenedEmailInfoProvider - provides management functionality for subscriber-issue relationships.

Newsletter_Link table API:

LinkInfo - represents a link in a newsletter.
LinkInfoProvider - provides management functionality for newsletter links.

Newsletter_SubscriberLink table API:

SubscriberLinkInfo - represents a relationship between a subscriber and a newsletter link (i.e. the
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amount of clicks that the given subscriber performed, if any).
SubscriberLinkInfoProvider - provides management functionality for subscriber-link relationships.

12.8 On-line marketing macros

There are many available macro expressions and methods that provide a way to dynamically load values
related to on-line marketing features. Properly using these expressions allows you to set up flexible
content and behaviour for your website.

With on-line marketing, one of the most important places where macros are required is in the conditions
that can be specified for Content personalization variants, dynamic Contact groups or Campaigns. They
may also be used in all other parts of Kentico CMS where macros are supported.

Please note that all expressions described below are context macros, which means they must be
enclosed in {% %} parentheses when entered into text or other general fields. This is not necessary
inside macro-specific fields, such as condition editors, where the system automatically ensures that the
content is processed as a macro. For more information about possible macro options and syntax in
general, please refer to the Development -> Macro expressions chapter in the Kentico CMS Developer's
Guide.

Contact management and Scoring data

The fundamental part of most on-line marketing macros is the loading of a specific contact or its data.
You may use the following expressions for this purpose:

OnlineMarketingContext.CurrentContact - returns a ContactInfo object representing the current
contact, i.e. the visitor who is viewing the website when the macro is resolved.
OnlineMarketingContext.CurrentContactID - returns the ID of the current contact.

Contact - you may use this expression when writing conditions for dynamic contact groups. It allows
you to work with a general ContactInfo object. When the contact group is rebuilt, all contacts under
the corresponding site (or from all sites in the system if the group is global) are processed and
checked whether they fulfill the specified condition (e.g. Contact.ContactGender == 1).

ContactInfo objects serve as a way to access the values set for the given contact (e.g.
OnlineMarketingContext.CurrentContact.ContactLastName). In addition to standard contact fields, you
can also use the following advanced properties to get data related to the contact:

Accounts - InfoObjectCollection containing all accounts (AccountInfo objects) to which the given
contact is assigned.
LastActivity - ActivityInfo object representing the most recently logged activity for the given contact.
Orders - InfoObjectCollection containing all e-commerce orders (OrderInfo objects) made by the
contact on the current site.
PurchasedProducts - InfoObjectCollection containing all products (SKUInfo objects) purchased by
the contact across all sites in the system.
Wishlist - InfoObjectCollection containing all products (SKUInfo objects) added to the wishlist of the
given contact (across all sites in the system).

There are many ways how an InfoObjectCollection can be further processed. For example:

OnlineMarketingContext.CurrentContact.Accounts.Exists(AccountName == "CompanyAccount")

This sample macro checks whether the current contact belongs to an account named CompanyAccount

http://devnet.kentico.com/docs/6_0/devguide/macro_expressions_overview.htm
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and returns the result as a boolean value.

OnlineMarketingContext.CurrentContact.Orders.Exists(OrderTotalPrice > 500)

Checks if the current contact has made an order with a total value greater than 500 of the given
currency.

Please see the Available macro methods topic in the Developer's Guide for a comprehensive list of the
possible options.

On-line marketing macro methods

You may also call the following methods inside macro expressions, which are specifically designed to
help retrieve on-line marketing data:

LastActivityOfType(Object contact, Object activityType)
Returns an ActivityInfo object representing the activity most recently logged for the specified contact.

contact - this parameter must contain the appropriate ContactInfo object of the contact whose
activity should be loaded.
activityType - optional parameter that may be used to get the last activity of a specific type. The
value must be entered as a string matching the code name of the appropriate activity type.

Example:

LastActivityOfType(OnlineMarketingContext.CurrentContact, "purchasedproduct")

or:

OnlineMarketingContext.CurrentContact.LastActivityOfType("purchasedproduct")

FirstActivityOfType(Object contact, Object activityType)
Returns an ActivityInfo object representing the first activity logged for the specified contact.

contact - this parameter must contain the appropriate ContactInfo object of the contact whose
activity should be loaded.
activityType - optional parameter that may be used to get the first activity of a specific type. The
value must be entered as a string matching the code name of the appropriate activity type.

OnlineMarketingContext.CurrentContact.FirstActivityOfType("productaddedtowishlist"
)

IsInContactGroup(Object contact, Object contactGroupName)
Checks if a contact belongs to a specific contact group and returns the result as a boolean value (true or
false).

contact - this parameter is used to specify the ContactInfo object representing the contact that will
be checked.
contactGroupName - must contain the code name of the given contact group. You can enter the
value as a string.

http://devnet.kentico.com/docs/6_0/devguide/available_macro_methods.htm
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OnlineMarketingContext.CurrentContact.IsInContactGroup("MaleCustomers")

GetScore(Object contact, Object scoreName)
This method returns the total number of score points that a given contact has in a specified score (as
an integer).

contact - used to specify the ContactInfo object representing the contact whose score points should
be loaded.
scoreName - must contain the code name of the given score. You can enter the value as a string.

OnlineMarketingContext.CurrentContact.GetScore("InterestedInSmartphones")

GetEmailDomain(Object email)
This method may be used to read an e-mail address and return only its domain part (all characters after
the "@" sign).

email - this parameter is used to specify the e-mail address from which the domain should be taken.
You can enter the address as a string.

OnlineMarketingContext.CurrentContact.ContactEmail.GetEmailDomain()

Scoring - Notification e-mail template macros

It is also possible to place macros into the text of the Scoring - Notification e-mail e-mail template, so
you can dynamically load the appropriate values. This template is used for the automatic messages that
inform administrators or marketers that a contact has reached a certain amount of score points. There
are several special macros available for this purpose.

The {% ScoreValue %} expression returns the current number of score points for the given contact.
Additionally, you can access the following related objects and their properties (e.g. {% Score.
ScoreDisplayName %} etc.):

{% Score %} - ScoreInfo object representing the given score.
{% Contact %} - ContactInfo object of the contact that has reached the designated number of score
points.

Campaign, A/B testing and multivariate testing context data

If you wish to check whether the current visitor has arrived on the website as a result of a campaign, or
passed through a page with an A/B or multivariate test, you can read the information from the
appropriate browser cookie. The following macro expressions may be used to get the values of the given
cookies:

Cookies.Campaign - returns the name of the campaign assigned to the visitor.
Cookies.CMSAB<A/B test code name> - returns the code name of the page variant assigned to
the visitor by the specified A/B test.
Cookies.CMSMVT<MVT test code name> - returns the internal code name of the combination
assigned to the visitor by the specified MVT test. Please note that this is not the custom name set
for the combination, but an identifier in format Combination_<order number>, e.g. Combination_003.
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