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1 Introduction

1.1 About this guide

Kentico CMS Intranet Administrator's Guide is a guide intended for administrators of Kentico Intranet
Solution, i.e. the Intranet Portal sample website based on Kentico CMS. It provides information on
how the solution can be managed from within the system's administration interface.

Pre-requisites

Before you start using this guide, it is recommended that you get familiar with the contents of Kentico
CMS Intranet User's Guide. Kentico CMS Intranet User's Guide is a guide intended for end users of the
solution and provides information on how it can be used by an ordinary company employee accessing
only the front-end website, not the administration interface. By going through the guide, you will get an
overview of the structure of the portal, its main features and functionality.

The next thing that is expected from you before referring to this guide is to go through Kentico CMS
Tutorial. Kentico CMS Tutorial is intended for first-time users of Kentico CMS, describing the system's
installation and the basics of its administration interface. The level of knowledge covered by the tutorial is
necessary to understand most of the topics in this guide.

Where to go next

If you meet all the pre-requisites listed above, but you are new to Kentico Intranet Solution, we
recommend proceeding to the Getting started chapter. The Installation topic in the chapter will guide
you step-by-step through the installation of the Intranet Portal sample website. Once the website is
installed and running, you may proceed to the Accessing the administration interface topic, where the
solution is described from the administrator's point of view. Finally, you may refer to the Configuration for
WebDAV editing topic, which describes additional configuration of the system necessary for WebDAV
editing to be functional.

Further information sources

This guide is not the only source of information related to the solution or Kentico CMS in general.
Complete documentation of Kentico CMS can be found at http://devnet.kentico.com/documentation.aspx
. At this address, you can find various documentation guides, each of them describing the system from
a different perspective or aimed at a different target audience.

The most important of the guides listed on the above mentioned page is Kentico CMS Developer's Guide
. It is the most comprehensive guide for developers and administrators of the system, providing a full
reference on its installation, configuration and functionality of all its features and built-in modules. You
will find many links referring to the Developer's Guide throughout this guide, as most of the information
necessary for administration of the solution is already contained in it.

http://www.kentico.com
http://devnet.kentico.com/docs/5_5r2/intranetusersguide/index.html
http://devnet.kentico.com/docs/5_5r2/intranetusersguide/index.html
http://devnet.kentico.com/docs/5_5r2/tutorial/index.html
http://devnet.kentico.com/docs/5_5r2/tutorial/index.html
http://devnet.kentico.com/documentation.aspx
http://devnet.kentico.com/docs/5_5r2/devguide/index.html
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2 Getting started

2.1 Installation

To get started, you need to have Kentico CMS and the Intranet Portal sample website installed. This
topic provides information on how this can be achieved. The topic is divided into two parts, depending on
if you already have Kentico CMS installed or not.

New Kentico CMS installation

Installation of Kentico CMS is fully described in Developer's Guide -> Installation and deployment. The
following points sum up which steps need to be taken in order to perform the installation and provide
links to the relevant topics in that chapter of the Developer's Guide:

1. Launch KenticoCMS_<version>.exe and follow the instruction in Installation procedure -> Setup
(KenticoCMS.exe).

2. Once the setup finishes, launch Kentico CMS Web Installer and follow the instructions in Installation
procedure -> Web installer.

3. When the Web Installer is finished, access the URL of the new website. The first step of the
Database Setup will be displayed. Follow the instructions in Installation procedure -> Database setup,
until you reach the Starter Site step (the number of the step may vary). In this step, select the Choose
starter site option and choose the Intranet Portal sample site. Click Next to continue.

4. Wait until the Database Setup finishes importing the site. Once finished, the Finished step will be

http://devnet.kentico.com/docs/5_5r2/devguide/installation_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/setup_kenticocms_exe.htm
http://devnet.kentico.com/docs/5_5r2/devguide/setup_kenticocms_exe.htm
http://devnet.kentico.com/docs/5_5r2/devguide/web_installer.htm
http://devnet.kentico.com/docs/5_5r2/devguide/web_installer.htm
http://devnet.kentico.com/docs/5_5r2/devguide/database_setup.htm
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displayed. Click the Continue to the new website link highlighted in the screenshot below.

5. You will be redirected to the Logon page of the portal.

Existing Kentico CMS installation

If you already have Kentico CMS installed, but without the Intranet Portal website, you can easily add it
using the New site wizard.

1. Log on to Site Manager and on the Sites tab, click the  New site wizard link.

http://devnet.kentico.com/docs/5_5r2/devguide/new_site_wizard.htm
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2. In the first step of the wizard, choose the Use web site template option and click Next.

3. In Step 2, choose the Intranet Portal website from the list of available website templates and click
Next.
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4. Go through the rest of the wizard as described in Developer's Guide -> ... -> New site wizard ->
Website template. It is recommended to leave the default settings unless you really need to change
them according to your specific requirements. Once the wizard finishes, you should see the website
present in the list of websites in Site Manager -> Sites.

5. Sign out of the administration interface (use the Sign out button at the top right corner of the UI). You
will be redirected to the Logon page of the portal.

http://devnet.kentico.com/docs/5_5r2/devguide/website_template.htm
http://devnet.kentico.com/docs/5_5r2/devguide/website_template.htm
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2.2 Accessing the administration interface

Once you have the Intranet Portal website installed and running (please refer to the Installation topic for
information on how this can be achieved), you can start getting familiar with its administration interface.

In Intranet User's Guide -> Getting started -> Intranet Portal overview, you can find an overview of the
portal's structure, main sections and features. The rest of the Intranet User's Guide focuses on how
particular sections of the portal can be used by ordinary live site users without access to the
administration interface, so please refer to the appropriate sections of the guide if you are looking for this
type of information.

As this guide describes administration of the solution from within its administration interface, we will
start by logging on to this interface. Open your web browser and type in the URL of your intranet
website, followed by the /cmsdesk postfix (e.g. //intra/cmsdesk ). 

Once you access the URL, you will be redirected to the administration interface's logon screen. The
default administrator username is administrator with blank password. It is highly recommended that you
change this password if you haven't done so yet. Enter your user name and password and click Log on.

http://devnet.kentico.com/docs/5_5r2/intranetusersguide/intranet_portal_overview.htm
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You will be redirected to the Content tab of CMS Desk (as depicted in the screenshot below), which is
the part of the administration interface where particular pages of the website can be edited. For a
complete overview of Kentico CMS administration interface and the basics of content management in it,
please refer to the whole Content management chapter of Kentico CMS Developer's Guide.

2.3 Configuration for WebDAV editing

WebDAV editing is a feature of the solution which enables direct editing of files stored on the portal,
without the need to create a local copy and re-upload the modified file back to the server. This greatly
simplifies the process of editing uploaded files and can be extremely useful, especially on intranet
websites. For detailed information about WebDAV integration in Kentico CMS, please refer to 

http://devnet.kentico.com/docs/5_5r2/devguide/content_management_overview.htm
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Developer's Guide -> Modules -> WebDAV integration.

Client-side requirements

For WebDAV integration to be functional, the following client-side requirements must be met:

WebDAV can be used only in Internet Explorer 6 or higher. No other web browsers are currently
supported.
Client applications with WebDAV support for particular file types need to be installed on the
client machine. E.g. Microsoft Office 2003 or higher or Paint and Notepad in Windows 7 support
editing of associated file types using WebDAV. 
Matching (x86) or (x64) versions of both Internet Explorer and Microsoft Office must be installed.
In other words, to be able to open documents using WebDAV in Internet Explorer (x86), Microsoft
Office (x86) must be installed on the client computer. For Internet Explorer (x64), you need to have
Microsoft Office (x64) installed.

Server-side requirements

For WebDAV integration to be functional, the following server-side requirements must be met:

Windows authentication must be enabled in IIS and the CMS must be configured to use this type
of authentication.
If you are using an older version of IIS than 7.0, the Kentico CMS website must be installed in the
root of the server. This is necessary because Microsoft Office submits configuration requests to the
site root and requires the server to respond properly. If the website is not installed to the root, 
Microsoft Office will open its associated documents as read-only.
If you are using IIS 7.0 or higher, the website needn't be installed in the root - it can also be installed
in a virtual directory.

The following paragraph guides you step-by-step through the process of enabling Windows
Authentication, which is the most important pre-requisite. The Configuration for WebDAV topic in
Developer's Guide -> Modules -> WebDAV integration explains the rest of the required configuration
procedure.

Enabling Windows Authentication

1. Before you configure your project for Windows authentication, you need to create a user account that
will be the same as your current domain name and assign administrator permissions to this user
account. This will allow you to access all features as an administrator once you sign in using Windows
authentication.

2. Sign in as an administrator to Site Manager and go to Administration -> Users. Create a new user
with the following values:

User name: your domain user name in format domain-username, example: office-johns
Full name: your full name

Click OK. 

3. On the General tab, set the following values:

http://devnet.kentico.com/docs/5_5r2/devguide/webdav_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/Configuration_for_WebDAV.htm
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Is global administrator: yes
Is external user: yes
Is domain user: yes

Click OK.

4. Now you can switch the application to Windows authentication mode. Edit the web.config file of the
web project and change the following line:

<authentication mode="Forms">

to:

<authentication mode="Windows">

5. Now you have Windows authentication enabled for the administration interface. To enable it for the live
site as well, the following piece of code also needs to be present in your web.config. By default, the
code is already there, but commented. So the only thing you need to do is locate it (just search for the
first line) and uncomment it.

<location path="">
  <system.web>
    <authorization>
      <deny users="?"/>
    </authorization>
  </system.web>
</location>

Verifying the configuration

Once you have all the necessary configuration performed, you can verify that WebDAV editing is
enabled. The easiest way is to verify it in any Document library on the portal. The screenshot below
shows the  Edit action, which is only present in the drop-down menu if WebDAV editing is enabled
and if WebDAV editing of the particular file type is supported. In the screenshot, you can see how a 
DOCX document is opened for direct editing in Microsoft Word. Saving the changes in Microsoft Word
(just by clicking the Save button or pressing Ctrl+S) replaces the original version of the file with the new
one automatically.

http://devnet.kentico.com/docs/5_5r2/devguide/document_library_overview.htm
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3 Departments

3.1 Departments overview

The Departments section of the portal provides a separate website section for each company
department. This section contains its own Home page, Project management, News, Document library,
Forums, Blogs, etc. When viewing a department's section, the main menu serves for navigation within
the department, not within the global section of the portal. It is recognizable by the Back to main portal
button at the left edge of the menu, as well as by the breadcrumbs below it beginning with Portal >
Departments > Department name. You can navigate back to the global section of the portal using these
two controls.

A comprehensive overview of the section's functionality and features can be found in Intranet User's
Guide -> Departments, so please refer to it if you are looking for further information on how the section
can be used on the live site.

Departments structure in the content tree

Let's take a look at how the section is created within the system's administration interface. Log on to 
CMS Desk and navigate to the Content tab. If you expand the Departments node of the content tree,
you should see the sub-nodes as in the screenshot below. As you can see, there is a number of pre-

defined departments recognizable by the  icon.

Below the pre-defined department, there is the Template document, which is a template used when
adding new departments. If you expand the Template node, you should see its sub-pages as in the
screenshot below. If you expand any of the pre-defined departments, you can see that they contain the
same sub-pages as the Template document. These sub-pages represent particular sub-sections of
each department's section. When a new department is created, the sub-pages from under the Template
document are copied under the new department's parent document, as demonstrated in step 6 of the 
Adding new departments topic.

Location of the departments template may be customized. However, a correct location of the template
must always be set in Site Manager -> Settings -> Intranet Portal -> Department template path in
order for the creation of new departments to be possible.

http://devnet.kentico.com/docs/5_5r2/intranetusersguide/departments_overview.htm
http://devnet.kentico.com/docs/5_5r2/intranetusersguide/departments_overview.htm
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Intranet department document type

Particular departments consist of the sub-pages mentioned above and their parent document. The parent
document is of the Intranet department (IntranetPortal.Department) document type. By default, each
newly created document of this type uses the Intranet Portal - Department master page page
template. This is ensured by the configuration of the Template document, which also has this page
template set.

As obvious from the name of the page template, this document works as a master page for the
department's section. The master page provides the common graphic elements in the header of each
department's section and the dedicated navigation in the main menu (area 1 in the screenshot below).
Particular sub-pages are displayed by the Page placeholder web part in the zoneContent web part
zone on the master page (area 2 in the screenshot below). 

http://devnet.kentico.com/docs/5_5r2/devguide/document_type_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/what_is_a_page_template.htm
http://devnet.kentico.com/docs/5_5r2/devguide/what_is_a_page_template.htm
http://devnet.kentico.com/docs/5_5r2/devguide/the_master_page_concept.htm
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Settings on the Form tab

Essential settings of the department can be performed on the parent document's Form tab. The
following fields can be configured:

Department name - name of the department used in the administration interface and on the live
site. 
Department description - text describing the department. It is used as the department's description
in the departments listing.
Department avatar - image used in departments listing and in the header of the department's
website section. You can click the  Upload file link and select an image from your local disk. You
may also leave the field blank, which assigns the default avatar to the department.
Used stylesheet - theme used for the department's section. You may use one of the three pre-
defined stylesheets, or even edit the selected one directly using the Edit button.
Used department sections - using these check-boxes, you can choose which sub-sections will be
included in the department's website section.
Department roles - roles of department members. Members of the roles selected in this field will
have access to the department's website section (see the Departments security topic for more
details).
Publish from - date and time from when the department will be published on the live site. If you
leave the field blank, it will be published immediately after its creation.
Publish to - date and time until when the department will be published on the live site. If you leave
the field blank, it will be published until it is deleted.

For sample values that can be entered in the fields, please see the pre-defined sample departments or
refer to the Adding new departments topic.
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3.2 Adding new departments

The following topic provides a step-by-step example of how a new department can be added to the
portal.

1. The first step in creation of a department is creation of roles that the members of the department will
belong to. This is necessary in order to control access to the department's section, as described in the 
Departments security topic. Go to CMS Desk -> Administration -> Roles and click the  New role
link above the list.

2. In the New role dialog, enter the following details:



Departments 21

© 2011 Kentico Software

Role display name: Support Engineer; name of the role displayed in the system's administration
interface and on the live site.
Role code name: SupportEngineer; name of the role used in website code.
Role description: enter some text describing the role.
Is domain role: disabled; indicates if the role is a domain role from Active Directory.

Click OK. Repeat the procedure and create another role using the following details:

Role display name: Customer Care Manager
Role code name: CustomerCareManager
Role description: enter some text describing the role.
Is domain role: disabled

Click OK.

3. With the roles defined, you may proceed with creating the actual department section in the content
tree. Go to CMS Desk -> Content and select the Departments node in the content tree. Click the New
button above the tree.

4. In the New document dialog which gets displayed, select the  Intranet department document
type.
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5. On the department creation form, you need to specify the following details. For detailed descriptions
of particular fields, please refer to the Departments overview topic.

Department name: Customer Care
Department description: enter some text describing the department.
Department avatar: for the purpose of this example, you may leave the field blank, which assigns
the default avatar to the department. Otherwise, you may click the  Upload file link and select an
image from your local disk. 
Used stylesheet: Intranet Portal - Blue
Used department sections - enable all available check-boxes
Department roles: add the Customer Care Manager and Support Engineers roles created in step 2. 
Publish from: leave the field blank. 
Publish to: leave the field blank. 

Finally, click  Save to create the department with the entered details.
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6. Now, the department should be created. You should see it in the content tree, under the 
Departments node. If you expand the Customer Care node, you should see that all pages from under
the Template document were copied under it, as depicted in the screenshot below.

7. The last thing you need to do is configure permissions for access to the new department. With the 
Customer Care document selected, switch to the Properties -> Security tab. By default, both the
Customer Care Manager and the Support Engineer roles have only the Read permission assigned.
This only enables them to view the content of the department. 

As we want the Customer Care Manager role members to manage the content in all possible ways,
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let's give them the Full control permission. Enable the Full control check-box in the Allow column, all
check-boxes below it will be enabled too. Finally, click OK to save the configuration. 

8. Let's see what we have created. If you go to the live site and browse to the title page of the 
Departments section, you should see the department present in the All departments list.

9. Click the department's name or avatar. You will be redirected to the Home page of the department's
dedicated website section. As you can see in the following screenshot, the page already contains all
web parts that are present on other departments' Home pages, but they have no content yet. 

In a real-world scenario, the next logical step would be to assign ordinary members of the department to
the Support Engineer role and the department's management to the Customer Care Manager role.
The rest of the department's section is pre-configured and ready to be used. Once the department starts
being used by its members, web parts on this page will get populated with content from the respective
sub-section of the department automatically.
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Automatically created objects

When a new department is created, a number of objects is automatically created within the system's
administration interface. These objects are necessary to provide object-based functionality of the
department's section. The following text describes which objects are created and what display name and
code name they are created with. In the code names, the globally unique identifier (GUID) of the
particular department's parent document is always used. This identifier can be found in the Node GUID
field on the Properties -> General tab of the parent document's editing interface.

Media library

If you choose that the new department should contain the Media sub-section (in step 5 of the example
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above), a media library is created for the department in CMS Desk -> Tools -> Media libraries. The
media library is created with the following names:

Display name: <display name of the department> media libary
Code name: Department_<guid of the department's parent document>

Forum group

If you choose that the new department should contain the Forums section (in step 5 of the example
above), a forum group is created for the department in CMS Desk -> Tools -> Forums. The forum group
contains a single forum, which is also created automatically. The forum group is created with the
following names:

Display name: <display name of the department> forum group
Code name: Department_<guid of the department's parent document>

The forum in the forum group is created with the following names:

Display name: <display name of the department> forum
Code name: Default_department_<guid of the department's parent document>

Please note that if you wanted to add another forum into the forum group, it would be necessary for its
code name to end with the _department_<guid of the department's parent document> suffix. Otherwise,
content of the forum would not be indexed by the department's forum smart search index (see below for
more details).
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Search indexes

Each newly created department gets a search index for its content created in Site Manager ->
Administration -> Smart Search. In addition, if you choose that the new department should contain
the Forums section (in step 5 of the example above), another search index gets created for the
department's forums. The index for general content of the department is created with the following
names:

Display name: <display name of the department> - Default
Code name: default_department_<guid of the department's parent document>

The index for department forums is created with the following names:

Display name: <display name of the department> - Forums
Code name: forums_department_<guid of the department's parent document>

Tag group

In Site Manager -> Development -> Tag groups, a tag group is created automatically for each newly
created department. This tag group is intended for tagging of blog posts in the department's Blogs sub-
section, but it is created even if you choose not to include the Blogs sub-section in the department (in
step 5 of the example above). The tag group is created with the following names:

Display name: <display name of the department>
Code name: <guid of the department's parent document>
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3.3 Customizing departments

It is possible to customize of each department's website section, i.e. modify particular pages on the 
Design tab, add additional sub-sections or remove the existing ones. This can be done at three levels:

Page templates customization - useful to customize pages on the Design tab.
Individual department customization - useful if you want to add or remove sub-sections of a single,
already existing department.
Customization of the department template - useful if you want all newly created departments to
reflect certain customization.

In a real-world scenario where you already have some departments created, it is expected that you will
have to combine these approaches to achieve the expected result. The following examples will guide you
through the process of performing these types of customization. These examples are intentionally
simple, but the principles shown in them are applicable for all customizations you would possibly want
to perform.

Reordering and renaming default department sub-pages

Configuration of most of the web parts and widgets used within the department
sections, as well as other configuration, is dependent on alias paths of particular
department sub-pages. Therefore, it is not recommended to change the default alias
paths. 

In case that you needed to perform this, please refer to the Customizing the portal ->
Modifying structure of the website topic for more details on how this can be achieved.

Page templates customization

Documents of particular department sub-sections share common page templates. For example, the

http://devnet.kentico.com/docs/5_5r2/devguide/what_is_a_page_template.htm
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Home pages of all pre-defined departments, as well as the one under the Template node, share the
Intranet Portal - Department home page page template. This fact implies that if you customize one
Home page on the Design tab (e.g. if you add a web part), the customization will be reflected on all
Home pages that share the page template.

To prevent this behavior, i.e. to customize only one single document using the template without affecting

the other ones, you can use the  Clone as ad-hoc action on the Properties -> Template tab of
the document's editing interface.

The following example demonstrates both of these approaches:

1. At first, we will try modifying one page so that all pages that share the same page template will reflect
this customization as well. Log on to CMS Desk and in the content tree, choose the Departments/IT/
Home document and switch to the Design tab of its editing interface.

2. We will customize the page by adding one extra web part to the zoneCenterTop web part zone.
Click the Add web part ( ) icon in the top right corner of the web part zone.

3. In the Select web part dialog which pops-up, choose the General -> Powered by Kentico web
part. In its web part properties, only add <br/><br/> into the Content after property, which will ensure
some free space between the web part and the ones under it. Leave all other properties at their defaults
and click OK. The web part will be added to the page template, as can be seen in the following
screenshot.



Kentico CMS 5.5 R2 Intranet Administrator's Guide30

© 2011 Kentico Software

4. Now if you view the Home page of any other department, e.g. Finance, you will see that the web part
is present there as well. The same applies to the Home page under the Template node.

5. Let's try the other approach. Now that all Home pages contain the added web part, we can try
removing it from just one of these pages, while keeping it in the rest of them. With the Finance

department's Home page selected, switch to its Properties -> Template tab and click the  Clone
as ad-hoc action. 

6. The page template will be cloned as an ad-hoc one, which will be recognizable by its name changing
to Ad-hoc: Home. Now you can modify the page without affecting the other Home pages. For example,
if you remove the Powered by Kentico web part added in step 3, it will only be removed from this
Home page, not from all the other ones.
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Individual department customization

In case that you want to customize the dedicated website section of a single department, you only need
to perform the required customization on documents under the department's parent document in the
content tree. This customization will then be reflected only in this particular department's website
section. 

In the following example, you will learn how to add a sample FAQ page to the IT department's section:

1. Log on to CMS Desk and on the Content tab, select the Departments/IT document in the content
tree. Click the New button above the tree. When the New document dialog appears, select the Page
(menu item) document type.

2. In the following dialog, enter FAQ into the Page name field and choose to Create a blank page
using the Simple layout (in a real-world scenario, you may use any other page template according to
your specific needs). Finally, click Save to save the changes.
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3. The new page is added as the first page under the department's main document (before the Home
page). The position of the page in the content tree determines the position of the page in department
navigation. As you will probably want the page to be located a bit more to the right in the navigation, drag
and drop the page to the desired position in the content tree.

4. Once the page is created, switch to the Design tab of its editing interface and add the required web
parts. For the purposes of this example, we will only add a single Editable text web part with all its
properties left at the defaults.
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5. Now go to the Page tab of the page's editing interface and add the actual content of the page. For the
purposes of this example, you can just add some sample text as in the screenshot below. Click Save
to save the changes.

6. Once you are finished, go to the live site to see what you have created. Browse to the IT department's
website section. You should see the FAQ menu item present in the main navigation, at the position
where you dragged it in step 3. If you click the document, you should see the page with the content
defined in the previous step.
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Customization of the department template

As explained in the Departments overview and Adding new departments topics, the Departments/
Template node contains sub-pages with pre-configured web parts. These pages are copied under each
newly created department's parent document. By performing customization of the documents under the 
Template document, you ensure that each newly created department will reflect this
customization too. However, this will not be the case for already existing departments. To ensure
uniformity in this case, you will need to copy the new page under the existing departments manually.

In the following example, you will learn how to add the FAQ page to to the department template:

1. Log on to CMS Desk and on the Content tab, select the Departments/Template document in the
content tree. Go through steps 1. to 5. in the example above to create the FAQ page under the
Template document.

2. At this point, the page is created with an ad-hoc page template. To ensure uniformity with all other
department sub-pages, i.e. that modification of a single FAQ page will be reflected in all other FAQ
pages (see Page templates customization above for more details), we need to save the ad-hoc template
as a new regular page template. To do this, go to the Properties -> Template tab of the FAQ page's

editing interface and click the  Save as new page template action.
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3. In the Save as new page template dialog which pops-up, enter the following details:

Template display name: Intranet Portal - Department FAQ
Template code name: IntranetPortal.DepartmentFAQ
Template category: Intranet Portal
Template description: enter some text describing the page template.

Click OK.

4. Now try creating a new department, just as described in the Adding new departments topic.

5. Once the new department is created, you can see that it contains the FAQ page as well. The same
would apply to any other newly created department.
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3.4 Departments security

Access to department sections is limited based on document permissions configured on the three-level
permissions hierarchy. However, the permissions configurable on the two higher levels, i.e. permissions
for all content and permissions for particular document types, are typically only used in special cases.
Therefore, you will typically configure department permissions on document-level.

As explained in the Departments overview topic, you can choose department member roles in the
Department roles field on the Form tab of the department's parent document. By adding a role to this
field, the role is added to the Users and Roles list on the Properties -> Security tab of the parent
document and the Read document-level permission is granted to it. All documents stored under the
parent document inherit document-level permissions from their parent by default, which results in the fact
that members of the roles can view all documents in the department's section. On top of it, these
permissions ensure that the department is displayed to them in the My departments list on the
Departments section's title page.

Apart from the basic Read permission, it is possible to set up additional permissions to enable
management of document-based features of the section:

News
Calendar
Documents
Wiki

A typical example of this configuration can be seen in the configuration of each pre-defined department
shipped with the portal. Let's take the IT department for demonstration:

The IT role is intended for ordinary employees without document management permissions. Therefore,
only the Read permission is granted to the role on document-level. Contrary to that, the CIO role is
intended for the head of the department who should be able to manage all content within the
department's section. Therefore, full permissions are granted to the role (as can be seen in the
screenshot below) to provide full permissions for all possible content management actions.

http://devnet.kentico.com/docs/5_5r2/devguide/document_permissions.htm
http://devnet.kentico.com/docs/5_5r2/devguide/document_permissions.htm
http://devnet.kentico.com/docs/5_5r2/devguide/document_level_permissions.htm
http://devnet.kentico.com/docs/5_5r2/devguide/document_level_permissions.htm
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3.5 Managing department features

The most of the functionality provided by the Departments section is based on standard Kentico CMS
modules and features. The following topic provides brief descriptions of the particular sub-sections and
the modules and features that they are based on. With each module or feature, you can find a link
leading to its full documentation in Kentico CMS Developer's Guide.

News

The News section is based on standard Kentico CMS documents. Each published news item is a
document of the News (CMS.News) document type stored under the News document in the
department's section. For more information on document types, please refer to Developer's Guide ->
Development -> Document types and transformations.

http://devnet.kentico.com/docs/5_5r2/devguide/document_type_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/document_type_overview.htm
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To enable adding of news on the live site, the User contributions (Wiki) module is leveraged. Detailed
information about the module is located in Developer's Guide -> Modules -> User contributions (Wiki).

Calendar

The calendar used for events scheduling and attendees registration is based on the Booking system
module. To find more information about the module, please refer to Developer's Guide -> Modules ->
Booking system.

Documents

Documents storage on the live site is provided by the Document library module. More information
about the use of this module on the portal can be found in the Document libraries chapter of this guide.
Complete documentation of the module is located in Developer's Guide -> Modules -> Document library.

Media

The Media section is based on the Media libraries module. Each department has its own media library
created in CMS Desk -> Tools -> Media libraries. The library is recognizable by the name in the
<Department name> media library format. Detailed documentation of the module can be found in
Developer's Guide -> Modules -> Media libraries.

Blogs

Functionality of the Blogs section is provided by the Blogs module. Blogs are standard documents in
Kentico CMS content tree, but the module also has its dedicated user interface in CMS Desk -> Blogs.
Detailed documentation of the module can be found in Developer's Guide -> Modules -> Blogs.

Forums

The discussion forums are based on the Forums module. Each department has its own forum group
created in CMS Desk -> Tools -> Forums. The forum group is recognizable by the name in the
<Department name> forum group format. Detailed documentation of the module can be found in
Developer's Guide -> Modules -> Forums.

http://devnet.kentico.com/docs/5_5r2/devguide/user_contributions_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/booking_system_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/booking_system_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/document_library_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/media_libraries_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/module_blogs_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/forum_module_overview.htm
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Wiki

Similarly as the News section, the Wiki section is also based on standard Kentico CMS documents.
Each published wiki article is of the Simple article (CMS.SimpleArticle) document type, stored under
the Wiki document within the department's section in the content tree. 

To enable adding of articles on the live site, the User contributions (Wiki) module is leveraged. Detailed
information about the module is located in Developer's Guide -> Modules -> User contributions (Wiki).

Projects

Functionality of the Projects section is provided by the Project management module. The module's
user interface is located in CMS Desk -> Tools -> Project management. Its functionality and
management is briefly described in the Project management chapter of this guide. Full documentation of
the module can be found in Developer's Guide -> Modules -> Project management.

Members

The Members page only contains a combination of the following three interconnected web parts: Basic
repeater + Department members data source + Filter. These web parts are configured so that the
Basic repeater displays users provided by the Department members data source. The data source is
configured so that it displays only members of the current department (i.e. members of the roles added
in the Department roles field on the Form tab of the department's parent document's editing interface).
The filter enables further filtering of displayed users based on their names.

Detailed information about data source web parts can be found in Developer's Guide -> Development ->
Web parts -> Data source web parts. A detailed reference concerning management of users and roles in
Kentico CMS can be found in Developer's Guide -> Development -> Membership.

RSS

The RSS page is not accessible via the department's navigation. It contains special sub-pages which
provide RSS feeds of the department's content. The feeds are created using web parts of the 
Syndication module. A full reference on the module can be found in Developer's Guide -> Modules ->
Syndication.

Search

http://devnet.kentico.com/docs/5_5r2/devguide/user_contributions_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/project_management_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/using_datasource_web_parts.htm
http://devnet.kentico.com/docs/5_5r2/devguide/using_datasource_web_parts.htm
http://devnet.kentico.com/docs/5_5r2/devguide/security_model.htm
http://devnet.kentico.com/docs/5_5r2/devguide/syndication_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/syndication_overview.htm
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Search of the department's content is provided by the Smart search module. Each department has two
indexes created in Site Manager -> Administration -> Smart search: one for its discussion forums
(with name in the <Department name> - Forums format) and one for the actual content of the department
pages (with name in the <Department name> - General format). For a full reference on the module,
please refer to Developer's Guide -> Modules -> Smart search.

http://devnet.kentico.com/docs/5_5r2/devguide/smart_search_overview.htm
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4 Workgroups

4.1 Workgroups overview

Workgroups are separate sub-sections within the Intranet Portal website that are dedicated to a certain
activity. A workgroup's content and tools are only available within the context of the given workgroup. A
full description of all the features offered by workgroups from the live site point of view can be found in 
Intranet User's Guide -> Workgroups.

Workgroups utilize the standard groups module. For general information about groups, please refer to 
Developer's Guide -> Modules -> Groups. There are two main elements that each workgroup is
composed of: a section of documents in the content tree and a corresponding object in the
administration interface. An overview of workgroup documents may be found below and information about
managing workgroups via the CMS Desk -> Tools -> Groups interface is given in the Managing
workgroups topic.

Workgroups in the content tree

If you log on to CMS Desk, navigate to the Content tab and expand the Workgroups node in the
content tree, you will see all documents related to workgroups as depicted in the screenshot below.

The Template node and its child documents define the structure that Intranet Portal workgroups are all
based on and the Create document allows users to add new workgroups directly from the live site. The
workgroup creation process is described in the Creating new workgroups topic. Below are the document
sections of several pre-defined sample workgroups, e.g. Marketing_Strategy. Each section is stored
under a document with the same name as the workgroup that it represents.

Workgroup document structure

Expand the Template node to view the default document structure of Intranet portal workgroups. If you
expand one of the sample workgroups, you will see that it contains the same child documents. To learn
how the structure of workgroups may be modified, please see the Customizing workgroups topic.

http://devnet.kentico.com/docs/5_5r2/intranetusersguide/workgroups_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/groups_module_overview.htm
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Individual workgroups consist of a parent document and child documents that reflect the various
workgroup sections available on the live site. The parent document serves as a master page for the
remaining pages of the workgroup. This means that all workgroup pages inherit the header, navigation
menu and all other content defined in the parent document (area 1 in the screenshot below). Particular
sub-pages are displayed by the Page placeholder web part in the zoneContent web part zone on the
master page (area 2 in the screenshot below).

http://devnet.kentico.com/docs/5_5r2/devguide/the_master_page_concept.htm
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4.2 Managing workgroups

All workgroups on the Intranet Portal website can be managed through the interface located at CMS
Desk -> Tools -> Groups. The workgroups displayed on this page may be filtered according to their
display name and approval status.

New workgroups that require an administrator's approval before they are published can be approved here
by clicking the Approve ( ) action icon. Using the Reject ( ) icon returns the given workgroup to the
state it was in before approval. Rejected workgroups are not displayed on the live site.
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The listed workgroups may also be Edited ( ) or Deleted ( ). When deleting a workgroup, it is
possible to choose whether all its documents should be deleted as well. The edit action opens the 
Group properties dialog, where the settings and content of the given workgroup can be defined and
managed. For more detailed information about the available options, please refer to Developer's Guide ->
Modules -> Groups -> Editing a group.

Users designated as administrators of a workgroup may also edit it in a similar fashion through the live
site workgroup management interface, as documented in Intranet User's Guide -> Workgroups ->
Managing workgroups. Certain settings, such as code names, are not available when editing on the live
site.

Additional settings that are applied to all workgroups may also be specified at Site Manager ->
Settings -> Community as described in Developer's Guide -> Modules -> Groups -> Settings.

http://devnet.kentico.com/docs/5_5r2/devguide/editing_a_group.htm
http://devnet.kentico.com/docs/5_5r2/devguide/editing_a_group.htm
http://devnet.kentico.com/docs/5_5r2/intranetusersguide/managing_workgroups.htm
http://devnet.kentico.com/docs/5_5r2/intranetusersguide/managing_workgroups.htm
http://devnet.kentico.com/docs/5_5r2/devguide/groups_settings.htm
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4.3 Managing document-based workgroup features

Most of the functionality provided by the various sub-sections of a workgroup is based on standard
Kentico CMS modules and features. The following topic provides brief descriptions of individual
workgroup sections and the modules and features that they are based on, including links to the
appropriate documentation in Kentico CMS Developer's Guide. Sections linked with the features that
are manageable through the CMS Desk -> Tools -> Groups workgroup editing interface, as described
in Developer's Guide -> Modules -> Groups -> Editing a group, are not listed in this topic.

News

The News section is based on standard Kentico CMS documents. Each published news item is a
document of the News (CMS.News) document type stored under the News document within the
workgroup' s section of the content tree. For more information on document types, please refer to 
Developer's Guide -> Development -> Document types and transformations.

To enable the adding of news on the live site, the User contributions (Wiki) module is leveraged.
Detailed information about the module is located in Developer's Guide -> Modules -> User contributions
(Wiki).

Calendar

The calendar used for event scheduling is based on the Booking system module. To find more
information about the module, please refer to Developer's Guide -> Modules -> Booking system.

Documents

Document storage on the live site is provided by the Document library module. More information about
the use of this module on the portal can be found in the Document libraries chapter of this guide.
Complete documentation of the module is located in Developer's Guide -> Modules -> Document library.

http://devnet.kentico.com/docs/5_5r2/devguide/editing_a_group.htm
http://devnet.kentico.com/docs/5_5r2/devguide/document_type_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/user_contributions_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/user_contributions_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/booking_system_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/document_library_overview.htm
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Blogs

The functionality of the Blogs section is provided by the Blogs module. Blogs are standard documents
in the Kentico CMS content tree, but the module also has its dedicated user interface in CMS Desk ->
Blogs. Detailed documentation of the module can be found in Developer's Guide -> Modules -> Blogs.

Wiki

Similar to the News section, the Wiki section is also based on standard Kentico CMS documents.
Each published wiki article is of the Simple article (CMS.SimpleArticle) document type, stored under
the Wiki document within the workgroup' s section of the content tree. 

To enable the adding of articles on the live site, the User contributions (Wiki) module is leveraged.
Detailed information about the module is located in Developer's Guide -> Modules -> User contributions
(Wiki).

Members

The Members document contains a combination of the following four interconnected web parts: Basic
repeater + Group members data source + Filter + Universal pager. These web parts are configured
so that the Basic repeater displays users provided by the Group members data source. The data
source displays only users who are members of the current workgroup. The filter allows further filtering of
the displayed users based on their names and the pager ensures that the list of users is divided into
multiple pages in case there is a large amount of workgroup members.

http://devnet.kentico.com/docs/5_5r2/devguide/module_blogs_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/user_contributions_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/user_contributions_overview.htm
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Detailed information about data source web parts can be found in Developer's Guide -> Development ->
Web parts -> Data source web parts. A detailed reference concerning the management of users and
roles in Kentico CMS is located in Developer's Guide -> Development -> Membership.

Access

This document is not visible in a workgroup's navigation menu. Instead, users are redirected to it when
they attempt to view the pages of a workgroup to which they do not have access permissions, typically
when they are not members. Relevant information is displayed by the Group security message web
part. The path to this document is specified in the Site Manager -> Settings -> Community -> Group
security access denied path setting. 

This functionality is ensured by Group security access web parts, which are placed on all workgroup
documents apart from this one.

Management

This document is also not reachable through a workgroup's navigation menu. It allows workgroup
administrators to manage the workgroup directly on the live site as described in Intranet User's Guide ->
Workgroups -> Managing workgroups. It must contain the Group profile web part, which provides all
necessary functionality. The path to this document is specified in the Site Manager -> Settings ->
Community -> Group management path setting.

RSS

http://devnet.kentico.com/docs/5_5r2/devguide/using_datasource_web_parts.htm
http://devnet.kentico.com/docs/5_5r2/devguide/using_datasource_web_parts.htm
http://devnet.kentico.com/docs/5_5r2/devguide/security_model.htm
http://devnet.kentico.com/docs/5_5r2/intranetusersguide/managing_workgroups.htm
http://devnet.kentico.com/docs/5_5r2/intranetusersguide/managing_workgroups.htm
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The RSS document is not accessible via a workgroup's navigation menu. It contains special child
documents which allow users to access RSS feeds of the workgroup's content. This is achieved by web
parts of the Syndication module. A full reference can be found in Developer's Guide -> Modules ->
Syndication.

Search

This document ensures the functionality of the search box available under the menu in all workgroup
sections and displays the search results. The necessary functionality is provided by the Smart search
dialog with results web part. Each workgroup uses two search indexes created in Site Manager ->
Administration -> Smart search: one for the content of its documents (with a name in format
<Workgroup display name> - Default) and another for its forums (with a name in format <Workgroup
display name> - Forums). Information about the creation of these indexes for a sample workgroup is
described in steps 10 and 11 of the Creating new workgroups topic. For a full reference on the smart
search module, please refer to Developer's Guide -> Modules -> Smart search.

4.4 Creating new workgroups

All authenticated users of the Intranet Portal website may create workgroups directly on the live site.
This approach is how most workgroups are normally created, since it is easy to use and automatically
performs many tasks that are necessary for the correct functioning of the new workgroup. The details of
this process may be found in Intranet User's Guide -> Workgroups -> Creating a new workgroup.

This feature is facilitated by the Group registration web part. It is possible to modify how workgroups
are created by changing the properties of this web part. To do so, access CMS Desk -> Content, select
the Workgroups -> Create document from the content tree, switch to the Design tab and Configure (

) the web part (named WorkgroupRegistration by default).

http://devnet.kentico.com/docs/5_5r2/devguide/syndication_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/syndication_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/smart_search_overview.htm
http://devnet.kentico.com/docs/5_5r2/intranetusersguide/creating_a_new_workgroup.htm
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Additional settings related to workgroups and their creation may be specified at Site Manager ->
Settings -> Community as described in Developer's Guide -> Modules -> Groups -> Settings.

A new workgroup may also be defined manually in the administration interface, as is demonstrated in
the following example:

Please note

This example is not a recommended way of creating workgroups. The following steps
are all performed automatically when a workgroup is created via the Group
registration web part, they only serve to help understand the process.

1. Log on to CMS Desk as a global administrator (username administrator with a blank password by
default) and the Content tab will automatically be displayed. The first thing that needs to be done is
create the documents that will form the section of the portal dedicated to the new workgroup. Expand
the Workgroups node in the content tree, select the Template child node and create a copy of it under
the same parent. This can be done either using the Copy button from the menu above the content tree
or by holding down the Control key and dragging the given node to its target location in the tree. When
copying, ensure that the Copy also all child documents box is checked.

http://devnet.kentico.com/docs/5_5r2/devguide/groups_settings.htm
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2. Select the new copy of the Template document and switch to the Form tab. Now change the
Document name to the name that you wish to give to the new workgroup. This example uses
New_Product_Line.

Click  Save.

3. Switch to the Properties -> URLs tab and change the value of the Document alias property to
New_Product_Line as well. The value of this property will be used in the URL of the workgroup's
documents, so it cannot contain spaces or other forbidden characters. When a workgroup is created
automatically, the name specified for the workgroup is used as the value of this property and any
forbidden characters are converted to underscores.
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Click  Save. With default Intranet Portal website settings, a document alias will automatically be
created for the previous value of the Document alias property. Delete ( ) this alias, so that the
documents of the workgroup cannot be accessed under the old URL.

4. Now that the workgroup's documents are prepared, the workgroup object itself must be added to the
system. Go to Tools -> Groups and click the  New group link at the top of the page.
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The New group form will be displayed. Fill in the following fields:

Display name - the name of the workgroup that will be displayed on the website and in the
administration interface. This example uses New Product Line.
Code name - a unique name used to identify the workgroup. The value of this field must be the
same as that of the Document alias property set in step 3 to ensure that links to the workgroup
function correctly. For the purposes of this example, the value must be New_Product_Line.
Description - text describing the new workgroup.
Group pages location - contains the alias path of the node that contains the workgroup's
documents. Select the /Workgroups/New_Product_Line node for the purposes of this example.
Avatar - allows the selection of the workgroup avatar image used for graphical representation.
Approve members - this selection determines if users can join the workgroup with or without a
workgroup administrator's approval. The Only approved members can join option requires all new
members to be approved, while Only approved members can join except for invited members allows
users who accept an invitation from a workgroup member to join without approval.
Content access - this selection determines what type of users can view the content of the
workgroup. Please keep in mind that if the Only group members can view the content option is
selected, users cannot apply to join the workgroup and must be invited to become members.
Notify group admins when a user joins/leaves - if checked, workgroup administrators will
receive a notification e-mail when a user joins/leaves the workgroup.
Notify group admins on pending members - if checked, workgroup administrators will receive a
notification e-mail when a user requests to join the workgroup and approval is required.
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Click OK.

5. Now return to the Content tab, select the Workgroups/New_Product_Line document from the
content tree and switch to its Properties -> General tab. Click the Change button next to the Owned
by group property, choose the New Product Line workgroup in the displayed dialog and check the
Inherit by child documents box.
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This assigns the given document and all documents under it to the workgroup object that was created in
step 4, which ensures that the tools provided by these documents operate correctly within the context of
the new workgroup.

6. When a default Intranet Portal workgroup is created automatically, several other associated objects
are also added to the system. These include a forum group, forum and media library under the given
workgroup, a tag group and a pair of search indexes for the content of the workgroup. The next steps
describe how these objects can be defined manually.

7. To add forums to a workgroup through the administration interface, go to Tools -> Groups, edit ( )
the New Product Line workgroup, open its Forums tab and click the  New forum group link.
Forums are described in Developer's Guide -> Modules -> Forums, so please refer to this chapter if you
are unfamiliar with the use of the forum management interface.

http://devnet.kentico.com/docs/5_5r2/devguide/forum_module_overview.htm
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Fill in the displayed form according to the following information:

Group display name - the name of the forum group that will be displayed on the website and in the
administration interface. When a workgroup's initial forum group is created automatically, this name
is in format <Display name of the edited workgroup> forums, for example New Product Line forums.
Group code name - a unique name used to identify the forum group.
Description - a text description for the forum group that will be displayed on the website.
Forum group base URL - the URL of the document where the workgroup's forums are displayed.
Default workgroups use the Forums child document, so enter ~/Workgroups/New_Product_Line/
Forums.aspx for the purposes of this example.
Forum group unsubscription URL - the URL of a page where users can unsubscribe from the
forums under the given group. On the default Intranet Portal, this page may be found at ~/Special-
Pages/Forum-Unsubscribe.aspx and the URL can be loaded from the value of the Site Manager ->
Forums -> Forum unsubscription URL setting automatically by checking the Inherit from settings
box.

Click OK. The Forums tab of the new forum group will now be displayed. Click the  Add forum link
and enter the following details:

Forum display name - the name of the forum that will be displayed on the website and in the
administration interface. When a workgroup's initial forum is created automatically, it is named 
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General discussion.
Forum code name - a unique name used to identify the forum. It must end with the following string:
_group_<GUID of the edited workgroup>. This is necessary to ensure that the forum will be fully
functional. A workgroup's GUID is a string of 32 characters generated when the workgroup is created
and serves as a globally unique identifier. If necessary, the GUID of a workgroup may be found in the
database, specifically the GroupGUID column of the Community_Group table.
Description - a text description for the forum that will be displayed on the website.
Forum base URL, Forum unsubscription URL - leave the Inherit from forum group boxes checked
to use the same values as the parent forum group.

The remaining fields may be left unchanged for the purposes of this example.

Click OK to create the new forum.

8. Media libraries can be created on the Media libraries tab of the same group editing interface.
Information about managing media libraries may be found in Developer's Guide -> Modules -> Media
libraries. There are no special requirements for defining media libraries under workgroups.

http://devnet.kentico.com/docs/5_5r2/devguide/media_libraries_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/media_libraries_overview.htm
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9. Now create the workgroup's tag group, which is intended for the tagging of blog posts under the
workgroup's Blogs section. For more information about tags, please refer to Developer's Guide ->
Modules -> Tags. Go to Site Manager -> Development -> Tag groups and click the  New tag
group link.

Fill in the New tag group form. By default, the display and code names of the tag group are the same
as those of the new workgroup, so enter these values.

The tag group also needs to be assigned to the appropriate workgroup documents. Return to CMS Desk
-> Content, select the Workgroups/New_Product_Line document from the content tree and switch to
its Properties -> Metadata tab. Here, uncheck the Inherit box under the Page tag group drop-down
list and select the New Product Line tag group.

http://devnet.kentico.com/docs/5_5r2/devguide/tags_module_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/tags_module_overview.htm
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Click  Save. All child documents will inherit this tag group.

10. Next, to ensure that searching within the new workgroup is possible, appropriate smart search
indexes must be defined. To learn more about the smart search module, please see Developer's Guide -
> Modules -> Smart search. Go to Site Manager -> Administration -> Smart search and click the 
New index link.

http://devnet.kentico.com/docs/5_5r2/devguide/smart_search_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/smart_search_overview.htm
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First, create the index for regular workgroup documents by entering the following values into the New
search index form:

Display name - the name of the index used in the administration interface. The standard format for
this name is <Display name of the indexed workgroup> - Default, for example New Product Line -
Default. This format is used when a workgroup search index is created automatically, but it is not
strictly necessary.
Code name - a unique name used to identify the index. It must be in format default_group_<GUID of
the indexed workgroup> in order for the index to be applied to the given workgroup.
Analyzer type - leave the default value.
Stop words - leave the default value.
Index type - select Documents.
Assign index to website Intranet Portal - leave this box checked.
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Click OK. Now switch to the Index tab of the newly created index, click the  Add allowed content
link and fill in the displayed form according to the following information:

Path - the path to the documents that should be indexed. For this example, either manually enter /
Workgroups/New_Product_Line/% or click the Select button and choose the /Workgroups/
New_Product_Line node with the Only sub-items box checked.
Document types - the document types that should be indexed. It is recommended to leave this field
empty to allow all types of workgroup content to be indexed.
Including ad-hoc forums, Including blog comments, Including message boards - these fields
determine what types of additional content should be indexed. When a workgroup index is created
automatically, these fields are disabled, but you may set them as required. Please note, the forums
contained by default Intranet Portal workgroups are not ad-hoc forums, they are pre-defined and thus
require their own search index as shown in the next step.

Click OK. Switch to the Cultures tab and add the culture(s) used by your website. Finally, return to the
General tab and  Rebuild the index.

11. In a similar fashion, a second search index must be added to allow searching of the workgroup's
forums. To do this, go back to the Smart search indexes list, click the  New index link again and
enter the following values into the form:

Display name - the name of the index used in the administration interface. The standard format for
this name is <Display name of the indexed workgroup> - Forums, for example New Product Line -
Forums. This format is used when a workgroup search index is created automatically, but it is not
strictly necessary.
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Code name - a unique name used to identify the index. It must be in format forums_group_<GUID
of the indexed workgroup> in order for the index to be applied to the given workgroup.
Analyzer type - leave the default value.
Stop words - leave the default value.
Index type - select Forums.
Assign index to website Intranet Portal - leave this box checked.

Click OK. Switch to the Index tab of the new index and click the  Add allowed forums link. Use the
Site name drop-down list to select your Intranet Portal website. Now enter a string in the following
format into the Forums field: *_group_<GUID of the indexed workgroup>. The asterisk character (*)
serves as a wildcard, ensuring that all forums under the specified workgroup using the correct code
name format (as specified in step 7) are indexed. The Select button cannot be used to assign the index
to workgroup forums.

Click OK. Now return to the General tab and  Rebuild the index.

Please keep in mind

When a workgroup is deleted, its search indexes will remain in the system and must
be removed manually.

12. The workgroup and its associated objects are now created. If you go to the live site, you should see
it listed under the Workgroups section of the portal, as depicted below. If you open the workgroup, all
sections should be fully functional (but without any content).
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4.5 Customizing workgroups

It is possible to customize the website sections dedicated to workgroups by adding new documents,
deleting unwanted documents or modifying existing ones. This can be done at two levels:

Customizing all workgroups
Customizing one specific workgroup

Relocating and renaming default workgroup sub-pages

The configuration of many web parts and widgets used within the sections dedicated to
workgroups and certain other settings are dependent on the alias paths of particular
workgroup sub-pages. Therefore, it is not recommended to change the default alias
paths.

In case that this is absolutely necessary, please refer to the Customizing the portal ->
Modifying structure of the website topic for more details on how this can be achieved.

Customizing all workgroups

If you wish to customize a document for all workgroups, you can perform the required change by adding,
removing or configuring the web parts of the given document on the Content -> Edit -> Design tab of
CMS Desk. The default documents of all workgroups share common page templates, so changes made
to a document under any existing workgroup or to the documents under the Workgroups/Template
node will immediately affect every workgroup.

When altering the workgroup document structure by adding or deleting a document, the change needs to
be carried out under the Template node. This will ensure that all new workgroups are created with the
updated document structure. Customization of this type does not affect existing workgroups and must
be performed for each one individually to ensure uniformity across all workgroups.

http://devnet.kentico.com/docs/5_5r2/devguide/what_is_a_page_template.htm
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The following example will demonstrate how to add a simple FAQ page to the workgroup Template:

1. Log on to CMS Desk and on the Content tab, select the Workgroups/Template document in the
content tree. Click the New button above the tree. When the New document dialog appears, select
the Page (menu item) document type.

2. In the following dialog, enter FAQ into the Page name field and choose to Create a blank page
using the Simple layout (in a real-world scenario, you may use any other page template according to
your specific needs). Finally, click Save to create the new document.
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3. The document will be added as the first item under the Template node. Because the document order
in the content tree determines the position of the given page in the workgroup navigation menu, you will
probably want to move the FAQ document further down. Drag and drop it to the desired position in the
content tree.

4. Now switch to the Design tab of the editing interface and add ( ) a Text -> Editable text web part
to the only zone on the page. Leave the properties of the new web part in their default state.
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5. Go to the Page tab and add the actual text content to the page. For the purposes of this example,
you can just add some sample text as shown below. Click Save when you are done.

6. At this point, the document uses an ad-hoc page template. To ensure that modifications made to a
single FAQ page will be reflected on the FAQ pages of other workgroups, the ad-hoc template needs to
be saved as a new regular page template. To do this, go to the Properties -> Template tab and click

the  Save as new page template action.
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In the Save as new page template dialog which pops-up, enter the following details:

Template display name: Intranet Portal - Workgroup FAQ
Template code name: IntranetPortal.WorkgroupFAQ
Template category: Intranet Portal
Template description: enter some text describing the page template.

Click OK. This ensures that future workgroups all use the same template for the FAQ page.

7. Now the document is complete. All new workgroups will now be created with a FAQ page. If you want
this page to be present in all workgroups, the document will have to be added to all existing workgroups
individually. However, the process is now easier since the page template created in the previous step
can be selected directly when creating the document.

Setting the default widget layout on the Home page 

A special type of customization may be performed on the Home document of every workgroup. If you
select this document under one of the sample workgroups and switch to the Design tab, you will see
that it contains two widget zones: zoneLeftBottom and zoneRightWidgets.
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These zones are customizable directly on the live site by workgroup administrators, as described in 
Intranet User's Guide -> Workgroups -> Modifying a workgroup home page. On the Design tab, the
widgets in these two zones may be handled in the same way as web parts. However, any changes
made in the widget zones will only affect the default layout of the widgets. Modifications made for a
specific workgroup by a workgroup administrator will not be overridden and will still be displayed on the
live site.

A full widgets reference may be found in Developer's Guide -> Development -> Widgets.

Customizing a specific workgroup

When modifying only one specific workgroup, documents may be added or deleted without influencing
other workgroups. However, if you need to alter one of the existing default documents, certain additional
steps need to be taken due to the fact that workgroups share page templates. This is demonstrated in
the following example:

1. Log on to CMS Desk and on the Content tab, select the Workgroups/Microsoft_Office_Upgrade/

Forums document in the content tree. Switch to the Properties -> Template tab and click 
Clone as ad-hoc. This creates a separate copy of the page template used by the Forums page and
any modifications will now only affect the document under the given workgroup.

http://devnet.kentico.com/docs/5_5r2/intranetusersguide/modifying_workgroup_home_page.htm
http://devnet.kentico.com/docs/5_5r2/devguide/widgets_overview.htm
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2. Now switch to the Design tab and add ( ) a Text -> Editable text web part. In the Web part
properties dialog, select the Intranet content box option for the Web part container property and
enter Forum Guidelines as the Container title.

Click OK and move the new web part above the existing WorkgroupForumList web part.

3. Go to the Page tab and add some text content into the region above the displayed forums. For the
purposes of this example, you can just add some sample text as shown below. Click Save when you
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are done.

4. Once you are finished, go to the live site, open the Microsoft Office Upgrade workgroup's website
section and view the Forums page. You should see the text that you entered displayed above the
forums, enclosed in the specified container.



Workgroups 71

© 2011 Kentico Software

If you check the Forums page of any other workgroup, you will see that it is not modified.

5. In case you wish to re-use this modified page template for other workgroups, go back to CMS Desk ->
Content, select the Workgroups/Microsoft_Office_Upgrade/Forums document again and return to

the Properties -> Template tab. This time, click  Save as new template, which will allow you to
create a new permanent page template identical to the one used by this document that can be assigned
to any other document.
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5 Project management

5.1 Project management overview

Project management is a tool that helps organize work and keep track of its progress on the Intranet
Portal website. This is achieved by using objects called projects that represent a planned activity with a
specific goal. Projects contain objects called tasks that are individually assigned to specific users.
Tasks do not necessarily have to be a part of any project and may also created and assigned
individually. These types of tasks are referred to as personal tasks. Every project and task has a set of
properties that are used to define its goal, time frame, priority, current status and other characteristics.

An overview of project management and examples of use on the Intranet Portal from the live site
perspective can be found in Intranet User's Guide -> Project Management. A full reference for the module
is located in Developer's Guide -> Modules -> Project Management.

Projects can be created, viewed and managed either on pages (documents) containing the Project list
web part or through the administration interface. When a project is created on a certain document, it is
bound to that specific document. Projects may only be accessed on the document that they are bound
to. There are several types of projects available on the Intranet Portal:

Department projects
Workgroup projects
Ad-hoc projects

The website also uses other types of web parts and widgets that allow users to interact with projects
and tasks. These web parts may be configured ( ) as necessary. Information about all project
management web parts and their properties can be found in Developer's Guide -> Modules -> Project
Management -> Project management web parts and widgets.

The master page of the website and individual master pages of departments and workgroups contain the 
Task info panel web part. This web part displays the amount of active tasks that are assigned to the
current user and serves as a direct link to a page showing task details (this document is described
below). Due to being placed on the master pages, the web part is available in the header of all pages.

http://devnet.kentico.com/docs/5_5r2/intranetusersguide/project_management_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/project_management_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/project_management_web_parts.htm
http://devnet.kentico.com/docs/5_5r2/devguide/project_management_web_parts.htm
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Further project management web parts can be found on the Employees/Management/My projects
and tasks document, which implements a part of the employee profile. Here, projects and tasks relevant
to the current user can be seen. The web parts on this document also allow users to create new
personal tasks.
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Alternatively, users with access to CMS Desk may also view their tasks and projects under the various
tabs at My Desk -> My Projects and tasks.

Project management general configuration

There are several possible configuration options that affect all types of projects and tasks. The statuses



Kentico CMS 5.5 R2 Intranet Administrator's Guide76

© 2011 Kentico Software

and priorities that can be set for projects or tasks may be defined on the Configuration tab of the CMS
Desk -> Tools -> Project management interface.

Additional settings may also be specified at Site Manager -> Settings -> Project management as
described in Developer's Guide -> Modules -> Project management -> Settings.

To ensure that users are aware of task assignments or any events related to tasks they are involved
with, project management uses a system of notification e-mails that are automatically sent when
required. The format of these e-mails is based on specific e-mail templates, which may be customized
at Site Manager -> Development -> E-mail templates. The following project management templates
are available:

Project Management - New task - sent when a new task is assigned to the user.
Project Management - Changed task - sent when an assigned or owned task is in some way
modified.
Project Management - Overdue task - sent when an assigned task reaches its deadline before it
is finished.
Project Management - Task reminder - sent when the Send reminder ( ) button is used for an
assigned task.

5.2 Department projects

Each Intranet Portal department has a dedicated sub-section, where its projects can be managed from
the live site by users with access to the department. For departments using the default structure, this
functionality is provided by the Project list web part on the Projects document.

http://devnet.kentico.com/docs/5_5r2/devguide/project_management_settings.htm
http://devnet.kentico.com/docs/5_5r2/devguide/managing_e_mail_templates.htm
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Projects from all departments and their tasks can be administered at CMS Desk -> Tools -> Project
Management.

In order for department projects to be available on the live site, their Project page property must contain
the path to the document where they should be displayed, for example /Departments/IT/Projects. The
value of this property can be set during the creation of a new project or when editing ( ) an existing
project on its General tab.
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If you customize the website and create a document containing the Project list web part outside of a
department somewhere on the global part of the portal, the projects created there will also be available at
this location.

A full reference for the project management module can be found in Developer's Guide -> Modules ->
Project Management.

5.3 Workgroup projects

Project management is also integrated into workgroups. Workgroup projects only operate within the
scope of the workgroup that they belong under, which means that tasks can only be assigned to
workgroup members, project security settings can be configured for workgroup roles instead of global
site roles etc. 

Similar to departments, each workgroup has a dedicated sub-section, where its projects can be
managed from the live site by users with access to the workgroup. For workgroups using the default
structure, this functionality is provided by the Project list web part on the Projects document.

http://devnet.kentico.com/docs/5_5r2/devguide/project_management_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/project_management_overview.htm
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All projects associated with a workgroup can be accessed by editing the given workgroup via the CMS
Desk -> Tools -> Groups interface and switching to the Projects tab.

In order for workgroup projects to be available on the live site, their Project page property must contain
the path to the document where they should be displayed, for example /Workgroups/
Microsoft_Office_Upgrade/Projects. The value of this property can be set during the creation of a new
project or when editing ( ) an existing project on its General tab.
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A full reference for the project management module can be found in Developer's Guide -> Modules ->
Project Management.

5.4 Ad-hoc projects

Site administrators or developers may create projects for their own purposes directly in CMS Desk ->
Tools -> Project Management, without specifying any document to which the projects should be
bound. Projects of this type may only be managed through the administration interface and are not
visible on the live site.

http://devnet.kentico.com/docs/5_5r2/devguide/project_management_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/project_management_overview.htm
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The difference between these ad-hoc projects and standard projects is that the value of their Project
page property is empty.

Tasks under ad-hoc projects are shown normally by the appropriate web parts and widgets and in CMS
Desk -> My desk -> My projects and tasks.

Ad-hoc projects may be converted to projects visible on the website simply by entering the path to a
document containing the Project list web part into their Project page property, which can be set when
editing ( ) a project on its General tab.

A full reference for the project management module can be found in Developer's Guide -> Modules ->
Project Management.

http://devnet.kentico.com/docs/5_5r2/devguide/project_management_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/project_management_overview.htm
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6 Document libraries

6.1 Document libraries overview

Document libraries provide live site users with a convenient way of files storage on the intranet, without
the need to access the user interface of the system. These libraries are located at three places on the
portal:

In the global section.
In each department's dedicated website section.
In each workgroup's dedicated website section.

In Intranet User's Guide -> Document libraries, you can find a detailed overview of the document libraries
on the portal and instructions on how they can be used by live site users.

A full reference on the Document library module is located in Developer's Guide -> Modules ->
Document library. The chapter contains examples based on the Intranet Portal website, including a
step-by-step guide on creating a new document library, so please refer to it in case that you are looking
for this type of information.

http://devnet.kentico.com/docs/5_5r2/intranetusersguide/document_libraries_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/document_library_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/document_library_overview.htm
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7 Other features

7.1 RSS feeds

The portal contains numerous RSS feeds of blog posts, events, forum posts and news published in
the portal's global section and in each department's and workgroup's dedicated website section. The
feeds are created using web parts of the Syndication module. A full reference on the module can be
found in Developer's Guide -> Modules -> Syndication. In Intranet User's Guide -> Other features -> RSS
feeds, you can find a detailed summary of the available feeds and an explanation of how the feeds can
be used by live site users.

RSS feeds in the content tree

The RSS feeds are provided by a set of dedicated special pages. These special pages can be found at
three locations:

1) RSS feed pages for the content of the portal's global section are located under the RSS document in
the root of the content tree, as depicted below.

2) RSS feed pages for content of particular department sections are located under the RSS document in
each department's dedicated website section.

http://devnet.kentico.com/docs/5_5r2/devguide/syndication_overview.htm
http://devnet.kentico.com/docs/5_5r2/intranetusersguide/rss_feeds.htm
http://devnet.kentico.com/docs/5_5r2/intranetusersguide/rss_feeds.htm
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3) RSS feed pages for content of particular workgroup section are located under the RSS document in
each workgroup's dedicated website section.

RSS feed web part configuration

RSS pages of news, event and blog post feeds contain two interconnected web parts: a Documents
data source and an RSS repeater.

The Documents data source is used to retrieve data records for the feed from the system's database
and provide them to the RSS repeater. From all its properties, the following are configured to ensure the
required functionality (the sample values are taken from the Departments/IT/RSS/Blog posts page):

Web part control ID: DocumentsDataSource; code name of the data source (used for connection to
the RSS repeater).
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Path: {%cmscontext.currentdepartment.nodealiaspath%}/Blogs/%; documents under this path will
be provided by the datasource. The macro is used to retrieve the alias path of the current
department's parent document. 
Class names: CMS.BlogPost; only documents of this type located in the specified path will be
provided by the datasource.
ORDER BY Expression: BlogPostDate DESC; ordering of provided documents.
Select top N documents: 15; only the 15 top documents will be provided (based on the ORDER BY
expression sorting).

The RSS repeater ensures that the page becomes the actual RSS feed, i.e. that the URL of the page
will be the actual URL of the feed. From its properties, the following are configured to ensure the required
behavior:

Feed name: blogposts; name of the feed used for its identification (typically used if you have more
than one feed on a single page).
Feed title: Latest {%cmscontext.currentdepartment.documentname%} department blog posts; title
of the feed. The macro is used to retrieve the name of the current department.
Feed description: Latest {%cmscontext.currentdepartment.documentname%} department blog
posts RSS feed.; text describing the feed. The macro is used to retrieve the name of the current
department.
Data source name: DocumentsDataSource; code name of the datasource that provides documents
for the feed.
Transformation name: IntranetPortal.Transformations.SecuredBlogPostRSSItem; transformation
used to transform provided documents to the feed format.

Forum post RSS feed pages are created in a similar manner. They also contain an RSS repeater, but
the data is provided to it by a Forum posts data source instead of the Documents data source
described above. However, configuration of the web parts is very similar.

The Forum posts data source has its properties configured the following way (the sample values are
taken from the Departments/IT/RSS/Forum posts page):

Web part control ID: ForumPostsDataSource; code name of the data source (used for connection
to the RSS repeater).
Forum name: all; ensures that posts from all forums on the site should be provided, the posts are
then filtered using the WHERE condition below.
Select only approved: enabled; ensures that only approved posts will be provided (in case that
forum moderation is enabled).

http://devnet.kentico.com/docs/5_5r2/devguide/appendix_a___macro_expressions.htm
http://devnet.kentico.com/docs/5_5r2/devguide/appendix_a___macro_expressions.htm
http://devnet.kentico.com/docs/5_5r2/devguide/appendix_a___macro_expressions.htm
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ORDERY BY expression: PostLastModified DESC; 
Select Top N posts: 15; 
WHERE condition: GroupName = 'Department_{%cmscontext.currentdepartment.nodeguid%}'; 
Select columns: PostGUID,PostSubject,PostIDPath,PostForumID,ForumSiteID; 

The RSS repeater has the following properties configuration:

Feed name: forumposts; name of the feed used for its identification (typically used if you have more
than one feed on a single page).
Feed title: Latest {%cmscontext.currentdepartment.documentname%} department forum posts; title
of the feed. The macro is used to retrieve the name of the current department.
Feed description: Latest {%cmscontext.currentdepartment.documentname%} department forum
posts RSS feed.; text describing the feed. The macro is used to retrieve the name of the current
department.
Data source name: ForumPostsDataSource; code name of the datasource that provides
documents for the feed.
Transformation name: IntranetPortal.Transformations.SecuredForumPostsRSSItem;
transformation used to transform provided documents to the feed format.

Links to RSS feeds

Links to particular RSS feeds can be found throughout the whole portal. The first location where you may
come across them are the Home pages, both the global one and the ones of departments and
workgroups. The feeds are accessible under the  icons in widgets displaying latest news, blog posts
and forum posts (only on department and workgroup Home pages). Displaying of these links is ensured
by the code of the Intranet content box RSS and Intranet column box RSS web part containers,
which are used to encapsulate the web parts.

http://devnet.kentico.com/docs/5_5r2/devguide/appendix_a___macro_expressions.htm
http://devnet.kentico.com/docs/5_5r2/devguide/appendix_a___macro_expressions.htm
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The other location where links to RSS feeds can be found are the particular News, Events, Forums and
Blogs pages, both in the portal's global section and in particular department and workgroup sections. On
the Forums page, the feed is accessible under the  icon in the web part container of the Latest posts
repeater, similarly as described above. 

On the other pages, the respective feeds are accessible under the  icon next to the page's title (as
highlighted above). This time, the link is added to the page using the Feed link web part, whose Feed
URL property is configured to the path of the respective feed's page (e.g. ~/RSS/News.aspx in case of
the global section's news).
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Security of department and workgroup feeds

RSS feeds of department or workgroup content contain only titles of the new content. These titles work
as links to the page where the new content is published. This happens for security reasons, as RSS
feeds cannot be secured and anybody who knows the feed URL can subscribe to it. To prevent users
without appropriate permissions from viewing secured content, only links are included in the feeds. This
way, users have to log on to the secured portal to see the actual content.

7.2 Search

The portal comes with built-in index-based search functionality. Using it, it is possible to search for text
in website content and in the website's discussion forums. The whole functionality is provided by the 
Smart search module. Full documentation of the module can be found in Developer's Guide -> Modules
-> Smart search.

Smart search indexes

The Smart search module provides indexed-based search using the Lucene search engine. For your

http://devnet.kentico.com/docs/5_5r2/devguide/smart_search_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/smart_search_overview.htm
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website's content to be searchable, the content must be indexed by some of the smart search indexes
defined in Site Manger -> Administration -> Smart search. As you can see in the screenshot below,
the portal comes with an extensive number of default smart search indexes, so that all its default
content is already pre-indexed and fully searchable. 

There are two basic types of indexes: Documents indexes for content of documents and Forums
indexes for content of discussion forums. Primarily, there are two indexes for content of the portal's
global section: Intranet Portal - General content and Intranet Portal - General forums. The first one
is for content of the global section's documents, while the second one is intended for indexing of the
global section's forums. The two indexes are highlighted in the screenshot below.

Apart from the global section's indexes, two indexes are also created automatically when a new 
department or workgroup is created. These indexes are only used for search of the particular
department's or workgroup's website section, as described further below. You can identify them by the
display name of the department or workgroup present in the name of the index (e.g. Finance - Default
and Finance - Forums are indexes of the Finance department). 

Searching on the live site

On the live site, the search functionality is provided by the Smart search box web part. The web part is
placed below the main menu on master pages, both the global one and the ones used for department
and workgroup sections.

Among the web part's properties, the following configuration is the most important:
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Search button CSS class: CSS class used for the search button next to the textbox. In this case,
the SearchButton CSS class ensures that the  icon is used for the purpose.
Search textbox CSS class: CSS class used for the textbox where searched text is entered. The
SearchTextBox class is used by default.
Search results page URL: URL of the page where search results should be displayed. The target
page must contain either the Search results or the Smart search dialog with results web part with
proper configuration in order for search results to be displayed. 
Search mode: type of search matching. Determines if a match (search result) should be returned if
any word/all words/exact phrase is found in the searched content.

As you can see, the actual indexes to be searched are not set in the properties of this web part.
Contrary to that, the indexes are selected in properties of the Smart search dialog with results web
parts placed on the search results pages where users get redirected after submitting the search
request. 

Search results pages

The search result pages are special pages where search results are displayed to users. There are three
locations of search result pages:

~/Search.aspx - this page displays search results when searching content of the global section.
~/Departments/<department name>/Search.aspx - each department has its own search results
page where search results are displayed when searching the department's section.
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~/Workgroups/<workgroup name>/Search.aspx - each workgroup has its own search results
page where search results are displayed when searching the workgroup's section.

          

Global search results

The global section's search results are displayed on the ~/Search.aspx page. On this page, the
Search dialog with results web part is placed, with its Indexes property configured to IntranetPortal.
GeneralContent;IntranetPortal.GeneralForums. This ensures that when a user enters the searched text
into the search box anywhere in the global section, they are redirected to the ~/Search.aspx page,
where the web part displays search results found in the two indexes.

Department and workgroup search results

Particular departments and workgroups have their own search results pages. In master pages of the
department and workgroup sections, the following values are entered in the Search results page URL
property of the Smart search box web part:

Departments: ~{%cmscontext.currentdepartment.nodealiaspath%}/Search.aspx
Workgroups: ~/Workgroups/{%communitycontext.currentgroup.groupname%}/Search.aspx

This ensures that users are redirected to the correct search results page when searching a department
or workgroup. These search results pages also contain the Search dialog with results web parts. The
web parts are configured so that in the Indexes property, the following macros are used:

Departments: default_department_{%cmscontext.currentdepartment.nodeguid%};
forums_department_{%cmscontext.currentdepartment.nodeguid%}
Workgroups: default_group_{%communitycontext.currentgroup.groupguid%};forums_group_{%
communitycontext.currentgroup.groupguid%}

These macros ensure that correct smart search indexes are selected, depending on the department or
workgroup where the search is currently being performed.
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8 Customizing the portal

8.1 Changing the themes

The portal comes with three default themes - Blue, Green and Red, as described in Intranet User's
Guide -> Other features -> Available themes. These themes can be applied separately to the global
section of the portal and to particular departments and workgroups. While the global section themes and
departments documents themes can only be changed by the system administrators via the system
administration interface, the themes of workgroups documents can be changed by both the system
administrators and workgroup administrators. As the global administrator, you can thus not only add
your custom color themes, but also change the themes on all the three different levels:

Global section

1. Globally for the whole site

If you need to change the theme for the whole site, log on to Site Manager -> Sites and choose to Edit
( ) your intranet site. On the General tab of the Site properties page, choose the required theme from
the Site CSS stylesheet drop-down list and click OK. If you now go back to CMS Desk or live site, all
portal pages inheriting their theme from the portal global settings will have the color you have just
chosen. Please note that if you choose (none) from the Site CSS stylesheet drop-down list, your portal
pages will lack a theme unless you choose one as described below.

2. Globally for the root in the content tree

Another way to globally change the theme of the Intranet Portal is to choose one for its root. Log on to 
CMS Desk and choose the root from the content tree. Now select the theme that you would like to use
on the Properties tab in General -> CSS stylesheet . Please note that selecting (default) from the
CSS stylesheet drop-down list will result in applying the theme set in step 1. To save the theme for the

http://devnet.kentico.com/docs/5_5r2/intranetusersguide/Available_themes.htm
http://devnet.kentico.com/docs/5_5r2/intranetusersguide/Available_themes.htm
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portal root, click  Save. From now on, this theme will be used for all portal pages inheriting from the
root or from a parent inheriting directly or indirectly from the root.

3. Separately for different pages

On the Intranet Portal, you can also set a theme for a particular page. Log on to CMS Desk, choose the
page from the content tree and select the theme that you would like to use on the Properties tab in
General -> CSS stylesheet. Please note that selecting (default) from the CSS stylesheet drop-down
list will result in applying the theme set in step 1. To save the theme for the given page, click  Save.

Please note that if you set the Inherit option value to true, the CSS stylesheet drop-down list will
become inactive and the page will be inheriting its theme from the parent.

Departments

If you need to change the theme of a department, log on to CMS Desk and from the content tree,
choose the department root document whose theme you want to change. You can perform the task
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either the same way as described above, i.e. on the Properties tab in General -> CSS stylesheet, with
the possibility to inherit the theme from the parent by checking the Inherit check box.

Or you can change the department root document theme using the Used stylesheet drop-down list on
the Form tab. However, it is not possible to set inheritance from here.

In either case, clicking  Save will result in changing the theme of the given department root document
including all department pages inheriting directly or indirectly from this department root document.
Please note that choosing the department document theme on both the Form tab and Properties tab
has the same effect and the value chosen on the one tab is automatically set on the other.

Workgroups

If you need to change the theme of a workgroup, log on to CMS Desk and from the content tree, choose
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the workgroup root document whose theme you want to change. You can perform the task either the
same way as described above, i.e. on the Properties tab in General -> CSS stylesheet, with the
possibility to inherit the theme from the parent by checking the Inherit check box.

Or you can change the workgroup root document theme in Tools -> Groups -> Edit ( ) <group> ->
General using the Theme drop-down list. However, you will not be able to set inheritance from here.
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When you have the value entered, click  Save on the Properties tab or click OK on the General tab.
This will result in changing the theme of the given workgroup root document including all workgroup
pages inheriting directly or indirectly from this workgroup root document. Please note that choosing the
workgroup document theme on both the General tab and Properties tab has the same effect and the
value chosen on the one tab is automatically set on the other. What is more, workgroup administrators
can change the workgroup document theme also on the live site, as described in Intranet User's Guide -
> Workgroups.

Please note

If you choose any value other than (none) or (default) from the Site CSS stylesheet,
CSS stylesheet and Used stylesheet drop-down lists, the stylesheet Edit button will
be active enabling you to edit the code of the particular CSS style.

http://devnet.kentico.com/docs/5_5r2/intranetusersguide/Workgroups_overview.htm
http://devnet.kentico.com/docs/5_5r2/intranetusersguide/Workgroups_overview.htm
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Creating your custom color theme

1. If you need to create your own color theme, log on to Site Manager, go to Development -> CSS
stylesheets and choose to Edit ( ) either the Intranet Portal - Green or Intranet Portal - Red theme.
On the <CSS stylesheet> -> General tab, copy the content of the Stylesheet text field to clipboard.

Please note that the Intranet Portal - Blue theme is the portal default theme, which is used as the
basis of the Intranet Portal - Green and Intranet Portal - Red themes, defining only color differences.
The steps described in this section thus concern only the creation of a new theme color variant.
However, if you would like to create a new theme from scratch, you can use also the Intranet Portal -
Blue theme as the basis or you can start with a blank one, writing all the CSS stylesheet code yourself.

2. In Site Manager -> Development -> CSS stylesheets, click the  New CSS stylesheet link.
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3. This displays the dialog used for the creation of a new CSS stylesheet.

The following fields are available to define the CSS stylesheet:

Stylesheet display name - name of the stylesheet displayed in the user interface; a required field.
Stylesheet code name - name of the stylesheet used in website code; a required field.
Stylesheet text - standard CSS stylesheet code; a required field.
assign to web site Intranet Portal - indicates if the CSS stylesheet will be assigned to the Intranet
Portal web site; an optional field.

Now copy the content of the clipboard to the Stylesheet text field. Modify the style code as needed, fill
in the remaining two required fields and make sure that the assign to web site Intranet Portal option is
set to true. If you have all values entered, click OK to save the new CSS stylesheet. Please note that
you can optionally assign the CSS stylesheet to a web site from the <CSS stylesheet> -> Sites tab
using the Add sites button.

4. You may also want to modify some of the auxiliary image files related to the CSS style defining your
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custom color theme. You can either upload new image files with the same names or you can modify the
existing files using the built-in Image editor as described in more details in the Handling images
chapter in the Content management -> File management section of the Developer's Guide. Please
note that image files on the Intranet Portal are placed in the Files folder.

For a detailed description of how to deal with CSS styles on the Intranet Portal, please refer to the CSS
stylesheets and design chapter in the Development section of the Developer's Guide.

8.2 Modifying the Home page

In this topic you will learn how to modify some important elements of the Intranet Portal Home page,
such as the Quick links, Employee of the month and the Canteen menu widgets. You will also learn how
to add other widgets to the portal main page. Widgets introduce support for the personalization of pages.
They allow users and editors to edit the structure of page templates. The personalized settings are
saved within the system and can be invoked from the live site by authorized users or through the CMS
Desk interface in the case of website editors. If you need to modify the portal Home page, log on to CMS
Desk, choose Home from the content tree and navigate to the Content -> Edit -> Page tab. You should
see a page similar to the one depicted in the following screenshot.

http://devnet.kentico.com/docs/5_5r2/devguide/image_editor.htm
http://devnet.kentico.com/docs/5_5r2/devguide/CSS_Overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/CSS_Overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/Widgets_overview.htm
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Widgets management

As a content editor, you can add, modify or delete any widget placed in a widget zone. This can be used
to quickly customize pages beyond simply entering content into static page templates.

To add a new widget to your portal Home page, just click the Add widget ( ) button in the top left
corner of an editor widget zone.

You can modify any widget placed in an editor widget zone by clicking the Configure widget ( )
button. You can also delete widgets using the Delete widget ( ) button. Widgets can be moved
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between different widget zones by clicking the Drag widget ( ) button and dragging the widget to the
desired place.

If you would like to learn more about using widgets in Kentico CMS, please refer to the Development ->
Using widgets chapter in the Development section of the Developer's Guide.

Changing the Quick links

The Quick links box contains links to pages that you need to be accessible directly from the Intranet
Portal Home page. If you need to modify or delete some of these links or if you need to add new ones,
move the mouse over the box so that the widgets management buttons become visible.

By clicking the Configure widget ( ) button, you will open the Widget properties (Intranet quick
links) dialog window. In the Content -> Text field you can perform all editing actions concerning your
quick links using the built-in WYSIWYG editor. For more information on how to use the editor, please
refer to the WYSIWYG editor chapter in the Development section of the Developer's Guide.

http://devnet.kentico.com/docs/5_5r2/devguide/Using_widgets.htm
http://devnet.kentico.com/docs/5_5r2/devguide/Using_widgets.htm
http://devnet.kentico.com/docs/5_5r2/devguide/wysiwyg_editor_overview.htm
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The following fields are available to define the Intranet quick links widget:

Text - the text to be displayed in the Quick links box. All editing actions related to the actual links
can be performed using the built-in WYSIWYG editor.
Widget container - the container containing the particular widget.
Widget container title - the title of the widget container. It is displayed only if the {%ContainerTitle
%} macro is used in the container code.

When you have the values entered, click OK to save the widget new settings and close the dialog
window. Or click Apply to confirm the entered value(s) and leave the dialog window open. Or click
Cancel to close the dialog window. Please note that if you click the Cancel button after confirming
some previously made changes, these changes will not be lost. If you set the Refresh page option
value to false, the edited content will not be updated after closing the dialog window unless you either
refresh the Edit mode or switch to the Preview or Live site modes.

Changing the Employee of the month

The Employee of the month box contains an image of a selected company employee together with its
caption. The image is presented on the Intranet Portal Home page for the duration of one month and can
be partially customized. You can select a different image from the Intranet Portal file system by clicking
the  Select link, or you can click the  Clear link, which removes the selected image and replaces it
with the default one. Another option to modify some basic properties of the image is to move the mouse
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over the box so that the widgets management buttons become visible.

If you click the  Select link, the Select image dialog window will pop up. Choose an image file from
the Intranet Portal content tree and optionally adjust its width and height. You can Lock/Unlock ( ) the
image aspect ratio and you can also Reset ( ) its size. By clicking Refresh ( ) you can refresh the
image URL according to the current image file settings. When you have the values entered, click Select
to confirm selection and adjustment of the new image or click Cancel to discard the changes.

The following fields are available if you are selecting a new Employee of the month widget image using
the Select image dialog window:

URL - URL of the image file in your Intranet Portal file system.
Width - the width of the image in pixels. The image will be resized to this width.
Height - the height of the image in pixels. The image will be resized to this height.

If you click the Configure widget ( ) button, you will open the Widget properties (Employee of the
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month) dialog window. This dialog window enables you to modify some basic properties of the image
file. When you have the values entered, click OK to save the new widget settings and close the dialog
window. Or click Apply to confirm the entered value(s) and leave the dialog window open. Or click
Cancel to close the dialog window. Please note that if you click the Cancel button after confirming
some previously made changes, these changes will not be lost. If you set the Refresh page option
value to false, the edited content will not be updated after closing the dialog window unless you either
refresh the Edit mode or switch to the Preview or Live site modes.

The following fields are available to define the Employee of the month widget:

Image width - the width of the image in pixels. The image will be resized to this width.
Image height - the height of the image in pixels. The image will be resized to this height.
Image title - the title of the image region displayed on the Intranet Portal Home page.
Alternate text - the alternate text of the image displayed on the live website. It is the value of the alt
attribute of the image tag.
Widget container - the container containing the particular widget.
Widget container title - the title of the widget container. It is displayed only if the {%ContainerTitle
%} macro is used in the container code.

Please note

If you need to modify the image file using the standard image editing operations, please
refer to the Handling images chapter in the Content management -> File
management section of the Developer's Guide.

Changing the Canteen menu

http://devnet.kentico.com/docs/5_5r2/devguide/image_editor.htm
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The Canteen menu box contains the company canteen menu for the period of one week, optionally
together with a description. The Intranet Portal comes shipped with a canteen menu in the form of table.
However, you can fully customize the menu according to your needs. If you would like to modify the
canteen menu, move the mouse over the box so that the widgets management buttons become visible.

By clicking the Configure widget ( ) button, you will open the Widget properties (Intranet canteen
menu) dialog window. In the Content -> Text field you can perform all editing actions concerning your
canteen menu using the built-in WYSIWYG editor. For more information on how to use the editor, please
refer to the WYSIWYG editor chapter in the Development section of the Developer's Guide.

http://devnet.kentico.com/docs/5_5r2/devguide/wysiwyg_editor_overview.htm
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The following fields are available to define the Intranet canteen menu widget:

Text - the text to be displayed in the Intranet canteen menu box. All the editing actions related to the
text can be performed using the built-in WYSIWYG editor.
Widget container - the container containing the particular widget.
Widget container title - the title of the widget container. It is displayed only if the {%ContainerTitle
%} macro is used in the container code.

When you have the values entered, click OK to save the widget new settings and close the dialog
window. Or click Apply to confirm the entered value(s) and leave the dialog window open. Or click
Cancel to close the dialog window. Please note that if you click the Cancel button after confirming
some previously made changes, these changes will not be lost. If you set the Refresh page option
value to false, the edited content will not be updated after closing the dialog window unless you either
refresh the Edit mode or switch to the Preview or Live site modes.

Please note

If you switch to the Edit -> Design tab, you can modify the layout of the page.
However, special permissions are needed to perform this task. Please refer to the 
Portal engine development model chapter in the Development section of the Developer's
Guide for more details.

8.3 Modifying structure of the website

In case that you are planning to customize the portal so that alias paths of documents change, you
need to take into account that some intranet portal widgets may not work correctly. These widgets are
based on standard Kentico CMS web parts, but have most of their properties pre-configured. However,
some of them have their configuration dependent on the default structure of the portal. Therefore, it is
either necessary for the documents listed below to be accessible under their original URLs, or to change
the pre-configuration of particular widget properties in Site Manager -> Development -> Widgets -> ...
select a widget from the tree ... -> Properties to reflect your new custom location.

For more information on URLs in Kentico CMS, please refer to Developer's Guide -> Development ->
Page processing and URLs. A detailed reference on path expressions is located in Developer's Guide ->
Appendix B - Path expression.

Global section

The following alias paths of documents from the global section of the portal are pre-configured into the
default properties of at least one Intranet portal widget:

/Home - the Department quick links and Workgroup quick links widgets contain a link to this
alias path in their default text.
/Departments - the Intranet departments widget is by default configured to display departments
under this alias path. Also, the Intranet quick links widget contains a link to this alias path in its
default text.
/Workgroups - the Intranet quick links widget contains a link to this alias path in its default text.

http://devnet.kentico.com/docs/5_5r2/devguide/portal_engine_overview.htm
http://devnet.kentico.com/docs/5_5r2/webparts/KenticoCMS_WebParts.htm
http://devnet.kentico.com/docs/5_5r2/devguide/page_processing_and_urls_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/page_processing_and_urls_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/appendix_b___path_expressions.htm
http://devnet.kentico.com/docs/5_5r2/devguide/appendix_b___path_expressions.htm
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/Documents - the Intranet quick links widget contains a link to this alias path in its default text.
/News - the Intranet latest news widget is by default configured to display News documents under
this alias path and also provides a link to it. To modify this link, the default value of the widget's
ContentAfter property must be changed.
/Events - the Intranet upcoming events widget is by default configured to display Event documents
under this alias path.
/Events/Events-list - the Intranet upcoming events widget by default provides a link to this alias
path. To modify this link, the default value of the widget's ContentAfter property must be changed.
/Blogs - the Intranet latest blog posts widget is by default configured to display Blog documents
under this alias path.
/Blogs/Blog-posts - the Intranet latest blog posts widget by default provides a link to this alias
path. To modify this link, the default value of the widget's ContentAfter property must be changed.
/Employees - the Intranet quick links widget contains a link to this alias path in its default text.
/Employees/Management/My-projects-and-tasks - the My projects - Intranet Portal, Tasks
assigned to me - Intranet portal and Tasks owned by me - Intranet portal widgets by default
provide a link to this alias path. To modify these links, the default value of the ContentAfter property
of the appropriate widget must be changed.
/RSS/<BlogPosts, Events, ForumPosts, News> - the RSS feed buttons in the container headers of
the Intranet latest blog posts, Intranet upcoming events, Intranet latest forum posts and
Intranet latest news widgets link to the respective alias path (if a container that supports an RSS
link is used). To modify these RSS feed links, the default value of the ContainerCustomContent
property of the appropriate widget must be changed.

Workgroup sections

The following alias paths of documents from the sections dedicated to individual workgroups are
pre-configured into the default properties of at least one Intranet portal widget:

/Workgroups/<workgroup code name> - the Workgroup recent pages widget is by default
configured to display Simple article documents under this alias path.
/Workgroups/<workgroup code name>/News - the Workgroup latest news widget is by default
configured to display News documents under this alias path and also provides a link to it. To modify
this link, the default value of the widget's ContentAfter property must be changed.
/Workgroups/<workgroup code name>/Calendar - the Workgroup upcoming events widget is by
default configured to display Event documents under this alias path.
/Workgroups/<workgroup code name>/Calendar/Events-list - the Workgroup upcoming events
widget by default provides a link to this alias path. To modify this link, the default value of the
widget's ContentAfter property must be changed.
/Workgroups/<workgroup code name>/Documents - the Workgroup quick links widget contains a
link to this alias path in its default text.
/Workgroups/<workgroup code name>/Blogs - the Workgroup latest blog posts widget is by
default configured to display Blog documents under this alias path.
/Workgroups/<workgroup code name>/Blogs/Blog-posts - the Workgroup latest blog posts widget
by default provides a link to this alias path. To modify this link, the default value of the widget's
ContentAfter property must be changed.
/Workgroups/<workgroup code name>/Wik i - the Workgroup recent pages widget by default
provides a link to this alias path. To modify this link, the default value of the widget's ContentAfter
property must be changed.
/Workgroups/<workgroup code name>/Projects - the Workgroup quick links widget contains a link
to this alias path in its default text.
/Workgroups/<workgroup code name>/Members - the Workgroup quick links widget contains a
link to this alias path in its default text.
/Workgroups/<workgroup code name>/RSS/<BlogPosts, Events, ForumPosts, News> - the RSS
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feed buttons in the container headers of the Workgroup latest blog posts, Workgroup upcoming
events, Workgroup latest forum posts and Workgroup latest news widgets link to the respective
alias path (if a container that supports an RSS link is used). To modify these RSS feed links, the
default value of the ContainerCustomContent property of the appropriate widget must be changed.

Department sections

The following alias paths of documents from the sections dedicated to individual departments are
pre-configured into the default properties of at least one Intranet portal widget:

/Departments/<department code name>/News - the Department latest news widget is by default
configured to display News documents under this alias path and also provides a link to it. To modify
this link, the default value of the widget's ContentAfter property must be changed..
/Departments/<department code name>/Calendar - the Department upcoming events widget is by
default configured to display Event documents under this alias path.
/Departments/<department code name>/Calendar/Events-list - the Department upcoming events
widget by default provides a link to this alias path. To modify this link, the default value of the
widget's ContentAfter property must be changed.
/Departments/<department code name>/Documents - the Department quick links widget contains
a link to this alias path in its default text.
/Departments/<department code name>/Blogs - the Department latest blog posts widget is by
default configured to display Blog documents under this alias path.
/Departments/<department code name>/Blogs/Blog-posts - the Department latest blog posts
widget by default provides a link to this alias path. To modify this link, the default value of the
widget's ContentAfter property must be changed.
/Departments/<department code name>/Members - the Department quick links widget contains a
link to this alias path in its default text.
/Departments/<department code name>/RSS/<BlogPosts, Events, ForumPosts, News> - the RSS
feed buttons in the container headers of the Department latest blog posts, Department
upcoming events, Department latest forum posts and Department latest news widgets link to
the respective alias path (if a container that supports an RSS link is used). To modify these RSS
feed links, the default value of the ContainerCustomContent property of the appropriate widget
must be changed.

Remembering original URLs when moving documents

The Site Manager -> Settings -> URLs and SEO -> Remember original URLs when moving
documents setting may come in handy in this situation. 
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This setting is enabled by default and it ensures that when a document is moved or its alias path is
modified, the original alias path is added among its additional Document aliases. This way, the
document is still accessible under the original URL (2. in the screenshot below), as well as under the
new one (1. in the screenshot below). If you perform your alias-path-related modifications with this
setting enabled, the functionality of the structure-dependent widgets listed above will be preserved.

8.4 Configuration for multiple languages

The intranet portal can be multilingual, i.e. both the content of the front-end website and the resource
strings in the administration interface can be displayed in various languages, based on the current user's
preferences. This topic will give you a basic overview of how this configuration can be achieved. For a full
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reference on the multilingual possibilities of Kentico CMS, please refer to Developer's Guide ->
Development -> Multilingual and international support.

Multiple content cultures

If you want to make the portal's content multilingual, the first thing to do is to add the required cultures
in Site Manager -> Sites -> edit ( ) the site -> Cultures. By default, the portal only uses the English -
United States culture. You can add additional cultures using the Add cultures button, which opens a
culture selection dialog where all cultures defined in Site Manager -> Development -> Cultures will be
offered. Unwanted cultures can be removed from the list by checking their check-boxes and clicking the 
Remove selected button.

Once you have more than one culture in the list, the Language toolbar is displayed in CMS Desk ->
Content. Using this toolbar, you can switch between particular language versions of the document
currently selected in the content tree.

On the live site, you can switch between particular language versions of the website using the 
Lanugage selection or Language selection with flags web part. On the Intranet Portal website, the
second mentioned web part is located in the top right corner of the master page header. 

Multiple user interface cultures

User interface cultures can be managed in Site Manger -> Development -> UI cultures. In this part of
the administration interface, you can see a list of all user interface cultures currently available in the

http://devnet.kentico.com/docs/5_5r2/devguide/multilingual_support_overview.htm
http://devnet.kentico.com/docs/5_5r2/devguide/multilingual_support_overview.htm
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system. The default installation of Kentico CMS only contains the English, Czech and Slovak cultures.
Localization packs containing other cultures can be downloaded for free at http://www.kentico.com/
Download/Localization-Packs.aspx. 

It is also possible to create a completely new user interface culture using the  New UI culture link on
this page. If you click the Edit ( ) button next to a culture, you open its editing interface where you can
define custom resource strings. It is also possible to remove listed cultures using the Delete ( ) button.

Culture settings for users

Each user has the following two properties on the General tab of their editing interface in Site Manager
-> Administration -> Users:

Preferred content culture - preferred culture of website content displayed to the user. If set to
(default) or if the selected culture is not available, content is displayed in the default website culture.
Preferred user interface culture - preferred culture of the system's administration interface
displayed to the user. If set to (default) or if the selected culture is not available, user interface is
displayed in the default user interface culture.

http://www.kentico.com/Download/Localization-Packs.aspx
http://www.kentico.com/Download/Localization-Packs.aspx
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Users with access to CMS Desk can adjust these settings for their own accounts in My desk -> My
profile.

Default culture settings

When setting up a multilingual intranet, it is necessary to choose default cultures. These cultures are
used when the two preferred culture settings described above are set to (default), or when the user's
preferred culture is not available. These settings need to be adjusted separately for the website content
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and for the administration interface.

Default content culture

Default content culture can be configured in Site Manager -> Sites -> edit  the site -> General. The
following two settings on this tab are related to default cultures:

Default content culture - content culture displayed to registered users whose Preferred content
culture is set to (default).
Default visitor culture - content culture displayed to anonymous site visitors. If set to (Automatic),
the culture will be used based on client browser preferences.

The Default content culture option above is linked with the Default culture of the content setting in
Site Manager -> Settings -> Website. If you change the value here with the correct website selected,
it gets changed in the dialog described above too, and vice versa.
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Default user interface culture

The default UI culture can be set by adding the following key to the <appSettings> section of your site's
web.config file:

<add key="CMSDefaultUICulture" value=”en-nz” />

If you use this key, you also need to rename the ~\CMSResources\CMS.resx file to CMS.en-us.resx
and the CMS.en-nz.resx file to CMS.resx. This is needed because the CMS.resx file is used when the
(default) option in selected in users' Preferred user interface culture. When this key is used and the
CMS.resx file contains the en-nz dictionary, for the user who has their Preferred user interface
culture set to (default), the UI culture will be en-nz.

8.5 Changing the company logo

Here you will learn how to change and modify your company logo. You can change the logo in the
Intranet Portal root or you can update it in the Intranet Portal content tree.

Changing the company logo

1. If you need to change your company logo, log on to CMS Desk and choose the Intranet Portal root
from the content tree. You should see a page similar to the one depicted in the following screenshot.
You can select a different logo image from the Intranet Portal file system by clicking the  Select link
or you can restore the default logo image by clicking the  Clear link.
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2. If you click the  Select link, the Select image dialog window will pop up. Choose an image file
from the Intranet Portal content tree and optionally adjust its width and height. You can Lock/Unlock (
) the image aspect ratio and you can also Reset ( ) its size. By clicking Refresh ( ) you can refresh
the image URL according to the current image file settings. When you have the values entered, click 
Select to confirm selection and adjustment of the new image or click Cancel to discard the changes.

The following fields are available if you are selecting a new logo image using the Select image dialog
window:

URL - URL of the image file in your Intranet Portal file system.
Width - the width of the image in pixels. The image will be resized to this width.
Height - the height of the image in pixels. The image will be resized to this height.
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3. Finally, go to CMS Desk -> Content -> Edit, choose any Intranet Portal page displaying the company
logo, e.g. the Home page, from the content tree and switch to the Page tab. The new company logo will
be displayed. Please note that you can check your company logo also on the live site.

Updating the company logo

1. Another option to change your company logo is to update the existing one. The company logo image
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file can be found in the Intranet Portal Files folder. Navigate to this folder from CMS Desk -> Content
and choose the appropriate image file from the content tree.

Please note

The Files folder in CMS Desk -> Content does not only contain the company logo
image file and image files related to the Intranet Portal themes. All other image files
placed on the portal can be found in this folder, too.

2. Now go to CMS Desk -> Content -> Edit, switch to the Form tab and click Update ( ).

3. This will open the Choose file to Upload webpage dialog of the operating system enabling you to
choose the new logo image file from your local or network file system. Navigate to the appropriate file,
select it and click the Open button to confirm the update of your company logo.
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4. Finally, go back to CMS Desk -> Content -> Edit, choose any Intranet Portal page displaying the
company logo, e.g. the Home page, from the content tree and switch to the Page tab. The new
company logo will be displayed. Please note that you can check your company logo update also on the
live site.

Please note

If you don't need to change your company logo and only wish to modify it, navigate as
described in step 2. and click Edit ( ). This will open the Edit image webpage dialog
enabling you to perform standard image editing operations such as Resize, Rotation,
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Convert, Crop and Color adjustment, same as display the Properties of the image.
For more details on how to performs these operations, please refer to the Handling
images chapter in the Content management -> File management section of the
Developer's Guide.

http://devnet.kentico.com/docs/5_5r2/devguide/image_editor.htm
http://devnet.kentico.com/docs/5_5r2/devguide/image_editor.htm
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9 Special pages

The portal contains a number of special pages. These pages are standard Page (menu item)
documents in the content tree, but they are not visible in the navigation menu. Their function is to provide
functionality such as handling unsubscription requests, etc. 

The special pages described in this topic are located in the Special pages folder in the content tree.
The following pages can be found there:

Access denied
Blog unsubscribe
Board unsubscribe
Forum unsubscribe
Invitation acceptation
Registration approval

There are also other special pages in addition to the ones described in this topic - special pages for
search and RSS feeds. These pages are described separately in the RSS feeds and Search topics in
the Other features chapter of this guide.

Access denied

Users who attempt to access a page for which they do not have permissions are by default redirected to
a system page that displays a security message. A custom page may however be set as an alternative
for the default system page. The Access denied special page is prepared for this purpose, it only
requires the simple configuration process described below to be performed to ensure that users without
permissions are redirected correctly.

Go to Site Manager -> Settings -> Security, select the Intranet Portal site from the drop-down list on
the top left, uncheck the Inherit from global settings box on the right of the Access denied page

http://devnet.kentico.com/docs/5_5r2/devguide/document_permissions.htm
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URL setting and enter the appropriate value into the field. By default, the URL is ~/Special-pages/
Access-denied.aspx.

Click  Save to complete the process.

The content of the page is fully customizable. By default, the following message is displayed: You are
not allowed to access the required page. Please contact the administrator if you think  you should be
allowed to access it.

The pages of workgroups do not redirect to this page when accessed without the appropriate
permissions, since every workgroup has its own Access page dedicated to this purpose.

Blog unsubscribe

This page is used for the handling of blog post unsubscription requests. When a user subscribes to
receive notifications about new blog posts in some blog, a notification e-mail is sent to their e-mail
address when a new blog post is published. The notification e-mails contain unsubscription links leading
to this page. 

When the page is accessed, the Blog post unsubscription web part on the page recognizes the
subscription based on a value passed in the query string, performs unsubscription and displays a
message confirming it to the user. From now on, notifications about blog posts in the respective blog will
no longer be sent to the user.
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The URL of the page must be entered in Site Manager -> Settings -> Blogs -> Blog unsubscription
URL in order for the links to be functional. The portal is already pre-configured for the default location of
this page, so you only need to modify it in case you wish to change the page's alias path.

More information on blog subscriptions can be found in Developer's Guide -> ... -> Blog comments
notifications -> User subscriptions.

Board unsubscribe

This page is used for the handling of message board unsubscription requests. When a user subscribes
to receive notifications about new messages on a message board, a notification e-mail is sent to their e-
mail address when a new message is added. The notification e-mails contain unsubscription links
leading to this page. 

When the page is accessed, the Message board unsubscription web part on the page recognizes the
subscription based on a value passed in the query string, performs unsubscription and displays a
message confirming it to the user. From now on, notifications about new messages on the board will no
longer be sent to the user.

The URL of the page must be entered in Site Manager -> Settings -> Message boards -> Board
unsubscription URL in order for the links to be functional. The portal is already pre-configured for the
default location of this page, so you only need to modify it in case you wish to change the page's alias
path.

More information on board subscriptions can be found in Developer's Guide -> ... -> Message board
notifications -> User subscriptions.

Forum unsubscribe

This page is used for the handling of forum unsubscription requests. When a user subscribes to receive
notifications about new posts in a forum, a notification e-mail is sent to their e-mail address when a new
forum post is added. The notification e-mails contain unsubscription links leading to this page. 

When the page is accessed, the Forum unsubscription web part on the page recognizes the
subscription based on a value passed in the query string, performs unsubscription and displays a

http://devnet.kentico.com/docs/5_5r2/devguide/blogs_notifications_user_subscriptions.htm
http://devnet.kentico.com/docs/5_5r2/devguide/blogs_notifications_user_subscriptions.htm
http://devnet.kentico.com/docs/5_5r2/devguide/message_boards_user_subscriptions.htm
http://devnet.kentico.com/docs/5_5r2/devguide/message_boards_user_subscriptions.htm
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message confirming it to the user. From now on, notifications about new posts in the forum will no longer
be sent to the user.

The URL of the page must be entered in Site Manager -> Settings -> Forums -> Forum
unsubscription URL in order for the links to be functional. The portal is already pre-configured for the
default location of this page, so you only need to modify it in case you wish to change the page's alias
path.

More information on forum subscriptions can be found in Developer's Guide -> Modules -> Forums ->
Subscriptions.

Invitation acceptation

This page is used to handle workgroup invitations. A new user can be invited to a workgroup via e-mail or
the internal messaging message. Both types of messages contain links that can be used to accept the
invitation. The links lead to this page.

When the page is accessed, the Group invitation web part on the page recognizes the invitation based
on a value passed in the query string and makes the user a member of the workgroup.

The alias path of the page must be entered in Site Manager -> Settings -> Community -> Invitation
acceptation path in order for the links to be functional. The portal is already pre-configured for the
default location of this page, so you only need to modify it in case you wish to change the page's alias
path.

Registration approval

This page is used to handle registration confirmations. When a new user registers on the Logon page,
an e-mail is sent to them, asking them to confirm their registration by clicking a link in the e-mail. The
link leads to this page.

When the page is accessed, the Registration confirmation web part on the page recognizes the
registration based on a value passed in the query string and confirms the user's registration. From now
on, the new user account will be enabled and the new user can log on to the portal using the account.

http://devnet.kentico.com/docs/5_5r2/devguide/subscriptions.htm
http://devnet.kentico.com/docs/5_5r2/devguide/subscriptions.htm
http://devnet.kentico.com/docs/5_5r2/devguide/messaging_module_overview.htm
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The URL of this page needs to be entered in the E-mail confirmation page property of the
Registration form web part on the Logon page. The web part is already pre-configured for the default
location of the page, so you only need to modify it in case you wish to change the page's alias path.

Detailed information on user registration can be found in Developer's Guide -> ... -> User registration ->
Registration approval and double opt-in.

http://devnet.kentico.com/docs/5_5r2/devguide/registration_approval_and_double_opt_in.htm
http://devnet.kentico.com/docs/5_5r2/devguide/registration_approval_and_double_opt_in.htm
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10 Intranet widgets and web parts

The portal comes with a number of widgets designed specifically for intranet scenarios. These widgets
are derived from standard Kentico CMS web parts, but have most of their properties pre-configured so
that the required configuration is limited to the minimum. In any case, you can always modify the
configuration of the widgets in Site Manager -> Development -> Widgets. Some of the widgets have
their properties configured depending on the default alias paths of certain documents in the content tree.
For more information on this topic, please refer to Customizing the portal -> Modifying structure of the
website.

All intranet widgets are stored in the Intranet Portal widget category. Other widget categories are also
available, but the widgets in them are meant for general use and it may be necessary to pre-configure
the properties of these widgets according to the document structure of the portal website. Each of the
widgets can be used in one of the following scenarios:

User widgets - can be used by live site users on their personalizable pages, typically on the My
Dashboard page.
Editor widgets - can be used by website editors on the Page tab in CMS Desk, typically on the
Home page of the global portal or of individual departments.
Workgroup widgets - can be used by workgroup administrators, typically on each workgroup's Home
page.

The following paragraphs describe widgets in each of these three categories.

User widgets

General widgets

The following widgets are available in the root of the Intranet Portal category:

My blogs - based on the Repeater web part, displays all blogs belonging to the current user.
My blogs comments - based on the Blog comments viewer web part, displays blog comments
from all blogs belonging to the current user.
My workgroups - based on the Groups viewer web part, displays all workgroups to which the
current user belongs.

Project management widgets

The following widgets are available in the Intranet Portal/Project management sub-category:

My projects - Intranet Portal - based on the My projects web part, displays all projects for which
the current user has access permissions.
Tasks assigned to me - Intranet Portal - based on the Tasks assigned to me web part, displays
all tasks assigned to the current user.
Tasks owned by me - Intranet Portal - based on the Tasks owned by me web part, displays all
tasks owned by the current user.

http://devnet.kentico.com/docs/5_5r2/devguide/widgets_overview.htm
http://devnet.kentico.com/docs/5_5r2/webparts/KenticoCMS_WebParts.htm
http://devnet.kentico.com/docs/5_5r2/intranetusersguide/using_mydashboard.htm
http://devnet.kentico.com/docs/5_5r2/intranetusersguide/using_mydashboard.htm
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Editor widgets

The following widgets are available in the Intranet Portal widget category when adding widgets to pages
on the Page tab in CMS Desk.

General widgets

The following widgets are available in the root of the Intranet Portal category:

Employee of the month - based on the Editable image web part, displays an image selected by a
website editor.
Intranet canteen menu - based on the Static HTML web part, displays a pre-defined text, typically
a weekly canteen menu.
Intranet departments - based on the Repeater web part, displays a list of all existing
departments. 
Intranet employees - based on the Users viewer web part, displays a list of all users of the
system (i.e. company employees).
Intranet latest blog posts - based on the Repeater web part, displays latest blog posts published
in the portal's global section.
Intranet latest forum posts - based on the Forum posts viewer web part, displays latest posts
from the global section's forums.
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Intranet latest news - based on the Repeater web part, displays latest news published in the
portal's global section.
Intranet poll - based on the Poll web part, displays a poll where users can vote to express their
opinion.
Intranet quick links - based on the Static HTML web part, contains customizable links leading to
the most frequently used sub-sections of the portal.
Intranet upcoming events - based on the Repeater web part, displays the latest events scheduled
on the Events page of the global section.

Department widgets

The following widgets are available in the Intranet Portal/Departments sub-category:

Department latest blog posts - based on the Repeater web part, displays latest blog posts
published in the current department's section.
Department latest forum posts - based on the Forum posts viewer web part, displays latest
posts from the current department's forums.
Department latest news - based on the Repeater web part, displays latest news published in the
current department's section.
Department quick links - based on the Static HTML web part, contains customizable links leading
to the Home page of the portal and sub-sections of the current department.
Department upcoming events - based on the Repeater web part, displays the latest events
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scheduled in the current department's calendar.

Workgroup widgets

The following widgets can be found in the Intranet Portal widget category when adding widgets to
workgroup pages:

Workgroup administrators - based on the Group members viewer web part, displays all
administrators of the current workgroup.
Workgroup latest blog posts - based on the Repeater web part, displays latest blog posts
published in the current workgroup's section.
Workgroup latest forum posts - based on the Group forum posts viewer web part, displays
latest forum posts published in the current workgroup's section.
Workgroup latest news - based on the Repeater web part, displays latest news published in the
current workgroup's section.
Workgroup members - based on the Group members viewer web part, displays all members of
the current workgroup.
Workgroup messages - based on the Group message board viewer web part, displays latest
messages from the current workgroup's message board.
Workgroup quick links - based on the Static HTML web part, contains customizable links leading
to the Home page of the portal and sub-sections of the current workgroup.
Workgroup recent pages - based on the Repeater web part, displays the latest wiki pages in the
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current workgroup's section.
Workgroup upcoming events - based on the Repeater web part, displays latest events scheduled
in the current workgroup's calendar.
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11 Microsoft SharePoint integration

Using Microsoft SharePoint, you can collaborate and share files with your colleagues more effectively
and publish your website content more efficiently. Kentico CMS provides integration with SharePoint and
allows you to access data stored on a SharePoint (Windows SharePoint Services 3.0 (WSS) or MOSS -
Microsoft Office SharePoint Server) server and display it on your site. This can be done using the web
parts of the SharePoint module. Please note that the module enables you to get list and list item data
from SharePoint and provide it to Kentico CMS. You can also download documents or images using the
SharePoint module. However, it is not possible to modify SharePoint data or display Kentico CMS data
in SharePoint.

How it works

SharePoint web parts use pre-generated proxy classes of selected SharePoint web services to get data
from the server. The following services are used:

http://server/_vti_bin/Lists.asmx - methods for working with lists 
http://server/_vti_bin/Imaging.asmx - methods for working with picture libraries 
http://server/_vti_bin/Copy.asmx - methods for retrieving file content

The returned data is in CAML (XML) format, which needs to be further processed to display the data in a
meaningful way. XSLT or ASCX transformations may be used for this purpose. For ASCX, the CAML
response must be transformed to an ASP Dataset.

The whole integration functionality is provided by the following web parts from the Microsoft SharePoint
category:

SharePoint data source - this data source web part enables you to retrieve some of the data from
the SharePoint server. It uses web services (Lists.asmx, Imaging.asmx).
SharePoint datagrid - this web part displays a grid with data retrieved from the SharePoint server. It
uses web services (Lists.asmx, Imaging.asmx).
SharePoint datalist - this web part enables you to retrieve and display some of the data from the
SharePoint server. It uses web services (Lists.asmx, Imaging.asmx). The inner datalist control
displays can display the data in multiple rows/columns.
SharePoint repeater - this web part enables you to retrieve and display some of the data from the
SharePoint server. It uses web services (Lists.asmx, Imaging.asmx).

http://devnet.kentico.com/docs/5_5r2/devguide/sharepoint_Web_parts.htm
http://devnet.kentico.com/docs/5_5r2/devguide/sharepoint_Web_parts.htm
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Please note

Detailed information and examples of the use of these web parts can be found in the 
SharePoint integration chapter in the Modules section of the Developer's Guide.

http://devnet.kentico.com/docs/5_5r2/devguide/sharepoint_Web_parts.htm
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