Kentico CMS 5.5 Personal Site Guide
# Table of Contents

**Personal Site Guide** | 4  
--- | ---  
Overview | 4

**Getting Started** | 6  
--- | ---  
Editing content | 6  
Adding a blog post | 9  
Adding a photo gallery | 12  
Adding a forum | 16

**Adjusting Design** | 20  
--- | ---  
Changing the theme | 20  
Editing CSS stylesheets | 25

**Adding web parts** | 31  
--- | ---  
Adding text | 31  
Adding a poll | 35

**Further reading** | 40

© 2010 Kentico Software
1 Personal Site Guide

1.1 Overview

Kentico CMS Personal Site allows you to easily run your own personal website. It comes with several design templates and you can easily change the graphics.

The Personal Site is built with Kentico CMS and it comes with following features out-of-the-box:

- Content editing
- Blogs
- Forums
- Photo Galleries

You can also use other Kentico CMS modules (such as newsletter, polls or forms) as you need.

To learn about other features and capabilities of Kentico CMS, please refer to other Kentico documentation, such as Kentico CMS Tutorial (http://www.kentico.com/devnet/documentation.aspx).

You can contact our technical support at http://www.kentico.com/Support.aspx.
Part II

Getting Started
2  Getting Started

2.1  Editing content

In this chapter, you will learn how to change the About text on your website.

1. Go to CMS Desk -> Content -> Personal Site -> About me.
2. Make sure you are on the Page tab and click into the Main text text box. Erase the text from the text box and enter This is the new About me text. Then click Save at the top-left.
3. Now switch to the **Preview** viewing mode. You can see that the **About me** text has been updated.
2.2 Adding a blog post

In this chapter, you will learn how to add a new post to your blog.


2. Choose Blog post as a new document type.
3. Next, enter information for your new blog post.

- **Post title**: My new blog post
- **Post Summary**: Summary of the blog post.
- **Post text**: The entire text of the blog post.

Then click **Save** at the top.
Your new blog post has been added to My Blog.
2.3 Adding a photo gallery

In this chapter, you will learn how to add the new photo gallery and upload some photos.

1. Go to CMS Desk -> Content -> Personal Site -> Photo Gallery and click New in the document action toolbar.

2. Choose Image gallery as a new document type.
3. Enter New gallery into the Name text box and click Browse ... . Choose some Teaser image. Then click Save at the top.

4. Now, go to Properties -> Template and click Select to choose template to use. Choose Personal Site\Personal Site - Photo Gallery. Click Save at the top.
5. Your new gallery is ready. All you have to do is to add some pictures into your new created gallery. Make sure **New gallery** is selected in the content tree and click **New** in the document action toolbar. Choose **File** as the new document type.

6. Click the **Upload file** icon and choose a picture to upload.

   Then enter *The description of the first picture.* into the **File description** text box and click **Save** at the top.
Congratulations, you've just learned how to create a new gallery and add some pictures into it.

Please note that you can take advantage of the File Import module to upload more images and files. The File Import module can be found at CMS Desk -> Tools -> File import.
2.4 Adding a forum

In this chapter you will learn how to create a new forum, create new thread and post a message.

1. Go to CMS Desk -> Tools -> Forums and click Edit next to the My Forums group.

2. In the Forum group properties, click Add forum.
3. Add the following information for the new forum:

- **Forum display name**: New forum
- **Forum code name**: newForum
- **Description**: The description of the new forum.

Then click **OK**.
4. The forum has been added as you can see in the following screenshot.
Part III

Adjusting Design
3 Adjusting Design

3.1 Changing the theme

The sample Personal Site comes with several predefined CSS stylesheets. In this chapter, you will learn which stylesheets are available and how you can choose the CSS stylesheet you want to use on your website.

To choose the CSS stylesheet for your website, go to CMS Site Manager -> Sites and click Edit site next to the Personal Site.

In the Site Properties, choose your CSS stylesheet from the Site CSS stylesheet drop-down list.
The following CSS stylesheets are available in the sample **Personal Site**:

**Personal Site**

![Personal Site Screenshot]

**Tags**
- airport
- Austria
- bus
- cuisine
- Czech Republic
- France
- Germany
- hitchhiking
- hostel
- Italy
- luggage
- raclette
- Slovakia
- Swiss
- subway
- tourism
- traffic
- train

**Recent posts**
- Saying goodbye Europe
- We need insurance
- Disappointment in Prague
- Sweetness of loneliness
- Sachertorte and Austrian capital

**Syndication**
Personal Site - Blue

Personal starter site

"Illusion is the first of all pleasures." - Oscar Wilde.

Tags
- airport
- Austria
- bus
- cuisine
- Czech Republic
- France
- Germany
- hitchhiking
- hostel
- Italy
- baggage
- sauerkraut
- Slovenia
- Spain
- subway
- tourism
- traffic
- tram

Recent posts
- Saying goodbye Europe
- Wir sind Berliners
- Disappointment in Prague
- Sweetness of loneliness
- Saucers torte and Austrian capital

Syndication

Saying goodbye Europe

Paris, our final destination. Because there’s no upcoming hitchhiking trip, the tension between P3 and me is all gone. I have a friend here, so the last night we spend in his place, drinking wine and using his computer to look at pictures we’ve taken during our month in Europe.

Today, P3 went to do some shopping and we’ve promised each other go out have dinner tonight.

Posted: 7/5/2008 1:56:04 PM by Abigail Woodworth | 6 comments

Wir sind Berliners

Berlin, after a long time the city we both wanted to see. And as we’re almost done with our trip, we’re getting much more relaxed in
Personal Site - Green

Personal starter site

"Illusion is the first of all pleasures." - Oscar Wilde

Tags
- airport
- Austria
- bus
- cuisine
- Czech Republic
- France
- Germany
- hitchhiking
- Hostel
- Italy
- luggage
- sachertorte
- Slovenia
- Spain
- subway
- tourism
- Traffic
- train

Recent posts
- Saying goodbye Europe
- Wir sind Berliners
- Disappointment in Prague
- Sweetness of loneliness
- Sachertorte and Austrian capital

Saying goodbye Europe

Paris, our final destination. Because there's no upcoming hitchhiking trip, the tension between PJ and me is all gone. I have a friend here, so the last night we spend in his place, drinking wine and using his computer to look at pictures we've taken during our month in Europe.

Today, PJ went to do some shopping and we've promised each other go out have dinner tonight.

Posted: 7/8/2008 1:56:09 PM by Abigail Woodworth | with 3 comments

Wir sind Berliners

Berlin, after a long time the city we both wanted to see. And as we're almost done with our trip, we're getting much more relaxed in...
Personal starter site

"Illusion is the first of all pleasures." - Oscar Wilde.

Saying goodbye Europe

Paris, our final destination. Because there’s no upcoming hitchhiking trip, the tension between PJ and me is all gone. I have a friend here, so the last night we spend in his place, drinking wine and using his computer to look at pictures we’ve taken during our month in Europe.

Today, PJ went to do some shopping and we’ve promised each other go out have dinner tonight.

Post date: 7/7/2008 1:56:01 PM by Abigail Woodworth | +3 comments

We sind Berliners

Berlin, after a long time the city we both wanted to see. And as we’re almost done with our trip, we’re getting much more relaxed in
3.2 Editing CSS stylesheets

In this chapter, you will learn how to change the design of your website by modifying the CSS stylesheets.

Changing the header picture

1. Go to CMS Site Manager -> Development -> CSS stylesheets, click Edit next to Personal Site and choose Main styles -> Master page section in the text box on the left side.

2. In the .zoneTop style, change the url of the background image to ../App_Themes/PersonalSiteGreen/Images/bg_head.jpg so that the entire style reads as follows:

```css
.zoneTop
{
  height: 239px;
  width: 795px;
  background-color: #fff;
  padding: 0px 0px 7px;
  margin: 0px 0px 0px;
  background: #fff url(../App_Themes/PersonalSiteGreen/Images/bg_head.jpg) no-repeat top left;
}
```

Then click Save at the top-left.
3. Now click **Sign out** at the top-right. You can see that the header image has been changed.
Changing the top menu

1. Go to CMS Site Manager -> Development -> CSS stylesheets and choose Main styles/Master page section in the text box on the left side.

2. Scroll down to see .zoneTopMenu style.

3. Change the background color to #B0C4DE and erase the URL part so that the entire section reads as follows:

   ```
   .zoneTopMenu
   {
     height: 43px;
     width: 795px;
     background: #B0C4DE;
     padding: 0px;
     margin: 0px;
   }
   ```

This will change the background of the navigation at the top to dark blue.
4. Now, switch to the **Top menu** section and find `.CMSListMenuLI a:hover` style. This style modifies the appearance of menu item when mouse is over it.

```
.CSSListMenuLI a:hover, .CMSListMenuLinkHighlighted, .CMSListMenuLIlast a:hover, .CMSListMenuHighlightedLIlast a, .CMSListMenuHighlightedLI a {
    color: #fff;
    background: #87CEFA;
    text-decoration: none;
}
```

This will change the background of the menu item to light blue and its font color to white when mouse hovers above it.

5. Change **color** to `#fff` and replace the url part with `#87CEFA`. The entire style should read as follows:

```
.CMSListMenuLI a:hover, .CMSListMenuLinkHighlighted, .CMSListMenuLIlast a:hover, .CMSListMenuHighlightedLIlast a, .CMSListMenuHighlightedLI a {
    color: #fff;
    background: #87CEFA;
    text-decoration: none;
}
```

Check out the stylesheet to file `c:\InpPath\var\root\ Mamato\CHS\CSS\Stylesheets\PersonalSite.css` to edit the stylesheet externally.
You've just learnt how modify CSS stylesheets to change design of your website.
Part IV

Adding web parts
4 Adding web parts

4.1 Adding text

In this chapter, you will learn how to add the new editable text region into your website.

1. Go to CMS Desk -> Content -> About Me and switch to the Design tab. Click Add web part in zoneRight.
2. Select **Text/EditableText** web part.

3. In the **Web part properties** dialog, enter the following information for the new web part.

   - **Editable region title**: AboutWebPageTitle
   - **Content before**: `<h1>`
   - **Content after**: `</h1>`

   Then click **OK**.

4. Click **Add web part** again and select the same **Text/EditableText** web part.

5. In the **Web part properties** dialog, enter **AboutWebPageText** into the **Editable region title** textbox. Then click **OK**.

6. Now you have the new web parts ready and you can enter some new text. Switch to the **Page** tab and click into the **AboutWebPageTitle** editable region. Enter **About my web page**. Click **Save** at the top.
7. Click into the **AboutWebPage** editable region and enter *This is a short text about my web page.* Click **Save** again.
That is how you add a new editable region into your website.
4.2 Adding a poll

In this chapter, you will learn how to create a new poll and add it to your web page.

1. First of all we need to create a new poll. Go to CMS Desk -> Tools -> Polls and click New poll.

2. Enter the following information for the new poll.

   - **Display name**: My poll
   - **Code name**: MyPoll
   - **Question**: How do you like my pictures?

   Then click OK.

3. Now we need to defined some questions for your new poll. In the poll properties, switch to Answers tab and click New answer. Into the Text text box, enter I love them! and click OK.
4. Click **New answer** again and enter *Not bad.* as **Text**. The **Enabled** check box should be checked. Then click **OK**.

5. Click **New answer** again and enter *Waste of time!* into the text box provided. Click **OK**.

6. Now we are ready to add your new poll to website. Go to **CMS Desk -> Content -> Personal Site -> Photo Gallery** and switch to the **Design** tab. Click **Add web part in zoneLeft**.
7. In the **Select web part** dialog, select **Polls\Poll** web part.
8. In the Web part properties dialog, make sure My poll is selected as Poll name and click OK.

Congratulations, you've just learned how to add a new poll to your website.
Part V

Further reading
5 Further reading

This guide has provided you only with a short introduction to some of the aspects of the Kentico CMS. For more detailed information about Kentico CMS please consult the following resources:

- Kentico CMS Tutorial
- Kentico CMS Developer's Guide

Should you need any further assistance, please do not hesitate to contact us at http://www.kentico.com/Support.aspx.
Index

- A -
  Adding a blog post  9
  Adding a forum     16
  Adding a photo gallery  12
  Adding a poll       35
  Adding text        31

- C -
  Changing the theme  20

- E -
  Editing content     6
  Editing CSS stylesheets  25

- F -
  Further reading     40

- O -
  Overview           4

- S -
  Support            4, 40

- T -
  Technical support   4, 40