Table of Contents

Part I  Introduction  .................................................. 4
  1 Kentico CMS overview ............................................. 4
  2 Signing in ................................................................... 5
  3 User interface overview ............................................. 7

Part II  Managing my profile ........................................... 8
  1 Changing my e-mail and preferred language ....................... 8
  2 Changing my password ................................................ 9

Part III  Getting started .................................................. 10
  1 Creating a new web page ............................................. 10
  2 Editing page content .................................................. 13

Part IV  Using the editor .................................................. 14
  1 Using What You See Is What You Get editor ...................... 14
  2 Text formatting ....................................................... 15
  3 Inserting images ....................................................... 16
  4 Creating links ........................................................ 19
  5 Inserting a table ....................................................... 20

Part V  Editing structured documents ................................ 21
  1 Creating a news item .................................................. 21
  2 Editing a news item ................................................... 23

Part VI  Deleting, moving and sorting documents .................... 25
  1 Deleting and restoring a document ................................ 25
  2 Changing document order .......................................... 27
  3 Moving documents to another section .............................. 27
4 Copying a document ........................................................................................................................... 28

Part VII Translating documents ........................................................................................................... 30

Part VIII Workflow and versioning ....................................................................................................... 32
  1 Publishing document .......................................................................................................................... 32
  2 Archiving a document ......................................................................................................................... 33
  3 Versioning and rollback ..................................................................................................................... 34

Part IX Security ..................................................................................................................................... 37
  1 Granting permission to edit a document ............................................................................................. 37

Part X Newsletters .................................................................................................................................. 40
  1 Creating a newsletter issue ................................................................................................................ 40

Part XI Bizforms ..................................................................................................................................... 43
  1 Creating and publishing a new on-line form ..................................................................................... 43

Part XII E-commerce ............................................................................................................................. 48
  1 Creating a new product .................................................................................................................... 48
  2 Changing order status ....................................................................................................................... 51

Part XIII File import .............................................................................................................................. 58
  1 Bulk import of files ........................................................................................................................ 58

Part XIV Polls ......................................................................................................................................... 62
  1 Creating and publishing a new poll .................................................................................................. 62

Part XV Forums ....................................................................................................................................... 65
  1 Creating a new forum ....................................................................................................................... 65
  2 Moderating forum posts .................................................................................................................... 70
Please note: In Kentico CMS user’s guide, we demonstrate the capabilities of the Kentico CMS on the example of the sample Corporate Site. Your particular web site application may vary.

1 Introduction

1.1 Kentico CMS overview

Kentico CMS for ASP.NET is a piece of software that allows a person without any programming knowledge to create a powerful dynamic website.

By using Kentico CMS, you will be able to manage and edit the content of your website in a quick, efficient and professional manner.
1.2 Signing in

1. Open your favorite web browser and go to your web site.

2. At the very top of your web site, click **Sign in to CMS Desk**. This link is only available on the sample Corporate Site. On your own web site, you will need to go to [http://<your web site>/cmsdesk – e.g.: http://www.mydomain.com/cmsdesk](http://www.mydomain.com/cmsdesk).
3. In the following interface, type in your user name and password and click Log on.

![CMS Logon Interface]

Congratulations, you’ve just log on to the CMS Desk for the first time.
1.3 User interface overview

The user interface of Kentico CMS consists of several sections. You will see that each of these sections has its specific functionality and its logical relation to the others. As a whole, the sections form and graphical interface that is easy to use and quick to navigate through.

The main sections are:

- **Main menu** where you can switch between the Content, My Desk, Tools and Administration sections. You will be using only the Content tab most of the time.
- **Document actions** toolbar where you can create, delete, edit, copy, move or sort documents.
- **View mode** selection that allows you to choose between editing, preview, live view and list view depending on whether you want to edit content of your web site or just see how it looks in a browser.
- **Content tree** that displays the structure of your web site and allows you to organize documents/pages in it.
- **Page editing mode** where you can choose the way you want to edit the content of the page. You can choose from editing a content of your page, editing document fields and product or document properties. If you're an administrator, you can also design the page template.
- **Editing/viewing space** where the page chosen in the content tree is displayed in the mode that has been selected in the view and page editing toolbar.

2  Managing my profile

2.1 Changing my e-mail and preferred language

Now you will learn how to change your e-mail and preferred language.

1. In the main menu, switch to the My Desk tab and choose My profile in the content tree.

2. Place the cursor into the My e-mail text box and type in your e-mail address. Then click the Preferred content culture drop-down list and choose the preferred culture.

That's how you change your e-mail address and your preferred language.
2.2 Changing my password

Now you will learn how to change your password for logging in to the CMS Desk.

1. Go to My Desk -> Change password.

2. Into the Old password textbox, enter your old password. (Leave blank if you don’t have to use password for signing in to the CMS Desk). Then type in your new password to the New password textbox and re-type it again to the Confirm new password textbox. Click Ok.

That's how you change your password for the access to the CMS Desk.
3 Getting started

3.1 Creating a new web page

Let’s start from the beginning, therefore, with creating a new webpage.

1. Firstly you have to choose in the Content tree where you want your new page to be located in the structure of your website.

2. Click on the existing document. The new page will be appended to the document you’ve just clicked on. Click the New button in the document action toolbar.
On the right side in the editing/viewing space, you should see the types of documents you are allowed to create in the chosen location.

New document

Please select new document type:

- Article
- Blog
- Cell phone
- Event
- Event (booking system)
- FAQ
- File
- Folder
- Job opening
- Knowledge base article
- Landing
- News
- Offer
- Page (menu item)
- Press
- Press release
- Product
- Simple article

Link an existing document
3. Click the **Page (menu item)** option. In the following step, please enter the name of your new web page: *System integration*. Choose to use a page template and select the template **Templates with editable regions/Header and text with left menu**. If you’re an administrator, you can also choose to create a blank page and create it from scratch. Click **Save**.

Now you can see your **System integration** page added to the content tree under the already existing page.

Congratulations, you’ve just created your first web page. In the next chapter, we will add some content to it.
3.2 Editing page content

Now we will edit the content of the newly created page.

Click on the **System integration** page in the content tree on the left side. On the right side in the **Editing/viewing space**, you can see its content. As we have used the template with two editable regions – header text and content text, we are now able to enter some information into these regions.

Please make sure that the **Page** tab in the page editing mode toolbar is selected. Only then, you will be able to edit content in the editable regions of your page.

1. Place the cursor into the **Header text** box and type in **System integration**.
2. Then enter *We provide system integration services* in the **Content text** box.

3. Click the **Save** at the top-left and switch to the **Live site** mode in the page editing mode toolbar. You should see the System integration page with updated content.

You’ve just entered your first content to your web page.

4 **Using the editor**

4.1 **Using What You See Is What You Get editor**

In Kentico CMS, you can use the WYSIWYG (What You See Is What You Get) editor to create web content without HTML knowledge. Its functions are similar to Microsoft Word.
Open your System integration page and choose the Edit mode and click the Page tab so that you could enter content into the editable regions. The WYSIWYG editor toolbar should be visible.

4.2 Text formatting

Now let's take a look at how you can change formatting of your text content.

1. Highlight the part of your text you want to change (i.e. System integration).

2. Now click on Italic sign in the WYSIWYG editor. The highlighted text should change.
3. Then highlight another part of the text and change its size by clicking the **Size** drop-down menu and click the **Medium**.

4. Now click the **Save** button at the top.

5. Switch to the **Live site** viewing mode. You should see your text with changed formatting.

That’s how you change formatting of your text.

4.3 Inserting images

Very often, you will want to have some pictures on your web site. Even for this task, you can use the WYSIWYG editor.

1. Choose the page to which you want to insert a picture. Switch in the editing mode and click the **Insert/Edit Image** icon in the WYSIWYG editor.

2. The Image properties dialog appears. Here you can either type in URL of the picture you want to use if you know it or you can browse the uploaded files. Click the **Browser Server** button.
3. The web page dialog should appear with the content tree on the left side. Click the **Images** folder. On the right side, you should see the images already uploaded on the server.

4. You can choose to use one of these or you can upload picture from your computer. Click **Upload Image** at the top to upload a new image on the server.

5. In the new dialog click the **Browse...** button, find a picture on your computer and click **Save**.
6. You will see a preview of the uploaded image. Click **Paste Image**.

![Image preview](image)

7. In the **Image properties** dialog, you can choose the width and height of the picture, its border, vertical and horizontal spacing and alignment. Do not change anything for now and just click **OK**.

![Image properties dialog](image)

8. You should see the picture being pasted in the text. Click **Save**. Click the **Live site** button to see the result of your efforts.

In a similar manner, you can upload flash movies to your website.
4.4 Creating links

Now you will learn how to add links to your web content.

1. In the **Page editing** mode, highlight the text you want to link to some part of your website.

   ![Content Text](image1)

   This is a single page with left menu and content on the right. You can create links similar to those above using the Insert/Edit Link button in the editor toolbar.

2. Click the **Insert/Edit Link** button in the **WYSIWYG editor** toolbar.

   ![WYSIWYG Editor Toolbar](image2)

3. A new web page dialog opens. Make sure there is the **URL** option selected in the **Link Type** drop-down menu and click **Browser Server**.

   ![Link Dialog](image3)
4. All you have to do now is to choose the target page and click **OK**.

![Select document dialog](image1)

5. Click OK again to close the dialog. Click Save and switch to the Live Site mode. Click the newly created link. You should be redirected to the page chosen in the previous step.

### 4.5 Inserting a table

Now you will learn how to add a table to your web site.

1. Click the **Insert/edit table** icon in the WYSIWYG editor.

![Insert/edit table icon](image2)

2. In the **Table properties** dialog, change the number rows to 4 and the number of columns to 5. Then enter **My table** into the **Caption** field and click **OK**.

![Table Properties dialog](image3)

Your table has been added to the web content.
5 Editing structured documents

Unlike pages with editable regions, structured documents have specific fields that you need to fill in. For example, the news have fields like News title, Release date, News summary and News text. These fields can be edited on the Form tab rather than on the Page tab.

5.1 Creating a news item

Now you will learn how to create a news item and add it to the news section.

Please note: Your news item must be added to the section that can show them. In the sample Corporate Site, it is the News page but it may be some other page on your site. Please contact your administrator.

1. In the content tree, click the News page and click the New button in the document action toolbar.

![Document action toolbar](image)
2. Choose the **News** document type.

![New document](image)

Please select new document type:

- Article
- Blog
- Call phone
- Event
- Event (booking system)
- FAQ
- File
- Folder
- Job opening
- Knowledge base article
- Laptop
- News
- Office
- Page (menu item)
- FAQ
- Press release
- Product
- Simple article

![Link an existing document](image)

3. Now enter the title of your news: *My first news*. Then click the **Now** button to fill in the **Release date** value. In the **News summary** enter: *My first news summary*. In the **News text** enter: *My first news text* and skip the remaining fields.
4. Now click **Save and create another**.

5. Enter the title of your news: *My second news*. Then click the **Now** button to fill in the **Release date** value. In the **News summary** enter: *My second news summary*. In the **News text** enter: *My second news text* and skip the remaining fields. Click **Save**.

6. Now click on the **News** page in the content tree and switch to the **Live Site** mode. You can see your two news items added to the news page.

Congratulations, you have just learned how to add a news item.

### 5.2 Editing a news item

Now you will learn how to edit the content of the news item you have just created.

1. Click **My First news** in the content tree and choose the **Form** tab.
2. Change the **News Summary** text to *My first news updated summary*. Then change the **News Text** to *My first news updated text* and click **Save**.

3. Switch to the **Live site** to see your updated news.
6 Deleting, moving and sorting documents

6.1 Deleting and restoring a document

Now you will learn how to delete a document and how to restore it later on.

1. Click the My second news item in the content tree. Click the Delete button in the document action toolbar.

2. Make sure that the Destroy document and its history checkbox is NOT checked and click Yes. (You may not see the Destroy document option if you do not have sufficient permissions.)
3. Now click the **My desk** tab at the main menu.

4. In the content tree on the left side, find **My recycle bin**. Click it and you will see all the deleted documents on the right side.
5. Find the one you have just deleted and click **Restore**.

![Image of deleted document](image)

6. Now you can switch back to the **Content** tab and you will see the restored **My second news** added back to the default location.

Congratulations, you've just learned how to delete and restore a document.

### 6.2 Changing document order

Now you will learn how to change the order of a document in the content tree.

1. Click the page you want to relocate (e.g. the Services page in the Corporate Site) in the content tree and click the **Down** button in the document action toolbar. You'll see that your page has been moved.

2. Now switch to the **Live site** view mode and you will see that your page has been moved in the main menu as well.

### 6.3 Moving documents to another section

Now, it's important to realize that the **Up** and **Down** buttons in the document action toolbar can be used only to move documents in a one level of the content tree. To move documents to any location in the structure of web site you can use the **Move** button.

1. Click the page you want to move in the content tree (e.g. the Services page). Then click the **Move** button in the document action toolbar.
2. In the web dialog, click on the document where you want to move your page (e.g. the Company section) and then click **Move document** button at the bottom.

Your page has been moved to the chosen location.

### 6.4 Copying a document

Now you will learn how to copy a document from one place to another.

1. Click on the document you want to copy (e.g. the News page) in the content tree and click the **Copy** button in the document action toolbar.
2. In the web dialog click on the location where you want to copy your document (e.g. the Company section). Then click the **Copy document** button at the bottom.

You have just learned how to copy a document.
7 Translating documents

You might want to have your website in multiple languages so that your website would be useful for many visitors with different cultural backgrounds.

Please note: For this part of the guide, your website has to be configured for multiple language versions. You should see the language option drop-down menu in the view mode toolbar. If you cannot see it, please contact your administrator to configure multilingual support for you.

1. Make sure you are in the editing mode and choose from the Language drop-down menu the language to which you want to translate your documents.

2. In the content tree, click one of documents with a little cross next to it. The cross icon indicates the document hasn’t been translated yet.
3. You will be displayed with dialog for creating a translated version of the document. In the following option, choose the **Copy content from another language** option and select from which language version you want your document to be copied. Then click the **Create document** button.

![New culture version (fr-FR)](image)

The document does not exist in current culture. You can create a new culture version of the document.

- [ ] Create empty document
- [x] Copy content from another language

![Create document](image)

4. In the **Document name** field enter the translated title of your page. Click **Save**.

![Save](image)

5. Now you can switch to the **Page** editing mode and start translating the content of your page.

Congratulations, you have just learned how to translate a document to another language.
8 Workflow and versioning

Please note: for the Workflow tutorial, we assume that your website has been configured for workflow. For more information please contact your administrator or consult the Kentico CMS Developer’s guide.

8.1 Publishing document

Please note: for this part of the user’s guide, we use an example with three default workflow steps – edit, publish, archive. Your web site might use different workflow steps. However, the procedure will be the same.

1. In the content tree on the left side, choose the document you want to edit. At the top of the editing/viewing space, there is a bar indicating your current Workflow step: Edit.

2. Edit the content of your page and click Save.

3. Now switch to the Preview viewing mode. You can see your page updated. However, you won’t see your changes in the Live site viewing mode so far because your updated page has not been published yet and it’s still in the Edit workflow step.
4. Click the **Publish** icon.

5. Now switch to the **Live site**. Your edited page has been published and is now visible on your real web site.

That’s how you get your document through the workflow steps to be published.

### 8.2 Archiving a document

You can use the Kentico CMS to archive a document from your web site. It won’t be visible to visitors but it will be stored in a database ready to be posted again any time you need.

1. In the content tree, click on the document you want to archive and choose the **Edit** viewing mode. Click the **Properties** tab.
2. In the vertical menu on the left, switch to the **Workflow** tab.

3. Now click the **Archive** button.

That’s how your document is withdrawn from the web site and stored in the archive.

### 8.3 Versioning and rollback

**Please note:** Versioning and rollback work only for documents that use workflow.

You may want to list through previous versions of your document and choose one of the older versions to be published on the web site. For that you can use Kentico CMS versioning and rollback.
1. In the content tree, click on the document you want to change. Make sure you are in the Edit viewing mode and go to the Properties -> Versions.

2. On the right side, you can see the list of versions of the document.

3. Choose the version you want to publish and click the Rollback version button.

4. Click OK to return to the selected version of the document.

5. Now switch to the Workflow tab in the vertical menu. You will see that the restored version of the document is in the workflow step Edit. You need to publish it again to be visible on the live site.

<table>
<thead>
<tr>
<th>Workflow steps</th>
<th>Order</th>
<th>Step name</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>1</td>
<td>Edit</td>
</tr>
<tr>
<td></td>
<td>3</td>
<td>Published</td>
</tr>
<tr>
<td></td>
<td>4</td>
<td>Archived</td>
</tr>
</tbody>
</table>

6. Switch to the Page editing mode and click Publish.
7. Now switch to the **Live site** viewing mode.

Congratulations, you have successfully rolled back to the older version of your document and you have published it on your web site.
9 Security

9.1 Granting permission to edit a document

Please note: For this part of the tutorial, you have to be a user with the access rights for granting permissions to other users.

For more information about security in Kentico CMS please consult the Developer's Guide.

1. In the content tree, choose the document to change its security settings.

2. Make sure you are in the Edit viewing mode and go to Properties -> Security.
3. Click **Add**.

![Add User or Role web dialog](image)

4. In the **Add User or Role** web dialog, click on the C letter and choose **CMS Editor**. Then, click **OK**.

![Add User or Role web dialog](image)

5. The role CMS Editors has been added to the list. Now click the **Allow** checkboxes in the **Read**, **Modify** and **Create** line. Then click **OK**.

![Add User or Role web dialog](image)
Congratulations, you’ve just granted the **CMS editors** role with the editing rights for the given document.
10 Newsletters

You might want to send your customers e-mail newsletters to inform them about your new products. In Kentico CMS, you can create your e-mail newsletters in a manner of minutes.

10.1 Creating a newsletter issue

1. At the main menu, switch to the Tools tab, choose Newsletter in the content tree and click Edit next to the existing newsletter (e.g. Corporate Newsletter).
2. In the **Issues** tab, click **Create new issue**. A new issue wizard appears. It will guide you step by step through the process of creating the new issue.

3. In the first step of the wizard, enter *My newsletter issue* into the **Subject** textbox. Check the **Show in newsletter archive** checkbox and enter *The content of my newsletter issue* into the **Content** textbox (Please note that for editing the content of the issue, you can use the WYSIWYG editor). Then click **Save** button at the bottom. You might need to scroll down a little bit to see it.

4. The issue has been saved. Now click the **Next** button at the bottom next to the **Save** button.
5. In the step 2, click **Next** again.

6. In the step 3, make sure the **Send now** option is chosen and click **Finish** at the bottom.

Your new newsletter issue has been send to the subscribers.

Please note that sending of e-mails with a new newsletter issue may take some time. Switch to the **E-mail queue** tab to check the status of your e-mails.
11 Bizforms

11.1 Creating and publishing a new on-line form

1. Go to Tools -> BizForms.
2. Enter:

- **Form display name:** Send us a message
- **Form code name:** SendMessage
- **Table name:** Messages

Then click **Ok**.

3. Switch to the **Fields** tab and click **New attribute**.
4. Enter following information:
   - **Column name**: FirstName
   - **Field caption**: Enter your first name
   - **Maximum length**: 15

   Click Ok.

5. Click new attribute and enter:
   - **Column name**: LastName
   - **Field caption**: Enter your last name
   - **Maximum length**: 20

   Then click Ok.

6. Now click New attribute again to add another column. Enter:
   - **Column name**: Email
   - **Field caption**: Enter your e-mail address
   - **Maximum length**: 40

   Click Ok.
7. Click **New attribute** again to add the last column. Enter:
   - **Column name**: Text
   - **Field caption**: Enter your message
   - **Maximum length**: 1000
   Click **Ok**.

8. Your form is ready to be published on your website. At the main menu, switch to the **Content** tab and choose the **System integration** page in the content tree.

9. In the **Page** editing mode, place the cursor inside the **ContentText** textbox and click the **Insert BizForm** button in the WYSIWYG editor.

10. In the web dialog, click the newly created **Send us a message** form.
11. Now, click **Save** and switch to the **Preview** mode. You can see that your form has been added to the **System Integration** page.

After the form is submit, you can find the form data at **CMS Desk/Tools/BizForms/<edit your form>/Data**. You can set e-mail notification as well at **CMS Desk/Tools/BizForms/<edit your form>/Notification e-mail**.

Congratulations, you’ve just got through the process of creating a brand new form for your website.
12 E-commerce

12.1 Creating a new product

Now you will learn how to create a new product for your e-commerce.

1. In the content tree, choose Products -> PDAs and click New in the document action toolbar.

2. Select the PDA document type.
3. In the **Form** tab, enter:

- **Name**: New PDA
- **Battery**: Li-Ion
- **Display type**: Color
- **Resolution**: 240 × 320
- **RAM (MB)**: 64
- **Processor (MHz)**: 400
- **Operating System**: MS Windows Mobile 5

Then check the **Create a new product** check box and enter **900** as **Price**. Click **Save** at the top. Your has new product has been created.
4. Now go to **Product -> Tax classes**. Here you can apply the chosen tax to the new product. Check the **Sales tax** checkbox and click **Ok** to save the changes again.

5. Switch to the **Volume discounts** tab and click **New volume discount**.

6. Enter 10 in the **Minimum amount** textbox. Choose the **Relative discount** radio button and enter 5 in the **Discount value** textbox (this will add the 5% discount to the product price.). Click **Ok** and close the dialog.

7. In the content tree, choose the **PDAs** page. You can see your new product has been successfully added to your e-commerce website.

Congratulations, you’ve just learned how to create a new product.
12.2 Changing order status

Now you will learn how to change the status of your order.

Firstly you have to make an order to be able to change its status.

1. Open your favorite internet browser, go to the Corporate site and choose Products in the main menu.
2. Click the Add to shopping cart button below Nokia N73.

3. In the Step 1 of the check out process, click the Check out button at the bottom.
4. In the Step 2, choose **Create a new account** and enter following information:

- **First name**: David
- **Last name**: Simons
- **E-mail (user name)**: DavidSimons@gmail.com
- **Password/ Confirm password**: davidsimons

Then click **Next**.
5. In the **Step 3**, enter following information:
   - Name (company or personal): Development Software
   - Address lines: 1020 Blueberry Ln.
   - City: Tucson
   - ZIP: 8574

   Then click **Next**.

6. In the **Step 4**, do not change anything and click **Next**.
7. In the **Step 5**, click **Order now**.
8. You should see the order confirmation text now. Your order has been received. Now sign in to the CMS Desk and go to Tools -> E-commerce -> Orders.

9. Click **Edit** next to the newly created order.
10. In the **General** tab, choose **Payment received** from the **Status** the drop down menu and click **Ok**.

The status of your order has been changed successfully.
13 File import

13.1 Bulk import of files

Now you will learn how to import files and documents to your website.

1. Go to Tools -> File import.

2. On the right side, you should see the files from the folder designated as the source for the file import. If you can’t see any that means there are no files in your file import folder. Please check the path to the file import folder at the top and place the files you want to upload to that folder.
3. Check the **Select** checkbox next to the file you want to import and click **Select Path**.
4. Choose **About us** and click the **Select document** button.
5. Click **Start import**.

Congratulations, you've just imported selected file to your website.
14 Polls

14.1 Creating and publishing a new poll

1. Go to Tools -> Polls.

2. Click New poll.
3. The **Display name**, **Code name** and **Title** textboxes fill with *Shopping*. Into the **Question** textbox, enter the poll question: *Have you ever bought anything from our website?* and click **Ok**.

4. Next, switch to the **Answers** tab and click **New answer**.

5. Enter **Yes** as **Text** and click **Ok**.

6. Then click **New Answer** again. Enter **No** into the **Text** textbox and click **Ok**.

7. Now switch to the **View** tab to make sure that your poll looks the way you want it to.

8. Your poll is ready; all you have to do is to publish it on your website. At the main menu, switch to the **Content** tab and choose the **System Integration** page in the content tree.

9. Place the cursor into the **ContentText** textbox and click the **Insert poll** button in the editor panel.
10. In the webpage dialog, click the **Shopping** poll.

![Insert Poll - Webpage Dialog](image_url)

11. Click **Save** and switch to the **Preview** mode to make sure that your poll displays correctly.

That’s how you create a poll and publish it on your web site.
15 Forums

15.1 Creating a new forum

Please note: for this part of the guide, we assume that the forum group is already created for your web site and it’s published. We also assumed that the users have the right to create forums.

1. Go to Tools -> Forums.

2. Click Edit next to the existing forum group.

3. Now click the Add forum button.
4. Into the **Forum display name** and **Forum code name** textboxes enter *My new forum* and *MyNewForum* respectively. Click **Ok**.
5. You’ve just created your new forum. Now you’ll learn how to post a new thread. Click **Sign out** at the top-right.
6. You are redirected to the **Home** page of the **Corporate site**. Click **Forums** at the main menu.

7. In the **Site forums** section, click **My new forum**.

**Forums**

You can set up any number of forum groups and each forum group may have multiple forums on particular topic. The forums are organized into threads. You can also use the Forums module for article comments if you use so called "ad-hoc" forums that are bound to some particular document (article, product, etc.).
8. Click the **new thread** button.

![New thread button](image)

9. Enter following information:

- **User name**: Administrator
- **E-mail**: admin@gmail.com
- **Subject**: Welcome
- **Post**: Welcome to our new forum.

Click **Ok**.
Congratulations, you’ve just created a new forum and posted the very first thread.

15.2 Moderating forum posts

Now you will learn how to create a moderate forum so that every post has to be approved before being published.

1. Go to Tools -> Forums.
2. Click Edit next to the existing forum group.
3. Now click the Add forum button.
4. Into the **Forum display name**, enter *My moderated forum*. Into the **Forum code name**, enter *MyModeratedForum*. Check the **Forum is moderated** checkbox. Then click **Ok**.

5. Now, enter your user name and your e-mail address to the **User name** and the **E-mail** checkboxes. Next, enter *Welcome* as the **Subject** and to the **Post** textbox enter *Come try our new moderated forum*. Click **Ok**.
6. The thread has been posted, however, to be visible in the forum, it has to be approved by the designated moderator. Click the **Approve** button.

![Forum post]

**Welcome**

Come try our new moderated forum.

Congratulations, you've just approved your new thread and it's visible on your web site.