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1 Introduction

1.1 About this guide

Welcome to Kentico CMS Community Guide. This guide will provide you assistance with building on-
line communities using Kentico CMS. 

Kentico CMS comes with the sample Community Starter site. This sample web site template can be
conveniently used as a starting point of your own community site development. In the first part of this
guide, we will go through the various customization tasks that need to be done if you want to develop
your community site based on this template. The second part will describe building community sites
from scratch.
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1.2 Community features

Community sites are such web sites that bring the possibility of on-line interconnection of people,
usually those who share the same interests or who are members of some real-world group and have
the need to meet on-line. For the purposes of the community, such site should provide the possibility of
gathering in groups, discussing in forums, blogging, advanced membership with the possibility of
friendship between users, customized user profiles, various sign-in possibilities, etc. 

Kentico CMS is a full-featured solution for building complex community sites without any complex
programming. Here is a list of the most important built-in community features of Kentico CMS:

· Community Groups

· Forums 

· Blogs

· User profiles

· Badges

· Friends

· Bad words

· Abuse report

· Polls

· Content rating

· Time zones

All the implementation processes have been diminished to only a few clicks, so that you can use most
of the features out-of-the-box.
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2 Part 1

2.1 Getting started

2.1.1 Installing the site

To get started, you need to have the sample Community Site installed. There are two ways how this
can be achieved:

1. If you are performing a new installation, you can choose the site in Step 4 of the Database Setup.
Select the Choose starter site radio-button and choose the Community Site from the list of starter
sites. Click Next to finish the setup procedure.

2. If you already have Kentico CMS installed, but without the Community Site, you can easily add the
site in Site Manager -> Sites.

a) Click the New site wizard link at the top left corner of the page.
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b) In Step 1, choose Use web site template and click Next.

c) In Step 2, choose Community Site form the list of available web site templates and click Next.
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d) In Step 3, specify the display name, code name and domain name of your site and click Next.
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e) In Step 4, leave the settings at their default values and click Next.

f) Wait until the end of site import process and click Next.



Part 1 13

© 2006 Kentico Software

g) In the last step, you can click the Edit your new web site link to go to CMS Desk, where you can
start editing the site immediately.

You can also click the Finish button to go back to Site Manager -> Sites, where the site should be
listed with the name specified in Step 3.
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2.1.2 First sight

When you have the Community Site installed and running, why not go to the live site and see it in
action. To see all the features working, sign in using the Sign in form at the top of the right side
column. Use e.g. user name David with blank password. Once signed-in, you should see the site as in
the screenshot below:

1. At the very top of the page, you can see the CMS Desk and CMS Site Manager links. These can
be used to access the administration interface from the live site. Default user name is administrator
with blank password. Alternatively, the administration interface can be accessed via the following
URLs: <site domain>/CMSDesk or <site domain>/CMSSiteManager.

2. Links to the current user's public profile, profile editing, internal messaging inbox and the Sign
out link that can be used to log off the site.

3. Main menu. The menu reflects site structure, particular items in the menu lead to the following
sections:

· Home - home page of the web site, displaying latest blog and forum posts in the main area and
various other information in the side column

· Blogs - in this section, you can read blog posts in site users' blogs or easily create your own blog
right on the live site and start blogging immediately

· News - the news section is designed for displaying news items created by authorized CMS Desk
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users, typically site administrators and editors
· Media - in this section, you can view content of the site's public media libraries; various types of files

can be stored in these libraries, while large file sizes (several GB) are supported
· Forums - discussion forums, you can read or join discussions on various topics and create new

topics; both classical and Q-A forum types are supported
· Groups - in this section, you can view existing community groups and join some of them or even

create your own new group; groups can have their own media libraries, forums, polls and message
boards

· Members - this is where you can see a complete list of site members; by right clicking their avatars,
you can display a context menu allowing you to do several actions related to the clicked user; by left-
clicking a user's avatar, you can view her public profile

· Examples - in this section, you can find isolated examples of particular community web parts; these
examples are particularly useful when you access them from CMS Desk, where you can view web
part properties settings

4. This is the main zone where the content is displayed. On the Home page, it displays the Sign-in/
Join banner and extracts from the latest blog and forum posts.

5. Integrated full-text search of all documents on the site.

6. The shortcuts box displays shortcuts to various community functions. It offers different actions
depending on which section of the site is currently displayed.

7. The rest of the side column displays various repeaters and information boxes depending on which
section of the site is currently displayed.
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2.2 User registration and Sign-in

2.2.1 Current functionality

In the following example, you will learn how to register to the site and become its member.

1. If you come to the site as a site visitor and want to register, there are several links to click. All of the
links highlighted in the screenshot below will take you to the Logon page where registration can be
performed. Click one of them.

2. On the logon page, site visitors can register by filling in the Join the community form. Enter some
sample details and click Register.
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3. You will be redirected to your public profile. This profile is visible to all site visitors and users and
gives them an overview about yourself. Let's modify your details a bit now. Click the Edit my profile
link in the Shortcuts menu. You will be redirected to the profile editing page.
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4. Let's choose some avatar so that your profile looks more personal. Click the Select pre-defined
avatar link as highlighted in the screenshot below. 

5. The gallery of pre-defined avatars will be displayed. Choose one and click OK. 
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6. Let's also add your date of birth. Click the calendar icon next to the Date of birth field, pick a date
and click OK. 

7. Finally, click OK on the profile editing page to save the changes. If you click the My profile link in
the Shortcuts menu again, you will see your profile with the avatar and date of birth added.

Further steps: This was only a brief example of what can be done. Try playing around with the
settings and explore the various possibilities. You can for example use an image from your local disk
instead of the pre-defined avatars. You can also go to the Members section, where profiles of all
sample site users can be accessed from. Notice that the Shortcuts menu displays various actions
depending on what content is currently displayed. Performing the actions is very intuitive, so don't be
afraid and try them out.
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2.2.2 Modifying the registration form

In the following example, you will learn how to modify the registration form used on the logon page. For
the purpose of this example, we will want the Middle name field to be specified by users on
registration.

The registration form is displayed using the Custom registration form web part. This web part
enables user registration based on an alternative form of the CMS_User system table. For more
information about the Alternative forms concept, please refer to the Module Alternative forms chapter
of Kentico CMS Developer's Guide.

1. Sign in to Site Manager (login administrator with blank password by default). Go to Development -

> System tables and choose to Edit ( ) the User (CMS_User) system table.

http://devnet.kentico.com/docs/devguide/alternative_forms_module_overview.htm
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2. Switch to the Alternative forms tab. Choose to Edit ( ) the Registration form alternative form,
which is the one currently used on the logon page. As you can see, the other alternative forms are
used for user profile displaying and editing. 
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3. Switch to the Fields tab. This is where you can define which fields of the User system table will be
displayed in the form. Select the MiddleName field from the list on the left and check the Display
attribute in the editing form check-box. Enter the following details:

· Field caption: Middle name
· Field type: Text box

Click OK.
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4. Switch to the Layout tab. This is where you can define the layout of the form. Right-click the line
with the FirstName controls. From the context menu, choose Row -> Insert row after. Select
MiddleName from the Available fields list and use the Insert label, Insert input and Insert
validation label buttons below to insert the label, input and validation controls into the new table row.
The result should look as in the following screenshot.

Click Save.
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5. If you go to the live site now and open the Logon page, you should see the modified version of the
alternative form, just as in the screenshot below.

Further steps: You have learned how to modify the registration alternative form. The same way, you
can add other fields to the form according to your needs. You may also try creating a completely new
alternative form and using it for registration. The new alternative form needs to be specified in the
Alternative form property of the Custom registration form web part. You can find a step-by-step
tutorial on how to do this in Kentico CMS Developer's Guide -> Membership and User registration ->
Creating a custom registration form.

http://devnet.kentico.com/docs/devguide/creating_a_custom_registration_form.htm
http://devnet.kentico.com/docs/devguide/creating_a_custom_registration_form.htm
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2.2.3 Modifying user profiles

You can define which information will be displayed on users' public profiles. In the following example,
you will learn how to add the User ID field to the public profiles. 

User public profiles display information from the CMS_User system table using an alternative form. In
our case, it is the Display profile alternative form. We will have to modify the alternative form to
achieve the required functionality. For more information about the Alternative forms concept, please
refer to the Module Alternative forms chapter of Kentico CMS Developer's Guide.

1. Sign in to Site Manager (login administrator with blank password by default). Go to Development -

> System tables and choose to Edit ( ) the User (CMS_User) system table.

2. Switch to the Alternative forms tab and choose to Edit ( ) the Display profile alternative form. 

http://devnet.kentico.com/docs/devguide/alternative_forms_module_overview.htm
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3. Switch to the Fields tab. Select the UserID field from the list on the right and check the Display
attribute in the editing form check-box. Click OK to save the changes.
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4. Now we need to modify the layout of the profile, so switch to the Layout tab. Place the cursor in the
first column of the empty line below the FullName line and choose UserID from the Available fields
list on the right.

Click the Insert label button. Select the text that was entered and make it bold so that it looks the
same as the other labels. Place the cursor to the second column of the line and click the Insert input
button.

The result should look as in the screenshot below. Finally, click Save to save the changes.
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5. Now if you switch to the live site and sign in as some of the sample users (e.g. David with blank
password), you should see the UserID field present on his profile, as highlighted in the screenshot
below.

Further steps: You have learned how to modify the user public profile. This way, you can add any
other field to the profile. You may also try creating your own alternative form and use it for displaying
user profiles. The new alternative form needs to be specified in the Form name property of the User
public profile web part. You may also try modifying the Edit profile (Community) alternative form the
same way. Like this, you can allow users to modify some additional details of their profile on the profile
editing page.
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2.2.4 Enabling public profile fields visibility controls

You can let users specify who will see particular details on their public profiles. By default, this is
enabled for the e-mail field, as you can see in the screenshot below. Using the highlighted radio-
buttons, users can make their e-mail address visible to:

· Nobody - nobody can see the e-mail address
· All - everyone including anonymous site visitors can see the e-mail address
· Site members - only authenticated site users can see the e-mail address
· Friends - only authenticated site users who are among the user's friends can see the e-mail

address
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In the following example, you will learn how to let users set the visibility of their full name. 

User profiles display data stored in the CMS_User system table based on the specified alternative
form. In our case, it is the Edit profile (Community) alternative form. We will have to modify it to
achieve the required functionality. For more information about the Alternative forms concept, please
refer to the Module Alternative forms chapter of Kentico CMS Developer's Guide.

1. Sign in to Site Manager (login administrator with blank password by default). Go to Development -

> System tables and choose to Edit ( ) the User (CMS_User) system table.

http://devnet.kentico.com/docs/devguide/alternative_forms_module_overview.htm
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2. Switch to the Alternative forms tab and choose to Edit ( ) the Edit profile (Community)
alternative form. 
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3. Switch to the Fields tab and select FullName from the list on the left. Check the Allow user to
change field visibility check box and switch the value of the Visibility control drop-down list to
Visibility (radio buttons - horizontal). Click OK to save the changes. 



Part 1 33

© 2006 Kentico Software

4. Switch to the Layout tab. Place the cursor to the FullName line, right-click and from the context
menu, select Row -> Insert Row After. Type 'Display full name to:' into the first column of the new
line. Then place the cursor into the second column, choose FullName from the Available fields list
and click the Insert visibility control button. The result should look as in the screenshot below.

Click Save to save the changes.
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5. Now if you go to the live site and sign in as some of the sample users (e.g. David with blank
password) and go to the profile editing section (click Edit my profile in the Shortcuts menu), you
should be able to choose the Full name field visibility, as shown in the screenshot below.

Further steps: You have learned how to let site users specify who will see their full name. The same
way as described above, visibility controls can be added to any other field of their profiles.
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2.2.5 Registration approval and double opt-in

By default, users are signed-in to the site and their user account becomes active immediately after
successful registration. However, the two options highlighted in the following screenshot can be
enabled in Site Manager -> Settings -> Membership. By enabling these options, you can include
additional steps in the registration procedure. 
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Registration requires e-mail confirmation 

If checked, newly registered users will receive confirmation e-mail to the e-mail address specified on
registration. This e-mail contains a confirmation link that needs to be clicked in order to activate the
account. The e-mail is based on the Membership - Registration e-mail template.

After clicking the link, a special page will be opened in user's web browser, displaying the following
message:

Your registration has been approved. Now you are able to login using your username and
password. Click here to continue.

The link at the end of the message will redirect the user to the title page of the web site. The user can
then log in using the registration details received in the e-mail.
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Registration requires administrator's approval

If this option is enabled, users will not be able to sign-in immediately after registration. Their
registration will have to be approved by site administrator. At this point, users will receive an e-mail
based on the Membership - Registration waiting for approval e-mail template. You can see the
default version of the e-mail in the screenshot below.

In case that the option is enabled, the Waiting for approval tab will be displayed in Site Manager ->

Administration -> Users. On this tab, site administrators can Approve ( ) or Reject ( ) users'
registration.
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After the administrator's approval, users receive another e-mail, confirming that their account has been
approved and can be used. The e-mail is based on the Membership - Registration approved e-mail
template. You can see the default appearance of the e-mail in the screenshot below.

Enabling both options

In case that you enable both of the options mentioned above, e-mail with the confirmation link will be
sent first. After user's confirmation, registration will have to be approved by the administrator. 

Please note

If you have one or both of the options enabled, it  is important to set the Redirect to
URL property of the registration web part properly. This means that users should not
be redirected to any page displaying information about their user account (just as the
Members  ->  Profile  page  on  the  sample  Community  Starter  site).  Because  the
account  is  not  active  yet  (it  is  waiting  for  e-mail  activation  or  approval),  such  page
would display an error message, which might be misleading for the users.

Further steps: You have learned how to enable registration approval and double opt-in. At this point,
you may want to try enabling the options and registering to the site to see how they work in practice. In
this case, it will be necessary to set up the SMTP server in Site Manager -> Settings -> E-mails in
order for the e-mails to be sent correctly. You may also want to go to Site Manager -> Development -
> E-mail templates and modify some of the notification e-mail templates mentioned in the text above.
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2.2.6 Windows Live ID

2.2.6.1 Overview

Windows LiveID is a single sign-on service provided and maintained by Microsoft. By integrating
LiveID into your web site, you can allow site visitors to log in to your web site using their LiveID login
and password. Even unregistered users can log in using their LiveID, in which case a new user
account will be created automatically based on their LiveID account.

The following diagram shows how the process of LiveID login works.

For this to work on your site, you have to do the following things:

1. Register your web site at https://msm.live.com/app - to learn how to do it click here

2. Setup Kentico CMS LiveID support - to learn how to do it click here

3. Add the LiveID web part to your site - info here

https://msm.live.com/app
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2.2.6.2 Registering your application

To enable the LiveID log on for your site, you must register your web site at the following address: 
https://msm.live.com/app. Click the Register an application link in the left menu, you will be
redirected to the application registration page. You have to enter the following details:

· Application Name - this is simply an identifying name of your web application used in the LiveID
system and has no effect on functionality

· Return URL - enter a URL in the following format: http://<yourdomain>/CMSPages/liveidlogin.
aspx where <yourdomain> should be replaced with the domain name of your site entered in the
Domain name field

· Domain name - enter the fully qualified domain name of your web site
· Secret key - enter some key that will be used to encrypt data transferred between your web site and

the LiveID server; be sure to remember this key as you will have to enter it in Kentico CMS settings
· Application verifier required - it is recommended to choose 0

https://msm.live.com/app
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When you're finished, retype the CAPTCHA, agree with terms of use and click the Submit button. You
will be displayed with the following message, showing you the Application ID. You will use this ID later
in Kentico CMS settings.

2.2.6.3 Settings

LiveID settings are located in Site Manager -> Settings -> Windows LiveID. Before you start making
the settings, make sure you have the right site selected using the Site drop-down list at the top left part
of the page.

· Application ID - identifier of your web site; you were given this ID when registering your web site to
LiveID

· Application secret - secret code that will be used for encryption of messages transferred between
your web site and the LiveID server; you entered this key when registering your web site to LiveID

· Security algorithm - algorithm used for encryption of messages transferred between your web site
and the LiveID server; it is recommended to use wsignin1.0

· Assign new users to roles - new users registered via LiveID login will be assigned to these roles
· Required user data page - alias path to a page containing the 'Required LiveID user data' web part;

if entered, then when a new LiveID user logs in to the site, her user account is not created
automatically, but she is required to enter some additional data (or merge with an existing account)
using the web part
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2.2.6.4 Adding the sign in button

After registering your web site at msm.live.com and making the necessary settings, you only need to
place the Membership -> Windows LiveID web part to your site. This web part works fine without any
additional settings and can be placed on any page of your web site.

In the following example, you will learn how to add the Windows LiveID web part to the sample 
Community Starter site. We will add the web part to the zoneTopMembership web part zone of the
master page, next to the sign-in link. Like this, the LiveID sign-in button will always be displayed, no
matter which particular page is currently displayed.

1. Sign in to CMS Desk (login administrator with blank password by default). Select the master page
(the root of the content tree) and switch to the Design tab.

2. Click the Add web part ( ) icon of the zoneTopMembership web part zone. 

3. In the Web part selection dialog which pops-up, choose Membership -> Windows LiveID and
click OK. The web part properties dialog pops-up. As mentioned above, no properties need to be set,
so just click OK.
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4. The web part is now placed on the master page. The web part itself is not visible now, but it is
represented by the blue rectangle labeled WindowsLiveID. If you log-off now, you should see the web
part on the page and it should be fully functional. 

Further steps: You have learned how to add the Windows LiveID sign-in functionality to your web site.
In some cases, you may want the users to provide some additional details on registration via Windows
LiveID. In this case, you would use the LiveID required data web part. A detailed description of this
web part and the way it can be used can be found in Kentico CMS Developer's Guide -> Membership
and User registration -> Windows LiveID -> Available web parts.

http://devnet.kentico.com/docs/devguide/live_id_available_web_parts.htm
http://devnet.kentico.com/docs/devguide/live_id_available_web_parts.htm


Kentico CMS Community Site Guide44

© 2006 Kentico Software

2.3 Groups

2.3.1 Current functionality

1. Go to the live site and sign-in as Kelly with blank password. Click Groups in the main menu. You
will be redirected to the Groups title page. 

The Your groups section of this page displays all groups where the current user is a member. The
Recently added groups section displays all groups on the site. If you click a group name or avatar,
you will be redirected to the group's profile page. Enter the African travellers group profile.

2. You can see the group profile page now, just as in the screenshot below. The page has the
following sections:

· Group profile - basic information about the group - its avatar, name, description, type of access and
date of creation

· Group announcements - this is a message board where group administrators can leave important
group-related messages

· Latest in forums - displays latest posts in the group's forums
· Most recent pages - displays latest articles in the group pages section

· Shortcuts menu - the following group-related actions are offered in the menu:
· Create a new group - can be used for creating new groups
· Leave the group - by clicking this link, the current user leaves the currently displayed group so

that she is no longer a member of it
· Invite to a group - by clicking this link, group members can send invitations to the currently

displayed group to other site members or via e-mail

· Group links menu - this menu offers links to all sections of the currently displayed group:
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· Home - group profile page
· Pages - group pages section with articles related to the group's field of interest, added by group

members directly on the live site
· Media - group's media libraries where various types of files can be stored
· Members - page displaying a list of all members of the group; after clicking a user, you will be

redirected to her public profile; right-clicking the users' avatars displays a context menu with other
possible actions

· Forums - group's discussion forums

· Group administrators - displays administrators of the current group; right-clicking the avatars
displays a context menu with possible actions

· Recent members - displays the latest group members; right-clicking the avatars displays a context
menu with possible actions

Try browsing the sections and using the actions listed above. The site was designed to be very intuitive
to work with, therefore you should not encounter any problems playing around with it.
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3. If you want to become a member of some other group, you can do it on the Groups title page. Right
click the group you want to join. A context menu appears. Select the Join the group command.

A pop-up window appears, asking you if you really want to join the group. Click Join. Depending on the
group settings, you will either become a group member immediately, or your request will have to be
approved by the group administrator.

Alternatively, you can also join a group by clicking the Join the group command in the Shortcuts
menu when viewing a group profile.
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4. You have just learned what the group member can see and do in this section. Now let's switch to
the group administrator's point of view. Log-off the site and sign-in again as David with blank
password. David is the administrator of the Czech Republic fans group, so view this group's profile
the same way as you did above with Kelly.

The first thing you will probably notice is that there is the Leave message section below the Group
announcements message board. Because David is the admin of this group, he can leave
announcements. Try leaving one.

After clicking the Add button, you should see the message present on the board:

5. You might have also noticed the Manage the group link in the Shortcuts menu. 
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Click it, you will be redirected to the group management section, which is also available only for group
administrators. Try going through all the tabs and changing some settings. As this on-site group
management interface is identical to the groups management interface in CMS Desk, you can refer to 
Kentico CMS Developer's Guide -> Module Groups -> Editing a group for a detailed description and
explanation of all the available settings. Other topics of the Module Groups chapter can be used as a
source of other detailed information on the Groups module.

http://devnet.kentico.com/docs/devguide/editing_a_group.htm
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2.3.2 Creating a new group

New groups can be created two ways: 

· Site users can create new groups on the live site using the Create a new group link in the
Shortcuts menu. This is the most common way and most of the groups on most sites are created
this way.

· Alternatively, if you want to pre-define a group manually from the administration interface, this can
be done in CMS Desk -> Tools -> Groups.

In the following example, you will learn about both ways of creating groups:

1. Go to the live site and sign in as David with blank password. Click the Create a new group link in
the Shortcuts menu.
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2. Enter the following details into the Create new group form:

· Group name - name of the group displayed on the live site and in the administration interface
· Description - text describing the group, displayed in the list of groups
· Approve members - determines if users can join the group with or without group admin's approval;

the last options allows invited members to join without the approval
· Content access - determines who can view content of the group pages

Click OK. You will receive a message saying that your group has been created, but needs
administrator's approval.



Part 1 51

© 2006 Kentico Software

3. Let's switch to the administrator's perspective now. Sign in to CMS Desk (use login administrator
with blank password) and go to Tool -> Groups. You should see the new group present in the list, with
the Approved column saying No. Click the Approve ( ) icon. From now on, the group is approved
and published on the live site.
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4. Now we will try the second way how groups can be created - pre-defining a group in the
administration interface. Our group will be named ASP.NET Developers. At first, we will have to go to
CMS Desk -> Content and create the group pages section. Select Groups -> Template from the
content tree and copy the document under the Group pages node.

5. Select the new Template document that was copied under the Group pages node. Switch to the
Form tab and change its name to ASP_NET_Developers. Click Save.
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6. Switch to the Properties -> URLs tab and change the Document alias also to
ASP_NET_Developers. Click Save.

7. As we have the group pages section prepared, we can proceed to creating of the group itself. Go to 
Tools -> Groups and click the New group link at the top of the page.
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8. The New group form appears. Compared to the on-site form described in step 2, this one contains
some additional fields. We won't describe all of them now, you can find detailed descriptions in the
context help (accessible via the green '?' icon at the top right corner of the page). Enter the following
details:

· Display name - ASP.NET Developers
· Code name - ASP_NET_Developers
· Description - Building web sites using this Microsoft technology? Join us!!!
· Group pages location - /Group-pages/ASP_NET_Developers
· Avatar - click Select pre-defined avatar and pick one

· Approve members - Any site member can join
· Content access - Anybody can view the content
· Notify group admins when a user joins/leaves - leave unchecked
· Notify group admins on pending members - leave unchecked

Click OK.
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9. The group is now created. If you go to the live site now, you should see it listed in the Groups
section, as depicted below. If you enter the group profile, all sections should be fully functional (but of
course with no content).
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2.3.3 Modifying the group public profile

You can define which details will be displayed on group public profiles. The process is quite similar to
modifying user public profiles described here. In the following example, you will learn how to add the
Group ID field to the group public profiles.

Group public profiles display information from the Community_Group system table using an
alternative form. In our case, it is the Display profile alternative form. We will have to modify the
alternative form to achieve the required functionality. For more information about the Alternative forms
concept, please refer to the Module Alternative forms chapter of Kentico CMS Developer's Guide.

1. Sign in to Site Manager (login administrator with blank password by default). Go to Development -

> System tables and choose to Edit ( ) the Group (Community_Group) system table.

2. Switch to the Alternative forms tab and choose to Edit ( ) the Display profile alternative form. 

http://devnet.kentico.com/docs/devguide/alternative_forms_module_overview.htm
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3. Switch to the Fields tab, select GroupID from the list of available fields and check the Display
attribute in the editing form check-box. Click OK.
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4. Switch to the Layout tab. We will place the GroupID field above the GroupAccess field. Place the
cursor in the line with GroupAccess controls, right-click and choose Row -> Insert Row Before from
the context menu. 

5. The former layout gets a bit scrambled by this action. We will need to make this right before we
proceed. Select the three empty cells highlighted in the screenshot below, right-click and choose Cell -
> Delete Cells from the context menu.
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6. Now we have the layout as we want it, so we can proceed to adding the controls. Select GroupID
from the Available fields list, place the cursor in the first empty cell and click Insert label. Highlight
the entered text and make it bold, so that it looks the same as the other two labels. Place the cursor in
the second empty cell and click Insert input. The result should look as in the screenshot below. Click
Save to save the changes.

7. Go to the live site now and view some group's profile. You should see the GroupID field as
highlighted in the screenshot below.
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2.3.4 Modifying templates for group pages

The Groups -> Template page and its child (Pages) are the group pages template. Based on this
template, group pages section for user-contributed articles is created for each group. As you may have
noticed in the Creating a new group chapter, these pages are copied under the Group pages node
when a group is created on-site. The Template page is renamed to the name of the new group in this
case. When creating a group via the administration interface, you need to copy the pages manually,
rename the Template page, change its alias and specify the path in the group creating form.

In the following example, you will learn how to add the Content rating web part to the template so that
users will be able to rate the articles in the group pages sections.

1. Log in to CMS Desk (login administrator with blank password by default). Switch to the Edit ->
Design tab and select Groups -> Template -> Pages from the content tree. 

2. Click the Add web part ( ) icon of the zoneList web part zone and choose the Content rating ->
Content rating web part.

3. In the web part properties window, set only the following property:

Show for document types: CMS.SimpleArticle

This ensures that the web part will be displayed only for the articles and not in the list. Click OK.
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4. The web part is now placed on the page. Notice that when you switch to some of these pages in the 
Group pages section (e.g. Group pages -> American travellers -> Pages), the web part appears there
too. This happens because these pages share the same page template - Community Site - Group
pages. Any modifications that you make to the original page or to the copies will be reflected on all the
pages using this page template.
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5. If you go to the live site now, you should see the Content rating web part on all articles in all group
pages sections. If you create a new group and create some article in its group pages section, the web
part will appear on it too.

Further steps: You have learned how to add the Content rating web part to the group pages. This
way, you can place any web part to the pages and achieve your required functionality. As you have
seen, modifications made to any of the group pages are automatically reflected on all other group
pages because of the shared page template. If you want to achieve different functionality on some of
the group pages, you will have to switch to the Properties -> Template tab and click Clone as ad-hoc
template. Changes made to a page with this cloned ad-hoc template will not be reflected on pages
using the original page template.
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2.4 Forums

2.4.1 Current functionality

The Forums section contains the typical discussion forums that can be found on most web sites on
today's Web, allowing site users to read and contribute to discussions on various topics. While forums
are one of the most common features on today's web sites, we won't go deep in describing how they
can be used, as we believe it should be familiar to you already. For detailed information on the Kentico
CMS Forums module, please refer to Kentico CMS Developer's Guide -> Module Forums. 

If you enter the Forums section as a site visitor, you can see that the forums are divided into two main
sections - Community forums and Back-packer forums. These sections are called forum groups.
Forum groups contain forums (Announcements, Community FAQs, ...) and the forums contain
particular threads. There are two types of threads:

· Discussion forums - threads contain classical discussion on a given topic
· Question-Answer forum - threads are structured so that the first post is a question and the

following posts are trying to answer the given question

http://devnet.kentico.com/docs/devguide/forum_module_overview.htm
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If you view the Forums page in CMS Desk's Design tab, you can see that each forum group is
displayed via one Forum group web part. You can place  a  forum group to any page of your web site
by placing the Forum group web part on the page and setting its Group name property. 
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Forums management can be performed in CMS Desk -> Tools -> Forums. On the page, you can see

a list of existing forum groups. By clicking the Edit ( ) icon, you can enter the Forum group
properties section.

There are three tabs available in this section:

· Forums - a list of forums in the forum group; you can change the order in which the forums will be

displayed by clicking the Move up ( ) and Move down ( ) arrows; you can also Delete ( )

particular forums or click the Edit ( ) icon, which displays the forum's management section
described below

· General - on this tab, you can set some basic properties of this forum group; the properties can be
inherited by particular forums

· View - displays a preview of how the forum group appears on the live site
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The forum management section accessible by clicking the Edit ( ) icon offers the following tabs:

· Posts - tree-like view of threads in the forum, with the possibility of performing management tasks
like editing or deleting posts, replying to them, approving or rejecting, etc.

· General - general properties of the forum, which can be inherited from the forum group's general tab
mentioned above

· Subscriptions - management of subscriptions; users can subscribe to receiving notifications about
new posts

· Moderators - on this tab, you can set if the forum is moderated and assign site users with the rights
to moderate this forum

· Security - on this tab, you can set permissions for particular actions in the forum
· View - displays a preview of how the forum group appears on the live site
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2.4.2 Modifying the forums structure

When developing your community site from the Community Starter site template, you will probably
want to modify the forums structure so that it matches the needs of your community. In the following
example, you will learn how to create a new forum group and replace the Back-packer forums with
it.

1. Go to CMS Desk -> Tools -> Forums and click the Add forum group link at the top of the page.
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2. On the New forum group page, enter the following details:

· Group display name - name of the forum group displayed on the live site and in the administration
interface

· Group code name - name of the forum group used in web site code
· Description - text describing the forum group, displayed above the list of forums in the group on the

live site
· Forum group base URL - URL of the page where the Forum group web part displaying this forum

group resides; leave the Inherit from settings check-box checked
· Forum group unsubscription URL - URL of the page where the Forum unsubscription web part

resides; leave the Inherit from settings check-box checked

Click OK.
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3. The Forum group properties page will be displayed. Let's make some additional settings which
you may find useful before we start defining the forums within this forum group. Switch to the General
tab and set the following properties:

· Forum type - User can choose; this option enables users to choose from classical or Question-
Answer type when creating a new thread

· User can edit own posts - enable this option so that users can edit their own posts
· User can delete own posts - enable this option so that users can delete their own posts
· Enable * macros in posts - enable all the check-boxes so that users can use all BBcode macros in

their posts; for more details on supported BBcode macros, please refer to Kentico CMS Developer's
Guide -> Module Forums -> BBcode support

Leave the rest of the properties at their default values and click OK.

http://devnet.kentico.com/docs/devguide/bb_code_support.htm
http://devnet.kentico.com/docs/devguide/bb_code_support.htm
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4. Now we will define the forum group structure - the particular forums. Switch to the Forums tab and
click the Add forum link.

5. Enter the following details:

· Forum display name - name of the forum displayed on the live site and in the administration
interface

· Forum code name - name of the forum used in web site code
· Description - text describing the content of the forum, displayed in the list of forums in the group on

the live site
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You can leave the rest of the properties at their default values and click OK to save the forum.
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6. You are redirected to the forum editing section. If you switch to the Forums tab again, you should
see the newly created forum in the list. Repeat the procedure and define some other forums in this
forum group. When you are finished, you should see all the forums in the list on the Forums tab like in
the screenshot below.
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7. Now when the forum group is created and the forums in it defined, we can publish the forum group
on the live site. We will place it instead of the original Back-packer forums.

Go to CMS Desk -> Content -> Edit. Select the Forums document from the content tree and switch

to the Design tab. Scroll down the page and choose to Configure ( ) the ForumGroup1 web part.
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8. In the web part properties window, change the value of the Group name property to the name of the
new forum group created above, which is Web development forums in our case. Click OK.
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9. If you switch to the live site now, you should see that the Back-packer forums have been replaced
by the Web development forums defined earlier in  this example. The forum group is fully functional
and the discussion may begin.

Further steps: You have learnt how to define a new forum group and publish it on the live site. Like
this, you can define another forum group and publish it instead of the Community forums forum group.
In case that you wanted to have more than two forum groups published, you only need to place
another Forum group web part on the page and define its Group name property. You may also want to
have only one forum group published, in which case you only need to remove one of the Forum Group
web parts.
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2.5 Blogs

2.5.1 Current functionality

The Blogs module is a 'ready-made' solution and you will probably not need to make any customization
tasks to it. However, we will at least describe its functionality from the site user's perspective in brief.
Detailed information on the Blogs module can be found in Kentico CMS Developer's Guide -> Module
Blogs.

1. Go to the live site and sign in as David with blank password. Click Blogs in the main menu. 

On the Blogs section's title page, you can see recent blog posts from all blogs on the site.You can
browse the posts by topic - by clicking a keyword in the Tag cloud, a list of blog posts tagged with the
keyword will be displayed. You can also browse the posts by particular blogs. The Recent blogs box
displays links to the most recently created blogs and a link to the list of all blogs. After clicking a blog
link, both in this box or in the list of blogs, you will be redirected to its title page. 

http://devnet.kentico.com/docs/devguide/module_blogs_overview.htm
http://devnet.kentico.com/docs/devguide/module_blogs_overview.htm
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2. Click some blog to display its title page. The blog's title page is similar to the Blogs section's title
page, but displays only posts from the current blog. In addition to the Tag cloud, you can browse posts
in the current blog by months too. By clicking a month link in the Post archive box, you can display
only posts from the clicked month. 
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3. Click some blog post to display it. Below the text, you can find the Content rating web part, social
bookmarking links, trackbacking URL and the comments section where you can post comments on the
blog post.
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4. When we have seen what the Blogs section on the site looks like, we can try creating our new blog.
This can be done anywhere on the live site by clicking the Create a new blog link in the Shortcuts
menu.

5. On the Create new blog page, you only need to enter the name and description of your new blog
and click OK.

6. The blog is now created and you are redirected to the blog's title page, where you can Edit blog (
) properties or write a New blog post. 

7. From now on, the blog is fully functional. You can find a link to the blog in the Recent blogs box on
the Blogs title page, in the list of all blogs and on your public profile page.

2.6 Media libraries

2.6.1 Current functionality

The media libraries allow convenient storage of large amounts of files. Not only media files, but also
files of any other types can be stored within the libraries, while even large file sizes (several GB) are
supported. Media libraries can be either global or related to a particular group. For detailed information
on the module, please refer to Kentico CMS Developer's Guide -> Module Media libraries.

http://devnet.kentico.com/docs/devguide/media_libraries_overview.htm
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1. If you go to the live site, you can enter the site's global media libraries section by clicking the Media
link in the main menu. This section displays the content of the only global media library on the site,
which is named Media. You can see the library's folder structure tree on the left. By clicking a folder,
files stored within the folder will be displayed in the main area. 
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2. If you click a file's thumbnail, the file will be displayed in the main area. Depending on the type of file,
the display may vary. Images will be displayed in large size, videos or sound files display a player
where the files can be played. Documents are displayed only in form of the document type icons.
Additional information about the file is displayed in the bottom left corner. All files can be downloaded
using the Download link at the bottom right corner.
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3. As we mentioned above, groups can also have their own media libraries. This is the case of the 
Czech Republic fans group on this sample site. If you go to Groups -> Czech Republic fans and
click the Media link in the Group links box, media libraries of the group will be displayed.
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2.6.2 Creating custom media libraries

In the following example, you will learn how to create a new global media library and publish it on the
site. 

1. Go to CMS Desk -> Tools -> Media libraries and click the New media library link at the top of the
page.

2. Enter the following details into the form:

· Display name - name of the library displayed on the live site and in the administration interface
· Code name - name of the library used in web site code
· Description - text describing the media library, displayed in the list of media libraries on the live site
· Teaser image - upload some image which will be used as a teaser in the list of media libraries
· Folder name - name of the physical folder in the file system which will contain the library files; it is

located under <web project>/<site name>/media/

Click OK.
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3. You will be redirected to the media library management interface, which is also accessible by

clicking the Edit ( ) icon in CMS Desk -> Tools -> Media libraries. 

First, we will define the folder structure. Select the root of the tree and click the New ( ) icon. Enter
the name of the new folder and click OK. Repeat the procedure so that you have at least two different
folders in the library.

Please note: due to ASP.NET architecture, site restart occurs whenever a folder is moved, renamed
or deleted. To prevent this, it is a good practice to define the library structure when creating it and not
to modify it when the site is already running.

4. Now we can upload the files. Select one of the folders and click the Upload file ( ) icon at the top
right corner. 

In the pop-up window that you can see in the screenshot below, enter the path or browse for the File
that you want to upload. The Preview is an image displayed as the file teaser in the list of files. This is
useful for non-image files. If you are uploading an image, you don't need to upload any preview file, as
the image itself will be resized and used as the preview automatically. Finally, enter some text
description and click Save.

Repeat the procedure so that you have several files in each of the folders.
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5. Our media library is now finished and we can publish it. Switch to CMS Desk -> Content -> Edit ->

Design tab and choose the Media page from the content tree. Choose to Configure ( ) the
MediaGallery web part. 

6. In the web part properties window, select your new media library in the Media library drop-down list
and click OK.
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7. If you switch to the live site now, you should see that the original media library has been replaced by
your new media library.

Further steps: You have created a new media library, defined its structure, uploaded some files and
published it on the live site instead of the original sample media library. As obvious, you can publish
only one global media library this way. This might be fine for many sites, but if you want to have more
global media libraries published on the site, go to the next chapter where you can find more
information on how to achieve this functionality.
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2.6.3 Publishing more than one global media library

In the following example, you will learn how to publish more than one global media library on the site.
We will try to achieve a functionality similar to group media libraries (see Groups -> Czech Republic
fans and click Media in the Group links box). As you can see, we have two pages where a list of
available libraries is on the first page. Links in the list lead to the second page where the content of the
clicked library is displayed dynamically.

1. Go to CMS Desk -> Content -> Edit and select the Media page from the content tree. Click the
New icon above the content tree to create a new page under the Media page.
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2. Choose the Page (menu item) document type. For Page name, enter Media gallery and choose
the Community site -> Community site - Media page template. Click Save.
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3. Now we have two pages showing the same content because they use the same page template. But
the required functionality is the following: the Media page should display a list of global media
libraries; after clicking a library, users should be redirected to the Media gallery page, which shall
display the content of the clicked library. 

First, select the Media gallery page and switch to the Properties -> Template tab. Select the Select
inherited levels radio-button and choose to inherit from Root only.

4. Switch to the URLs tab and enter /Media/{LibraryName} into the Document URL path filed. Click
Save.
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5. Switch to the Design tab and choose to Configure ( ) the Media gallery web part. Set the value
of the Media library property to (current media library) and click OK.
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6. Select the Media page and on the Properties -> Template tab, click the Clone as ad-hoc
template link. Click Save. 

7. Switch to the Design tab and choose to Remove the MediaGallery web part.
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8. Add ( ) the Media Library -> Media libraries viewer web part to the zoneCenter web part zone,
to the place of the removed MediaGallery web part. In the web part properties window, choose to Edit
the Transformation Name property.
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9. In the pop-up window, replace the original transformation code with the following code. The
transformation below is the original transformation with the highlighted code added. 

This code ensures that library teasers and names will work as links leading to the /Media/
{LibraryName} URL, where {LibraryName} will be replaced with the name of the clicked library. This is
the URL we have set in step 4 for the Media gallery page. Because the Media library property of the
Media gallery web part on the page is set to (current media library), it will display content of the
media library from the URL.

Click Save. 

<div class="MediaListItem">
<table>

<tr>
<td class="MediaLibraryListPhoto">
<a href="~/Media/<%# Eval("LibraryName") %>.aspx">

<%# IfEmpty(Eval("LibraryTeaserPath"), "<img border='0'
src=\"~/App_Themes/CommunitySite/Images/DefaultMediaTeaser.gif\" alt=\"\" />",
"<img src=\"" +
UrlHelper.GetAbsoluteUrlWithPort(ValidationHelper.GetString(Eval("LibraryTeaserP
ath"), "")) + "?width=180\" alt=\""+ Eval("name") +"\" border='0' />") %>

</a>
</td>

<td class="MediaLibraryListDescription">
<a href="~/Media/<%# Eval("LibraryName") %>.aspx">
<b>

<%#
LimitLength(ResHelper.LocalizeString(Convert.ToString(Eval("LibraryDisplayName",
true))), 20, "...") %>

</b>
</a>

<div class="MediaLibraryListDescriptionText">
<%#
LimitLength(ResHelper.LocalizeString(Convert.ToString(Eval("LibraryDescription",
true))), 40, "...") %>

</div>
</td>
</tr>

</table>

<div class="MediaListItemBottom"></div>
</div>
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10. If you go to the live site now and click the Media link in the main menu, you should see the
functionality described in the beginning of this chapter. A list of all global media libraries on the site will
be displayed. After clicking a library in the list, its content will be displayed.
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2.7 Design and styles

2.7.1 Changing the header image

Changing the header image is a procedure of a few clicks. You only need an image of the same width
as the original image, which is 960 pixels. For the purpose of this example, you may use the
community_header02.gif. The file can be found in the attached files package that can be found at
http://www.kentico.com/Downloads/CommunityGuide/CommunitySiteGuide_files.zip. Once you have
the image prepared, follow these steps:

1. Go to CMS Desk, select the Files folder from the content tree and click New.

2. Browse for your file on your local drive, optionally enter some text describing the image and click 
Save.

 

http://www.kentico.com/Downloads/CommunityGuide/CommunitySiteGuide_files.zip


Kentico CMS Community Site Guide96

© 2006 Kentico Software

3. The image is now uploaded, so let's use it on the master page. Select the root of the content tree in 
Page tab and click the Select button at the top left corner of the header image.
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4. Select your previously uploaded image from the content tree and click the Paste image link.
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5. Finally, click Save to save the changes made to the master page. 

6. If you switch to the live site now, you should see the new header image in its full beauty.

Further steps: You have learned how to change the header image on the master page. As you will
probably not be satisfied with this level of customization, you can try modifying the site's CSS
stylesheet. Like that, you will be able to fully customize the site's design according to your needs. In the
next chapter, you can find a simple example showing how the site's CSS stylesheet can be modified.
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2.7.2 Modifying the stylesheet

In this example, you will learn how to edit the site's CSS stylesheet. We will follow the previous
example and modify the main menu so that it matches the new header image. Any other modifications
of your choice can be done to the stylesheet the same way as described below.

1. Go to Site Manager -> Development -> CSS Stylesheets and choose to Edit ( ) the Community
Site stylesheet.
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2. The CSS stylesheet is divided into sections so that you can easily find the appropriate classes. The
sections can be quickly accessed by selecting from the listbox on the right. Choose the Top menu
section. Within this section, you can find all classes defining the appearance of the main menu. 
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3. Replace the text of this section (all classes before the /*#Main styles/Search box#*/ line, which
indicates the beginning of the new section) with the code below. Click Save to save the changes.

/*#Main styles/Top menu#*/
.zoneTopMenu
{

width: 960px;
background: #000000;
padding: 0px;
margin: 0px;

}

.PagePlaceholder .zoneTopMenu
{

height: 90px;
background-color: #BABABA;

}
/*
.DesignMode .zoneTopMenu .CMSListMenuUL
{

background: #BABABA
url(../App_Themes/CommunitySite/Images/topmenu-bg.gif) repeat-x top center;
}
*/
.CMSListMenuUL
{

list-style-type: none;
line-height: 27px;
font-weight: bold;
font-size: 13px;
margin: 0px;
padding: 0px;
float: left;
color: #000000;

}

.CMSListMenuLI, .CMSListMenuHighlightedLI
{

display: block;
float: left;
padding: 0px;
background: #000000;

}

.CMSListMenuLIlast, .CMSListMenuHighlightedLIlast
{

background: none;
display: block;
float: left;
padding: 0px;

}

.CMSListMenuLink, .CMSListMenuLinkHighlighted
{

color: #cccccc;
text-decoration: none;
display: block;
padding: 0px 15px;
margin-right: 2px;

}

.CMSListMenuLI a:hover, .CMSListMenuLinkHighlighted, .CMSListMenuHighlightedLI a
{

color: #FFFFFF;
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background: #000000;
text-decoration: none;

}

4. If you switch to the live site now, you can see that the colors of the main menu have changed as
defined in the pasted stylesheet code.

Further steps: You have learned how to access, modify and save changes to the site's CSS
stylesheet. If you are familiar with CSS in general, it should be no problem for you to fully customize
any class of the site's CSS stylesheet and thereby customize the site's design as you wish.



Part

III



Kentico CMS Community Site Guide104

© 2006 Kentico Software

3 Part 2

3.1 Introduction

In this part of Kentico CMS Community Site Guide, you will learn how to create a community site from
scratch. Our goal in the following series of step-by-step tutorials will be to create an identical site to the
sample Community Starter site from the very beginning, so that you can see all the stages of the
web site development process. 

You will learn how to define the site structure, populate the pages with web parts and set the web
parts' properties to achieve the required functionality. Finally, you will make some settings to specify
pages with certain special functionalities.

Here are some things to keep on mind when reading the tutorials in order to get the most out of them:

· These tutorials are intended for web developers with at least the basic knowledge of Kentico CMS. If
you are new to Kentico CMS, please read at least the portal engine version of Kentico CMS Tutorial
to get familiar with the basics of the system. 

· Most of the code examples are self-explaining for people with a certain knowledge of HTML, CSS
and transformations, so they are therefore not always commented. It is therefore highly
recommended that you have a solid understanding of these languages.

· The most important part of the tutorials are the web part properties settings. Because it would
take many times as much space to describe all the settings in detail, some of them are just listed
without further explanation. The good news is that when you click the Documentation link at the top
right corner of each web part properties window. 

http://devnet.kentico.com/docs/tutorial/index.html


Part 2 105

© 2006 Kentico Software

After clicking the link, you get the web part's documentation with all the properties explained.

· Other valuable information can be found in Kentico CMS Developer's Guide. References to this
reference guide can be found throughout the tutorials. In addition, going through the particular
modules' chapters can enrich your knowledge and understanding of the system too. So for example
if you don't understand something related to Groups, just open the Module Groups chapter of the
guide and see if you can find the answers.

Wildcard URLs are used throughout the whole web site, mainly in the Groups section and on user
profiles. If you are not familiar with the wildcard URLs concept, please read this chapter of Kentico
CMS Developer's Guide.

· Last but not least, Kentico CMS is well-known for its outstanding technical support. So if you get
really stuck, don't hesitate and contact our support team at http://www.kentico.com/Support.aspx.
They are always there to help you.

3.2 Pre-development tasks

3.2.1 Creating the site

To get us started, we need to create a new web site. This can be achieved using the New site wizard.
You can access it both when making new installation and when you already have Kentico CMS
installed.

· When making a new installation, you can choose Continue to the New site wizard in Step 4 of the

http://devnet.kentico.com/docs/devguide/index.html
http://devnet.kentico.com/docs/devguide/wildcard_urls.htm
http://www.kentico.com/Support.aspx
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Database Setup. After clicking Next, you will be redirected to the first step of the wizard.
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· Alternatively, if you already have Kentico CMS installed, you can access the New site wizard by
clicking the alike named link in Site Manager -> Sites.

1. In the first step of the wizard, choose Create a new site using a wizard and click Next.
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2. In the second step, enter the following details:

· Site display name: My Community Site
· Site code name: MyCommunitySite
· Domain name: localhost
· Site culture: English - United States

Click Next to proceed.
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3. In Step 3, leave all settings at their default values and click Next.

4. An import log will be displayed. When it finishes, click the Next button.
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5. In Step 5, you can choose from three default master page layouts. Choose the Blank master page,
as we will define the layout later on.
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6. The sixth step of the wizard allows you to define basic site structure. As we will create the pages
when creating the particular sections, you can skip this step by clicking the Next button.
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7. If you have reached the seventh step, you have created the site successfully. Click Finish to return
to Site Manager -> Sites.
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3.2.2 Assigning the CSS stylesheet

Once you have the site created, you can create its CSS stylesheet and assign it to the site. For the
purposes of this guide, you should use the CommunitySite.css, which is the Community Starter site's
original CSS stylesheet. The file can be found in the attached files package that can be found at http://
www.kentico.com/Downloads/CommunityGuide/CommunitySiteGuide_files.zip.

1. Go to Site Manager -> Development -> CSS Stylesheets and click the New CSS stylesheet link
at the top of the page.

2. Enter the following details:

· Stylesheet display name: My community site
· Stylesheet code name: MyCommunitySite
· Stylesheet text: copy and paste the stylesheet text from the CommunitySite.css file

Leave the Assign to web site My Community Site check-box checked and click OK.

http://www.kentico.com/Downloads/CommunityGuide/CommunitySiteGuide_files.zip
http://www.kentico.com/Downloads/CommunityGuide/CommunitySiteGuide_files.zip
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3. Go to Site Manager -> Sites and choose to Edit ( ) your site.

4. On the General tab, select the new stylesheet in both Site CSS stylesheet and Editor CSS
stylesheet drop-downs and click OK. 

You have learned how to create a new CSS stylesheet and assign it to your site.
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3.2.3 Creating page templates category

Throughout the process of the web site creation, you will create various pages. It is a good practice to
store the pages as page templates so that they can be reused later on at some other part of the web
site, without the need to define the page structure again. For you to keep the page templates
organized neatly, it is recommended to create a new page template category where the templates will
be stored.

1. Go to Site Manager -> Development -> Page templates. Select the root of the template
categories tree (Page Templates) and click the New category link. Enter the following details:

· Category display name: My Community Site templates
· Category name: MyCommunitySiteTemplates

Click OK. Your category is now created and you can save all your page templates for this site in it.
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3.2.4 Defining web part containers

Web part containers are elements of the web site which can encapsulate web parts. They consist of a
HTLM code before the web part and a after the web part. Throughout the web site, we will use six
different web part containers which we will define in the following example.

1. Go to Site Manager -> Development -> Web part containers and click the New container link
above the list.

2. In the New container dialog, enter the following details:

· Display name: Community Site - Blue Box
· Code name: CommunitySite.BlueBox
· Text before web part:

<div class="blueBoxTop"></div>
<div class="blueBox">
<h3 class="blueBoxTitle">{%ContainerTitle%}</h3>

· Text after web part:

</div>
<div class="blueBoxBottom"></div>

Click OK. 
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3. Switch to the Sites tab and enable the web part container for My Community Site. Click OK.

4. Repeat the same procedure for the following five web part containers:

· Display name: Community Site - Blue Box Light
· Code name: CommunitySite.BlueBoxLight
· Text before web part:

<div class="boxBlueLight">
<h3>{%ContainerTitle%}</h3>

· Text after web part:

</div>

· Display name: Community Site - Gray Box
· Code name: CommunitySite.GrayBox
· Text before web part:

<div class="grayBoxTop"></div>
<div class="grayBox">
<h3 class="grayBoxTitle">{%ContainerTitle%}</h3>

· Text after web part:

</div>
<div class="grayBoxBottom"></div>
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· Display name: Community Site - Orange Box
· Code name: CommunitySite.OrangeBox
· Text before web part:

<div class="orangeBoxTop"></div>
<div class="orangeBox">
<h3 class="orangeBoxTitle">{%ContainerTitle%}</h3>

· Text after web part:

</div>
<div class="orangeBoxBottom"></div>

· Display name: Community Site - Red Box
· Code name: CommunitySite.RedBox
· Text before web part:

<div class="redBoxTop"></div>
<div class="redBox">
<h3 class="redBoxTitle">{%ContainerTitle%}</h3>

· Text after web part:

</div>
<div class="redBoxBottom"></div>

· Display name: Community Site - Red Box Light
· Code name: CommunitySite.RedBoxLight
· Text before web part:

<div class="boxRedLight">
<h3>{%ContainerTitle%}</h3>

· Text after web part:

</div>

You have created six new web part containers. These containers can now be used to encapsulate any
web part on the site, using the Web part container property. This property is common to all web parts.
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3.2.5 Uploading images

We will upload some images that we will use later on. You can find the images in the images folder
inside the files package attached to this guide, which can  be downloaded at http://www.kentico.com/
Downloads/CommunityGuide/CommunitySiteGuide_files.zip. Please extract the images from the
archive into a separate folder on your local disk before you start with the following steps.

1. Go to CMS Desk, select the root of the content tree and click New. 

2. As the document type, choose Folder.

3. Enter Files as the Document name and click Save.

http://www.kentico.com/Downloads/CommunityGuide/CommunitySiteGuide_files.zip
http://www.kentico.com/Downloads/CommunityGuide/CommunitySiteGuide_files.zip
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4. Now you have the folder ready in the content tree. Select it and click New. Choose the File
document type.

5. Browse into the folder with the images, choose one of them, enter some text describing of the
image and click Save.

6. Repeat the same procedure for the rest of the images in the folder. The result should look as in the
following screenshot.
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3.2.6 Creating a sample poll

In this exmple, you will learn how to create a sample poll that you will publish on the Home page later
on. More information about Kentico CMS Polls module can be found in Kentico CMS Developer's
Guide -> Module Polls.

1. Go to CMS Desk -> Tools -> Polls and click the New poll link.

2. Enter the following details:

· Display name: Continents
· Code name: Continents
· Title: leave blank
· Question: Which continent are you planning to visit during your next trip?

Click OK.

http://devnet.kentico.com/docs/devguide/polls_overview.htm
http://devnet.kentico.com/docs/devguide/polls_overview.htm
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3. The poll appears in the Edit mode, offering you five tabs where settings can be done. On the
General tab, enter the following:

· Message after vote: Thank you for your vote.

Click OK.

4. Switch to the Answers tab and click the New answer link.
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5. Enter Africa into the Text field and click OK.

6. Repeat the procedure so that you have all five continents entered as answers.

3.2.7 Creating the tag groups

Kentico CMS Tags module enables assigning documents with key words for better content-related
navigation and search. These key words are called tags and they are organized in tag groups. There
is one tag group called Content in the default instalation. We will create two additional tag groups
called Blogs and News, so that blog posts and news can be tagged with tags from separate groups. 

More information about the Tags module can be found in Kentico CMS Developer's Guide -> Module
Tags.

http://devnet.kentico.com/docs/devguide/tags_module_overview.htm
http://devnet.kentico.com/docs/devguide/tags_module_overview.htm
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1. Go to Site Manager -> Development -> Tag groups and click the New tag group ( ) link at the
top of the page.

2. Enter the following details into the form:

· Display name: Blogs
· Code name: Blogs
· Description: This is the group of tags used for blog posts.

Click OK.
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3. Repeat the same procedure and create a tag group with the following details:

· Display name: News
· Code name: News
· Description: This group contains tags used for news items.

Click OK.

4. If you go back to the list of tag groups, you should see the Blogs, Content and News tag groups.
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3.2.8 Creating the News notification template

There will be the News page on the site, where news will be added by content editors or site
administrators. On the page, users will have the possibility to sign up for receiving notifications about
new news items published on the site. You can find a tutorial on creating the page here.

In this chapter, we will create a notification template. Notification e-mails will be based on this
template. More information about Kentico CMS Notifications module can be found in Kentico CMS
Developer's Guide -> Module Notifications.

1. Go to Site Manager -> Notifications and switch to the Templates tab. 

2. From the Sites drop-down list, select My Community Site and click the New template ( ) icon.

3. In the next dialog, enter the following details: 

· Display name: News notification
· Code name: NewsNotification

Click OK.

http://devnet.kentico.com/docs/devguide/notifications_overview.htm
http://devnet.kentico.com/docs/devguide/notifications_overview.htm
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4. Switch to the Text tab and define the template's text the following way:

· Subject: Community Site News

Enter the following template text into both HTML text and Plain text fields:

Hello,

news item {%notificationcustomdata.newstitle%} has been just published on the
Community site. You can see it at {%documentlink%}.

You are subscribed for receiving this automatic e-mail notification. If you no
longer wish to receive these notifications, please change your preferences in
your user profile at the Community Site.

Click Save. The template is ready to be used.
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3.2.9 Creating a sample Media library

In the following example, we will create a sample media library. This media library will be global, which
means that all site users and visitors will be able to see its content on the Media page. We we will
create the Media page later on in this guide in this chapter. 

Detailed information about the Media libraries module can be found in Kentico CMS Developer's
Guide -> Module Media libraries.

1. Go to CMS Desk -> Tools -> Media libraries and click the New media library link.

2. In the following dialog, enter the details listed below:

· Display name: My Community Site Media
· Code name: MyCommunitySiteMedia
· Description: enter some text describing the media library
· Teaser image: you can leave the field blank
· Folder name: MyCommunitySiteMedia

Click OK.

http://devnet.kentico.com/docs/devguide/media_libraries_overview.htm
http://devnet.kentico.com/docs/devguide/media_libraries_overview.htm
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3. The media library has been created and you are redirected to the library's editing interface. We will
define the folder structure first. 

Click the New icon while the root of the library is selected. Enter the name of the new folder into the
Folder name field and click OK. 

Repeat the procedure so that you have the following four folders in the root of your library:

· Documents
· Music
· Pictures
· Video

4. Now that we have the folders ready, we can start uploading some files. We will use files from the 
media_library_files folder inside the files package attached to this guide. The package can be found
at http://www.kentico.com/Downloads/CommunityGuide/CommunitySiteGuide_files.zip. Inside the
folder, you will find four sub-folders with the same names that you defined in the previous step. Each of
the folders contains several files. For the purposes of this example, you don't need to upload them all.
Uploading at least one file into each folder will do the job.

There are several ways how you can achieve this. You can find a detailed description of how files can
be uploaded into the media libraries in Kentico CMS Developer's Guide -> Module Media libraries ->
Uploading files into media libraries. 

Here, we will describe how you can upload files via the administration interface:

http://www.kentico.com/Downloads/CommunityGuide/CommunitySiteGuide_files.zip
http://devnet.kentico.com/docs/devguide/uploading_files_into_media_libraries.htm
http://devnet.kentico.com/docs/devguide/uploading_files_into_media_libraries.htm
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Select the target folder from the tree on the left and click the Upload file ( ) icon at the top right
corner of the page. In the pop-up dialog, enter the following details:

· File: enter or browse for the path to the uploaded file
· Preview: enter or browse for the path to the file's preview; the preview image will be displayed in the

list of files on the Media page; for image files, you don't need to enter anything as the image itself will
be used as the preview

· Description: enter some text describing the uploaded file

Click Save. 

Repeat the same procedure so that you have at least one file in each of the folders. Once finished, the
library is ready to be published on the site.
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3.3 Creating the Master page

As we have the site created and the pre-development tasks carried out, we can start defining the
master page. The master page is represented by the root of the content tree. It is the page from which
all other pages inherit the default content, such as the main menu, header image, etc. Like this, you
can avoid laborious adding and setting of these elements at all pages. Instead, you only use them on
the master page and all other pages will inherit it.

In Step 5 of the New site wizard, we chose to use the Blank master page page template. This is the
most simple master page with two web part zones. As we want the master page to be a bit more
complex, we will have to modify its layout.

Further information on master pages can be found in chapters The master page concept and Editing
the master page of Kentico CMS Developer's Guide.

1. The master page uses the Blank master page page template. If you made any changes to the
page now, the changes would be reflected on the page template too so that the original page template
definition would be overwritten and could not be reused anymore. 

To prevent this, you need to save the page as a new page template. We will stick to this practice
throughout the whole guide.

Go to CMS Desk -> Edit, select the master page from the content tree and switch to the Properties ->
Template tab. Click the Save as new template link. 

http://devnet.kentico.com/docs/devguide/the_master_page_concept.htm
http://devnet.kentico.com/docs/devguide/editing_the_master_page.htm
http://devnet.kentico.com/docs/devguide/editing_the_master_page.htm
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2. In the pop-up window, enter the following details:

· Template display name: My Community Site - Master Page
· Template code name: MyCommunitySite.MasterPage
· Template category: My Community Site templates
· Template description: some text describing the template

Click OK.

3. Now we can start making modifications to the page. First, we will re-define the page layout so that
we get more web part zones on the page. Switch to the Master page tab and replace the original
layout in the main text area (within the <body> tags) with the following piece of code. 

Click Save to save the changes.

<!-- Top info -->
<div class="zoneTopInfo">

<cc1:CMSWebPartZone ID="zoneTopInfo" runat="server" />
</div>
<div class="mainDiv">
<div class="zoneTopMembership">

<cc1:CMSWebPartZone ID="zoneTopMembership" runat="server" />
</div>
<div class="zoneTop">

<cc1:CMSWebPartZone ID="zoneTopImage" runat="server" />
</div>
<div class="zoneTopMenu">

<cc1:CMSWebPartZone ID="zoneTopMenu" runat="server" />
<div class="clear">&nbsp;</div>

</div>
<div class="zoneMain">

<cc1:CMSWebPartZone ID="zoneContent" runat="server" />
</div>
<div class="zoneBottom">

<cc1:CMSWebPartZone ID="zoneBottom" runat="server" />
</div>
</div>
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4. If you switch to the Design tab now, you should see that the master page has been populated with
several web part zones. The layout is now ready and we can start populating the page with web parts.

5. Let's start from the top where the logon bar with links to CMS Desk and Site Manager is located. 

Click the Add web part ( ) icon of zoneTopInfo. In the pop-up window, choose the Text -> Static
text web part and click OK. 

In the web part properties window, you only need to set the value of the Text property. Use the
following code for the value:

<div style="border: 1px solid #cecfce;background:#f7f3ef;color:#555555;font-
weight:bold;padding:3px;font-size:10px;text-align:center">
Sign in to <a href="~/CMSPages/logon.aspx?ReturnUrl=~/cmsdesk/default.aspx&amp;
username=administrator">CMS Desk</a>. Sign in to <a href="~/CMSPages/logon.aspx?
ReturnUrl=~/cmssitemanager/default.aspx&amp;username=administrator">CMS Site
Manager</a>. The default account is administrator with blank password.
</div>

Leave the rest of the properties at their default values and click OK. You should see the logon bar
appear in the web part zone.
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6. Let's move on to zoneTopMemebership. This web part zone will contain the sign in/out link, link to
the current user's private messaging inbox, link to the current user's profile editing page and
information about the current user with link to her public profile.

Click the Add web part ( ) icon, choose the Membership -> Sign out button web part and click OK
. Set the following properties of the web part, leave the rest at the default values:

· Show as link: enabled
· Button text for sign out: Sign out
· Show only when authenticated: disabled
· Sign in page path: /Logon
· Return page path: /Home
· Content before: <div class="signOut">
· Content after: </div>

Click OK.

Click the Add web part ( ) icon again, choose the Messaging -> Messaging info panel web part
and click OK. Set the following properties of the web part, leave the rest at the default values:

· Display to roles: _authenticated_
· Inbox link URL: ~/Members/{%UserName|(encode)true%}/Messages.aspx
· Show outbox: disabled
· Show new message: disabled
· Content before: <div class="messagesPanel">
· Content after: " |&nbsp;</div>" (do not enter the parentheses, these are here to indicate that the

string begins with a blank space)

Click OK.

Click the Add web part ( ) icon again, this time, choose the Text -> Static HTML web part and click
OK. Set the following properties of the web part, leave the rest at their default values:

· Display to roles: _authenticated_
· Content before: <div class="myAccountInfo">
· Content after: " |&nbsp;</div>" (do not enter the parentheses, these are here to indicate that the

string begins with a blank space)
· Text: place the cursor into the text area, click the Source ( ) icon at the WYSIWYG editor and

replace the original HTML code with the following code:

<a title="My profile" href="/KenticoCMS_40/Members/{%CurrentUser.UserName|
(encode)true%}/Management.aspx">Edit my profile</a>

Click OK.

Click the Add web part ( ) icon again and finally choose the Membership -> Current user web part.
Click OK. Set the following properties of the web part, leave the rest at their default values:

· Authenticated URL link: ~/Members/{%CurrentUser.UserName|(encode)true%}.aspx
· User text CSS class: userName
· Content before: <div class="currentUser">
· Content after: " |&nbsp;</div>" (do not enter the parentheses, these are here to indicate that the

string begins with a blank space)
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Click OK.

7. Next on is the zoneTopImage web part zone, where the header image should be placed. Click the

Add web part ( ) icon of this web part zone and choose the Text -> Editable image web part. Set its
following properties, the rest can be left at their default values:

· Image width: 960
· Image height: 148
· Alternate text: Community Site

Click OK.

Now switch to the Page tab. The added web part is represented here only by the two link buttons as in
the screenshot below. Click the Select button of the added web part.

7. In the pop-up window, select the previously uploaded community_header_img.jpg and click the
Paste image link. 
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8. The header image is now at its place. Click Save to save the master page.

9. Now we need to populate the zoneTopMenu web part zone where the search box and the main

menu will reside. Click the Add web part ( ) icon of this web part zone and choose the Full-text
search -> Search box web part. Set the following properties of the web part, the rest can be left at
their default values:

· Disable view state: enabled
· Search button text: Search
· Search button CSS class: buttonSearch
· Search textbox CSS class: inputSearch
· Search results page URL: ~/Search.aspx
· Show search label: disabled

Click OK.

10. Let's add the main menu now. Click the Add web part ( ) icon of the zoneTopMenu web part
zone again and choose the Navigation -> CSS list menu web part. Set the following properties of the
web part, the rest can be left at their default values:

· Path: /%
· Document types: CMS.MenuItem;CMS.Blog
· Maximum nesting level: 1
· Render CSS classes: enabled
· Use default cache dependencies: enabled

11. The zoneContent web part zone is where content of all the pages will be loaded. To achieve this
behavior, you need to place the Page placeholder web part into the web part zone. Click the Add web

part ( ) icon and choose the General -> Page placeholder web part. You can leave all its properties
at their default values and click OK.
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12. Finally, we will add the Kentico logo into the zoneBottom web part zone. Click the Add web part

( ) icon and choose the General -> Powered by Kentico web part. Replace the value of the Text
property with the following code:

<a href="http://www.kentico.com" title="Kentico CMS for ASP.NET - the WEB 2.0
Content Management System for .NET developers"><img border="0" src="~/
App_Themes/CommunitySite/Images/Powered_by_kentico_cms.gif" alt="This web site
uses Kentico CMS, the content management system for ASP.NET developers." /></a>

Click OK.

13. And that's us finished with the master page. If you switch to the Live site mode now, you should
see the page appear as in the screenshot below. The main menu is not visible yet as there are no
pages defined. The rest of the page is already at its required appearance. Content of all site's pages
will be loaded into the main white zone where the Page placeholder web part resides.
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3.4 Creating the Search page

In the previous chapter, you have defined the master page. In the ninth step, you placed the Search
box web part next to the main menu and set its Search results page URL property to ~/Search.aspx.
This is where the user will be redirected after submitting the search request and where the search
results will be displayed. On this page, users will also be able to perform full-text search with extended
options using the Search dialog with results web part. 

Further information on Kentico CMS Search Engine can be found in Kentico CMS Developer's Guide -
> Search Engine -> Overview.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Page (menu item)
document type. 

http://devnet.kentico.com/docs/devguide/search_engine_overview.htm
http://devnet.kentico.com/docs/devguide/search_engine_overview.htm
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2. Choose to Create a blank page using the Simple layout. For Page name, enter Search and click
Save.
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3. Switch to the Properties -> Template tab and click the Edit template properties link.

4. In the pop-up Page template properties window, switch to the Layout tab and replace the original
layout with the following code:

<div class="subcontentDiv">
<div class="zoneCenterHome">

<cc1:CMSWebPartZone ID="zoneCenter" runat="server" />
</div>
<div class="clear">&nbsp;</div>
</div>
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Click Save.

5. Switch to the Design tab. You should see one web part zone named zoneCenter on the page, just

as you defined by the layout above. Let's add some heading text first. Click the Add web part ( ) icon
of this web part zone and choose the Text -> Static text web part. In the web part properties window,
set the following values. The rest of the properties can be left at the default values:

· Text: <h1 class="header">Search results</h1>

Click OK. 
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6. Displaying search results and the search function itself will be achieved using the Search dialog

with results web part. Click the Add web part ( ) icon  again and choose the Full-text search ->
Search dialog with results web part. In the web part properties window, enter the following values.
The rest of the properties can be left at their default values:

· Paging mode: Postback
· Use default cache dependencies: enabled
· Web part container: Content padding
· Content after: <br/>

Click OK. 

From this moment on, if you switch to the Live site, the page should be fully functional. Try searching
both using the Search box next to the main menu and the Search dialog with results web part. Use
e.g. community as the keyword, since this word is included in two previously uploaded images' names
and the master page's name. You will get the results as in the following screenshot.
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7. We don't want the Search page to be displayed in the main menu. To prevent this, select the page
in CMS Desk and switch to the Properties -> Menu tab. Disable the Show in navigation check-box
and click Save.

8. Finally, we will save the page as a page template so that it can be reused in the future. This is a
good practice to avoid repeating laborious task. Switch to the Edit mode and go to the Properties ->
Template tab. Click the Save as new template link and enter the following details:

· Template display name: My Community Site - Search page
· Template code name: MyCommunitySite.SearchPage
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. The page is now saved as a new page template and can be reused when creating new
pages with similar layout or content.
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3.5 Creating the Logon page

On the Master page, we placed the Sign out button web part and set its Sign in page path property
to /Logon. This is where the user will be redirected in order to sign in. This can also happen in other
cases such as when a user tries to access a section which is available only to authorized users. 

The page will provide the sing-in functionality via the Logon form web part, as well as the possibility to
register for anonymous site visitors, which will be achieved using the Custom registration form web
part. 

Information about the Custom registration form and how you can modify the appearance of the form
can be found in this chapter.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Page (menu item)
document type. 
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2. Choose to Create a blank page using the Simple layout. For Page name, enter Logon page and
click Save.
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3. Switch to the Properties -> Template tab and click the Edit template properties link.

4. In the pop-up Page template properties window, switch to the Layout tab and replace the original
layout with the following code:

<!-- Container -->
<div class="logonReg">

<!-- Left zone -->
<div class="zoneLeft" style="width: 50%; float: left;">

<div style="width: 270px; margin: 30px 0px 10px 90px;">
<cc1:CMSWebPartZone ID="zoneLeft" runat="server" />  

</div>
</div>
<!-- Right zone -->
<div class="zoneRight" style="width: 50%; float: left;">

<div style="width: 280px; margin: 30px auto;">
<cc1:CMSWebPartZone ID="zoneRight" runat="server" />

</div>
</div>

</div>
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Click Save.

5. Switch to the Design tab. You should see two web part zones on the page - zoneLeft and
zoneRight - just as you defined by the layout code above. The left web part zone will host the logon

form, the registration form will be placed in the right one. Click the Add web part ( ) icon of the
zoneLeft web part zone and choose the Membership -> Logon form web part. Set the following
properties of the web part, the rest can be left at their default values:

· Default target URL: ~/Home.aspx
· Web part container: Community Site - Blue Box Light
· Web part container title: Sign in
· Content before: <div style="min-height: 160px;height:auto">
· Content after: </div>

Click OK.

6. User registration will be achieved using the Custom registration form web part. This web part has
no default appearance - the way it will look like is defined by an alternative form of the cms.user
system table. We will use the pre-defined Registration form alternative form. However, you can
customize the alternative form according to your needs, as described here, or even create your own
form a similar way. 

First, click the Add web part ( ) icon of the zoneRight web part zone and choose the Membership -
> Custom registration form web part. Set the following properties of the web part, all other properties
can be left at their default values:
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· Alternative form: cms.user.RegistrationForm
· Redirect to URL: ~/Members/{%CMSContext.CurrentUser.UserName%}.aspx
· Registration error message: There was an error during registration. Please see details below.
· E-mail confirmation page: ~/Special-pages/Registration-approval.aspx
· Web part container: Community Site - Blue Box Light
· Web part container title: Join the community

Click OK.

7. If you switch to the Live site mode, you should see the following appearance of the page.
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8. Switch back to the Edit mode and go to the Properties -> URLs tab. Enter the following details:

· Document alias: Logon
· Document URL path: /Join

Click Save.

9. We don't want the Logon page to be displayed in the menu. Go to the Properties -> Menu tab and
disable the Show in navigation check-box. Click Save.
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10. Finally, we will save the page as a page template for further re-usability. Go to the Properties ->
Template tab and click the Save as new template link. Enter the following details:

· Template display name: My Community Site - Logon Page
· Template code name: MyCommunitySite.LogonPage
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK.
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3.6 Creating the Home page

In this chapter, you will see how to create the Home page. This is the initial landing page - the page
that the site visitors will see at first when they enter the URL of your site into the browser. It is
important to set the alias path of this page in Site Manager -> Settings -> Web site -> Default alias
path, as described here.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Page (menu item)
document type. 
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2. Choose to Create a blank page using the Simple layout. For Page name, enter Home and click
Save.
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3. Switch to the Properties -> Template tab and click the Edit template properties link.

4. In the pop-up Page template properties window, switch to the Layout tab and replace the original
layout with the following code:

<div class="subcontentDiv">
<div class="zoneCenterHomePage">
<div class="centerLeft">

<cc1:CMSWebPartZone ID="zoneCenterLeft" runat="server" />
</div>
<div class="centerRight">

<cc1:CMSWebPartZone ID="zoneCenterRight" runat="server" />
</div>
<div class="clear">&nbsp;</div>

<div class="centerHome">
<div class="left">
<cc1:CMSWebPartZone ID="zoneCenterBottomLeft" runat="server" />
</div>
<div class="right">
<cc1:CMSWebPartZone ID="zoneCenterBottomRight" runat="server" />
</div>
<div class="clear">&nbsp;</div>

</div>

</div>
<div class="zoneRight">

<cc1:CMSWebPartZone ID="zoneRight" runat="server" />
</div>
<div class="clear">&nbsp;</div>
</div>
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Click Save.

5. Switch to the Design tab. You should see an empty page with five web part zones. Let's start with
zoneRight, where the right side column with various info boxes will be placed. Click the Add web part

( ) icon of the zoneRight web part zone and choose the Membership -> Logon miniform web part.
Set the following properties of the web part, leave the rest of them as they are:

· Display to roles: _notauthenticated_
· Logon failure text: Error logging in.
· Web part container: Community Site - Red Box
· Web part container title: Sign in

Click OK. The next web part to add is the handy Shortcuts web part, displaying shortcuts to various

actions and sections depending on the current context. Click the Add web part ( ) icon again,
choose the Community -> Shortcuts web part and click OK. In the web part properties window, set
the following properties:

· Display Join/Leave the group link: disabled
· Display Friendship links: disabled
· Display Add to contact list link: disabled
· Display Add to ignore list link: disabled
· Display manage group link: disabled
· Display Sign in link: disabled

· My messages path: /Members/{%UserName|(encode)true%}/Messages
· My friends path: /Members/{%UserName|(encode)true%}/Friends
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· My invitations path: /Members/{%UserName|(encode)true%}/Invitations
· Sign out path: /Home
· Web part container: Community Site - Red Box
· Web part container title: Shortcuts

Click OK. Let's go on with the scrolling news. This will be the Scrolling text web part set up so that it
displays news from the News section. The News section will be created later on in this guide. Click the 

Add web part ( ) icon again, choose the Listings and viewers -> Scrolling text web part and click
OK. In the web part properties window, set the following properties:

· Path: /News/%
· Document types: CMS.News
· ORDER BY expression: NewsReleaseDate DESC
· Select top N documents: 5
· Transformation: CMS.News.Preview
· Cache dependencies: nodes|{%currentsite.sitename|(tolower)%}|cms.news|all
· Width (px): 150
· Height (px): 150
· Script stop time (milliseconds):4000
· Web part container: Community Site - Blue Box
· Web part container title: Latest News

Leave the rest of the properties at their default values and click OK.

So now we have a web part displaying the latest five news items. Let's have a similar info box
displaying the latest groups. Again, the Groups section is not created yet, but we will get to it later in

this guide. Click the Add web part ( ) icon again, choose the Community -> Groups viewer web
part and click OK. In the web part properties window, set the following properties:

· Disable view state: enabled
· Transformation name: Community.Transformations.GroupsPreviewList
· Show filter: disabled
· ORDER BY condition: GroupCreatedWhen DESC
· No record found text: There are currently no groups.
· Use default cache dependencies: enabled
· Web part container: Community Site - Gray Box
· Web part container title: Latest Groups
· Content after: <div class="clear"></div> <div><a href="~/Groups.aspx">View all</a></div>

Leave the rest of the properties at their default values and click OK.

One more info box to go. This time, it will be displaying three latest registered site users. Click the Add

web part ( ) icon again, choose the Membership -> Users viewer web part and click OK. In the
web part properties window, set the following properties:

· Disable view state: enabled
· Transformation name: Community.Transformations.MembersPreviewList
· No record found text: There are currently no members.
· Show filter: disabled
· ORDER BY condition: UserCreated DESC
· Selected columns: UserID,UserNickName,UserGender,UserDateOfBirth,UserAvatarID,

UserCreated,UserName,AvatarGuid
· Use default cache dependencies: enabled
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· Web part container: Community Site - Gray Box
· Web part container title: Latest Members
· Content after: <div class="clear"></div><div><a href="~/Members.aspx">View all</a></div>

Leave the rest of the properties at their default values and click OK.

That's us finished with the info boxes in this web part zone. However, we will place the sample poll

created in this chapter to the bottom of the web part zone. Click the Add web part ( ) icon for the last
time, choose the Polls -> Poll web part and click OK. In the web part properties window, set the
following properties:

· Poll name: Continents
· Web part container: Community Site - Blue Box
· Web part container title: Poll

Click OK. That's us finished with the zoneRight web part zone. Now we can move on and populate
the other web part zones.

6. We will place the community_home_img.jpg image, which we uploaded earlier in this chapter, to

the zoneCenterRight web part zone. Click the Add web part ( ) icon, choose the Text -> Editable
image web part and click OK. In the web part properties window, set the following properties:

· Alternate text: Community photo

Click OK.

Switch to the Page tab and click the Select link of the Editable image web part.
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Select the file from the content tree and click the Paste image link. Click Save to save the content of
the page.

7. The zoneCenterLeft web part zone will host the welcome text and links for sing-in and registration.

Click the Add web part ( ) icon, choose the Text -> Editable text web part and click OK. You can
left all web part's properties at the default values and click OK.

8. Switch to the Page tab. Using the WYSIWYG editor, try to achieve the same result that you can see
in the screenshot below. You can find detailed description of the WYSIWYG editor's capabilities in 
Kentico CMS Developer's Guide -> Content management -> WYSIWYG editor. However, you can see
the controls that you will use highlighted in the screenshot. 

http://devnet.kentico.com/docs/devguide/wysiwyg_editor_overview.htm


Part 2 159

© 2006 Kentico Software

You will need to write the heading and change its Format to Heading 1. Then you will need to add a
table with one row and two columns. Set the Border size  property of the table to 0. You will insert the
images into the table. Then you will select each of the images and add a hyperlink to the Logon page
to it. Then you will have to select both of the images  in the table and choose the center alignment.
Finally, you will have to type the remaining text and set its Format to Normal.

9. Two web part zones are remaining. In the zoneCenterBottomLeft, we will place a repeater
displaying extracts from the latest blog posts. The Blogs section from that the extracts will be

displayed will be created later in this guide. Click the Add web part ( ) icon, choose the Listings and
viewers -> Repeater web part and click OK. Set the following properties of the web part, leave the
rest of them at their default values:

· Disable view state: enabled
· Path: /Blogs/%
· Document types: CMS.BlogPost
· ORDER BY expression: BlogPostDate DESC
· Select top N documents: 6
· Transformation: Community.Transformations.HomeBlogPostsCenter
· Cache dependencies: nodes|{%CurrentSite.SiteName|(tolower)%}|cms.blogpost|all
· No record found text: There are currently no posts.
· Web part container: Community Site - Blue Box Light
· Web part container title: Latest blog posts

Click OK.

10. Last but not least, we will place a similar repeater to the zoneCenterBottomRight web part zone.
This repeater will be displaying latest forum posts. The Forums section will be created later in this

guide. Click the Add web part ( ) icon, choose the Forums -> Forum posts viewer web part and
click OK. Set the following properties of the web part, leave the rest of them at their default values:

· Disable view state: enabled
· Top N: 6
· Order by: PostTime DESC
· Use default cache dependencies: enabled
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· Web part container: Community Site - Blue Box Light
· Web part container title: Latest forum posts

Click OK.

11. You have just finished creating the Home page. Most of the web parts are not displaying any
content because the related sections of the web are not created yet. However, as you will be creating
these sections further in this guide, you will see the related content appear on the home page. In the 
Design tab, the page should look as in the following screenshot.
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12. The last step is to save the page as a page template for further reusability. Switch to the 
Properties -> Template tab and click the Save as new template link. Enter the following details:

· Template display name: My Community Site - Home page
· Template code name: MyCommunitySite.HomePage
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK.
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3.7 Creating a starter page template

Many pages on the site will have the same layout and contain the same web parts. To prevent
repeating the same development tasks again and again, it is a good practice to create a starter page
template. This template will contain the required layout with two web part zones and three web parts - 
Editable text for heading in zoneLeft web part zone and the Logon mini form and Shortcuts web
parts in zoneRight web part zone. 

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Page (menu item)
document type.
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2. Choose to Create a blank page using the Simple layout. For Page name, enter starter page
template and click Save.
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3. Switch to the Properties -> Template tab and click the Edit template properties link.

4. In the pop-up window, switch to the Layout tab and replace the original layout with the following
code:

<div class="subcontentDiv">
<div class="zoneCenterHome">

<cc1:CMSWebPartZone ID="zoneCenter" runat="server" />
</div>
<div class="zoneRight">

<cc1:CMSWebPartZone ID="zoneRight" runat="server" />
</div>
<div class="clear">&nbsp;</div>
</div>
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Click Save.

5. Switch to the Design tab. You can see a page layout with two web part zones - zoneCenter and
zoneRight. This layout is common to many of pages  that we will create on the site. In the
zoneCenter web part zone, all of the pages will contain a heading, provided by the Editable text web

part. We will add the web part now. Click the Add web part ( ) icon, choose the Text -> Editable
text web part and click OK. In the web part properties window, set the following properties:

· Editable region type: Text box
· Content before: <h1 class="header">
· Content after: </h1>

Click OK.

6. In the zone zoneRight web part zone, two web parts will be common to all the pages. The first of

them will be the Logon mini form. Click the Add web part ( ) icon of the zoneRight web part zone
and choose the Membership -> Logon mini form web part. Set the following properties of the web
part, leave the rest of them as they are:

· Display to roles: _notauthenticated_
· Logon failure text: Error logging in.
· Web part container: Community Site - Red Box
· Web part container title: Sign in

Click OK. 
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7. The next web part common on all the pages is the handy Shortcuts web part, displaying shortcuts

to various actions and sections depending on the current context. Click the Add web part ( ) icon
again, choose the Community -> Shortcuts web part and click OK. In the web part properties
window, set the following properties. Leave the rest of the properties at the default values:

· Display Join/Leave the group link: disabled
· Display Friendship links: disabled
· Display Add to contact list link: disabled
· Display Add to ignore list link: disabled
· Display manage group link: disabled
· Display Sign in link: disabled

· My messages path: /Members/{%UserName|(encode)true%}/Messages
· My friends path: /Members/{%UserName|(encode)true%}/Friends
· My invitations path: /Members/{%UserName|(encode)true%}/Invitations
· Sign out path: /Home
· Web part container: Community Site - Red Box
· Web part container title: Shortcuts

Click OK.

When you are finished, the page in Design tab should look as in the following screenshot.
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8. We will save the page template so that it can be reused later. Switch to the Properties -> Template
tab and click the Save as new template link. Enter the following details into the pop-up dialog:

· Template display name: _StarterTemplate
· Template code name: _StarterTemplate
· Template category: My Community Site templates
· Template description: enter some text describing the page template

Click OK. Click Save.

9. As the page template is now saved, we do not need the page created in this chapter anymore. 
Delete the page from the content tree. The page template will remain saved and can be used in the
future.
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3.8 Creating the Blogs section

3.8.1 Creating the Blogs page

In this part of the guide, we will create the Blogs section. This section will allow users to read blog
posts from any number of blogs. Users will also be able to create a new blog directly on the site, as
well as add new blog posts. Most of this functionality is is achieved using the User contributions
module web part. For more information about the module, please refer to Kentico CMS Developer's
Guide -> Module User contributions. Detailed information about the Blogs module can be found in
Kentico CMS Developer's Guide -> Module Blogs.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Page (menu item)
document type.

http://devnet.kentico.com/docs/devguide/user_contributions_overview.htm
http://devnet.kentico.com/docs/devguide/user_contributions_overview.htm
http://devnet.kentico.com/docs/devguide/module_blogs_overview.htm
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2. We will use the starter page template created in this chapter as the starting point for this page.
Choose the My Community Site templates -> _StarterTemplate. For Page name, enter Blogs and
click Save.
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3. Go to the Properties -> Template tab and click the Save as new template link. Enter the following
details in the pop-up dialog:

· Template display name: My Community Site - Blogs
· Template code name: MyCommunitySite.Blogs
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK.

4. On the same tab, click the Edit template properties link. In the pop-up Page template properties
window, switch to the Layout tab and replace the original layout with the following code:

<div class="subcontentDiv">
<div class="zoneCenterBlog">

<cc1:CMSWebPartZone ID="zoneCenter" runat="server" />
</div>
<div class="zoneRight">

<cc1:CMSWebPartZone ID="zoneRight" runat="server" />
</div>
<div class="clear">&nbsp;</div>
</div>
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Click Save.

5. Switch to the Design tab. You should see two web part zones - zoneLeft and zoneRight - just as
you defined by the layout above. Let's add web parts to the zoneRight web part zone first. 

Below the Shortcuts menu, the Tag cloud web part will be displayed. After clicking a tag in the web
part, users will be redirected to the /Blogs/Blog-posts page, where a list of blog posts tagged with the

clicked tag will be displayed. Click the Add web part ( ) icon again, choose the Tagging &
categories -> Tag cloud web part and click OK. In the web part properties window, set the following
properties:

· Show for document types: CMS.Blog;CMS.MenuItem
· Tag group name: Blogs
· Document list URL: /Blogs/Blog-posts
· Use default cache dependencies: enabled
· Web part container: Community Site - Orange Box
· Web part container title: Tag cloud

Click OK. 

Below the Tag cloud, we will place an info-box displaying links to 3 latest blogs on the site. This will be

achieved using the Repeater web part. Click the Add web part ( ) icon again, choose the Listings
and viewers -> Repeater web part and click OK. In the web part properties window, set the following
properties:

· Web part control ID: LatestBlogs
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· Disable view state: enabled
· Show for document types: CMS.MenuItem
· Path: ./%
· Document types: CMS.Blog
· Select top N documents: 3
· Transformation: Community.Transformations.BlogsListRight
· Cache dependencies: nodes|{%CurrentSite.SiteName|(tolower)%}|cms.blog|all
· Web part container: Community Site - Gray Box
· Web part container title: Recent blogs
· Content after: <a href="~/Blogs/Blog-list.aspx" title="All blogs" class="viewAllBlogs">View all

blogs</a>

Click OK.

Next on is another similar info box. This one will be displaying latest blog comments. Click the Add

web part ( ) icon again, choose the Blogs -> Blogs comments viewer web part and click OK. In
the web part properties window, set the following properties:

· Transformation name: Community.Transformations.BlogComments
· Selected columns: CommentPostDocumentID,CommentDate,CommentUserName,CommentText
· Hide if no record found: disabled
· No record found text: There are currently no comments.
· Use default cache dependencies: enabled
· Web part container: Community Site - Gray Box
· Web part container title: Latest blog comments

Click OK.

The last web part in the right column will be the Posts archive web part. This web part will be
displaying links to the latest blog months. The web part will not be displayed on this page, but only

when a blog, blog month or blog post is displayed. Click the Add web part ( ) icon again, choose the
Blogs ->  Post archive web part and click OK. In the web part properties window, set the following
properties:

· Show for document types: cms.blog;cms.blogmonth;cms.blogpost
· Hide if no record found: disabled
· No record found text: No data in archive.
· Use default cache dependencies: enabled
· Web part container: Community Site - Gray Box
· Web part container title: Post archive

Click OK. 
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The zoneLeft web part zone is finished. You can see the desired appearance in the screenshot below.
Notice that some of the web parts are not displaying any content yet. This is because there is no
content to be displayed yet, but when the content is added, all the web parts should work fine. You will
see later on in this guide.

We will move to the zoneCenter web part zone now. First, let's enter the heading text. Switch to the
Page tab and enter Recent blog posts into the text box representing the web part. Click Save.

The heading that we've just added will be displayed only on the title page. When a content of a blog is
displayed, the heading will be replaced by breadcrumbs of the same size. These breadcrumbs will be

clickable and will indicate the current position in the blogs hierarchy. Click the Add web part ( ) icon
again, choose the Navigation -> Breadcrumbs web part and click OK. In the web part properties
window, set the following properties:

· Show for document types: CMS.BlogMonth;CMS.BlogPost;CMS.Blog
· Starting path: /Blogs
· Class names: CMS.Blog;CMS.BlogMonth;CMS.MenuItem
· Use default cache dependencies: enabled
· Content before: <div class="blogsTopBreadcrumbs">
· Content after: </div>

Click OK.

Now we have the heading ready, so let's get to the three web parts enabling users to edit blog
properties, create blog posts and edit blog posts directly on the live site. As mentioned above, this
functionality will be achieved using the User contributions module web parts.

The first one will be used for blogs editing. Click the Add web part ( ) icon again, choose the User
contributions -> Edit contribution web part and click OK. In the web part properties window, set the
following properties:
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· Web part control ID: EditBlog
· Show for document types: CMS.Blog
· Alternative form name: CMS.Blog.EditBlog
· Edit button label: Edit blog
· Allow delete: disabled
· Content before: <div class="EditPanel">
· Content after: </div>

Click OK.

The second of the User contributions web parts will be used to enable users edit blog posts. Click the 

Add web part ( ) icon again, choose the User contributions -> Edit contribution web part and
click OK. In the web part properties window, set the following properties:

· Web part control ID: EditBlogPost
· Show for document types: CMS.BlogPost
· Alternative form name: CMS.BlogPost.EditBlogPost
· Content before: <div class="EditPanel">
· Content after: </div>

Click OK.

The last of the three User contributions web parts will enable adding of new blog posts. Click the Add

web part ( ) icon again, choose the User contributions -> Edit contribution web part and click OK.
In the web part properties window, set the following properties:

· Web part control ID: NewBlogPost
· Show for document types: CMS.Blog
· Path for new documents: "." (do not include the parentheses, these are only indicating that you

should enter the dot only)
· Allowed new document types: CMS.BlogPost
· Alternative form name: CMS.BlogPost.EditBlogPost
· Display a list of documents: disabled
· New item button label: New blog post
· List button label: My blog posts
· Allow delete: disabled
· Content before: <div class="EditPanel">
· Content after: </div>

Click OK.

Now we will add two repeaters with similar settings. The first repeater will be displayed only on Blog
month documents and will display a list of all blog posts in the month, paged by 5 posts. Click the Add

web part ( ) icon again, choose the Listings and viewers -> Repeater web part and click OK. In the
web part properties window, set the following properties:

· Web part control ID: rptMonthPosts
· Show for document types: cms.blogmonth
· Path: ./%
· Document types: CMS.BlogPost
· Transformation: Community.Transformations.BlogsAllBlogsPosts
· Selected item transformation: Community.Transformations.BlogPostDetail
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· Enable paging: enabled
· Page size: 5
· Cache dependencies: nodes|{%CurrentSite.SiteName|(tolower)%}|cms.blogpost|all

Click OK.

The second repeater will display a list of 5 latest blog posts on the Blogs title page (the page that you
are creating now) and on a particular blog's title page. The repeater will also be used for displaying

particular blog posts. Click the Add web part ( ) icon again, choose the Listings and viewers ->
Repeater web part and click OK. In the web part properties window, set the following properties:

· Web part control ID: rptLatestPostsAllBlogs
· Disable view state: enabled
· Show for document types: CMS.Blog;CMS.BlogPost;CMS.MenuItem
· Path: ./%
· Document types: cms.blogpost
· Order by expression: BlogPostDate DESC
· Select top N documents: 5
· Transformation: Community.Transformations.BlogsAllBlogsPosts
· Selected item transformation: Community.Transformations.BlogPostDetail
· Cache dependencies: nodes|{%CurrentSite.SiteName|(tolower)%}|cms.blogpost|all

Click OK.

Three web parts remaining. The next one will be the Content rating web part. It will be displayed only

for blog posts and will enable users to rate the content of the blog posts. Click the Add web part ( )
icon again, choose the Content rating -> Content  rating web part and click OK. In the web part
properties window, set the following properties:

· Show for document types: CMS.BlogPost
· Content before: <div class="blogContentRating">
· Content after: </div><br />

Click OK.

The Social bookmarking web part will be placed below the Content rating web part and will enable
users to bookmark blog posts via a large number of social bookmarking services. Click the Add web

part ( ) icon again, choose the Community services -> Social bookmarking web part and click OK
. In the web part properties window, set the following properties:

· Show for document types: CMS.BlogPost
· Bookmarking services: enable the check-boxes for all social bookmarking services that you want

to be available
· Content after: <br /><br />

Click OK.

The last web part on the page will also be displayed only for blog posts. It is the Comments view web

part, enabling users to post blog comments and displaying the comments. Click the Add web part ( )
icon again, choose the Blogs -> Comment view web part and click OK. In the web part properties
window, set the following properties:

· Show for document types: CMS.BlogPost
· Check permissions: disabled
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· Comment separator: <div class="PostCommentSeparatorLine">&nbsp;</div>
· Show edit button: enabled
· Enable user pictures: enabled
· User picture width: 66
· User picture height: 66
· Content before: <div class="blogComments">
· Content after: </div>

Click OK. 

In the screenshot below, you can see the desired appearance of the page in Design tab. As
mentioned above, no content is displayed as there is no content (no blogs, no posts, ...) on the site yet.
However, as the site gets populated with content, all web parts should be fully functional.
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3.8.2 Creating the Create page

The Create page is where users are redirected when they want to create a new blog. The page is
accessible via the Shortcuts menu, after clicking the Create a new blog link. In the following
example, you will learn how to create the page. We will use the My Community Site - Blogs page
template created in the   previous chapter so that we don't have to waste time by adding the same web
parts again.

1. Go to CMS Desk, select the Blogs page in the content tree and click the New icon. Choose the
Page (menu item) document type.

2. Choose the My Community Site templates -> My Community Site - Blogs page template. For
Page name, enter Create and click Save.
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3. Now we have the Create page created. It uses the My Community Site - Blogs page template. If
we started making modifications to the page now, the  page template would also get modified, so that
the Blogs page would be modified too. To prevent this, we will have to save the page as a new page
template before the actual modification. Switch to the Properties -> Template tab and click the Save
as new template link. Enter the following details in the pop-up dialog:

· Template display name: My Community Site - Blog creation
· Template code name: MyCommunitySite.BlogCreation
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.
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4. Now switch to the Design tab. Because the page template already contains some web parts that we
will need on the page, we can focus on deleting the not-needed ones first. You can delete a web part
by opening the web part's context menu (down-pointing arrow on the left) and selecting the Remove
command.

From the zoneRight web part zone, delete the Logon miniform, Post archive and Blog comments
viewer web parts. 

5. We will add two more web parts to this web part zone. The first one will be a repeater displaying the

current user's blogs. Click the Add web part ( ) icon of the zoneRight web part zone and choose
the Listings and viewers -> Repeater web part. Set the following properties of the web part, leave the
rest of them as they are:

· Web part control ID: repeaterYourBlogs
· Path: /Blogs/%
· Document types: CMS.Blog
· ORDER BY expression: DocumentCreatedWhen DESC
· WHERE condition: NodeOwner='{%CurrentUser.UserID%}'
· Transformation: Community.Transformations.BlogsListRight
· Use default cache dependencies: enabled
· No record found text: You have currently no blogs.
· Web part container: Community Site - Orange Box
· Web part container title: Your blogs

Click OK.

The second web part that we will add to the zoneRight web part zone is the Users viewer. We will set

it up so that it displays the four most active bloggers on the site. Click the Add web part ( ) icon and
choose the Membership -> Users viewer web part. Set the following properties of the web part, leave
the rest of them as they are:

· Web part control ID: TopBloggers
· Transformation name: Community.Transformations.MembersPreviewList
· Hide if no record found: disabled
· No record found text: There are currently no bloggers.
· Show filter: disabled
· ORDER BY condition: UserBlogPosts DESC
· Select top N members: 4
· Use default cache dependencies: enabled
· Web part container: Community Site - Blue Box
· Web part container title: Top bloggers

Click OK.
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Now that you have the web parts in place and configured, let's just reorder them by dragging and
dropping. In the result, they should be ordered as in the screenshot below:

6. In the zoneCenter web part zone, we will need only the Editable text web part at the top, hence
you can remove all the other web parts in this web part zone. Switch to the Page tab and enter Create
new blog into the web part's text box. Click Save.

7. Switch back to the Design tab. You should see the heading displayed in the appropriate font size.
The rest of the zoneCenter web part zone will host only another Editable text web part displaying

some info text and the New blog web part. Click the Add web part ( ) icon and choose the Text ->
Editable  text web part. You can leave all properties of the web part at their default values and click
OK.
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Switch to the Page tab and enter some info text into the web part's text area. You can use the
following sample text:

You can create your new blog by entering the required details into the fields
below. You will be able to change the entered data later. After submitting these
details, you will be able to edit your blog's properties or start blogging
immediately.

Click Save.

8. Switch back to the Design tab. Let's finish the page by adding its main part - the New blog web

part. Click the Add web part ( ) icon and choose the Blogs -> New blog web part. Set the following
property of the web part, leave the rest at their default values:

· Blog parent path: /Blogs

Click OK. You have just finished creating the blogs creation page. In Design tab, it should look as in
the following screenshot.
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3.8.3 Creating the Blog list page

The Blog list page displays a list of all blogs on the site. This functionality will be achieved using the 
Repeater web part. The page is accessible from the Recent blogs repeater on the Blogs title page, by
clicking the View all blogs link.

1. Go to CMS Desk -> Edit mode, select the Blogs page from the content tree and click New.

2. We will use the page template from the previous chapter so that we can save time by eliminating
adding some identically configured web parts. Choose the My Community Site templates -> My
Community Site - Blog creation page template. For Page name, enter Blog list and click Save.



Part 2 183

© 2006 Kentico Software

3. Switch to the Properties -> Template tab. We will save the page as a new page template so that
the modifications made to this page will not be reflected on the Blog creation page. Click the Save as
new template link and enter the following details in the pop-up dialog:

· Template display name: My Community Site - Blog list
· Template code name: MyCommunitySite.BlogList
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.
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4. Switch to the Design tab. Let's start with zoneRight web part zone. Remove the
repeaterYourBlogPosts and LatestBlogs web parts. These web parts wouldn't make sense in t

Click the Add web part ( ) icon and choose the Membership -> Logon mini form web part. Set the
following properties of the web part, leave the rest of them as they are:

· Display to roles: _notauthenticated_
· Logon failure text: Error logging in.
· Web part container: Community Site - Red box
· Web part container title: Sign in

Click OK. 

Drag and drop the web part to the top of the web part zone, above the Shortcuts box. The web part
zone is ready now and should look as in the screenshot below.

5. Modifying the zoneCenter web part zone will also be a task of a few clicks. Firstly, remove the
DescriptionText and NewBlog web parts so that the only web part remaining is the Editable text for
the heading. 

Now we will add the main part of the page - the repeater for displaying blogs. Click the Add web part (

) icon and choose the Listings and viewers -> Repeater web part. Set the following properties of
the web part, leave the rest of them at the default values:

· Web part control ID: rptListOfBlogs
· Show for document types: CMS.MenuItem
· Path: /Blogs/%
· Document types: CMS.Blog
· Transformation: Community.Transformations.BlogPostDetail
· Selected item transformation: Community.Transformations.BlogPostDetail
· Paging: enabled
· Page size: 5
· Cache dependencies: nodes|{%CurrentSite.SiteName|(tolower)%}|cms.blog|all

Click OK.
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6. Finally, switch to the Page tab and enter Blogs list into the text field of the heading Editable text
web part. Click Save.

In the screenshot below, you can see the desired appearance of the page in Design tab. The page is
not displaying anything yet, because there are no blogs on the site. If you create one, it will be
displayed here.

3.8.4 Creating the Blog posts page

The last page in the Blogs section is the Blog posts page. When a user clicks a tag in the Tag cloud
web part, she is redirected to this page. On the page, all blog posts will be displayed by the Repeater
web part based on a querystring parameter.

1. Go to CMS Desk, select the Blogs page from the content tree and click New. Choose the Page
(menu item) document type.
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2. We will use the page template of the Blog list page created in the previous chapter. The page
template is almost identical, only the settings of the main repeater will be modified. Choose the My
Community Site template -> My Community Site - Blog list page template. For Page name, enter
Blog posts and click Save.

3. View the new page in Page tab. Enter Blog posts into the heading Editable text web part's text box
and click Save.
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4. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details into the pop-up dialog:

· Template display name: My Community Site - Blog posts
· Template code name: MyCommunitySite.BlogPosts
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.

5. Switch to the Design tab. There is the rptListOfBlogs web part already on the page in the
zoneCenter web part zone. It is configured for the purposes of the Blog list page, so we will have to

modify its properties. Click the Configure ( ) icon of the web part and set the following properties:

· Web part control ID: rptBlogPosts
· Show for document types: CMS.Blog;CMS.BlogPost;CMS.MenuItem
· Document types: cms.blogpost
· ORDER BY expression: BlogPostDate DESC
· WHERE condition:

({?tagid|(toint)?} = 0 AND '{?tagname?}'='') OR (DocumentID IN (SELECT
DocumentID FROM CMS_DocumentTag WHERE TagID = {?tagid|(toint)?})) OR (DocumentID
IN (SELECT DocumentID FROM CMS_DocumentTag WHERE TagID IN (SELECT TagID FROM
CMS_Tag WHERE TagName = '{?tagname?}' AND TagGroupID = {?groupid|(toint)?})))
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· Transformation: Community.Transformations.BlogsAllBlogsPosts
· Selected item transformation: clear the value as it wouldn't make sense in this context
· Cache dependencies: nodes|{%CurrentSite.SiteName|(tolower)%}|cms.blogpost|all

Click OK.

The page is now finished. In Design tab, it should look as in the following screenshot: 
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3.9 Creating the News page

The News page will contain a repeater displaying news. News items can be created by users with
access to CMS Desk, typically content editors or site administrators. They are useful for announcing
important information to all site users and visitors. 

Creating the News page will be very simple. We will re-use the starter page template created in this
chapter and add some web parts, mainly the Repeater for displaying news items.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Page (menu item)
document type.
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2. Choose the My Community Site templates -> _SarterTemplate page template. For Page name,
enter News and click Save.

3. View the page in Page tab and enter News into the heading Editable text web part's text box. Click
Save.
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4. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details into the pop-up dialog:

· Template display name: My Community Site - News
· Template code name: MyCommunitySite.News
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.

5. Switch to the Design tab. Firstly, we will add a tag cloud that will display tags from the News tag
group. After clicking a tag, users will be redirected  to this page again, where the repeater in the 
zoneCenter web part zone will display all news items tagged with the clicked tag.Click the Add web

part ( ) icon of the zoneRight web part zone and choose the Tagging & Categories -> Tag cloud
web part. Set the following properties of the web part, leave the rest of them at their default values:

· Show for document types: leave the field empty
· Tag group name: News
· Document list URL: /News
· Use default cache dependencies: enabled
· Web part container: Community Site - Orange Box
· Web part container title: Tag cloud

Click OK.
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6. Now we will add the Content subscription web part to enable users subscribe to receiving

notifications about new news items. Click the Add web part ( ) icon of the zoneRight web part zone
and choose the Notifications -> Content subscription web part. Set the following properties of the
web part, leave the rest of them at their default values:

· Display to roles: _authenticated_
· Path: /News/%
· Document types: CMS.News
· Create event enabled: enabled
· Create event display name: Community news notification
· Create event template name: News notification
· Web part container: Community Site - Blue Box
· Web part container title: News notification

Click OK. The zoneRight web part zone is finished and in Design tab, it should look as in the
screenshot below.

7. Now to the zoneCenter web part zone. The main web part will be a repeater displaying the news

items. Click the Add web part ( ) icon, choose the Listings and viewers -> Repeater web part and
click OK. In the web part properties window, set the following properties:

· Web part control ID: NewsRepeater
· Show for document types: don't enter any value
· Path: /News/%
· Document types: CMS.News
· ORDER BY expression: NewsReleaseDate DESC
· WHERE condition:

({?tagid|(toint)?} = 0) OR (DocumentID IN ( SELECT DocumentID FROM
CMS_DocumentTag WHERE TagID = {?tagid|(toint)?} ))

· Transformation: Community.Transformations.NewsPreview
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· Selected item transformation: Community.Transformations.NewsDetail
· Enable paging: disabled
· Use default cache dependencies: enabled
· Show new button: enabled
· New button text: Add news<br />
· Show Edit and Delete buttons: enabled
· Content before: <div class="newsRepeater">
· Content after: </div>

Click OK.

8. Now let's add the Breadcrumbs web part. This web part will be displayed only when a news item is
displayed, not in the list of news items. When the News item is displayed, the breadcrumbs will make

the heading of the page in format News > Title of the news item.  Click the Add web part ( ) icon of
the zoneRight web part zone and choose the Navigation -> Breadcrumbs web part. Set the following
properties of the web part, leave the rest of them at their default values:

· Show for document types: CMS.News
· Breadcrumb separator: <span class="TitleBreadCrumbSeparator">&nbsp;</span>
· Encode name: disabled
· Use default cache dependencies: enabled
· Web part container: Breadcrumbs box
· Content before: <div class="blogsTopBreadcrumbs">
· Content after: </div>

Click OK and drag-and-drop the web part between the NewsTitle and the NewsRepeater web part.

9. Finally, we will add the possibility to sign up for RSS notifications about new news items. Click the 

Add web part ( ) icon of the zoneRight web part zone and choose the Text -> Static text web part.
Set the following properties of the web part, leave the rest of them at their default values:

· Web part control ID: RSSImage
· Text: 

<br /><a href="~/CMSPages/NewsRss.aspx" style="border:0; padding-left: 10px;
padding-right: 10px;"><img src="~/App_Themes/Default/Images/rss.gif" border="0"
alt="RSS" /></a>
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Click OK. The News page is now ready. You can try out its functionality by adding some news items
under the News page via CMS Desk. The page should display the news items correctly. In Design tab,
the page should look as in the screenshot below.

3.10 Creating the Media page

The Media page will display content of the site's global media library created in this chapter. As you will
see, the page is very easy to create as all the required functionality will be achieved using the Media
gallery web part.

Further information can be found in the Module Media libraries chapter of Kentico CMS Developer's
Guide.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Page (menu item)
document type.

http://devnet.kentico.com/docs/devguide/media_libraries_overview.htm
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2. Enter Media into the Page name field. Select the My Community Site templates ->
_StarterTemplate page template and click Save.
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3. Now we will save the page as a new page template so that the changes made to the page would not
be reflected to the _StarterTemplate. Select the Media page from the content tree, switch to the
Properties -> Template tab and the Save as new template link. Enter the following details into the
pop-up dialog:

· Template display name: My Community Site - Media
· Template code name: MyCommunitySite.Media
· Template category: My Community Site templates
· Template description: enter some text describing the page template

Click OK.

4. The only web part that we need to add is the Media gallery web part. Obviously, it will be placed in

the zoneCenter web part zone. Click the Add web part ( ) icon of the zoneLeft web part zone and
choose the Media library -> Media gallery web part. Set the following properties of the web part,
leave the rest of them as they are:

· Media library: My Community Site Media
· Show subfolders content: enabled
· Use secure links: disabled
· Page size: 8
· Group size: 8
· No record found text: There are no files in the library.

Click OK.
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5. The last step is to change the header text. Switch to the Page tab and enter Media gallery into the
Editable text web part's text field. Click Save.

6. And that's the Media page finished. If you switch to the live site now, you should see the page
displaying content of the previously created sample media library.
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3.11 Creating the Forums section

3.11.1 Creating the Forums page

The forums page will host the site's discussion forums. All the forum content will be displayed by this
single page using the Forum group web part. In order for the page to display some content, there has
to be some forum group defined via the administration interface. 

Before you start creating the page, it is therefore recommended to create one forum group. In this
chapter, you can see how a sample forum group can be created. 

If you needed some more information about the Kentico CMS Forums module, you can find it in 
Kentico CMS Developer's Guide -> Module Forums.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Page (menu item)
document type.

http://devnet.kentico.com/docs/devguide/forum_module_overview.htm
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2. In the following dialog, choose to Create a blank page using the Simple layout. Enter Forums into
the Page name field and click Save.

3. Switch to the Properties -> Template tab and click the Edit template properties link.
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4. In the pop-up window, switch to the Layout tab and replace the layout code with the following code:

<!-- Container -->
<div class="forumSearch">

<cc1:CMSWebPartZone ID="zoneLeft" runat="server" />
</div>

Click Save.

5. Switch to the Design tab. You can see only one web part zone on the page, so let's start adding

web parts to it. First, we need a heading. Click the Add web part ( ) icon of the zoneLeft web part
zone and choose the Text -> Editable text web part. Set the following properties of the web part,
leave the rest of them as they are:

· Web part control ID: editabletextHeader
· Editable region title: Header
· Editable region type: Text box
· Content before: <h1 class="header">
· Content after: </h1>

Click OK.
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6. Switch to the Page tab and enter Forums into the Editable text web part's text box. Click Save.

7. Switch back to the Design tab. Because some forums might be accessible only to authenticated
users, we will add the Logon miniform web part below the heading. It will be displayed only to

unauthenticated anonymous site visitors. Click the Add web part ( ) icon of the zoneLeft web part
zone and choose the Membership -> Logon miniform web part. Set the following properties of the
web part, leave the rest of them as they are:

· Display to roles: _notauthenticated_
· Logon failure text: Error logging in.
· Username text: username
· Content before: <div class="ForumLogonBox">
· Content after: </div>

Click OK.

8. Below the logon mini form, the Forum search box web part will reside. It will enable users to search

in the forum contents. Click the Add web part ( ) icon of the zoneLeft web part zone and choose
the Forums -> Forum search box web part. Set the following properties of the web part, leave the
rest of them as they are:

· Advanced search path: /Forums/Forum-search
· Context search: enabled

· Content before:

<div class="ForumSearchBox">
<table cellspacing="0" cellpadding="0">
<tr><td style="vertical-align:top;padding-top:3px;"><b>Search forums:&nbsp;</
b></td>
<td style="text-align: right">

· Content after: 

</td></tr></table></div><div class="clear"></div>

Click OK.

9. Below the Forum search box, we will place the Forum group web part. In order for it to display any
content, you should have created some sample forum group as mentioned in the beginning of this

chapter. Click the Add web part ( ) icon of the zoneLeft web part zone and choose the Forums ->
Forum group web part. Set the following properties of the web part, leave the rest of them at the
default values:

· Group name: choose your previously created forum group
· Enable favorites: enabled
· Thread view mode: Flat - oldest to newest
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· Allow private messaging: enabled
· Allow friendship request: enabled
· Access denied page URL: ~/Special-pages/Access-denied.aspx
· Use friendly URLs: enabled
· Friendly Base URL: ~/Forums
· Content after: <div style="height: 15px;"></div>

Click OK.

10. Below the Forum group, we will place the Forum search results. The web part will be displaying
results of forum search performed by the Forum search box web part above. Click the Add web part

( ) icon of the zoneLeft web part zone and choose the Forums -> Forum search results web part.
You can leave all properties of the web part at the default values.

11. The last web part on the page is the On-line users web part. We will set it up so that it displays the

number of users who are currently browsing the forums section. Click the Add web part ( ) icon of
the zoneLeft web part zone and choose the Membership -> On-line users web part. Set the
following properties of the web part:

· Transformation name: Community.Transformations.MembersOnline
· Path: /Forums
· Use default cache dependencies: enabled
· Content before: <br />

Click OK.

12. The page is now finished. In Design tab, it should look as in the following screenshot.

13. Finally, we will save the page as a new page template so that it can be reused in the future (we will
use it when creating the Forum search page). Switch to the Properties -> Template tab and click the
Save as new template link. In the pop-up dialog, enter the following details:

· Template display name: My Community Site - Forums
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· Template code name: MyCommunitySite.Forums
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.
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3.11.2 Creating the Forum search page

The Forum search page is accessible from the Forums page, after clicking the Advanced search
link of the Forum search box web part. The page contains the Forum search - advanced dialog
web part which enables searching the forums with extended search criteria. 

1. Go to CMS Desk, select the Forums page from the content tree and click New. Choose the Page
(menu item) document type.
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2. We will use the page template created in the previous chapter as the starting point. Choose the My
Community Site templates -> My Community Site - Forums page template. Enter Forum search
into the Page name field and click Save.
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3. Switch to the Properties -> Template tab and click the Save as new template link. In the pop-up
dialog, enter the following details:

· Template display name: My Community Site - Forum search
· Template code name: MyCommunitySite.ForumSearch
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.

4. Switch to the Design tab. Firstly, delete all web parts so that only the editabletextHeader and
ForumSearchResults web parts remain.
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5. Click the Add web part ( ) icon of the zoneLeft web part zone and choose the Forums -> Forum
search - advanced dialog web part. You can leave all properties of the web part at the default values.
Drag and drop the web part between the other two web parts on the page.

6. Switch to the Page tab and enter Forums advanced search into the Editable text web part's text box.
Click Save.

7. The page is finished. If you view it in Design tab, it should look as in the following screenshot.
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3.12 Creating the Groups section

3.12.1 Creating the Groups page

The Groups page is the title page of the Groups section. Users will see two Groups viewer web parts.
The first one of them will be displaying the groups where the user is a members. The second one will
be displaying all groups sorted from the newest to the oldest, paged by 9 groups. 

If you right-click a group in one of the Groups viewers, you will be offered some actions by a context
menu. This functionality is provided in the transformation and here, you can find a description of how
exactly it is achieved.

In case you needed detailed information about Kentico CMS Groups module, please refer to the 
Module Groups chapter of Kentico CMS Developer's Guide.

1. Select the root of the content tree and click New. Choose the Page (menu item) document type.

http://devnet.kentico.com/docs/devguide/context_menus_in_transformations.htm
http://devnet.kentico.com/docs/devguide/groups_module_overview.htm
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Groups and click Save.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

· Template display name: My Community Site - Groups
· Template code name: MyCommunitySite.Groups
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.

4. Switch to the Design tab. First, we will add another Editable text web part to zoneCenter. This web
part will be displaying a text informing users that they can get context menus with available group-

related actions by right clicking a group. Click the Add web part ( ) icon of the zoneCenter web part
zone and choose the Text -> Editable text web part. You do not need to set any properties of the web
part, just leave all of them at the default values.



Part 2 211

© 2006 Kentico Software

5. Switch to the Page tab. Enter Groups into the first Editable text web part's text field. Into the second
one, enter: Right click the group to get available actions. Click Save.

6. Switch back to the Design tab. We will add the first Groups viewer for displaying the current user's

groups. Click the Add web part ( ) icon of the zoneCenter web part zone and choose the
Community -> Groups viewer web part. Set the following properties of the web part, leave the rest at
the default values.

· Web part control ID: YourGroups
· Display to roles: _authenticated_
· Transformation name: Community.Transformations.GroupsList
· Show filter: disabled
· ORDER BY condition: GroupDisplayName
· WHERE condition: GroupID IN (Select MemberGroupID FROM Community_GroupMember

WHERE MemberUserID = {%currentuser.userid%} AND MemberStatus = 0)
· Selected columns: GroupCreatedWhen,GroupID,GroupName,GroupDisplayName,

GroupDescription,GroupAvatarID, AvatarGuid
· Hide if no record found: disabled
· No record found text: You are not currently in any group.
· Use default cache dependencies: enabled
· Web part container: Community Site - Red Box Light
· Web part container title: Your groups
· Content after: <div class="clear">&nbsp;</div>

Click OK.

7. The second Groups viewer will be displaying all groups ordered from the newest to the oldest,

paged by 9 groups. Click the Add web part ( ) icon of the zoneCenter web part zone and choose
the Community -> Groups viewer web part. Set the following properties of the web part, leave the
rest at the default values.

· Web part control ID: RecentlyAddedGroups
· Display to roles: _authenticated_
· Transformation name: Community.Transformations.GroupsList
· ORDER BY condition: GroupCreatedWhen DESC       
· Selected columns: GroupCreatedWhen,GroupID,GroupName,GroupDisplayName,

GroupDescription,GroupAvatarID,AvatarGuid
· Hide if no record found: disabled
· No record found text: There are no recently added groups at this moment.
· Page size: 9
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· Paging mode: PostBack
· Use default cache dependencies: enabled
· Web part container: Community Site - Blue Box Light
· Web part container title: Recently added groups       
· Content after: <div class="clear">&nbsp;</div> 

8. The page is now finished. In Design tab, it should look as in the following screenshot.

3.12.2 Creating the Create page

On this page, users will be provided with the possibility to create new groups. This is achieved using
the Group registration web part. There will also be the Groups viewer web part in zoneRight, which
will be displaying the latest 5 groups. The page is accessible from the Shortcuts menu, by clicking
the Create a new group link.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)
document type.
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Groups and click Save.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

· Template display name: My Community Site - Groups create
· Template code name: MyCommunitySite.GroupsCreate
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.

4. Switch to the Design tab. Firstly, delete the Logon mini form in zoneRight. We will not need it on
this page as the page is accessible only to authenticated users (the Shortcuts menu doesn't display
the link to unauthenticated users).

5. Now that the Logon mini form is deleted, we will add the Groups viewer below the Shortcuts

menu. Click the Add web part ( ) icon of the zoneRight web part zone and choose the Community
-> Groups viewer web part. Set the following properties of the web part, the rest of them can be left at
the default values:

· Transformation name: Community.Transformations.GroupsPreviewList
· Show filter: disabled
· ORDER BY condition: GroupCreatedWhen DESC
· Select Top N groups: 5
· Hide if no record found: disabled
· No record found text: There are currently no groups.
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· Use default cache dependencies: enabled
· Web part container: Community Site - Blue Box
· Web part container title: Recent groups

Click OK.

6. Let's move on to zoneCenter. First, we will add another Editable text web part for displaying

additional info text. Click the Add web part ( ) icon of the zoneCenter web part zone and choose
the Text -> Editable text web part. You do not need to set any properties of the web part, just leave all
of them at the default values.

7. Below the second Editable text web part, we will add the main web part of this page - the Group

registration web part. Click the Add web part ( ) icon of the zoneCenter web part zone and choose
the Community -> Group registration web part. Set the following properties of the web part, leave
the rest of them at the default values.

· Template source alias path: /Groups/Template
· Template target alias path: /Group-pages
· Text after successful registration: Group has been succesfully registered. <a href="{0}">Click

here to view group profile</a>

Click OK.

8. Switch to the Page tab. Enter Create new group into the first Editable text web part's text field. Into
the second Editable text web part's HTML area, enter the following text: 

By entering the details into the form below, you can create your new user group. Make sure you give
the group a  name and description according to the group's field of interest. It is a good way of
attracting site users with the same interest to join your group.

Click Save.
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9. The page is now finished. In Design tab, it should look as in the following screenshot.

3.12.3 Creating the Management page

On the Management page, group administrators will be able to manage the profile and settings of their
groups. This functionality is provided by the Group profile web part. The page is accessible by clicking
the Manage the group link in the Shortcuts menu. This link is displayed only to group administrators
when viewing the group's profile.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)
document type.
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2. Choose to Create a blank page using the Simple layout. Into the Page name field, enter
Management and click Save.



Kentico CMS Community Site Guide218

© 2006 Kentico Software

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

· Template display name: My Community Site - Groups management
· Template code name: MyCommunitySite.GroupsManagement
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.

4. On the same tab, click the Edit template properties link. In the pop-up window, switch to the
Layout tab and replace the original layout with the following code:

<div class="subcontentDiv">
<div class="forumSearch">

<cc1:CMSWebPartZone ID="zoneCenter" runat="server" />
</div>
<div class="clear">&nbsp;</div>
</div>
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Click Save.

5. Switch to the Properties -> URLs tab and enter /Groups/{GroupName}/Management into the
Document URL path field.
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6. Switch to the Design tab. First, we will add the Group security access web part. This web part
checks if the user has the appropriate permissions for this group and redirects her to the Access
page, which we will create later in this chapter, in case that the permissions are insufficient. Click the

Add web part ( ) icon of the zoneCenter web part zone and choose the Community -> Group
security access web part. You do not need to set any properties of the web part, just leave all of them
at the default values. Click OK.

7. Below the Group securtity access, we will add the Static text web part, which will show the path to

the currently managed group in a form of breadcrumbs. Click the Add web part ( ) icon of the
zoneCenter web part zone and choose the Text -> Static text web part. Set the following properties
of the web part, leave the rest of them at the default values.

· Web part control ID: Breadcrumbs
· Text:

<div class="GroupBreadcrumbs">
<a href="~/Groups.aspx" class="CMSBreadCrumbsLink">Groups</a> <span
class="TitleBreadCrumbSeparator">&nbsp;</span> <a href="~/Groups/{%
CommunityContext.CurrentGroup.GroupName%}.aspx" class="CMSBreadCrumbsLink">{%
CommunityContext.CurrentGroup.GroupDisplayName|(encode)true%}</a> <span
class="TitleBreadCrumbSeparator">&nbsp;</span> <span
class="CMSBreadCrumbsCurrentItem"> {%CMSContext.CurrentDocument.DocumentName|
(encode)true%} </span>
</div>

Click OK.

8. Finally, we will add the Group profile web part. Click the Add web part ( ) icon of the zoneCenter
web part zone and choose the Community -> Group  profile web part. Set the following properties of
the web part, leave the rest of them at the default values.

· Group name: (current group)

Click OK.

9. The page is now finished. In Design tab, it should look as in the following screenshot.
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3.12.4 Creating the Access page

Many of the pages in the Groups section contain the Group security access web part. This web part
checks if the user is permitted to see the content of the page. When a user tries to access such a
page with insufficient permissions, she is redirected to the Access page. Here, a message is displayed
telling that access is not permitted. This message is displayed by the Group security message web
part.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)
document type.

2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Access and click Save.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

· Template display name: My Community Site - Access
· Template code name: MyCommunitySite.Access
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.
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4. Switch to the Properties -> URLs tab. Enter /Groups/{GroupName}/Access into the Document
URL path field and click Save.

5. Switch to the Design tab. First, remove the Editable text web part from zoneCenter. We will add
the Static text web part instead of it. The Static text web part will be set up so that it displays the path

to the page in a form of breadcrumbs. Click the Add web part ( ) icon of the zoneCenter web part
zone and choose the Text -> Static text web part. Set the following properties of the web part, leave
the rest of them at the default values.

· Web part control ID: Breadcrumbs
· Text:

<div class="GroupBreadcrumbs">
<a href="~/Groups.aspx" class="CMSBreadCrumbsLink">Groups</a> <span
class="TitleBreadCrumbSeparator">&nbsp;</span> <a href="~/Groups/{%
CommunityContext.CurrentGroup.GroupName%}.aspx" class="CMSBreadCrumbsLink">{%
CommunityContext.CurrentGroup.GroupDisplayName|(encode)true%}</a> <span
class="TitleBreadCrumbSeparator">&nbsp;</span> <span
class="CMSBreadCrumbsCurrentItem"> Access denied </span>
</div>

Click OK.
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6. The main part of this page is the Group security message web part. The web part will display the

warning message about insufficient permissions. Click the Add web part ( ) icon of the zoneCenter
web part zone and choose the Text -> Static text web part. You do not need to set any properties of
the web part, leave all of them at the default values.

7. The page is finished. In Design tab, it should look as in the following screenshot.

3.12.5 Creating groups starter template

In this example, we will create another starter template. In the Groups section, there will be pages
displaying content of particular groups - group's profile, pages (articles), media libraries, group
members and group forums. All of the pages will contain the same three web parts, so we will create a
starter template with these web parts to facilitate development of these pages. 

The page template will be based on the _StarterTemplate page template created in this chapter.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)
document type.
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter _GroupsTemplate and click Save.



Kentico CMS Community Site Guide226

© 2006 Kentico Software

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

· Template display name: _GroupsTemplate
· Template code name: _GroupsTemplate
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.
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4. Switch to the Design tab. First, we will add the Group links menu into zoneRight web part zone.
The menu will contain links interconnecting particular pages of the currently displayed group like its
forums, media, etc. The menu will be created using the Static text web part. Click the Add web part (

) icon of the zoneRight web part zone and choose the Text -> Static text web part. Set the
following properties of the web part, leave the rest of them at the default values.

· Web part control ID: Links
· Text:

<a href="~/Groups/{%CommunityContext.CurrentGroup.GroupName%}.aspx">Home</
a><br />
<a href="~/Group-pages/{%CommunityContext.CurrentGroup.GroupName%}/Pages.
aspx">Pages</a><br />
<a href="~/Groups/{%CommunityContext.CurrentGroup.GroupName%}/Media-list.
aspx">Media</a><br />
<a href="~/Groups/{%CommunityContext.CurrentGroup.GroupName%}/Members.
aspx">Members</a><br />
<a href="~/Groups/{%CommunityContext.CurrentGroup.GroupName%}/Forums.
aspx">Forums</a><br />

· Web part container: Community Site - Blue Box
· Web part container title: Group links

Click OK.

5. In zoneCenter, you first need to remove the Editable text web part that is already in the template.
Now that zoneCenter is clear, we can add Group security access web part to the top of the web part

zone. Click the Add web part ( ) icon of the zoneCenter web part zone and choose the Community
-> Group security access web part. You do not need to set any properties of the web part. Just use
the default values and click OK.
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6. The page is now finished. In Design tab, it should look as in the following screenshot.

7. Finally, delete the _GroupsTemplate page from the content tree. The page template will remain
saved and available.
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3.12.6 Creating the Profile page

The Profile page displays a profile of a group besed on the {GroupName} wildcard part of the URL,
which gets translated into a query string parameter and is then taken as the current group. More
information about wildcard URLs can be found in this chapter of Kentico CMS Developer's Guide.

The profile is displayed using the Group public profile based on the Community.Group.
DisplayProfile alternative form. You can learn how to modify the alternative form here. 

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)
document type.

2. Select the My Community Site templates -> _GroupsTemplate created in this chapter. Into the
Page name field, enter Profile and click Save.

http://devnet.kentico.com/docs/devguide/wildcard_urls.htm
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

· Template display name: My Community Site - Groups profile
· Template code name: MyCommunitySite.GroupsProfile
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.



Part 2 231

© 2006 Kentico Software

4. Switch to the Properties -> URLs tab. Enter /Groups/{GroupName} into the Document URL path
field and click Save.

5. Switch to the Design tab. We will start with zoneRight web part zone. Below the Group links info
box, we will add two more info boxes. The first one of them will be displaying the current group's

administrators. Click the Add web part ( ) icon of the zoneRight web part zone and choose the
Community ->  Group members viewer web part. Set the following properties of the web part, leave
the rest of them at the default values.

· Web part control ID: GroupMembersAdministrators
· Transformation name: Community.Transformations.MembersPreviewList
· Alternating item transformation name: erase the default value
· Separator transformation name: erase the default value
· Header transformation name: erase the default value
· Footer transformation name: erase the default value
· No record found text: There are currently no administrators.
· Show filter: disabled
· WHERE condition: MemberUserID IN (SELECT UserID FROM CMS_UserRole WHERE RoleID IN

(SELECT RoleID FROM CMS_Role WHERE RoleGroupID = '{%CommunityContext.CurrentGroup.
GroupID%}' AND RoleIsGroupAdministrator = 1))

· Selected columns: UserID,UserNickName,UserGender,UserDateOfBirth,UserAvatarID,
UserCreated,UserName, AvatarGuid

· Use default cache dependencies: enabled
· Web part container: Community Site - Red Box
· Web part container title: Group administrators

Click OK.

6. Below the group administrators, we will add the same Group members viewer web part, but this

one will be displaying the latest 5 approved members of the group. Click the Add web part ( ) icon of
the zoneRight web part zone and choose the Community ->  Group members viewer web part. Set
the following properties of the web part, leave the rest of them at the default values.

· Transformation name: Community.Transformations.MembersPreviewList
· Alternating item transformation name: erase the default value
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· Separator transformation name: erase the default value
· Header transformation name: erase the default value
· Footer transformation name: erase the default value
· No record found text: There are currently no members.
· Show filter: disabled
· ORDER BY condition: MemberApprovedWhen DESC
· Select Top N members: 5
· Selected columns: UserID,UserNickName,UserGender,UserDateOfBirth,UserAvatarID,

UserCreated,UserName, AvatarGUID
· Use default cache dependencies: enabled
· Web part container: Community Site - Red Box
· Web part container title: Group administrators

Click OK.

7. The zoneRight web part zone is finshed, so let's move to zoneCenter. To the top of the web part
zone, we will add a breadcrumbs heading using the Breadcrumbs web part. Click the Add web part (

) icon of the zoneCenter web part zone and choose the Navigation -> Breadcrumbs web part. Set
the following properties of the web part, leave the rest of them at the default values.

· Breadcrumb separator: <span class="TitleBreadCrumbSeparator">&nbsp;</span>
· Use default cache dependencies: enabled
· Content before: <div class="GroupBreadcrumbs">
· Content after: </div>

Click OK.

8. Below the breadcrumbs, we want the group's public profile to be displayed. This can be achieved
using the Group public profile web part, which displays  the group's public profile based on the
specified alternative form. By default, the Community.Group.DisplayProfile alternative form is used.

Click the Add web part ( ) icon of the zoneCenter web part zone and choose the Community ->
Group public profile web part. You do not need to set any properties of the web part. Just use the
default values and click OK.

9. Below the Group public profile, we will add a message board where group administrators will be able

to leave announcements. Click the Add web part ( ) icon of the zoneCenter web part zone and
choose the Community -> Group message board web part. Set the following properties of the web
part, leave the rest of them at the default values.

· Message transformation: Community.Transformations.MessageBoardComments
· No messages text: There are no announcements at this time
· Display name: Group {%CommunityContext.CurrentGroup.GroupDisplayName|(encode)true%}

board
· Access: Only group admin
· Enable subscriptions: enabled
· Board base URL: ~/Groups/{%CommunityContext.CurrentGroup.GroupName%}.aspx
· Web part container: Community Site - Blue Box Light
· Web part container title: Group announcements

Click OK.

10. Now we will add a Group forum posts viewer. This web part will be set so that it will display the 5

latest posts in the group's forums. Click the Add web part ( ) icon of the zoneCenter web part zone
and choose the Community -> Group forum posts viewer web part. Set the following properties of
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the web part, leave the rest of them at the default values.

· Transformation name: Community.Transformations.ForumGroupPostsList
· Top N: 5
· Order by: PostTime DESC
· Selected columns: PostIDPath,PostForumID,PostText,PostTime,PostSubject
· Hide if no record found: disalbed
· No record found text: There are currently no posts.
· Use default cache dependencies: enabled
· Web part container: Community Site - Blue Box Light
· Web part container title: Latest in forums

Click OK.

11. The last web part on the page will be a Repeater displaying articles in the Group pages section.

Click the Add web part ( ) icon of the zoneCenter web part zone and choose the Listings and
viewers -> Repeater web part. Set the following properties of the web part, leave the rest of them at
the default values.

· Web part control ID: MostRecentPages
· Path: /Group-pages/{%CommunityContext.CurrentGroup.GroupName%}/Pages/%
· Document types: CMS.SimpleArticle
· ORDER BY expression: DocumentCreatedWhen DESC
· Transformation: CMS.SimpleArticle.SimplePreview
· Selected item transformation: CMS.SimpleArticle.Default
· Use default cache dependencies: enabled
· Hide if no record found: disabled
· No record found text: There are currently no pages.
· Web part container: Community Site - Blue Box Light
· Web part container title: Most recent pages
· Content before: <div class="GeneralList">
· Content after: </div>

Click OK.
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12. The page is now finished. In Design tab, it should look as in the following screenshot.

3.12.7 Creating the Members page

On the Members page, users of the current group will be displayed. This will be achieved using the 
Group members viewer web part. 

If you right-click a user, you will be offered some actions by a context menu. This functionality is
provided in the transformation and here, you can find a description of how exactly it is achieved.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)
document type.

http://devnet.kentico.com/docs/devguide/context_menus_in_transformations.htm
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2. Select the My Community Site templates -> _GroupsTemplate created in this chapter. Into the
Page name field, enter Members and click Save.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

· Template display name: My Community Site - Group members
· Template code name: MyCommunitySite.GroupsMembers
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.
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4. Switch to the Properties -> URLs tab. Enter /Groups/{GroupName}/Members into the Document
URL path field and click Save.

5. Switch to the Design tab. We can leave zoneRight as it is and go straight to zoneCenter. First, we

will add a breadcrumbs heading using the Static text web part. Click the Add web part ( ) icon of
the zoneCenter web part zone and choose the Text -> Static text web part. Set the following
properties of the web part, leave the rest at the default values.

· Web part control ID: Breadcrumbs
· Text:

<div class="GroupBreadcrumbs">
<a href="~/Groups.aspx" class="CMSBreadCrumbsLink">Groups</a> <span
class="TitleBreadCrumbSeparator">&nbsp;</span> <a href="~/Groups/{%
CommunityContext.CurrentGroup.GroupName%}.aspx" class="CMSBreadCrumbsLink">{%
CommunityContext.CurrentGroup.GroupDisplayName|(encode)true%}</a> <span
class="TitleBreadCrumbSeparator">&nbsp;</span> <span
class="CMSBreadCrumbsCurrentItem"> {%CMSContext.CurrentDocument.DocumentName|
(encode)true%} </span>
</div>

Click OK.

6. Below the heading, it will be useful to add some info text. We will use the Editable text web part for

this purpose. Click the Add web part ( ) icon of the zoneCenter web part zone and choose the Text
-> Editable text web part. You do not need to set any properties of the web part, just leave all of them
at the default values. 

Click OK.

7. Switch to the Page tab and enter the following text into the Editable text web part's text area. 

Bellow you can find list of group members. Right click the user to get available
actions.
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Click Save.

8. Switch back to Design tab. Now we will add the Group members viewer web part, which displays

members of the current group. Click the Add web part ( ) icon of the zoneCenter web part zone and
choose the Community -> Group members viewer web part. Set the following properties of the web
part, leave the default values for the rest of them.

· Transformation name: Community.Transformations.MembersList
· Alternating item transformation name: erase the default value
· Separator transformation name: erase the default value
· Header transformation name: erase the default value
· Footer transformation name: erase the default value
· Selected columns: UserID,UserNickName,UserGender,UserDateOfBirth,UserAvatarID,

UserActivityPoints,UserName, AvatarGuid
· Page size: 9
· Paging mode: PostBack
· Group size: 9
· Use default cache dependencies: enabled
· Web part container: Community Site - Blue Box Light
· Web part container title: All members

Click OK.

9. The page is now finished. In Design tab, it should look as in the following screenshot.
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3.12.8 Creating the Media list page

Groups can have any number of media libraries. Because of this fact, we will create the Media list
page. On this page, a list of all media libraries of the current group will be displayed by the Group
media libraries viewer web part. After clicking a media library, users will be redirected to the Media
page, created  in this chapter, where the content of the library will be displayed.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)
document type.

2. Select the My Community Site templates -> _GroupsTemplate created in this chapter. Into the
Page name field, enter Media list and click Save.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

· Template display name: My Community Site - Media list
· Template code name: MyCommunitySite.MediaList
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.
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4. Switch to the Properties -> URLs tab. Enter /Groups/{GroupName}/Media-list into the Document
URL path field and click Save.

5. Switch to the Design tab. First, we will add a breadcrumbs heading using the Static text web part.

Click the Add web part ( ) icon of the zoneCenter web part zone and choose the Text -> Static text
web part. Set the following properties of the web part, leave the rest at the default values.

· Web part control ID: Breadcrumbs
· Text:

<div class="GroupBreadcrumbs">
<a href="~/Groups.aspx" class="CMSBreadCrumbsLink">Groups</a> <span
class="TitleBreadCrumbSeparator">&nbsp;</span> <a href="~/Groups/{%
CommunityContext.CurrentGroup.GroupName%}.aspx" class="CMSBreadCrumbsLink">{%
CommunityContext.CurrentGroup.GroupDisplayName|(encode)true%}</a> <span
class="TitleBreadCrumbSeparator">&nbsp;</span> <span
class="CMSBreadCrumbsCurrentItem"> Media </span>
</div>

6. Now we will add some info text using the Editable text web part. Click the Add web part ( ) icon of
the zoneCenter web part zone and choose the Text -> Editable text web part. You do not need to set
any properties of the web part, just leave all of them at the default values. 

Click OK.

7. Switch to the Page tab and enter the following text into the Editable text web part's text area.

Bellow you can find list of group media libraries.

Click Save.

8. Switch back to Design tab. We will add the Group media libraries viewer web part. Click the Add

web part ( ) icon of the zoneCenter web part zone and choose the Community -> Group media
libraries viewer web part. Set the following properties of the web part, leave the default values for the
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rest of them.

· Hide if no record found: disabled
· No record found text: There are currently no media libraries.
· Use default cache dependencies: enabled

Click OK.

9. The page is now finished. In Design tab, it should look as in the following screenshot.

3.12.9 Creating the Media page

When a user clicks a media library in a list on the Media list page, created in the previous chapter, she
is redirected to this page where the Media gallery web part displays the content of the selected library.
The name of the library is passed in the {GroupName}/{LibraryName} wildcard part of the URL of this
page. Then it gets translated into a query string parameter and displayed by the Media gallery web part
as the current group.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)
document type.
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2. Select the My Community Site templates -> _GroupsTemplate created in this chapter. Into the
Page name field, enter Media list and click Save.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

· Template display name: My Community Site - Group media
· Template code name: MyCommunitySite.GroupMedia
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.
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4. Switch to the Properties -> URLs tab. Enter /Groups/{GroupName}/{LibraryName} into the
Document URL path field and click Save.

5. Switch to the Design tab. First, we will add a breadcrumbs heading using the Static text web part.

Click the Add web part ( ) icon of the zoneCenter web part zone and choose the Text -> Static text
web part. Set the following properties of the web part, leave the rest at the default values.

· Web part control ID: Breadcrumbs
· Text:

<div class="GroupBreadcrumbs">
<a href="~/Groups.aspx" class="CMSBreadCrumbsLink">Groups</a> <span
class="TitleBreadCrumbSeparator">&nbsp;</span> <a href="~/Groups/{%
CommunityContext.CurrentGroup.GroupName%}.aspx" class="CMSBreadCrumbsLink">{%
CommunityContext.CurrentGroup.GroupDisplayName|(encode)true%}</a> <span
class="TitleBreadCrumbSeparator">&nbsp;</span> <span
class="CMSBreadCrumbsCurrentItem"> {%CMSContext.CurrentDocument.DocumentName|
(encode)true%} </span>
</div>

Click OK.

6. Below the breadcrumbs, we will add another Static text web part. This one will provide a link back

to the list of the group's media libraries. Click the Add web part ( ) icon of the zoneCenter web part
zone and choose the Text -> Static text web part. Set the following properties of the web part, leave
the rest at the default values.

· Web part control ID: BackLink
· Text:

<a style="margin: 20px 0px 0px 98px;" class="MediaBack" href="~/Groups/{%
CommunityContext.CurrentGroup.GroupName%}/Media-List.aspx">Back to libraries</a>

7. The last web part in zoneCenter will be the Media gallery web part. This web part displays content of
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the particular libraries based on the library name passed in query string. Click the Add web part ( )
icon of the zoneCenter web part zone and choose the Media library -> Media gallery web part. Set
the following properties of the web part, leave the rest at the default values.

· Show subfolders content: enabled
· Hide folder tree: enabled
· Content before: <div style="padding: 10px 0px 0px 100px">
· Content after: <div class="clear"></div></div>

Click OK.

8. The page is now finished. In Design tab, it should look as in the following screenshot.

3.12.10 Creating the Forums page

The forums page will provide the group forums functionality using the Group forum list web part. It
will display the content of the group forums based on the {GroupName} wildcard part of the URL. 

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)
document type.
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2. Select the My Community Site templates -> _GroupsTemplate created in this chapter. Into the
Page name field, enter Forums and click Save.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

· Template display name: My Community Site - Group forums
· Template code name: MyCommunitySite.GroupForums
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.
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4. Switch to the Properties -> URLs tab. Enter /Groups/{GroupName}/Forums into the Document
URL path field and click Save.

5. Switch to the Design tab. We will leave zoneRight web part zone as it is and start modifying
zoneCenter right off. First, we will add a breadcrumbs heading using the Static text web part. Click

the Add web part ( ) icon of the zoneCenter web part zone and choose the Text -> Static text web
part. Set the following properties of the web part, leave the rest at the default values.

· Web part control ID: Breadcrumbs
· Text:

<div class="GroupBreadcrumbs">
<a href="~/Groups.aspx" class="CMSBreadCrumbsLink">Groups</a> <span
class="TitleBreadCrumbSeparator">&nbsp;</span> <a href="~/Groups/{%
CommunityContext.CurrentGroup.GroupName%}.aspx" class="CMSBreadCrumbsLink">{%
CommunityContext.CurrentGroup.GroupDisplayName|(encode)true%}</a> <span
class="TitleBreadCrumbSeparator">&nbsp;</span> <span
class="CMSBreadCrumbsCurrentItem"> {%CMSContext.CurrentDocument.DocumentName|
(encode)true%} </span>
</div>

Click OK.

6. Below the breadcrumbs, we will add the Forum search box web part that will enable users to

search the forum content. Click the Add web part ( ) icon of the zoneCenter web part zone and
choose the Forums -> Forum search box web part. Set the following properties of the web part,
leave the rest at the default values.

· Content before: 

<div class="ForumSearchBox"><table cellspacing="0"
cellpadding="0"><tr><td><b>Search forums:&nbsp;</b></td><td>
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· Content after: 

</td></tr></table></div><div class="clear"></div>

Click OK.

7. The forum functionality itself is provided by the Group forum list web part. This is the only web part
that is needed for the whole forums structure, all forum content will be displayed from this page by this

web part. Click the Add web part ( ) icon of the zoneCenter web part zone and choose the
Community -> Group forum list web part. Set the following properties of the web part, leave the rest
at the default values.

· Groups separator: <br />
· Base URL: ~/{%CommunityContext.CurrentGroup.GroupName%}/Forums.aspx
· Unsubscription URL: ~/Special-Pages/Forum-Unsubscribe.aspx

Click OK.

8. In step 6, we added the Forum search box web part to the page. Now we need to add another web
part to the page where the search results will be displayed. This can be achieved by the Group forum

search results web part. Click the Add web part ( ) icon of the zoneCenter web part zone and
choose the Community -> Group forum search results web part. You do not need to set any
properties of the web part, just leave all of them at the default values.

Click OK.

9. The last web part in this web part zone will be the On-line users web part. It will be set up so that it
displays the number of users currently accessing the group's forum section. Click the Add web part (

) icon of the zoneCenter web part zone and choose the Membership -> On-line users web part.
Set the following properties of the web part, leave the rest at the default values.

· Transformation name: Community.Transformations.MembersOnline
· Path: /Groups/{GroupName}/Forums
· Use default cache dependencies: enabled
· Content before: <br />

Click OK.
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10. The page is now finished. In Design tab, it should look as in the following screenshot.

3.12.11 Preparing the Group pages section

3.12.11.1 Creating the Template page

This page is a special one. It will be used as a template for the group pages section, which is created
for each group under a specified page of the content tree, which we will create in this chapter. The
group pages section enables members of a group to create and edit articles related to the group and
displayed within the group's section.

On this page, there will be a Repeater displaying a list of articles of the particular group. This page will
also be used as a master page for the Pages page, which will be displaying the particular articles
placed under it. The Pages page will be created in the following chapter.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)
document type.
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2. Select the My Community Site templates -> _GroupsTemplate created in this chapter. Into the
Page name field, enter Template and click Save.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

· Template display name: My Community Site - Group pages template
· Template code name: MyCommunitySite.GroupPagesTemplate
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.
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4. Still on the Properties tab, click the Edit template properties link. In the pop-up window, scroll
down and check the Show as master template option. Also change the inheritance so that the page
template inherits from Level 0 and Level 2. Click Save in the pop-up window to save the changes and
close it.

5. Switch to the Design tab. First, we will add a breadcrumbs heading using the Breadcrumbs web

part. Click the Add web part ( ) icon of the zoneCenter web part zone and choose the Navigation -
> Breadcrumbs web part. Set the following properties of the web part, leave the rest at the default
values.

· Starting path: /{0}/{1}/
· Breadcrumb separator: <span class="TitleBreadCrumbSeparator">&nbsp;</span>
· Use default cache dependencies: enabled
· Content before:

<div style="padding-left:10px" class="GroupBreadcrumbs">
<a href="~/Groups.aspx" class="CMSBreadCrumbsLink">Groups</a> <span
class="TitleBreadCrumbSeparator">&nbsp;</span> <a href="~/Groups/{%
CommunityContext.CurrentGroup.GroupName%}.aspx" class="CMSBreadCrumbsLink">{%
CommunityContext.CurrentGroup.GroupDisplayName|(encode)true%}</a> <span
class="TitleBreadCrumbSeparator">&nbsp;</span> 

· Content after: </div>

Click OK.
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6. Now we will add a repeater displaying a list of pages of the current group. Click the Add web part (

) icon of the zoneCenter web part zone and choose the Listings and viewers -> Repeater web
part. Set the following properties of the web part, leave the rest at the default values.

· Web part control ID: repeaterPages
· Hide on subpages: enabled
· Path: ./Pages/%
· Document types: CMS.SimpleArticle
· Transformation: CMS.SimpleArticle.SimplePreview
· Use default cache dependencies: enabled
· Hide if no record found: disabled
· No record found text: There are currently no pages.
· Web part container: Community Site - Blue Box Light
· Web part container title: Most recent pages
· Content before: <div class="GeneralList">
· Content after: </div>

Click OK.

7. Finally, we will add the Page placeholder in which the page with the particular article will be

displayed. Click the Add web part ( ) icon of the zoneCenter web part zone and choose the
General -> Page placeholder web part. Leave all the properties of the web part at the default values
and click OK.

8. The page is now finished. In Design tab, it should look as in the following screenshot.

3.12.11.2 Creating the Pages page

This page also serves as the template for the group pages section. It will be copied along with the 
Template page to the specified path on each group's creation to form the group's group pages section.

On the page, there will be a Repeater for displaying the articles. We will also need the User
contributions module web parts providing on-site adding and editing of articles. For more details about
the User contributions concept, please refer to the Module User contributions chapter of Kentico CMS
Developer's Guide. 

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)

http://devnet.kentico.com/docs/devguide/user_contributions_overview.htm
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document type.

2. Select the My Community Site templates -> _GroupsTemplate created in this chapter. Into the
Page name field, enter Pages and click Save.
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3. Switch to the Properties tab and click the Edit template properties link. In the pop-up window,
scroll down and select the inheritance so that the page template inherits from Level 0 and Level 2.
Click Save. 

4. Switch to the Layout tab and replace the original layout code with the following code:

<div class="subcontentDiv">
<div class="contentGroupPages">

<cc1:CMSWebPartZone ID="zoneList" runat="server" />
</div>
</div> 
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Click Save.
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5. Back on the Properties -> Template tab, click the Save as new template link. Enter the following
details in the pop-up window:

· Template display name: My Community Site - Group template - Pages
· Template code name: MyCommunitySite.GroupTemplatePages
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK.

6. Switch to the Design tab. First, we will need the Group security access web part to ensure that

only users with appropriate permissions can access the group pages. Click the Add web part ( )
icon of the zoneList web part zone and choose the Community -> Group security access web part.
You do not need to set any properties of the web part, just leave the default values for all of them.

7. Click the Add web part ( ) icon of the zoneList web part zone and choose the Community ->
Group contribution list web part. Set the following properties of the web part, leave the rest of them
at the default values.

· Hide on subpages: enabled
· Path: ./%
· Path for new documents: ./%
· Allowed new document types: CMS.SimpleArticle
· Alternative form name: PublicSimpleArticle
· Display list of documents: disabled
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· New item button label: New page
· List button label: Pages
· Select only published: disabled
· Allow editing by users: Authenticated

Click OK.

8. Click the Add web part ( ) icon of the zoneList web part zone and choose the Community ->
Group edit contribution web part. Set the following properties of the web part, leave the rest of them
at the default values.

· Show for document types: CMS.SimpleArticle
· Alternative form name: PublicSimpleArticle
· Allow editing by users: Authenticated
· Content before: <div class="Contributions">
· Content after: </div>

Click OK.

9. Finally, we will add a Repeater for displaying the articles. Click the Add web part ( ) icon of the
zoneList web part zone and choose the Listings and  viewers -> Repeater web part. Set the
following properties of the web part, leave the rest of them at the default values.

· Web part control ID: ArticleRepeater
· Path: ./%
· Document types: CMS.SimpleArticle
· Transformation: CMS.SimpleArticle.SimplePreview
· Selected item transformation: CMS.SimpleArticle.Default
· Navigation buttons: None
· Use default cache dependencies: enabled
· Hide if no record found: disabled
· No record found text: There are currently no pages.
· Content before: <br /><div class="GeneralList">
· Content after: </div><br />

Click OK.

10. The page is finished. In Design tab, it should look as in the following screenshot.
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3.12.11.3 Creating the Group pages title page

The Group pages page will not be displayed in the site navigation. It will also not contain any content.
The only purpose of this page it for the group pages sections of particular groups to be placed under it.
It is important to set the alias path of this page in the Template target alias path property of the
Group registration web part, which was added to this page.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Page (menu item)
document type.

2. Choose to Create a blank page using the Simple layout. For Page name, enter Group pages and
click Save.
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3. Switch to the Properties -> Menu tab and disable the Show in navigation option. Click Save.

4. That's the page finished, now you've got to enter its alias path in the site settings and the group
pages of particular groups may be stored under it.
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3.13 Creating the Members section

3.13.1 Creating the Members page

This page will be the title page of the Members section. We will base it on the _StarterTemplate page
template created in this chapter. Besides the web parts from this page template, the page will contain
two Users viewer web parts in the zoneCenter web part zone. The first one will be displaying the 6
most active users of the site. The second one will be displaying all site users, with the pager enabled
and 9 records by page. In zoneRight, there will also be the On-line users web part showing who is
currently on-line.

If you right-click a user in of of the Users viewer, you will be offered some actions by a context menu.
This functionality is provided in the transformation and here, you can find a description of how exactly it
is achieved.

1. Select the root of the content tree and click New. Choose the Page (menu item) document type.

http://devnet.kentico.com/docs/devguide/context_menus_in_transformations.htm
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Members and click Save.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

· Template display name: My Community Site - Members
· Template code name: MyCommunitySite.Members
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.

4. Switch to the Design tab. Click the Add web part ( ) icon of the zoneRight web part zone and
choose the Membership -> On-line users web part. Set the following properties of the web part,
leave the default values for the rest of them:

· Transformation name: Community.Transformations.MembersOnline
· Select top N: 20
· Additional info text: {2} member(s) on-line:<br />
· Use default cache dependencies: enabled
· Web part container: Community Site - Orange Box
· Web part container title: On-line members
· Content after: <div><br /><a href="~/Members/Online.aspx">View all on-line members</a></div>

Click OK.
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5. In the zoneCenter web part zone, we will want an info text displayed above the Users viewers. Click

the Add web part ( ) icon of the zoneCenter web part zone and choose the Text -> Editable text
web part. Set the following properties of the web part, leave the default values for the rest of them:

· Web part control ID: editabletextContent

Click OK.

6. Switch to the Page tab. Enter the following texts into the Editable text web parts' text fields:

· Heading: Members
· Content: Bellow you can find list of site members. Right click the user to get available actions.

Click Save.

7. Now we will add the first Users viewer which will display the 6 most active users. Switch back to

the Design tab. Click the Add web part ( ) icon of the zoneCenter web part zone and choose the
Membership -> Users viewer web part. Set the following properties of the web part, leave the default
values for the rest of them:

· Transformation name: Community.Transformations.MembersList
· Show filter: disabled
· ORDER BY condition: UserActivityPoints DESC
· Select Top N members: 6
· Selected columns: UserID,UserNickName,UserGender,UserDateOfBirth,UserAvatarID,

UserActivityPoints,UserName,AvatarGuid
· Use default cache dependencies: enabled
· Web part container: Community Site - Red Box Light
· Web part container title: Top members
· Content after: <div class="clear">&nbsp;</div>

Click OK.

8. The second repeater will display all site members paged by 9. Click the Add web part ( ) icon of
the zoneCenter web part zone and choose the Membership -> Users viewer web part. Set the
following properties of the web part, leave the default values for the rest of them:

· Web part control ID: AllUsers
· Transformation name: Community.Transformations.MembersList
· Hide if no record found: disabled
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· No record found text: No users found
· Selected columns: UserID,UserNickName,UserGender,UserDateOfBirth,UserAvatarID,

UserActivityPoints,UserName,AvatarGuid
· Page size: 9
· Paging mode: PostBack
· Group size: 9
· Use default cache dependencies: enabled
· Web part container: Community Site - Blue Box Light
· Web part container title: All members
· Content after: <div class="clear">&nbsp;</div>

Click OK.

9. The page is now finished. In Design tab, it should look as in the following screenshot. Obviously,
because there are no users on the site yet, only the Administrator is displayed by the viewers.
However, you may try creating a few users via the administration interface or registering on-site. You
will see the new users listed on this page.
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3.13.2 Creating the Online page

In the previous example, we have put the On-line users web part to the right column. There is a link
added by the Content after property of the web part, leading to this page. On this page, there will be
another On-line users web part, which will display all users that are currently on-line.

1. Select the Members page in the content tree and click New. Choose the Page (menu item)
document type.
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Online and click Save.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

· Template display name: My Community Site - Members Online
· Template code name: MyCommunitySite.MembersOnline
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.

4. Switch to the Page tab and enter Members on-line to the heading Editable text web part's text field.
Click Save.
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5. Switch to the Design tab. Click the Add web part ( ) icon of the zoneCenter web part zone and
choose the Membership -> On-line users web part. Set the following properties of the web part,
leave the default values for the rest of them:

· Use default cache dependencies: enabled

Click OK.

6. The page is now ready. In Design tab, it should look as in the following screenshot.
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3.13.3 Creating the Profile page

On the Profile page, public profiles of users will be displayed based on the wildcard part of the URL.
We will set the page's URL to /Members/{UserName}. This means that if you type <sitename>/
Members/David.aspx into the browser, David will be recognized as the wildcard part of the URL and
David's profile will be displayed by this page.

The profile is displayed using the User public profile web part and is based on the cms.user.
EditProfileCommunity alternative form. You can find more information on how to modify the
alternative form in this chapter.

1. Select the Members page in the content tree and click New. Choose the Page (menu item)
document type.
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Profile and click Save.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

· Template display name: My Community Site - Members Online
· Template code name: MyCommunitySite.MembersOnline
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.
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4. Switch to the Properties -> URLs tab and enter /Members/{UserName} into the Document alias
field. Click Save.

5. Switch to the Design tab. In the zoneRight web part zone, we will want three info boxes - for
displaying the user's friends, blogs and groups. Let's start with the first one. Click the Add web part (

) icon of the zoneRight web part zone and choose the Community -> Friends -> Friends viewer
web part. Set the following properties of the web part, leave the default values for the rest of them:

· Transformation name: Community.Transformations.MembersPreviewList
· No record found text: Currently doesn't have any friends.
· Friend status: Approved
· Show filter: disabled
· Selected columns: UserID,UserNickName,UserGender,UserDateOfBirth,UserAvatarID,

UserCreated,UserName, AvatarGuid
· Use default cache dependencies: enabled
· Web part container: Community Site - Gray Box
· Web part container title: My friends

Click OK.

6. The second info box will be displaying links to the user's blogs. Click the Add web part ( ) icon of
the zoneRight web part zone and choose the Listings and viewers -> Repeater web part. Set the
following properties of the web part, leave the default values for the rest of them:

· Web part control ID: repeaterBlogs
· Path: /Blogs/%
· Document types: CMS.Blog
· ORDER BY expression: DocumentCreatedWhen DESC
· WHERE condition: NodeOwner = '{%SiteContext.CurrentUser.UserID%}'
· Transformation: Community.Transformations.BlogsListRight
· Use default cache dependencies: enabled
· Hide if no record found: disabled
· No record found text: Currently doesn't have any blogs.
· Web part container: Community Site - Orange Box
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· Web part container title: My Blogs

Click OK.

7. The third info box will be displaying the groups where the user is a member. Click the Add web part

( ) icon of the zoneRight web part zone and choose the Community -> Groups viewer web part.
Set the following properties of the web part, leave the default values for the rest of them:

· Transformation name: Community.Transformations.GroupsPreviewList
· Show filter: disabled
· ORDER BY condition: GroupDisplayName ASC
· WHERE condition: GroupID IN (Select MemberGroupID FROM Community_GroupMember

WHERE MemberUserID = '{%SiteContext.CurrentUser.UserID%}' AND MemberStatus = 0)
· Hide if no record found: disabled
· No record found text: Currently is not member of any group.
· Use default cache dependencies: enabled
· Web part container: Communty Site - Gray Box
· Web part container title: My groups

Click OK.

8. In the zoneCenter web part zone, the main web part is the User public profile. Click the Add web

part ( ) icon of the zoneCenter web part zone and choose the Membership -> User public profile
web part. Set the following properties of the web part, leave the default values for the rest of them:

· Apply visibility settings: enabled
· Use visibility settings from: cms.user.EditProfileCommunity

Click OK.

9. Below the user's profile, there will be two message boards. The first one will be used only by the
owner of the profile. This will be where the user can post announcements for the other users. Click the 

Add web part ( ) icon of the zoneCenter web part zone and choose the Message boards ->
Message board web part. Set the following properties of the web part, leave the default values for the
rest of them:

· Web part control ID: MessageBoardAnnouncements
· No messages text: There are currently no announcements.
· Display name: Anouncements of {%SiteContext.CurrentUser.FullName|(encode)true%}
· Message board owner: User message board
· Access: Only Owner
· Enable subscriptions: enabled
· Board base URL: ~/Members/{%SiteContext.CurrentUser.UserName|(encode)true%}.aspx
· Web part container: Community Site - Blue Box Light
· Web part container title: My announcements

Click OK.

10. Below the first message board, there will be another one. This one will be a public board, which
means that anybody can post messages on it. This is where users can leave comments on the user.

Click the Add web part ( ) icon of the zoneCenter web part zone and choose the Message boards
-> Message board web part. Set the following properties of the web part, leave the default values for
the rest of them:
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· Web part control ID: MessageBoardComments
· No messages text: There are currently no comments.
· Display name: Comments on {%SiteContext.CurrentUser.FullName|(encode)true%}
· Message board owner: User message board
· Access: Only authenticated users
· Enable subscriptions: enabled
· Board base URL: ~/Members/{%SiteContext.CurrentUser.UserName|(encode)true%}.aspx
· Web part container: Community Site - Red Box Light
· Web part container title: Comments on me

Click OK.

11. The page is now ready. In Design tab, it should look as in the following screenshot.



Kentico CMS Community Site Guide278

© 2006 Kentico Software

3.13.4 Creating the Members management starter template

Next on in the Members section, we will create a series of five pages that will be used by the users for
their accounts management. All the pages will have three web parts common in the zoneRight web
part zone. These will be info boxes displaying the user's blogs, groups and forum favorites. We will
create a starter page template to facilitate the creation of these pages.

1. Select the Members page in the content tree and click New. Choose the Page (menu item)
document type.
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter members management template and click Save.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

· Template display name: _MembersManagement
· Template code name: MembersManagement
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.
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4. Switch to the Design tab. We will place the three info boxes into the zoneRight web part zone. The

first info box will be displaying links to the user's blogs. Click the Add web part ( ) icon of the
zoneRight web part zone and choose the Listings and viewers -> Repeater web part. Set the
following properties of the web part, leave the default values for the rest of them:

· Web part control ID: BlogsRepeater
· Path: /Blogs/%
· Document types: CMS.Blog
· ORDER BY expression: DocumentCreatedWhen DESC
· WHERE condition: NodeOwner = {%CurrentUser.UserID%}
· Transformation: Community.Transformations.BlogsListRight
· Use default cache dependencies: enabled
· Hide if no record found: disabled
· No record found text: You currently do not have any blogs.
· Web part container: Community Site - Orange Box
· Web part container title: My Blogs

Click OK.

5. The second info box will be displaying the groups where the user is a member. Click the Add web

part ( ) icon of the zoneRight web part zone and choose the Community -> Groups viewer web
part. Set the following properties of the web part, leave the default values for the rest of them:

· Transformation name: Community.Transformations.GroupsPreviewList
· Show filter: disabled
· ORDER BY condition: GroupDisplayName ASC
· WHERE condition: GroupID IN (Select MemberGroupID FROM Community_GroupMember

WHERE MemberUserID = {%currentuser.userid%} AND MemberStatus = 0)
· Hide if no record found: disabled
· No record found text: Currently is not member of any group.
· Use default cache dependencies: enabled
· Web part container: Communty Site - Gray Box
· Web part container title: My groups

Click OK.

6. The last info box will be displaying the user's forum favorites. Click the Add web part ( ) icon of
the zoneRight web part zone and choose the Forums  -> Forum favorites web part. Set the following
properties of the web part, leave the default values for the rest of them:

· Use default cache dependencies: enabled
· Web part container: Community Site - Gray Box
· Web part container title: Forum favorites

Click OK.
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7. That's the page template finished. In Design tab, it should look as in the following screenshot.

10. Finally, you can delete the page created in this example. We will not need it anymore as the page
template is already saved and can be reused.

3.13.5 Creating the Management page

The Management page can be used by site members to manage the details in their public profiles.
This functionality is achieved using the My account web part, based on the cms.user.
EditProfileCommunity alternative form.

1. Select the Members page in the content tree and click New. Choose the Page (menu item)
document type.
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2. Select the My Community Site templates -> _MembersManagement created in this chapter. Into
the Page name field, enter Management and click Save.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

· Template display name: My Community Site - Members management
· Template code name: MyCommunitySite.MembersManagement
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.
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4. Switch to the Properties -> URLs tab. Into the Document URL path field, enter /Members/
{UserName}/Management and click Save.

5. Switch to the Design tab. We will only need to place the My account web part to the zoneCenter

web part zone and set it up properly. Click the Add web part ( ) icon of the zoneCenter web part
zone and choose the Membership -> My account web part. Set the following properties of the web
part, leave the default values for the rest of them:

· Form name: cms.user.EditProfileCommunity
· Allow user to edit field visibility: enabled
· Display my address: disabled
· Display my orders: disabled
· Display my credit: disabled
· Display my subscriptions: disabled
· Display my messages: disabled
· Display my friends: disabled
· Content before: <div class="myAccMenu">
· Content after: </div>

Click OK.
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6. Switch to the Page tab and enter My profile into the heading Editable text web part's text field. Click
Save.

7. The page is now finished. In Design tab, it should look as in the following screenshot.
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3.13.6 Creating the Invitations page

On the Invitations page, users will see their invitations to groups and will be able to manage them. This
functionality will be provided by the My invitations and My sent invitations web parts. The page is
accessible from the Shortcuts menu, by clicking the My invitations link. 

1. Select the Management page in the content tree and click New. Choose the Page (menu item)
document type.
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2. Select the My Community Site templates -> _MembersManagement created in this chapter. Into
the Page name field, enter Invitations and click Save.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

· Template display name: My Community Site - Invitations
· Template code name: My Community Site.Invitations
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.
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4. Switch to the Properties -> URLs tab. Into the Document URL path field, enter /Members/
{UserName}/Invitations and click Save.

5. Switch to the Page tab. Enter My invitations into the Editable text web part's text field and click Save
.

6. Switch to the Design tab. First, we will add the My invitations web part, which will display the user's

received invitations. Click the Add web part ( ) icon of the zoneCenter web part zone and choose
the Community -> My invitations web part. Set the following properties of the web part, leave the
default values for the rest of them:

· Zero rows text: You have currently no invitations.
· Hide control for zero rows: disabled
· Web part container: Community Site - Blue Box Light
· Web part container title: Received invitations

Click OK.

7. The second web part on this page will be displaying the user's sent invitations. Click the Add web

part ( ) icon of the zoneCenter web part zone and choose the Community -> My sent invitations
web part. Set the following properties of the web part, leave the default values for the rest of them:

· Web part container: Community Site - Blue Box Light
· Web part container title: My sent invitations

Click OK.
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8. The page is now finished. In Design tab, it should look as in the following screenshot.

3.13.7 Creating the Messages page

The Messages page will provide users with the functionality of private messaging. The page is
accessible from the Shortcuts menu, by clicking the My messages link. Its main part is the My
Messages web part. For more information on the Messaging module, please refer to Kentico CMS
Developer's Guide -> Module Messaging.

1. Select the Management page in the content tree and click New. Choose the Page (menu item)
document type.

http://devnet.kentico.com/docs/devguide/messaging_module_overview.htm
http://devnet.kentico.com/docs/devguide/messaging_module_overview.htm
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2. Select the My Community Site templates -> _MembersManagement created in this chapter. Into
the Page name field, enter Messages and click Save.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

· Template display name: My Community Site - Messages
· Template code name: My Community Site.Messages
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.
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4. Switch to the Properties -> URLs tab. Into the Document URL path field, enter /Members/
{UserName}/Messages and click Save.

5. Switch to the Page tab. Enter My messages into the Editable text web part's text field and click Save
.
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6. Switch to the Design tab. Here, we will only need to add the My messages web part into the

zoneCenter web part zone. Click the Add web part ( ) icon of the zoneCenter web part zone and
choose the Messaging -> My messages web part. You do not need to set any properties of the web
part, leave all of them at the default values.

7. The page is now finished, in Design tab, it should look as in the following screenshot.
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3.13.8 Creating the Friends page

On the Friends page, users will see an overview of their friends, provided by the Friends viewer web
part. Users will be able to request new friendships from this page too. There will also be a link to the 
Manage friends page which we will create in the following example. Detailed information on the
Friends module can be found in Kentico CMS Developer's Guide -> Module Friends.

1. Select the Management page in the content tree and click New. Choose the Page (menu item)
document type.

http://devnet.kentico.com/docs/devguide/friends_overview.htm
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2. Select the My Community Site templates -> _MembersManagement created in this chapter. Into
the Page name field, enter Friends and click Save.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

· Template display name: My Community Site - Friends
· Template code name: My Community Site.Friends
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.
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4. Switch to the Properties -> URLs tab. Into the Document URL path field, enter /Members/
{UserName}/Friends and click Save.

5. Switch to the Page tab. Enter My friends into the Editable text web part's text field and click Save.

6. Switch to the Design tab. Frist, we will add the Request friendship web part, which will enable

users to request other users' friendship. Click the Add web part ( ) icon of the zoneCenter web part
zone and choose the Community -> Friends -> Request friendship web part. Set only the following
property of the web part, leave the rest at the default values.

· Link text: Add a friend

Click OK.

7. Below, we will place the Static text web part with a link to the Manage friends page. Click the Add

web part ( ) icon of the zoneCenter web part zone and choose the Text -> Static text web part. Set
the following properties of the web part, leave the rest at the default values.

· Web part control ID: ManageFriendsLink
· Text: <span class="ManageFriends"><a href="~/Members/{%UserName|(encode)true%}/Friends/

Manage.aspx">Manage my friends</a></span><br /><br /><br />

Click OK.

8. Finally, we will add the Friends viewer web part, which will display the user's friends. Click the Add

web part ( ) icon of the zoneCenter web part zone and choose the Community -> Friends ->
Friends viewer web part. Set the following properties of the web part, leave the rest at the default
values.

· Transformation name: Community.Transformations.MembersList
· Hide if no record found: diabled
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· No record found text: You currently do not have any friends.
· Friend status: Approved
· Use default cache dependencies: enabled

Click OK.

9. The page is finished. In Design tab, it should look as in the following screenshot.
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3.13.9 Creating the Manage friends page

The Manage friends page, as its name should indicate, will provide users with the friendship
management functionality. It is accessible from the Friends page created in the previous chapter. The
friendship management functionality will be provided by the My friends web part.

1. Select the Management page in the content tree and click New. Choose the Page (menu item)
document type.

2. Select the My Community Site templates -> _MembersManagement created in this chapter. Into
the Page name field, enter Manage friends and click Save.

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:
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· Template display name: My Community Site - Manage friends
· Template code name: My Community Site.ManageFriends
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.
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4. Switch to the Properties -> URLs tab. Into the Document URL path field, enter /Members/
{UserName}/Friends/Manage and click Save.

5. Switch to the Page tab. Enter Manage my friends into the Editable text web part's text field and click
Save.

6. The zoneCenter web part zone will host two web parts. The first one of them will be the Static text

web part with a link leading back to the Friends page. Click the Add web part ( ) icon of the
zoneCenter web part zone and choose the Text -> Static text web part. Set the following properties
of the web part, leave the rest at the default values.

· Web part control ID: BackToFriends
· Text: <span class="ManageFriends"><a href="~/Members/{%UserName|(encode)true%}/Friends.

aspx">&lt; Back to friends</a></span><br /><br /><br />

Click OK.

7. Now we will add the My friends web part used for friends management. Click the Add web part (
) icon of the zoneCenter web part zone and choose the Community -> Friends -> My friends web
part. You do not need to set any properties of the web part. Just leave all of them at the default values
and click OK.
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8. The page is finished. In Design tab, it should look as in the following screenshot.

3.14 Creating the Special pages

3.14.1 Creating the Special pages folder

The special pages section consists of pages that do not display any content. Instead, these pages
contain special web parts for performing actions like user registration approval, unsubscription from
various notifications, acceptation for group invitation, etc.

In the following example, we will create a folder in which the special pages will be stored.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Folder document
type.
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2. Enter Special pages into the Document name filed and click Save.
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3. The folder has been created and the special pages can now be placed under it.

3.14.2 Creating the Access denied page

The first special page will be the Access denied page. This is where users with insufficient permissions
will be redirected after accessing some secured page. The page will contain only an Editable text web
part which will display the access denied message.

1. Select the Special pages folder in the content tree and click New. Choose the Page (menu item)
document type.
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Access denied and click Save.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

· Template display name: My Community Site - Access Denied
· Template code name: MyCommunitySite.AccessDenied
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.
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4. Switch to the Design tab. We will only need to add the Editable text web part into the zoneCenter

web part zone, below the Editable text web part for heading. Click the Add web part ( ) icon of the
zoneCenter web part zone and choose the Text -> Editable text web part. Set the following
properties of the web part. You do not need to set any properties of the web part, just leave all of them
at the default values.

In Design tab, the page should now look as in the following screenshot.
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5. Switch to the Page tab. You can see two editable text regions on the page now - one for heading
and one for the warning text. Enter the following texts into the text areas:

· Heading: Access denied
· Warning text: You're not allowed to access the required page. Please contact the administrator if

you think you should be allowed to access it. 

Click Save. 
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The page is complete. If you view it in Live site mode, you should see the page as in the following
screenshot. Please note that the Logon mini form is displayed only to unauthenticated users.

3.14.3 Creating the Blog unsubscribe page

The Blog unsubscribe page will be used to handle blog post unsubscription requests. Users are able to
subscribe to receiving notifications about new blog comments on a particular blog post. Notification e-
mails contain an unsubscription link leading to this page with the subscription GUID in the query string
parameter. By clicking this link, users can unsubscribe from receiving the notifications. The
unsubscription request is handled by the Blog post unsubscription web part on this page.

In order to for the page to be functional, you need to set its URL in Site Manager -> Settings -> Blogs
-> Blog unsubscription URL, as described in this chapter.

1. Select the Special pages folder in the content tree and click New. Choose the Page (menu item)
document type.
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Blog unsubscribe and click Save.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

· Template display name: My Community Site - Blog unsubscribe
· Template code name: MyCommunitySite.BlogUnsubscribe
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.

4. Switch to the Page tab and enter Blog unsubscribe into the Editable text web part's text box. Click
Save.
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5. Switch to the Design tab. Click the Add web part ( ) icon of the zoneCenter web part zone and
choose the Blogs -> Blog post unsubscription web part. Set the following properties of the web part,
leave the default values for the rest of them:

· Confirmation text: You have been successfully unsubscribed.
· Content before: <h3>
· Content after: </h3><br /><br />

Click OK. The page is now finished and ready to handle the unsubscription requests.

3.14.4 Creating the Board unsubscribe page

This page will be used to handle message board unsubscription requests. There are several message
boards throughout the whole site. Users can subscribe to receiving e-mail notifications about new
messages on a particular board. The notification e-mails contain an unsubscription link leading to this
page. When a user clicks it, she is redirected to this page with the subscription GUID in query string
parameter. On the page, the Message board unsubscription web part will handle the request and
perform unsubscription.

In order to for the page to be functional, you need to set its URL in Site Manager -> Settings ->
Message boards -> Board unsubscription URL, as described in this chapter.
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1. Select the Special pages folder in the content tree and click New. Choose the Page (menu item)
document type.

2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Board unsubscribe and click Save.

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

· Template display name: My Community Site - Board unsubscribe
· Template code name: MyCommunitySite.BoardUnsubscribe
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· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.

4. Switch to the Page tab and enter Blog unsubscribe into the Editable text web part's text box. Click
Save.
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5. Switch to the Design tab. Click the Add web part ( ) icon of the zoneCenter web part zone and
choose the Message board -> Message board unsubscription web part. Set the following
properties of the web part, leave the default values for the rest of them:

· Confirmation text: You have been successfully unsubscribed.
· Content before: <h3>
· Content after: </h3><br /><br />

Click OK. The page is now finished and ready to handle the unsubscription requests.

3.14.5 Creating the Forum unsubscribe page

The last of the unsubscription pages is the Forum unsubscribe page. In the Forums section, users
have the possibility to subscribe to receiving notification e-mails about new posts in a particular forum
thread. The notification e-mails contain unsubscription links leading to this page. The GUID of the
subscription is contained in the querystring parameter. The main part of this page is the Forum
unsubscription web part. When a user clicks the unsubscription link, she is redirected to this page
where the web part handles the unsubscription request. 

In order to for the page to be functional, you need to set its URL in Site Manager -> Settings ->
Forums -> Forum unsubscription URL, as described in this chapter.

1. Select the Special pages folder in the content tree and click New. Choose the Page (menu item)
document type.
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Forum unsubscribe and click Save.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

· Template display name: My Community Site - Forum unsubscribe
· Template code name: MyCommunitySite.ForumUnsubscribe
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.

4. Switch to the Page tab and enter Forum unsubscribe into the Editable text web part's text box. Click
Save.
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5. Switch to the Design tab. Click the Add web part ( ) icon of the zoneCenter web part zone and
choose the Forums -> Forum unsubscription web part. Set the following properties of the web part,
leave the default values for the rest of them:

· Content before: <h3>
· Content after: </h3><br /><br />

Click OK. The page is now finished and ready to handle the unsubscription requests.

3.14.6 Creating the Friend management page

One of the community features in Kentico CMS is the Friends module. It provides users the possibility
of creating social relations - friendships. This special page will contain the Friendship management
web part, which handles the friendship approval or rejection requests.

In order to for the page to be functional, you need to set its alias path in Site Manager -> Settings ->
Community -> Friend management path, as described in this chapter.
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1. Select the Special pages folder in the content tree and click New. Choose the Page (menu item)
document type.
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Friend management and click Save.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

· Template display name: My Community Site - Friend management
· Template code name: MyCommunitySite.FriendManagement
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.
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4. Switch to the Page tab and enter Friend management into the Editable text web part's text box.
Click Save.

5. Switch to the Design tab. Click the Add web part ( ) icon of the zoneCenter web part zone and
choose the Community -> Friends -> Friendship management web part. Set the following
properties of the web part, leave the default values for the rest of them:

· My friends page path: /Members/{%CurrentUser.UserName|(encode)true%}/Friends
· Send notification message: enabled
· Send notification e-mail: enabled
· Content after: <br /><br />

Click OK. The page is now finished and ready to handle the friendship management requests.



Kentico CMS Community Site Guide326

© 2006 Kentico Software

3.14.7 Creating the Invitation acceptation page

This special page is related to Kentico CMS Groups module. Members of a group can send e-mail
invitations to join the group. In the e-mail, there is a link leading to this page with the invitation GUID in
query string parameter. When a user clicks the link, she will be redirected to this page where the 
Group invitation web part handles the invitation and makes the user a member of the group.

In order to for the page to be functional, you need to set its alias path in Site Manager -> Settings ->
Community -> Invitation acceptation path, as described in this chapter.

1. Select the Special pages folder in the content tree and click New. Choose the Page (menu item)
document type.
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Invitation acceptation and click Save.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

· Template display name: My Community Site - Invitation acceptation
· Template code name: MyCommunitySite.InvitationAcceptation
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.

4. Switch to the Page tab and enter Invitation acceptation into the Editable text web part's text box.
Click Save.
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5. Switch to the Design tab. Click the Add web part ( ) icon of the zoneCenter web part zone and
choose the Community -> Group invitation web part. Set the following properties of the web part,
leave the default values for the rest of them:

· Content before: <h3>
· Content after: </h3><br /><br />

Click OK. The page is now finished and ready to handle the invitations.

3.14.8 Creating the Registration approval page

After registration to the page, users don't become members immediately. Instead, an e-mail is sent to
them with the registration approval link. The link is leading to this page and contains the registration
GUID in query string parameter. When the user clicks this link, the Registration e-mail confirmation
web part on this page handles the registration approval request and the user becomes a member.

In order to for the page to be functional, you need to set its URL into E-mail confirmation page
property of the Custom registration form web part, as described in this chapter.
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1. Select the Special pages folder in the content tree and click New. Choose the Page (menu item)
document type.
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Registration approval and click Save.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

· Template display name: My Community Site - Registration approval
· Template code name: MyCommunitySite.Registration approval
· Template category: My Community Site templates
· Template description: some text describing the page template

Click OK. Click Save.
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4. Switch to the Page tab and enter Registration approval into the Editable text web part's text box.
Click Save.

5. Switch to the Design tab. Click the Add web part ( ) icon of the zoneCenter web part zone and
choose the Membership -> Registration e-mail confirmation web part. Set the following properties
of the web part, leave the default values for the rest of them:

· From address: no-reply@mycommunitysite.com
· Administrator e-mail: admin@mycommunitysite.com
· Notify administrator: enabled
· Successful approval text: Your user account is now active. You can sign in using your user name

and password. <a href="~/Logon.aspx" title="Logon page">Click here to continue</a>
· Unsuccessful approval text: Your registration wasn't approved.
· User deleted text: The user account has been already deleted.
· Content after: <br /><br />

Click OK. The page is now finished and ready to handle the registration approval requests.
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3.15 Ordering pages in the content tree

Once all the pages are created, it is a good idea to give them a logical organization in the content tree.
Use the Up and Down buttons to move pages to achieve the same page order as in the screenshot
below.
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3.16 Making the settings

To get the site working, you also have to make several settings in the Site manager -> Settings
section.

1. First, select the name of your site from the Site drop-down list in the top left corner of the page.

1. In Site Manager -> Settings -> Web site, make the following settings. Remember that you need to
uncheck the Inherit from global settings check-box in order to be able to enter values into the fields.

· Default alias path: /Home
· Default culture of the content: English - United States
· Page title prefix: My Community Site
· Exclude documents from search: /Special-Pages/%

Click Save.

2. In Site Manager -> Settings -> Security, make the following settings:

· Check page permissions: No page
· Website logon page URL: ~/Logon.aspx

Click Save.

3. In Site Manager -> Settings -> Blogs, set the following value:

· Blog unsubscription URL: ~/Special-Pages/Blog-Unsubscription.aspx



Kentico CMS Community Site Guide336

© 2006 Kentico Software

Click Save.

4. In Site Manager -> Settings -> Community, enter the following values:

· Group security access denied path: /Groups/{GroupName}/Access
· Group management path: /Groups/{GroupName}/Management
· Group profile path: /Groups/{GroupName}
· Member management path: /Members/{UserName}/Management
· Member profile path: /Members/{UserName}
· Invitation acceptation path: /Special-Pages/Invitation-Acceptation
· Friend management path: /Special-Pages/Friend-Management

Click Save.

5. In Site Manager -> Settings -> Forums, enter the following values:

· Forum unsubscription URL: ~/Special-Pages/Forum-Unsubscribe.aspx
· Forum base URL: ~/Forums.aspx

Click Save.

6. In Site Manager -> Settings -> Message boards, adjust the following property:

· Board unsubscription URL: ~/Special-Pages/Board-Unsubscribe.aspx

Click Save.

7. The settings are done. The whole web site should now be fully functional.
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