Kentico CMS Personal Site Guide 4.1




2 Kentico CMS Personal Site Guide 4.1

Table of Contents

Part | Personal Site Guide 4
R @ 11T o V= PP 4

Part Il Getting Started 6
A Yo [ (T To [ eXo] o1 1T o) ST PPPTPTRO 6
2o (o [To o Ir=W o] (oo N o 11 AU PRSP OPPRPPP 9
SCTIAo [0 [Tq To BT o 1 T0) £o o[- 11 1= oY/ PSR 12

2 o Lo [ 10T i {0 1 o o S 15

Part 1l Adjusting Design 19
1 Changing the theme. ... ... e e e e e s s r e e e e e e e e annenes 19

2 EditiNg CSS StYIESNEELS .....eeeiiii e e e e aa e 23

Part IV Adding web parts 29
Yo (o [ o I (=3¢ ST PPPRUPTN 29

Y22 Ao [ [T To - T o o ] | S PSR 33

Part V Further reading 38

© 2009 Kentico Software






Kentico CMS Personal Site Guide 4.1

11

Personal Site Guide

Overview

Kentico CMS Personal Site allows you to easily run your own personal web site. It comes with several
design templates and you can easily change the graphics.

The Personal Site is built with Kentico CMS and it comes with following features out-of-the box:

e Content editing
e Blogs

e Forums

e Photo Galleries

You can also use other Kentico CMS modules (such as newsletter, polls or forms) as you need.

To learn about other features and capabilities of Kentico CMS, please refer to other Kentico
documentation, such as Kentico CMS Tutorial (http://www.kentico.com/devnet/documentation.aspx).

You can contact our technical support at http://www.kentico.com/Support.aspx.
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2.1

Getting Started

Editing content

In this chapter, you will learn how to change the About text on your web site.

1. Go to CMS Desk -> Content -> Personal Site -> About me.

CMS Desk

Content | My Desk | Tools | Administration
D D @ B ﬁ G Edit Preview Live site
New Delete, Copy Move Up Down @ @ * @

=4 Personal Site

] ?Hv Blog
About Me H Save

Page | Design | Form | Product | Propertes

pell check

g Forums

#-%) Phota Gallery Source | (& 2 |1&:
] Special pages @ B Q@e=a2le
[CR Images = Shyls - | Format

E List

| ¢4

- | Fort

- | Size

Switch to Site Manager

Bl #:B I U 2e|x <

Site: | Perscnal Site % | User: Global Administrator ~ Sign Out

T R

Sign in to CMS Desk. Sign in to CMS Site Manaqger. The default account is administrator with blank password.

it can you find on my web
There isn't much stuff

so far, still working on it.
it you might be interested

Awith my friand P1 this
\summer. Hope to upload more
iphotos in near future.

Documents | Search

Current user: Global Administrator| My details | Sign out

"Tlusion is the first of all pleasures.” - Oscar Wilde.

About Me Forums Photo Gallery
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Getting Started 7

2. Make sure you are on the Page tab and click into the Main text text box. Erase the text from the
text box and enter This the new About me text. Then click Save at the top-left.

Page | Design | Form || Product | Propertes

Spell check
£ [=] Source | (& BR®B &G o M EIB 7 U~ ciZE|==]Es= &
DO =0% 53O
AE Style = | Format |Mommal (DIV) ~ | Font - | Size z T-' %v E @l | @
Jon # so far, stil working on it. | LT o

What you might be interested
fin is my blog from a trip
Jground Europe that we took 1 |

|with my friend PJ this ~
lsummer. Hope to upload more |\ . T
Ephotos in near future. i i x

e LS

My latest blog posts iThis is the new About me text.

6/1/2008 | Destination Madrid

Spain welcomed us with the
entirely Spanish-only
environment. You would think
that they would bother to have
Some signs our announcements
in English at the international

i by, P1 knows

we were able to
find our way out of airport and
take the right bus to our hostel.

’l? Powered by
% KENTICO
CMS

|>

53]
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3. Now switch to the Preview viewing mode. You can see that the About me text has been updated.

| My details | Sign In

"Tusion is the first of all pleasures.” - Oscar W

My Blog About Me Photo Gallery

‘What can you find on my web About Me
site? There isn't much stuff on it o
so far, stil working on it. What you

might be interested in is my blog

from a trip around Europe that we

‘took with my friend PJ this

summer. Hope to upload more

photos in near future.

This is the new About me text.

My latest blog posts

6/1/2008 | Destination Madrid

Spain welcomed us with the
entirely Spanish-only
emvironment, “au would think
that they would bother to have
S0MMe Sighns aur annauncements
in English at the international
airport. Fortunately, PJ knows
little Spanish so we were able to
find our way out of arport and
take the right bus to our hostel,
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2.2 Adding a blog post
In this chapter, you will learn how to add a new post to your blog.

1. Go to CMS Desk -> Content -> Personal Site -> My Blog and click New in the document action
toolbar.

. Site: : Sign out
CMS Desk Cantent | 1y Desk | Tools | Administration Switch to Site Manager Site:| Personal Site | User: Global Administratar

D D @ B ﬁ @ @E(In @Prewew @Lwesne Eust

Mew Delete Copy  Move Up Down

24 Personal site

ere

Page | Design | Form | Fropetties
(-7 My Blog o ? D
About Me H Save _i’a Spell check
Forums

[E3] Photo Gallery
Special pages
Images

Source | [8 RBEE S [# LB #im 7O s <
Oz &S 0IRIo v w5 & H =
|7 st + | Farmat - | Font - | Size - |E Tge Oy [&,

Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password. =

@8

Current user: Global Administrator | My detais | Sign out

My Blog About Me

Forums Photo Gallery

Tags 9
Saying goodbye Europe

airport  Austria bus cuisine i

Czech Republic France Germany

i ikil oste aris, our final destination. Because there’s no upcoming hitchhiking
P final destination. By th hitchhik

—_— trip, the tension etween P1 and me is all gone. I have a friend here,

Ttal, I her tort H '
Shonie - Emai b (EPN=_4 S0 thelast night we spend in his place, drinking wine and using his

Documents | Search

2. Choose Blog post as a new document type.

CMS Desk

Content | My Desk | Tools | Administration
RF-AEEANE AR AR AT |
New || Delete| Copy || Move Up e mEtllt @PI’EVIBW @lee site ELIST

1= Personal Site

= My Blog
- My Blog
: About Me
D New document
: Forums
[©-[-] Photo Gallery
[ [ Special pages Please select new document type:
I+ Images

’_?l Blog maonth
") Blog post

@ Link an existing document
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3. Next, enter information for your new blog post.

e Post title: My new blog post
e Post Summary: Summary of the blog post.
e Post text: The entire text of the blog post.

Then click Save at the top.

My Blog » MyBlog » June 2008

Hj Save and create another

5| Spell check

£ & Sowee | [& BR®E & o o AULIEFIB 7 U % =S| E= &
BeD=0&S5i03l0

‘ Style - | Format | Momal - Font ~ | Size - Ty~ - G ‘ E‘
Posttitle: ‘My new blog post

=
Fost date: 6/27/2008 12:05:25 @RM

Summary of the blog post

Post Summary:

The entire text of the blog post.

Fosttext:
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Getting Started 11

Your new blog post has been added to My Blog.

Current user: Global Administrator | My details | Signout

My Blog About Me Forums Photo Gallery

Tags

My new blog post

airport  Austria bus cuisine e
Czech Republic France Germany

hitchh iking hostel Summary of the blog post.
Italy luggage sacher torte

Slovenia Spain  subway
tourism  traffic  train Posted: 5/18/2009 4:53:46 PM by Global Administrator | with 0 comments

D Recent posts Saying goodbye Europe
U
¥ My new blog post
» Saying goodbye Europe
» Wir sind Berliners [ Paris, our final destination. Because there’s no upcoming hitchhiking
¥ Disappointment in Prague . trip, the tension between PJ and me is all gone. I have a friend here,
¥ Sweetness of loneliness 3 : s0 the last night we spend in his place, drinking wine and using his
computer to look at pictures we've taken during our month in
Europe.

Today, PJ went to do some shopping and we've promised each

£ Syndication other go out have dinner tonight.

rRSS

Posted: 7/5/2008 1:56:04 PM by Abigail Woodwarth | with 3 comments
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2.3

Adding a photo gallery

Kentico CMS Personal Site Guide 4.1

In this chapter, you will learn how to add the new photo gallery and upload some photos.

1. Go to CMS Desk -> Content -> Personal Site -> Photo Gallery and click New in the document
action toolbar.

2. Choose Image gallery as a new document type.

FPhoto Gallery

D New document

Please select new document type:

) Article

7 Blog

l Cell phone

E Event (booking svstem!
@ £40

o Eile

Falder

Images gallery

4 Job opening

< Knowledge base article
E‘ Laptop

Page (menu item)

O eoa
<&, Press release
B Product
[£) simple article

@ Link an existing document
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Getting Started 13

3. Enter New gallery into the Name text box and click Browse ... . Choose some Teaser image. Then
click Save at the top.

0

pell check

H Save bj Save and create another

Name: Mew gallery

Description:

Teaser image: Upload: [C:\Documents and Setting[ Browse... |
Publish from: | | Naw

Publish to: | | Naw

[ create a new product

4. Now, go to Properties -> Template and click Select to choose template to use. Choose Personal
Site\Personal Site - Photo Gallery. Click Save at the top.

Page Design Form Product Properties

General
b 2

Template
Metadata
Menu Template: |F'ersona| Site - Photo Gallery H Select.
Workflow ;{‘P Save as new template...
e @ Inhertternpiate
Related docs .
e Clone as ad-hoc template
Linked docs
. [T] Edittemplate properties

Inherit content:
® Use page template settings

) Do natinherit any content
O Select inherited levels

© 2009 Kentico Software
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5. Your new gallery is ready. All you have to do is to add some pictures into your new created gallery.
Make sure New gallery is selected in the content tree and click New in the document action toolbar.
Choose File as the new document type.

D New document

Please select new document type:

 File

= Page (menu item)

@ Link an existing document

6. Click the Upload file () icon and choose a picture to upload.

H Save L!ij Save and create another

Upload file: Upload file

Spell check

File description:

Then enter The description of the first picture. into the File description text box and click Save at the
top.

Spell check

H Save Hj Save and create another

Actions Update Name Size

Upload file: ]
B %) = waterfallipg 281 kB

The description of the first picture.

File description:

© 2009 Kentico Software
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Congratulations, you've just learned how to create a new gallery and add some pictures into it.

| My detais | Sign In

"Tusion is the first of all pleasures.” - Oscar Wide

My Blog About Me Photo Gallery

About my photos List of galleries

Alright, let’s be clear on this. In these galleries, you can find pictures I took in past few months. I'm planning to upload
more picturas in near future.

I'm far from being 3 professional

photographer. Therefore, if you're European Tri

looking for mesmerzing pictures, T P P

advise you to search somewhere N ,
ale. = Sat of pictures, we've taken on our hitchhiking trip around

Europe with my friend P1. Additional pictures are to come.

Sweet Home Arizona

Nothing compares to smell of desert after moonson rain.
Nothing compares to nd of coyote howling at the Moon.
Mothing compares to view of blossoming saguaro.

Nothing compares to Arizona.

New gallery

Please note that you can take advantage of the File Import module to upload more images and files.
The File Import module can be found at CMS Desk -> Tools -> File import.

2.4  Adding forum

In this chapter you will learn how to create a new forum, create new thread and post a message.

1. Go to CMS Desk -> Tools -> Forums and click Edit next to the My Forums group.

CMS Desk Content | My Desk | Tools | Administration
5)-Tools
. [E] BizForms &3 Forum groups
.- i Booking system
.. ¥y Content staging 83 Add forum group
il E-commerce
..[fy File import
: 3 FI < Impo Actions Group name
....83 Forums
{5 Newsletter € & B wyFoums
.. Polls
- Reporting _ »
G Web Analytics @ Posts waiting for my approval

© 2009 Kentico Software
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2. In the Forum group properties, click Add forum & Add forum

3. Add the following information for the new forum:

e Forum display name: New forum

e Forum code name: newForum

e Description: The description of the new forum.

Then click OK.

Forums || General | View

& New forum

Forums » Mew forum

Forum display name: Mew forum

Faorum code name: newForum
The description of the new
forum.

Description:

Forum base URL:
Inherit from forum group
Forum unsubscription URL:

Inherit from forum group

Forum s open
Forumis moderated O
Require e-mail addresses: O
Display e-mail addresses: O
Enable WYSIWYG editor: O

Use security code (CAPTCHA): [

© 2009 Kentico Software



Getting Started 17

4. The forum has been added as you can see in the following screenshot.

| My details | Sign In

"Tusion is the first of all pleasures.” - Os:

About Me Forums Photo Gallery
Forums

Forum Threads Posts Last post

My Forums

i
Goodbye party (5/28/2008 3:57:25 PM)

New forum

administrator
The description of the new forum. (7/7/2008 1:57:32 PM)

Where to go in Europe

Kate
(5i22/2008 8:16:15 PM)

© 2009 Kentico Software
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3 Adjusting Design

3.1  Changing the theme

The sample Personal Site comes with several predefined CSS stylesheets. In this chapter, you will
learn which stylesheets are available and how you can choose the CSS stylesheet you want to use on
your web site.

To choose the CSS stylesheet for your website, go to CMS Site Manager -> Sites and click Edit site
next to the Personal Site.

CMS Site Manager

Sites Administration Settings Development Licenses Support

g) Sites

@ New site wizard @ Import site or ohiects .& Export objects

Actions Site name Status
&\.4 R ? @ [b \:. Corporate Site Stopped
L 4 ? @ [b \:. E-commerce site Stopped
@ el @ PersonalSite Running

© 2009 Kentico Software
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In the Site Properties, choose your CSS stylesheet from the Site CSS stylesheet drop-down list.

CMS Site Manager Sites | Administration Settings Development

0 Site Properties

Sites » PersonalSite

General | Domain aliases | Cultures

Site display name: |F'ersnnal Site |
Site code name: |F'ersnna|8ite |
Site damain name: |Inca|hust |
Default content culture: gnglish - United States

Default visitor culture: |(Aut0mati|:} "|
Site CSS stylesheet  |RETEISCEE I—
Editor CSS stylesheet | Parsonal Site v
Site description: Sample personal web =site

Licenses

Support

© 2009 Kentico Software
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The following CSS stylesheets are available in the sample Personal Site:

Personal Site

[ lEen

Tags

airport  Austria bus  cuisine
Czech Republic Frante Germany
hitchhiking hostel
Ttaly luggage sacher borte
Slovenia Spain  subway
tourism  traffic train

[ Recent posts

} Saying goodbye Europe

» Wir sind Berliners

} Disappointment in Prague
» Sweetness of loneliness

¥+ Sacher torte and Austrian
capital

£ Syndication
FRSS

Personal Site - Blue

| 1y detais |

My Blog aAbout Me Forums Photo Gallery

,] Saying goodbye Europe

U

Paris, our final destination. Because there’s no upcoming hitchhiking
trip, the tension between P and me is all gone. T have a friend here,
so the last night we spend in his place, drinking wine and using his
computer to look at pictures we’ve taken during our month in
Europe.

Today, P1went to do some shopping and we've promised each
other go out have dinner tonight.

Posted: 7/5/2008 1:56:04 PM by Abigail Woodwarth | with 3 comments

Wir sind Berliners
J

Berlin, after along time the city we both wanted to see. And as we're
almost done with our trip, we're getting much more relaxed in
comparison with just week ago. We are almost able to joke with
eath other again. We don't have much money left, though, so we're
mostly hanging around, considering every Euro, spent for the gallery
ticket.

| My details |

Personal starter site

"Th

» airpart * Austria » bus » cuisine
¥ Czech Republic * France

» Germany * hitchhiking

» hostel » 1taly ¥ luggage P sacher

torte b Slovenia » SPain » subway
¥ tourism  traffic  train

£ Recent posts

» Saying goodbye Europe

» Wir sind Berliners

» Disappointment in Prague
» Sweetness of loneliness

» Sacher torte and Austrian
capital

E) syndication
»RSS

My Blog About Me Forums Photo Gallery

J Saying goodbye Europe

sothe last nlght we spend in his place, drmkmg wine and usmg his
computer to look at pictures we’ve taken during our month in
Europe.

Taday, PJ went ta do some shapping and we've promised each
other go out have dinner tonight.

Posted: 7/5/2008 1:56:04 P by Abigail Woodwarth | with 3 comments

T Wir sind Berliners
)

Berlin, after a long time the city we both wanted to see. And as we're
almost done with our krip, we're gebting much more relaxed in
comparison with just week ago. We are almost able to joke with
each other again. We don’t have much money left, though, so we're
mostly hanging around, considering every Euro, spent for the gallery
ticket.

21
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Personal Site - Green

| My details |

—

¢ MyBlog 3§ AboutMe ¥ Forums % PhotoGallery

Tags .

Saying goodbye Europe
¥ airport ¥ Austria * bus ¥ cuisine
b C2ech Republic » France
+Germany * hitchhiking
+hostel » Italy * luggage * sacher
torte * Slovenia * Spain » subway
b tourism b traffic b train

our final destination. Because there’s no upcoming
trip, the tension between PJ and me is all gone. I have a friend here,
so the last night we spend in his place, drinking wine and using his
computer to look at pictures we‘ve taken during our month in
Europe.

Today, P went to do some shopping and we've promised each
other go out have dinner tonight.

) Recent posts Posted: 7/5/2008 1:56:04 PM by Abigail Woodwarth | with 3 comments
» Saying goodbye Europe

» Wir sind Berliners

» Disappointment i

» Sweetness of loneliness

¥ Sacher torte and Austrian

capital J Wir sind Berliners

E‘ . Berlin, after along time the city we both wanted to see. And as we're

B syndication almast done with our trip, we're getting much mare relaxed in

\Rss comparison with just weck ago. We are almost able ta joke with
each other again. We don't have much money left, though, so we're

mastly hanging around, considering every Euro, spent for the gallery

ticket.

Personal Site - Red

| My details |

Personal starter site

"llusicn is the first of all pleasures.” - Oscar Wilde,

My Blog Forums Photo Gallery

Tags

Saying goodbye Europe
¥ airport * Austria » bus » o
¥ Czech Republic * France

» ermany * hitchhiking Paris, our final destination. Because there’s no upcoming hitchhiking

» hostel » Ttaly * I > h trip, the tension between PJ and me is all gone. I have a friend here,
e T % 4 50 the last night we spend in his place, drinking wine and using his

torte P Slovenia * Spain b subway computer to look at pictures we’ve taken during our month in

¥ tourism b traffic ¥ train o R Europe.

Today, P] went to do some shopping and we've promised each
other go out have dinner tonight.

{1 Recent posts Posted: 7/5/2008 1:56:04 PM by Abigail Waodwarth | with 3 comments

rs goodbye Europe

» Wir sind Berliners

» Disappointment in Prague

» Sweetness of loneliness

» Sacher torte and Austrian

capital J Wir sind Berliners

= N Berlin, after a long time the city we both wanted to see. And as we're

Ell Syndication almost done with our trip, we're getting much more relaxed in

+ RES comparison with just week ago. We are almost able to joke with
each other again. We don’t have much money left, thaugh, so we're

mostly hanging around, considering every Euro, spent for the gallery

ticket.
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3.2  Editing CSS stylesheets

In this chapter, you will learn how to change the design of your web site by modifying the CSS
stylesheets.

Changing the header picture

1. Go to CMS Site Manager -> Development -> CSS stylesheets, click Edit next to Personal Site
and choose Main styles -> Master page section in the text box on the left side.

CMS Site Manager

Switch to CMS Desk  User: Global Administrator  Sign Out
Sites | Administration | Settinge | Development | Licenses | Support Switch to CMS Desk  User: Global Administrator  Sig

(=) Development

4055 stylesheats j CS8 stylesheet properties

@ Countries 38 stileshests » Personal Sits

@ Cultures

g Document types General | Sites

o) E-mail templates

.. Form controls s 4 checkouttofie

i.[Z) Inline controls

B _sMudules Check outthe stylesheetto file clinetpubh icoCMSICMSC \Persor ite.css to editthe stylesheet externally.

[T Page layouts

@ Page templates Stylesheet display 3 s
:.=3 Relationship names name: ersonal Sits
i) System tables

2 UI cultures

Veb part containers
L Farums
B Global
* [3@) web templates wi :

g Workflows

Stylesheetcode name:  |PersonalSite

in styles/Mascer pages=/ | ||Blogs

Boxes

Logon page

Main styles
Left menu

| Masterpage |
Membership top zone
Search box
Top menu

My profile

Photogallery

Search page

Styleshest text

r1(../Bpp Themes/PerscnalSite/Images/bg head.ipg)

2. Inthe .zoneTop style, change the url of the background image to ../App_Themes/
PersonalSiteGreen/Images/bg_head.jpg so that the entire style reads as follows:

-zoneTop
{ _

height: 239px;

width: 795px;

background-color: #fff;

padding: Opx Opx 7px;

margin: Opx Opx Opx;

background: #Ffff url(../App_Themes/PersonalSiteGreen/Images/bg_head. jpg)
no-repeat top left;

Then click Save at the top-left.

© 2009 Kentico Software
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3. Now click Sign out at the top-right. You can see that the header image has been changed.

| My details |

e MyBog | AboutMe | Foms | PhotoGallry

Tags o

Saying goodbye Europe
airport  Austria bus cuisine U
Czech Republic Frante Germany
I'l itCh hiking hostel > Paris, our final destination. Because there’s no upcoming hitchhiking
Taly luggage sacher torte - trip, the tension between P and me is all gone. T have a friend here,
Slovenia  Spain _ subswa E so the last night we spend in his place, drinking wine and using his
e et 7 F computer to look at pictures we’ve taken during our month in

gt Europe.

Today, P went to do some shopping and we've promised each
other go out have dinner tonight.

Recent posts
8] P Posted: 7/5/2008 1:56:04 PM by Abigail Woodwarth | with 3 comments

} Saying goodbye Europe
+ Wir sind Betliners

+ Disappointment in Prague

} Sweetness of loneliness

» Sacher torte and Austrian

capital U Wir sind Berliners

o - Berlin, after a long ime the city we both wanted to see. And as we're
Ll Syndication almost done with our trip, we're getting much more relased in
+RSS comparison with just week ago. We are almost able to joke with
each other again. We don’t have much money left, though, so we're
mostly hanging around, considering every Euro, spent for the gallery
ticket.

Changing the top menu

1. Go to CMS Site Manager -> Development -> CSS stylesheets and choose Main styles/Master
page section in the text box on the left side.

© 2009 Kentico Software
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2. Scroll down to see .zoneTopMenu style.

CMS Site Manager on | Settings | Devel Licenses | Support | Buy SN userclobaiacninistsion ISEREEY
) D.eue‘op‘“e”t 5 CS8S stylesheet properties
i 4 55 stylesheets
- @ Countries CSS stilesheets » Personal Site
4@ Cultures
i@ Document types General | sites
(23 E-mail templates -
‘... Form controls HM ’_'j Check outto file
i [Enline controls
ESMndules Check outthe stylesheet to file ciiinetpubh T OCMSICMSC \Persor css to editthe stylesheet externally.

[[JPage layouts

H & Page templates Stylesheetdisplay
+...m@ Relationship names name

* ] System tables
@) UI cultures

|Fersuna\ Site ‘

Stylesheet code name |Persnna\Sne ‘

eb part containers f:r,t.—we;;‘::iﬂr,:rrra,; #||Blogs
font-size: 32px; Forums
: eb parts margin-top:0px; Global
i..[@) Web templates 1 Boxes
g Workflows Logon page
= || Main styles
: Left menu

R _ Membership top zone
./Bpp_Thnemes/PersonalSite/Images/bg_topmenu.gd Search box

Top menu
Stylsshesttsxt s : gﬁ;i’ﬂ’;@ﬁew

Search page

.DesignMode .zon=TopMenu

height: 120px;

1

.zoneBottom

3. Change the background color to #B0OC4DE and erase the URL part so that the entire section reads
as follows:

-zoneTopMenu
{
height: 43px;
width: 795px;
background: #BOC4DE;
padding: Opx;
margin: Opx;

This will change the background of the navigation at the top to dark blue.
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4. Now, switch to the Top menu section and find .CMSListMenuLl a:hover style. This style modifies
the appearance of menu item when mouse is over it.

CMS Site Manager

Swj S Des : Adminis Sign Out
Sites | Administration | Settings | Development | Licenses | Support | Buy Switch to WS Desk  User: Glabal Administratar AT
2 Development N

. CSS stylesheet properties

i 4 55 stylesheets ‘5 ty prop

i@ Countries CSS stilesheets » Persanal Site

4@ Cultures

i@ Document types General | Sites .

i (2) E-mail templates

.. Form controls H Save 9 Check outto file

* [ Inline controls

srr'\odules Check outthe stylesheet to file ciiinetpubh T oCMSICMSC \Persor css to editthe stylesheet externally.

[[JPage layouts

H & Page templates Stylesheetdisplay P 'S

i@ Relationship names name ersonal Site

- [l system tables Stylesheet code name:  |PersonalSite

@ UI cultures
Web part containers #||Blogs
& Web parts .CM5ListMenulink, istMenuLinkdighlighted E\Tf;;m‘s

g Global

i..[@) Web templates Boxes

g Workflows Logon page

Main styles
Left menu

Master page
Membership top zone
Search box

My profile

Photogallery

Search page

Styleshesttext

LI, .leftMenu .CM5ListMenuHighlightedLI

5. Change color to #fff and replace the url part with #87CEFA. The entire style should read as follows:

-CMSListMenuLl a:hover, .CMSListMenuLinkHighlighted, .CMSListMenuLllast a:hover,

-CMSListMenuHighlightedLllast a, .CMSListMenuHighlightedLl a

{
color: #fff;
background: #87CEFA;
text-decoration: none;

This will change the background of the menu item to light blue and its font color to white when mouse
hovers above it.
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You've just learnt how modify CSS stylesheets to change design of your web site.

| My details |

[ r— MbotMe  Fomms | Photnsallery

Tags 8
‘ Saying goodbye Europe
airport  Austria bus cuisine u
Czech Republic France Germany
hitchhiking hostel - Paris, our final destination. Because there’s no upcoming hitchhiking
- trip, the tension between PJ and me is all gone. I have a friend here,
;::E’E“i'z"“"g;;in"‘:;'“:"‘ = 5o the last night we spend in his place, drinking wine and using his
e (2T (e 9 computer to look at pictures we’ve taken during our month in
ourism  traffic train > B

Today, P went to do some shopping and we've promised each
other go out have dinner tonight.

Recent posts
B B Posted: 7/5/2006 1:56:04 PM by Abigail Woodwarth | with 3 comments

» Saying goodbye Europe
* Wir sind Berliners

* Disappointment in Prague
» Sweetness of loneliness

* Sacher torte and Austrian
capital

Wir sind Berliners

- A after a long time the city we both wanted to see. And as we're
) Syndication almost dane with our trip, we're getting much more relaxed in
» RSS comparison with just week ago. We are almost able to joke with
each other again. We don't have much money left, thaugh, so we're
mostly hanging around, cansidering every Eura, spent far the gallery
ticket.
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4 Adding web parts

4.1  Adding text

In this chapter, you will learn how to add the new editable text region into your web site.

1. Go to CMS Desk -> Content -> About Me and switch to the Design tab. Click Add web partin
zoneRight.

- - N pers = . i Sign Out
CMS Desk Content |ty Desk || Tools | Admnistraton Switch to Site Manager  Site __PEr onal Site v | User: Global Administrator  Sigl

*+ 9 =
N% D?EIE C?Ey '% = | @ Edit Preview @ Live site E List

d'q Personal Site

k3 @'@

= Page Design | Form | Product | Properties Display web part content
@-[3 My Blog

§ About Me Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password.

== Forums

#-[=] Photo Gallery

] Special pages Current user: Global Administrator | My details | Sign out

= Images

Photo Gallery

~ [About Me - page template: Personal Site - About Me
¥ zoneleft ] * zoneRight (f\}

What can you find on my web About e

site? There isn't much stuff on it
so far, still wi
You might
Blon frnm =

Documents | Search
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2. Select Text/EditableText web part.

2 Portal engine - Web part selection -- Webpage Dialog
* Select web part

N
|1|L:] Listings and viewers —|| Editable text

&I Media

-J Membership B s AN e
|1|L:] Massaging x: E w‘-'-r;w Ll =

&) Navigation : i

(5 COINews e ey s o et ok s
& Newsletters

|:|L:] Palls

(-{J Reporting

- Text

-k Editable image

- pag‘?d text The Editable text web part displays an editable region that enabled
- Static HTML content editors to edit page content.

. i Static text
(- User contributions
&) Web services

e

I Ok H Cancel

hittp: fflocalhostkenticoCMS6/CMSDesk/PartalEngine SelectvwebPart, aspix ‘:g Local intranet

3. In the Web part properties dialog, enter the following information for the new web part.

e Editable region title: AboutWebPageTitle
e Content before: <h1>
e Content after: </h1>

Then click Ok.
4. Click Add web part again and select the same Text/EditableText web part.

5. In the Web part properties dialog, enter AboutWebPageText into the Editable region title textbox.
Then click Ok.

6. Now you have the new web parts ready and you can enter some new text. Switch to the Page tab
and click into the AboutWebPageTitle editable region. Enter About my web page. Click Save at the
top.
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7. Click into the AboutWebPage editable region and enter This is a short text about my web page.
Click Save again.

(@) eait
Page Design

@ Preview @ Live site

Form Product Properties

2]

pell check

E List

to see me. The trip to Prague is
one smooth tide. Butthe city
center is jammed with people
again. Why all tourists share the
nead nfwisitinn carme nlares at

E AboutWebPageTitle

Ei\hout myweb page

E AboutWebPageText

EThis is a shor text about my web page.

e®= Powered by
J :‘\ﬁf:ﬂco

|>

4]
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That is how you add a new editable region into your web site.

E—

‘What can you find on my web About Me
site? There isn't much stuff on it e
so far, still working on it. What you

might be interested in is my blog

from a trip around Europe that we

‘took with my friend PJ this About my web page
summer. Hope to upload more = This is 2 short text sbout my web page.
photos in near future.

This is the new About me text.

My latest blog posts

6/4/2008 | Along the coast of
Dragon to Montpellier

France, eventually. For a whils,
it seemed like we wouldn't be
able to make it. We spent more
than three hours waiting for a
ride at the Spanish — French
border in Pyrenees, The scenery
was cool, thaugh. Finally, an old
man in the rusty Seat took us
on board, &5 if unaware of his
vehicle condition, he drove like
nuts so that we sat in sience
with terror in our eyes, He
couldn’t speak English anyway.
However he took us all the way

+A Mentraliar

| My detais | Sign In

© 2009 Kentico Software



Adding web parts

4.2  Adding a poll

In this chapter, you will learn how to create a new poll and add it to your web page.

33

1. First of all we need to create a new poll. Go to CMS Desk -> Tools -> Polls and click New poll.

CMS Desk

Content | My Desk | Tools | Administration

[=)-Toals
...[E] BizForms © Polls
E....}&Booking system
ﬁ;. Content staging © vewpol
_g E-commerce
E....QFiIe import
.?.1 Farums
‘j MNewsletter
b Polls
.. [ Repaorting
i..[3 Web Analytics

2. Enter the following information for the new poll.

e Display name: My poll
e Code name: MyPoll
¢ Question: How do you like my pictures?

Then click Ok.
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3. Now we need to defined some questions for your new poll. In the poll properties, switch to Answers

tab and click New answer 5! Mew amswer  Into the Text text box, enter | love them!. Make sure that
the Enabled check box is checked and click Ok.

General | Answers | Security || Sites | View

ﬁ, New answer

Answers » MNew answer

% MNew answer

Text: | lave them!
Enabled:

4. Click New answer again and enter Not bad. as Text. The Enabled check box should be checked.
Then click Ok.

5. Click New answer again and enter Waste of time! into the text box provided. Click Ok.
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6. Now we are ready to add your new poll to web site. Go to CMS Desk -> Content -> Personal Site -
> Photo Gallery and switch to the Design tab. Click Add web part in zoneLeft.

CMS Desk Content || vy Do | ook | Admiisiation Suitch to Site Mansger  Site: [Personal Site v | User: Global Administrator  Sign Out
D a @ B ﬁ g Edit [G] Preview Live site List
New Delete, Copy Move Up Down @ @ E g
d'giersuﬂal S Page Design | Form Product Properties [¥] Display web part content g)
® _j My Blog
: About Me Sign in to CMS Desk. Sign in to CMS Site Manaqger. The default account is administrator with blank password. s |
== Forums
(+-[¥ Phota Gallery
@ Special pages Current user: Global Administrator | My details | Sign out
- Images
~ [Photo Gallery - page tempb;eg’emonal Site - List of galleries
¥ zoneleft (d} * zoneRight 7|
¥ LeftText op| ¥ HeaderText &7
About my photos List of galleries
Alright, let’s be clear on this. v DescrptionText o) find pictures I took in past few months. I'm planning to upload
. et
Limfagfiombenojalprotessonal | rr—| v
Documents | Search

7. In the Select web part dialog, select Polls\Poll web part.

& Portal engine - Web part selection -- Webpage Dialog

ﬁ Select web part
L
-{ZJ Events
(4] Forums
|:I'L:] Full-text search
-] General
|:I~LJ Google services
¢|~Lj Listings and viewers
&¢I Media
(i) Membership
¢|~Lj Messaging
(&) Navigation
&) News
¢|~Lj Newsletters
- Polls
@-{ZJ Reporting
@) Text
.11{3 User contributions

[ OK ] ’ Cancel

| £

Poll

Do you like our product?

s ez, | da.

' o, | dan't.

[ I don'tknow your praduct.

The Poll web part allows you to insert your own Poll an the page.

Ihttp:,l’,l’localhost,l’KenticoCMS6,!’CMSDeskJ'PortaIEngine,l’SeIectWebPart.aspx

‘-ﬁ Local intranet
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8. In the Web part properties dialog, make sure My poll is selected as Poll name and click Ok.

Congratulations, you've just learned how to add a new poll to your web site.

I soarcn

About my photos
Alright, let’s be clear on this.
I'm far from being 2 professional
photographer. Therefore, if youre
Inoking for mesmerizing pictures, I
advise you to search somewhere
else.
How do you like my pictures?
O1love them!
O Mot bad.

Waste of time!

My Blog

List of galleries

| My detais | Sign In

In these galleries, you can find pictures I took in past few months. I'm planning to upload

mare pictures in near future.

European Trip

Set of pictures, e taken on our hitchhiking trip around
Europe with my friend PJ. Additional pictures are to come.

Sweet Home Arizona

Nothing compares to smell of desert after moonson rain.
Nothing compares to sound of coyote howling at the Moon.
Nothing compares of blossoming saguaro.

Nothing compares f na.
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Further reading

This guide has provided you only with a short introduction to some of the aspects of the Kentico CMS.
For more detailed information about Kentico CMS please consult the following resources:

e Kentico CMS Tutorial
e Kentico CMS Developer's Guide
e Kentico DevNet at http://www.kentico.com/DevNet.aspx

Should you need any further assistance, please do not hesitate to contact us at http://www.kentico.

com/Support.aspx.
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