Web parts' visibility not applying to specified page types

Bryan Drenner asked on March 3, 2015 18:14

We're using a repeater for our blog's intro blurb. In its properties, in the "Visibility" section, "Show for page types" is set to "cms.blog;cms.blogmonth;cms.blogpost". It appears on the blog page, but not on the child cms.blogmonth or cms.blogpost pages, although those pages are inheriting the same template.

Correct Answer

Bryan Drenner answered on March 12, 2015 20:10

Resolved! I didn't realize that visibility could also be set at the web-part-zone level. The non-rendering web parts' web-part-zone had some funky visibility settings.

Michael Hennessey, a Kentico Support Engineer, helped me to resolve the problem.

0 votesVote for this answer Unmark Correct answer

Recent Answers


Bryan Drenner answered on March 3, 2015 18:16

I should also note that in the cms.blogmonth and cms.blogpost pages' Design view, the web parts do appear as expected. However, the web parts do not appear in Page view or on the published page.

0 votesVote for this answer Mark as a Correct answer

Brenden Kehren answered on March 3, 2015 18:37

Most likely you will need to set the path property to where your actual blog page is. You could hard code it like /Blog or use /{0}. This way it will always look at the /Blog page, whereas if you leave it blank, it will look at the current page and get that info. For instance /Blog/Feb 2015 which won't hold any of your "blog blurb" info.

0 votesVote for this answer Mark as a Correct answer

Bryan Drenner answered on March 3, 2015 19:40

The path property is already set to "/Blog". Also, the web part is configured to render "No data found" otherwise.

0 votesVote for this answer Mark as a Correct answer

Brenden Kehren answered on March 3, 2015 21:29

If you want it to display for all blog objects then I'd suggest removing the class names in the show for page types. Then it will be visible on all page types regardless just to verify it's not the issue.

Also make sure the "hide on sub pages" is unchecked in the visibility.

0 votesVote for this answer Mark as a Correct answer

Bryan Drenner answered on March 3, 2015 21:39

I cleared the "Show for page types" property. It still does not appear on blog months or posts. "Hide on subpages" remains unchecked.

0 votesVote for this answer Mark as a Correct answer

Chantale Laberge answered on March 4, 2015 01:46

To be sure you 're getting some data from it, turn on SQL debug, and check your generated SQL statement against your database. At least you'll know if your problem is data-wise or presentation-layer-wise !

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.