V7 to v8 SQL Script failure

Dan Morgan asked on May 28, 2014 14:31

During the automatic upgrade from v7 to v8, I get this error:Failed to run SQLscript: The DELETE statement conflicted with the REFERENCE constraint "FK_CMS_UIElement_ElementResourceID_CMS_Resource". The conflict occurred in database "db", table "dbo.CMS_UIElement", column 'ElementResourceID'. Any ideas? Thanks.

Recent Answers

Martin Danko answered on July 2, 2014 05:35

Hello Dan,

Just to be sure... did you try to perform the manual upgrade or automatic via KIM?

It seems that there is an inconsistence in the DB. Could you please check the CMS_UIElement table and search for any records that have the same ElementResourceID - duplicates? If possible, I would recommend to remove the duplicates form the DB and then try to repeat the operation.

Best regards, Martin

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.