Transfer-Encoding: chunked header returned on all pages after upgrade to Kentico 8.1

Christian Nickel asked on September 18, 2014 16:46

After upgrading our site from Kentico 7 to Kentico 8.1, we have noticed that all of our pages no longer provide the standard headers for Content-Length and Content-Encoding like so:

Content-Length: 9985
Content-Encoding:   gzip

Now they all return this Transfer-Encoding header:

Transfer-Encoding:  chunked

This happens regardless of the actual page size, if it is returned by any ASPX page on a Kentico 8.1 site it has this issue. I also tested this on a brand new installation and saw the Transfer-Encoding: chunked.

This isn't necessarily a bug, but I'm unsure of how to disable it. This causes problems with proxy servers as they can't handle chunked-encoded pages over a certain size.

How can I permanently disable this on all pages? I've made sure that the "Enable output compression" setting is disabled globally for all sites, I can only guess that it is set in a filter or handler somewhere.

Any ideas?

Recent Answers

Brenden Kehren answered on September 22, 2014 13:45

Are you using Portal or ASPX mode? You might check out this post

0 votesVote for this answer Mark as a Correct answer

Christian Nickel answered on September 23, 2014 17:48 (last edited on September 23, 2014 17:48)

We're using ASPX + Portal mode, unfortunately that post was not helpful. I did try creating an HTTPHandler but had no luck manually adding the Content-Length header.

The Transfer-Encoding: chunked header was causing problems with our IIS Proxy server once the page size grew to over 256K, which happens to be the default limit of cache buffer size on IIS when you use Application Request Routing. To fix this on the proxy we changed that buffer size to 1024K and our problem went away.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.