Stop the WYSIWYG editor navigating/following the links.

Lendon Sales asked on July 1, 2016 03:25

In kentico 7 when you clicked the hyperlink on the WYSIWYG editor nothing's gonna happened, but when double clicking it it allows you to edit the properties. My problem is I used kentico 8 and when you clicked the hyperlink on the WYSIWYG editor it follows/navigates to the new page or opens the file without having a prompt to save changes. This is really annoying because there is no way to get back, so you lose all the changes that were made since last saving.

I already set the Settings >> Content >> Content Management >> Prompt to save changes on exit to checked, but didn't work.

  • Thanks

Recent Answers

Jan Hermann answered on July 1, 2016 07:48

This is strange. It's working same way even with the new inline mode of the CK editor. However if you like the old way of rendering the WYSWIWYG, you can simply edit the \CMS\CMSWebParts\Text\editabletext.ascx.cs file and change the inline mode to false (line 85):

ucEditableText.UseInlineMode = false;

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.