Smart Search Filter Setup Question

Vic Carter asked on July 7, 2014 10:51

I have read the documentation and I appear to have set up the page correctly. I am using a smart search filter with the following values:

+Country;NZ;New Zealand

The search appears to be working, yet I am not actually getting filtered results. It is linked to a Smart Search Box, and the Smart search results web part is located on the same page. Is that syntax correct? I have re-indexed my search index and the fields in question have been set up in my document type. Any suggestions on how to debug this issue?


Correct Answer

Roman Koníček answered on July 12, 2014 22:51

Hi Vic,

The values in your search filter should be in following format Index field name;Value of the field;Displayed text -> this seems to be correct in your case. The field Country is set to be tokenized? Could you please also tell me what are the filter properties of your smart search filter web part? You can use "export webpart properties" functionality and copy & paste the desired section.

Best regards, Roman Konicek

0 votesVote for this answer Unmark Correct answer

Recent Answers

Vic Carter answered on July 14, 2014 15:53

Roman, as I continued to check my settings and compare to other examples I was able to get this working. At this point, I believe my initial issue was bad data. After some modification to the document type fields(wanted a particular display) and the addition of another filter, everything started to work as anticipated. Thank you for your response. I would recommend to anyone having similar issues to verify the fields you are using for the filter have the correct data and format. Also start simply and build complexity as you get each piece working.

Thank You

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.