Semicolons added to filepaths when uploading using wysiwyg editor (version 7.0.64)

Lewis Hankinson asked on August 17, 2015 12:23


I have an issue (and all users of the same instance of Kentico have the same issue) where, when uploading any type of file with the media uploader in the wysiwyg editor, semicolons are inserted into the filepath, therefore breaking the image, link, file, etc..

For example, uploading an image called test.jpg, the filepath was set as /getattachment/5d9bb43b-9437-4661-a11e-fbb233afa983/text.jpg;.aspx;;. I know to change this to get it to work, but it's a workaround, and it's the content editors that are struggling, of which we have a lot, many of whom have no knowledge of html.

Does anyone have any ideas why this is happening?

Many thanks, Lewis

Correct Answer

Roman Hutnyk answered on August 17, 2015 21:34

I'd recommend you checking Settings -> URl & SEO -> URL format section. It looks like there might be mess.

0 votesVote for this answer Unmark Correct answer

Recent Answers

Lewis Hankinson answered on August 18, 2015 11:13

Thanks Roman, that was issue, I didn't expect it to be a setting causing the issue.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.