Password Reset Link not containing hash

Jeff Steil asked on May 27, 2015 18:34

On a client site (v8.2) we are using the Logon Form web part to allow users to log in and also have checked the "allow forgotten password retrieval" to allow them to retrieve a forgotten password. This works fine when the new password is just sent to the email address of the user. However, I can't get it to work when "reset password requires email approval" is checked under settings > security > passwords.

The link to generate a new password is in the email but there isn't a "hash" parameter. The link to cancel the request is also in the email and it is correct, it has the hash parameter. I've looked at the email template for "Membership - Change password request" and it looks okay.

I'm not sure why this isn't working. Is there a setting or something else I need to add to get the hash parameter added to the link to generate a new password? I also tried this web part in the base Kentico v8 corporate site installation that I have running locally and it behaves the same way, the link is in the email without a hash parameter on it.

Any help would be appreciated, thanks.

Correct Answer

Juraj Komlosi answered on May 28, 2015 18:15

Hi Jeff,

I have tried the mentioned scenario in Kentico 8.2.21 and it works. Have you applied the latest hotfix? There was a bug in version 8.2.1 - "Macros - Reset password URL in forgotten password emails not resolved correctly."

If you enable setting "Reset password requires email approval", the reset password hash is automatically generated. So if the macro used for generating reset password url in e-mail template works (an it works after applying the 8.2.1 hotfix) the scenario you mentioned should work.

Hope it will help you.

1 votesVote for this answer Unmark Correct answer

Recent Answers

Jeff Steil answered on June 2, 2015 12:51

I just wanted to follow up on Juraj's answer and say that it was a bug in the version of Kentico we were using. After upgrading the site to 8.2.22 the password reset email works as expected. Thanks Juraj!

1 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.