Multilingual Not Working when switch culture.

Prashant Garg asked on June 11, 2015 10:58


We are working on Kentico 8.0 version and used GB and AU culture version. But when we clicked culture flag for switch culture, culture is not changing and page is redirecting to default culture.


Recent Answers

Bryan Soltis answered on June 11, 2015 15:22


Do you have a version of the page translated into the the selected culture? For any page of your content tree you want in multiple cultures, you have to create a version for each culture. If there isn't a translated page for the selected culture it will redirect tot he default site culture.

Using the default language version for untranslated pages You can configure websites to display content from the default language for pages that are not available in the selected language. In the Kentico administration interface, open the Settings application. Select the Content category. Choose your Site enable the Combine with default culture setting. Click Save.


1 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.