Multi Factor Authentication

Eric Garrison asked on January 6, 2015 23:49

Running 8.1

Has anyone been successful at using the 2 Factor Authentication for Membership side of the application. (Not the /Admin). I have the documentation and enabled it for a test user. Then install the Android app. Seems to be working find for the /Admin login.

I also want to enable this for USERS who are not Editors. There is a protected part of the website that needs 2FA. The member login webpart never ask for the 2nd factor. I actually cannot login at all with the account with the "Multi-factor authentication is required" turned on for a user. That account can only login to /Admin

Recent Answers


Brenden Kehren answered on January 7, 2015 01:05

Seems like you might be missing a setting for the user(s) or the global settings. Any settings you change are global, not site specific. I'd suggest making sure you have your settings right.

Settings>Security & Membership>Authentication and check Enable multi-factor authentication. Leave the "required" field unchecked otherwise it will require it for all users. Then go to a user you want to require MFA on and check the "Multi-factor authentication is required" box and save the user. Log out and try your MFA again.

There are no other settings you need to enable to require the webpart to use MFA, checking the box in Settings will do what you need. Good luck!

1 votesVote for this answer Mark as a Correct answer

Eric Garrison answered on January 7, 2015 03:51

Ok. Did work when I set on the Global setting, but also had to reset the app. Maybe something was cached.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.