Majority of applications missing after site import (Including pages)

Tom Barker asked on August 11, 2016 17:17


I've just exported and imported a site from a staging instance to a production instance and it all appears to have copied over and is working well on the frontend, however the vast majority of the applications are missing in the admin (Notably "Pages"!)

What do I have to do to enable them?

Thanks, Jack

Recent Answers

Trevor Fayas answered on August 11, 2016 17:23

First a couple of questions.

Did the exported site and imported site come from the same Kentico version? (most likely yes, but just checking).

Are you logged in as a global administrator privilege, in case it's a privilege issue?

Lastly, can you describe the steps you took during export and import, in terms of what you checked or didn't check?

0 votesVote for this answer Mark as a Correct answer

Rui Wang answered on August 11, 2016 17:38 (last edited on August 11, 2016 17:45)

Hi Tom

One common issue for export and import between 2 environments which may not started as the same copy of the site is the CMSHashStringSalt in the web.config. If it's not the same, a lot of things related to macro will not appear correctly. You can make sure the same value is in all the web.config among the different environments. Also, you can try to resign all macros after the import.

<add key="CMSHashStringSalt" value="1a6b510b-98f5-41ff-879f-5cbcaf774070"/>

One more thing to check is, are the site Code name the same? The apps might be missing for the site because they are not assign to the site. Go to Sites App > edit the site > Assign objects > Modules, and assign all modules to that site. Then do a hard refresh.

1 votesVote for this answer Mark as a Correct answer

Tom Barker answered on August 11, 2016 17:39

Hi Trevior,

Both instances are running the same version of Kentico (8.1), I am logged in as a Global Administrator and for the import and export I basically left all the default settings (First time)

Thanks, Jack

0 votesVote for this answer Mark as a Correct answer

Jan Hermann answered on August 12, 2016 08:27

Make sure, all the modules are assigned to the site (Sites -> your site -> Assigned objects -> Modules).

1 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.