Kentico hang while importing site

Mateusz Żebrowski asked on March 10, 2015 14:36

Kentico 7 issue.

I'm trying to import site from my "stage" environment. On this environment I don't have .cs files (everything is in dlls). I'm starting import and wait. Everything go well, but when It comes to importing object files kentico hang (I've even wait two hours but nothing happend).

On my web site I have custom web parts which I wish to import so I wonder if it is the main problem. Whole my programs are in dlls. Does Kentico convert them back to .cs files?

Correct Answer

Brenden Kehren answered on March 10, 2015 16:26

Kentico does not convert them to DLLs. The problem maybe that the site is trying to recompile since the new DLLs are added in the BIN directory and it just gets locked up. Try importing without the DLLs and just manually copy them over after the import.

1 votesVote for this answer Unmark Correct answer

Recent Answers

Alexander Kontsevoy answered on March 10, 2015 19:11

Hi Mateusz. I agreed with Brenden. And want to say more. You can get similar problem like as "Kentico hangs" when IIS application pool process out from memory. In this case app pool should be restarted by IIS. Kentico doesn't know nothing about this and still to wait answer from previous process. But IIS has new already. So, you can see that Kentico "hangs".

Try to check IIS app pool resources for your Kentico hosting, please.


1 votesVote for this answer Mark as a Correct answer

Mateusz Żebrowski answered on March 11, 2015 22:16

It seems that it works.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.