Kentico 8 - CMS Admin pages getting cached as well. How to disable that?

Phalgun Maddali asked on December 15, 2014 07:28


While setting up K8, I noticed that even the Admin pages are getting cached. In the settings -> system -> performance tab, I updated Client Cache settings from 60 to 0, and saved the changes successfully. When i refresh the page (ctrl-f5) I still see the old value of 60. In the CMS database, I can see the value CMSClientCacheMinutes set to 0. After some time I see the value in the CMS admin pages getting changed to 0 as well. So this is definitely a cache issue, but which Cache settings controls this? Ideally, I want the following behavior: - Admin pages should not be cached (the above should not happen) - output of pages, css, and resources should be cached in the server to reduce round trip to DB server - client's browser should see max-age=3600 for all resources - html, js and css.

Recent Answers

Brenden Kehren answered on December 15, 2014 16:52

Are you working in a web farm environment? I've not come across this before unless in a web farm environment. If you are concerned with a setting being cached, you can view all the items cached in Settings. You can also clear the cache in the Dashboard.

CTRL + F5 will only clear the browser cache, not the server cache. So if you continue to experience issues, you might clearing the server side cache as well.

0 votesVote for this answer Mark as a Correct answer

Phalgun Maddali answered on December 16, 2014 05:23

I see this issue happening in a non-web farm environment as well as in a web farm environment. Also, this is not just for settings - even page content, resource strings etc - I make a change, save it successfully, but the CMS still shows old content. The database shows the latest content. The CMS shows the updated content after some time. I have already disabled all cache settings in Settings -> Performance by setting them to 0, and yet this behavior persists. I know I can clear the server caching, the question is why is this stuff getting cached in the first place? This behavior shouldn't even be allowed! Struggling with this for a week now, very frustrating.

0 votesVote for this answer Mark as a Correct answer

Brenden Kehren answered on December 16, 2014 13:27

The behavior is allowed for performance reasons, it greatly increases performance.

Have you contacted Kentico support directly?

Have you ensured your web farm environment is setup correctly (within Kentico and outside Kentico)?

After you have made your cache setting changes have you restarted or cleared the cache on the server? (recommended, otherwise your site will use the existing settings until cache is cleared at the interval specified)

Unfortunately, there isn't an easy setting to differentiate the Admin interface with the Content interface for cache. You can however set cache in the settings to 0 and then in each web part or zone, set the cache settings individually. In my opinion, not very ideal but it could be done.

0 votesVote for this answer Mark as a Correct answer

Martin Danko answered on January 8, 2015 16:13

Hello Phalgun,

The problem here could be, as Brenden mentioned, with your web farm configuration which seems not to be setup properly.. or the synchronization doesn't work correctly for some reason.

Nothing in the Administration interface is cached, neither settings or content and there is definitely no reason why you should see a different value of settings when you refresh the page once the new value was saved... this would really make sense only with the web farm.

Best regards, Martin

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.