Kentico 8.2 Dashboard js errors

Pavan Josyula asked on February 10, 2015 04:40

Hi there,

I have upgraded Kentico 8.1 site to 8.2 successfully. But after the upgrade. I am getting JS error when I go to dashboard screen. Can you help me in resolving this

Uncaught ReferenceError: define is not defined angular.js:79 Uncaught Error: [$injector:modulerr] Failed to instantiate module undefined due to: Error: [ng:areq] Argument 'module' is not a function, got undefined http://errors.angularjs.org/1.2.20/ng/areq?p0=module&p1=not%20a%20function%2C%20got%20undefined at VALIDITY_STATE_PROPERTY (http://localhost/CMSScripts/Vendor/Angular/angular.js:79:20) at assertArg (http://localhost/CMSScripts/Vendor/Angular/angular.js:1483:19) at assertArgFn (http://localhost/CMSScripts/Vendor/Angular/angular.js:1493:9) at http://localhost/CMSScripts/Vendor/Angular/angular.js:3846:25 at Array.forEach (native) at forEach (http://localhost/CMSScripts/Vendor/Angular/angular.js:326:21) at loadModules (http://localhost/CMSScripts/Vendor/Angular/angular.js:3826:13) at createInjector (http://localhost/CMSScripts/Vendor/Angular/angular.js:3766:17) at doBootstrap (http://localhost/CMSScripts/Vendor/Angular/angular.js:1417:28) at Object.bootstrap (http://localhost/CMSScripts/Vendor/Angular/angular.js:1432:20) http://errors.angularjs.org/1.2.20/$injector/modulerr?p0=undefined&p1=Error…3A%2F%2Flocalhost%2FCMSScripts%2FVendor%2FAngular%2Fangular.js%3A1432%3A20)

Having same issue with Fresh installations of Kentico 8.2 site and default out of the box site template

Recent Answers


Pavan Josyula answered on February 10, 2015 05:08

I have also applied hotfix 8.2.4 no change. still cant make most of the admin site and cms desk to work.

0 votesVote for this answer Mark as a Correct answer

Brenden Kehren answered on February 10, 2015 13:43

Clear the cache on your server and on your browser(s).

1 votesVote for this answer Mark as a Correct answer

Brett Andrew answered on January 5, 2016 01:34

I applied 8.2.4 and it fixed the problem, but also remember to try running your usual browser in incognito mode, sometimes a page refresh doesn't force 2nd level scripts to refresh, incognito forces this every time!

Might save someone a few minutes trying to figure out why some browsers are working and your usual browser is not.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.