Kentico 8.2.33 After Enabling UI Personalization cms user can not login into CMS

ANKIT MISTRY asked on October 16, 2015 08:44

Hello,

I have recently moved to Kentico 8.2.33 from Kentico 6.0.34. I have many users in CMS with only few roles. In Kentico 6.0.34 in settings >> Security & Membership "Enable UI personalization" was checked. But after i upgraded to new Kentico 8.2.33 this option got unchecked. So i Checked that option in new kentico but after that my CMS users are getting "403 - Forbidden : Access is denied" and can not login.

Can any one please advise.

Thanks

Recent Answers


Juraj Ondrus answered on October 16, 2015 10:16

Hi,
Have you tried using the security debug to see what permission is missing? Are the users marked with Editor privilege level? What are the UI personalisation settings? Are appropriate modules selected in the tree and is the tree structure of the elements consistent?

0 votesVote for this answer Mark as a Correct answer

ANKIT MISTRY answered on October 16, 2015 11:00

Hello,

I can not do Security debug because i can only see "System objects", "Cache items" and "Worker threads" in Debug interface. Yes the user Privilege level is "Editor". When we were using Kentico 6.0.34 this user was only able to see "Orders" in E-commerece Tab and "Forms" in Tools tab. But after we upgraded to Kentico 8.2.33 this user is able to see many other sections also. So when i compare Kentico 8.2.33 and 6.0.34 settings the only difference i found is that in old kentico "Enable UI personalization" was checked but it is not checked in new kentico. So when i tried to check this option in new kentico. After that the user was not able to login into the CMS so again i unchecked that option.

For more information on this you can see my Ticket# 685856 which i have created in Kentico Support. In that i have attached screenshots also.

Can you please advise.

Thanks.

0 votesVote for this answer Mark as a Correct answer

Juraj Ondrus answered on October 16, 2015 11:19

Thank you!

Is the security debug enabled? At the bottom of the page I linked is described how to enable it:

"If you cannot see the security page, you have to enable the security debug first in Settings -> System -> Debug by selecting the option Enable security debug."

0 votesVote for this answer Mark as a Correct answer

ANKIT MISTRY answered on October 16, 2015 13:33

Hello,

I tried that and i can see Security tab in Debug interface. And i checked in that also and it was not showing any details.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.