K8, Gmail SMTP settings, not sending

Jakob Boyer-Dræby asked on May 5, 2014 07:24

Hi there Spend 2 hours struggling with SMTP on a localhost (virtual windows on a mac). I'd like to succeed in sending an email from Kentico, and have been working with SMTP settings, no luck. I've added a custom SMTP for my Corporate Site, and also tried default global settings.

This is what I have, that don't work: "Settings > System" No reply address, Error notification email, Send email notification email: All set to my custom domain, having my Gmail email (with my domain name) in all 3 fields.

"Settings > System > E-mails" Default SMTP server settings: SMTP server: smtp.gmail.com:465 SMTP user name: myemail@mydomain.com (gmail custom domain). SMTP Server password: My pass. Use SSL: True

I can go to Settings > Email, and do a Test-sending of an email. BUT BUT BUT, it never leaves the E-mail queue. Status keeps being "Sending", and no email is send.

What's wrong? I've Telnetted to smtp.gmail.com 465 from my localhost windows, and got the "clear clean screen" in my Telnet prompt. Supposed to mean that connection to Gmail works from my Windows.

Any help, appreciated. Rgds Jakob

Recent Answers

Jakob Boyer-Dræby answered on May 5, 2014 07:41

Allright, I made it work, I believe. I removed the Port spec for the server, so its just smtp.gmail.com. I tried this before, but guess some setting was mistaken.

So, above works, just don't specify the port (465) in server name. rgds


1 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.