Installing Kentico for 4.5.1

Tester Test asked on July 7, 2015 16:14

Hi! I'm trying to evaluate Kentico.

I read in the docs that for MVC development one should install for ".NET Framework 4.5/4.5.1". Now for me the Option Box ".NET Framework 4.5/4.5.1" is greyed out. I have .NET 4.5 and .NET 4.6 RC installed on my system. How can i unlock this for the installer?

Best regards Martin

Correct Answer

Virgil Carroll answered on July 7, 2015 17:59

Are you using 8.2? Check your hotfix level. There is a recent hotfix that addresses the issue of the 4.5.1 radio button being disabled due to 4.6 being installed.

Also be forewarned... .Net 4.6 is not yet fully supported. I just had to remove Visual Studio 2015 RC from my development machine because 4.6 was causing my Kentico install to take about 4 min to load a page on my localhost (I also had to manually uninstall 4.6 and its KB update as well)...not sure how much was totally 4.6 or something else, but once removed it worked fine.

0 votesVote for this answer Unmark Correct answer

Recent Answers

Tester Test answered on July 8, 2015 10:52

Thank you, Virgil. As i did not find any questions/posts about it i wasnt looking for hotfixes. ;) The recent hotfix enablee the installation. I will check how the Studio 15 works for me. Thx for the warning. Have a good day.

Best regards Martin

0 votesVote for this answer Mark as a Correct answer

Mohamed Rashed answered on July 22, 2015 14:42

I still facing same issue even after installing latest Hotfix (8.2.29)

also I uninstall VS 2015 RC and installed VS 2015 RTM & .NET 4.6 RTM

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.