I cannot login to site, because the "Use SSL for administration interface" option has been switched

Customer care manager

Juraj Ondrus asked on January 4, 2010 04:28

I cannot login to site, because the "Use SSL for administration interface" option has been switched on

Correct Answer

Juraj Ondrus answered on January 4, 2010 04:28

Sometimes it might happen that you accidentally switch on the option "Use SSL for administration interface" within Site Manager -> Settings -> (global) -> Security.

First option is generating SSL certificate and configure your IIS to use it. The easiest way is using SelfSSL certificate service, you can find more info about it using Google.

Another option is switching off this option manually in the database. Please open the database and in table CMS_SettingsKey find this record: CMSUseSSLForAdministrationInterface and in column KeyValue change the value to false. Now, you need to make some change in web.config file, e.g. add some space and save it. This will force the application to restart and after this everything should be like before.

0 votesVote for this answer Unmark Correct answer

   Please, sign in to be able to submit a new answer.