I’m getting „Maximum request length exceeded“ error message when uploading files into Kentico CMS

Customer care manager

Juraj Ondrus asked on July 28, 2009 08:14

I’m getting „Maximum request length exceeded“ error message when uploading files into Kentico CMS

Correct Answer

Juraj Ondrus answered on July 28, 2009 08:14

This exception is thrown because incoming request is greater than allowed maximum request length. By default Kentico CMS 4.0 allows to receive requests that are not greater than 10 MB. This value can be increased by specifying maxRequestLength parameter of <httpRuntime> section of the configuration file (web.config).

1. Open the web.config file in some editor.
2. Add the httpRuntime element in the system.web section as follows:

<httpRuntime executionTimeout="90" maxRequestLength="10000"/>


More detailed information about mentioned parameters can be found in Microsoft documentation.

0 votesVote for this answer Unmark Correct answer

   Please, sign in to be able to submit a new answer.