Encrypt password in Web config

Nadeem khan asked on July 31, 2014 11:25


I have enabled a Encrypted password in web.config file. But when I connect to CMS desk, it is giving me below error: The application could not connect to the database, please check the connection string in the web.config file and SQL server availability.

Could anyone please help me with this, why this is happening. And can anyone also let me know how to reslove this issue.


Recent Answers

Brenden Kehren answered on July 31, 2014 13:16

Check the server/computer event logs for more information. Most likely have issue with server, database, username or password being incorrect. Also try it without encryption and see if it works.

0 votesVote for this answer Mark as a Correct answer

Nadeem khan answered on July 31, 2014 13:45

I tried without encrypting it. It was working fine there. I checked the Event log in the DB. The message was.:- **[ExportWizard.ExportSettings]: Export settings has been lost. Stack Trace:atCMSModules_ImportExport_Controls_ExportWizard.get_ExportSettings()at CMSModules_ImportExport_Controls_ExportWizard.get_ExportManager() at CMSModules_ImportExport_Controls_ExportWizard.GetExportState(String argument).

Can you please let me know what Can I do to achieve this task.

0 votesVote for this answer Mark as a Correct answer

Martin Danko answered on August 1, 2014 09:50

Hello Nadeem,

Kentico CMS is standard ASP.NET application, so you should be able to use standard techniques supported by .NET Framework itself. For example Securing Connection Strings , Encrypt or Decrypt Connection Strings in web.config file using asp.net. or encrypt SQL connectionstring c#.

Best regards, Martin

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.