E-Mail Queue sending all email in a go

Michael Gralke Augusto asked on July 4, 2015 19:38


I was trying to throttle newsletter emails sending to 150 per hour and therefore set Settings > System > Emails > Batch Size to 150 and Scheduled Tasks > Send queued e-mails to Every 1 Hour, restarted the system, waited for the 1st hour but the system sends all emails in one go!

I tried several times, all the same, is there something I am missing here?

Please advise, many thanks,


Recent Answers

Roman Hutnyk answered on July 6, 2015 03:13


Batch size does not mean that system will send specified amount of emails per scheduled task run, it means that system takes specified amount of emails (150 in your case) from queue, processes them, takes another 150, until there are some emails in queue.

Sending emails is quite simple task, so I'd recommend you to implement your custom scheduled task and disable default one, as I'm not sure there is a setting that will allow you to specify the amount of emails to be sent out per task run.

Thanks, Roman

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.