Disable Metadata Inherit Values

Dave Nelson asked on July 28, 2016 16:40

It is very bad SEO to have multiple pages with the same Title, Description, and Keyword metadata.

How do I disable/uncheck the "inherit" box for ALL pages in my website and not end up with blank title tags?

I found another question with the same issue which has not had an acceptable answer: http://devnet.kentico.com/questions/do-not-inherit-metadata-title,-description,-keywords

Correct Answer

Jan Hermann answered on August 1, 2016 15:39

Yes, regrettably there is no setting for that and you need to do this in the code.

0 votesVote for this answer Unmark Correct answer

Recent Answers

emma zelewsky answered on July 28, 2016 19:26

You can set the page title dynamically with a macro to insert the desired name. That would prevent all pages from carrying the same title.

Go to Settings-->Content-->Metadata Then under Page title format you can set your macro. For instance, {%prefix%} - {%pagetitle_orelse_name%} The prefix would be what's set right below in the Page title prefix which could be the company name or something.

For documents, you can do something similar. Go to the parent folder or document, say, Articles and select Metadata from under the General tab. Uncheck Page title - Inherit, and add a macro like {%Headline%}. You can do the same for description with a macro like {%Summary%} or some other appropriate field from your page type.

Hope that helps!

0 votesVote for this answer Mark as a Correct answer

Dave Nelson answered on July 28, 2016 21:04

Emma, that does help and gave me a great way to make our search results page title unique. What I am looking for is a way to not have ANY pages on the website inherit Page Title, Description, or Keyword metadata, ever. As it stands we now have to make unchecking and deleting the text that is automatically inserted in the fields a part of our process.

0 votesVote for this answer Mark as a Correct answer

emma zelewsky answered on July 28, 2016 23:55

Dave, are you talking about when new documents are being created and they have Inherit page title, page description, etc. checked under the General-->Metadata tab? That seems to be default behavior, which makes sense only if you have a macro on the parent document or folder to dynamically generate the meta fields.

As for changing that particular behavior, I don't know of a setting or config to turn off the inheritance and my guess is that it's in the code behind. Wish I had a definitive answer for you. :(

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.