CKEditor Indent / Outdent not working.

Chris Isom asked on April 21, 2015 21:48

I cannot get the CKEditor's Indent and Outdent buttons to work in the ckeditor of CMS and I was hoping someone has ran into this.

The indent button is active when I first load the form view but as soon as I click in the text field it ghosts out and neither the Indent or outdent buttons are enabled. It is this way on a clean install of Kentico 8 as well as a site that has been upgraded.


Recent Answers

Brenden Kehren answered on April 23, 2015 22:06

When did you upgrade your site? If it was recently, I'd suggest clearing your browsers cache and restart the website or clear the website cache in Kentico. Do you know if any customizations were done to the CKEditor in your previous install?

0 votesVote for this answer Mark as a Correct answer

Martin Danko answered on May 1, 2015 16:25

Hello Chris,

What exact version of Kentico are you running? What browser are you using? Did you try it in another browser... Chrome, Firefox, IE? Please provide us with more details.

Regards, Martin

0 votesVote for this answer Mark as a Correct answer

Rui Wang answered on April 6, 2016 23:46 (last edited on April 6, 2016 23:47)

That is default behavior of CK Editor as you can see also on CKEditor's demo page:

The indent and outdent buttons are only enabled when you are using lists, which is also the reason why they are under one section next to each other. Please take a look at the following screenshot:

Image Text

which you can see, once you select a list, those two buttons become enabled.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.