CategoryList Webpart not displaying culture-specific categories

Web Master asked on February 22, 2016 19:26

We have a CategoryList webpart on the blog portion of our website. The control doesn't seem to filter out categories based on whether they are valid or not for that language culture (IE: pages created and categorized in that specific language culture). If you go to you will see multiple categories liste. However, if you click on "bagging" for instance you will see that it takes you to the display path but with no results. This is because no pages/blogs are categorized in this language culture (there are pages/blogs tagged in the en-US language culture however). How do I make the CategoryList webpart NOT display categories that dont' pertain to that language culture?

I've tried the following things already:

1) checking 'site' only: same results

2) checking 'global' only: gives me some of the default corporate ones but none of my won

3)'personal' only: no categories listed

I've also tried to change whether this was combined with default culture or not: no changes. I've also tried inserting a macro in for 'language culture' (rather than setting a specific culture) but this didn't make any difference either. Am I going about this correctly? Are categories specific to a language culture? If so, how are they filtered out for this webpart?

We are running 8.2 w/hotfix 48.


Correct Answer

Web Master answered on March 3, 2016 16:22

Just to update in case anyone else runs into this issue: The correct settings are as follows: Image Text

The big issue was the "Alias Path" which had been added previously and I, mistakenly, left it thinking that it was directing the location for the control.

Thanks to Jan Hermann @ Kentico Support for his assistance!

0 votesVote for this answer Unmark Correct answer

Recent Answers

Web Master answered on February 26, 2016 20:41

Does anyone have any ideas or is more information needed?

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.