Can't create blog

Martin Shin asked on August 4, 2015 13:39

Hi. I tried to create blog in my localhost site. When I fill required fields in blog and press "Save" button, I get next message:

The entered values cannot be saved. Please see the fields below for details.Blog name: Invalid input!

And I see error message in "Event log" Security check of the expression 'Rule("Value.Length <= 200", "200200falseinteger")|(user)administrator|(hash)6eac99b6489a57426eae1b3cb50f59286787d8d367879f8134b73d478c10334e' didn't pass. The expression was signed by user ''. Remove the signature and re-save the expression by a user with proper permissions.

Blog name is "Test blog". Why I can't save it?

I use Kentico 8.2.31

Correct Answer

Alexander Kontsevoy answered on August 4, 2015 15:02

1 votesVote for this answer Unmark Correct answer

Recent Answers

Martin Shin answered on August 4, 2015 15:24

Oh, yes! it works. Thank you, Alex!

Best regards, Martin

0 votesVote for this answer Mark as a Correct answer

Brenden Kehren answered on August 4, 2015 15:25

Check out the documentation on Macros and signatures.

Did you change the web.config key CMSHashStringSalt? If so, you'll need to resign your macros with the new key. The other option is to set the macro so it doesn't require a signature. In this case it looks like the easiest way to fix your issue is to resign all your macros.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.