Bizarre media relative URL issue / Media library images not showing in page type

Jon White asked on August 11, 2015 18:09

Hi everyone,

I have a page type with an editable HTML field and I have added some media from the media library (insert/edit image or media) in the 'form' tab.

The URL comes up fine i.e.:


This then renders fine within the form tab but anywhere else (such as live site) the URL gets changed to:


It's using a double slash at the beginning and this is breaking the link completely. I can add the full domain in front and create an absolute URL which works, it's just default relative path which is the issue.

I have lots of sites all working ok with this method, all global settings are the same across sites, AND I can use this method on a regular editable text page. It just seems to be strange on custom page types on this particular site.

Can anyone shed any light on this? I'm going crazy! I can't see any difference to any other site!

Thank you Jon

Correct Answer

Bryan Soltis answered on August 12, 2015 19:39

Hi Jon,

I was looking through our old support tickets and found a similar issue to the one your described. In that ticket, the culprit ended up being the Output filter settings for the site. (Admin / Settings / System / Output filter). In the tickets I found, the answer was to reset those settings to the default. Is it possible you have some settings set in this area of your site that are affecting how the site is functioning?

I also found an older article (v6/7) that discussing how to handle when ~'s don't resolve correctly, which may also be of help.

1 votesVote for this answer Unmark Correct answer

Recent Answers

Jon White answered on August 13, 2015 11:06

Thank you Bryan!

It was due to the output filter --> XHTML --> Excluded XHTML filter URLs..

This box was empty but supposed to have a forward slash (compared it to my other sites), once I put that in it worked!

I would've never ever have known or figured that out. ever. so thank you for your help.


0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.