AutomationDesignerService.svc/js - Bad Request

Kurt Schindler asked on May 21, 2015 19:46

I'm trying to work with the automation process designer as per but the design service is not working due to the following error:

GET http://mysite/CMSModules/Automation/Services/AutomationDesignerService.svc/js 400 (Bad Request)

This is on a Windows 2012 Server. I have enabled HTTP Activation under WCF Services, .NET Framework 4.5 features. (and in troubleshooting I have removed, and added back, this as well as ASP.NET)

I've enabled tracing and see the following message in the logs:

System.ServiceModel.ProtocolException: There is a problem with the XML that was received from the network. See inner exception for more details. ---> System.Xml.XmlException: The body of the message cannot be read because it is empty.

When I access http://mysite/CMSModules/Automation/Services/AutomationDesignerService.svc I successfully see the auto-generated service description. But the full url with /js at the end doesn't work.

I have this same website on another server and this service endpoint is working (it returns some javascript).

What else can I do to troubleshoot and investigate the cause of this issue?

Recent Answers

Bryan Soltis answered on May 22, 2015 15:53 (last edited on May 22, 2015 15:54)

Have you checked your file/folder permissions? Typically a 400 response is because the system cannot figure out what kind of request is being made to it. Another idea might be to ensure you have the runaAllManagedModulesForAllRequests option set in your web.confg.

< system.webServer > ... < modules runAllManagedModulesForAllRequests="true" >

This is the same setting needed for extensionless urls.

Extensionless urls

  • Bryan
0 votesVote for this answer Mark as a Correct answer

Kurt Schindler answered on May 22, 2015 17:49

Thank you for the reply, but this doesn't seem to be the issue. File permissions are good (the App pool has write access to the entire website directory) and whether runAllManagedModulesForAllRequests is true or false makes no difference.

I edited my question above w/ more detail.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.