Analytics for Kentico 5.5

Keirei Yanagi asked on March 10, 2015 04:31

Hi! :)

So the company I'm working for has a site developed in Kentico 5.5R2 and they requested that we activate the Web Analytics feature so that we'd be able to pull the most viewed page within their site but I can't seem to see the reports?

What I've done so far:

  • Activated Web Analytics for the website as instructed in the documentation (Site Manager > Settings > Web Analytics) -
  • Verified that Process Analytics Log is running under Site Manager > Administration > Scheduled Tasks (Global) - as per (I cannot seem to find Process Activities Log though. Do I need to set it up? If so, how?)

The analytics have been activated since Thursday but up until now, there's still no results (of any kind) logged within the database, nor do I see any reports within CMS Desk > Tools. I also checked this location (/App_Data/CMSModules/WebAnalytics/) and found no log files.

Kindly advise, thank you so much.

[EDIT] To clarify, the version of Kentico that I am using is v5.53996 R2, Professional edition.

Recent Answers

Martin Danko answered on March 11, 2015 03:57

Hello Kairey,

regrettably, versions 5.x are not supported anymore since Kentico 8 has been released.

For more details please read this article from CEO of Kentico: Announcing End of Support of pre-5.0 Versions

But I would recommend you to:

  1. Check the Event log if there are any errors
  2. Mare sure that the disk permissions are set correctly as it's described in the Dev Guide:

"Please note that the Web Analytics module requires that the Modify permission for the ~/app_data folder on your disk is granted to the ASP.NET account"

Regards, Martin

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.