Add Link - WYSIWYG Editor

Gavin Maxwell asked on June 19, 2014 06:30

Hello, I wonder if anyone can help me please?

In Kentico we have set up a number of roles. In each of these roles we have ticked all of the settings within CMS Desk => UI Personalisation => Editor.

The users in these roles can now see all of the buttons on the WYSIWYG toolbar. However, if they click onto 'Add Link' then they get a message "Your UI profile is not granted with permission to access this section. Please contact the administrator."

Does anyone know why this is, and how I can grant them permission to use this option?

Thank you, Gavin

Correct Answer

Gavin Maxwell answered on June 20, 2014 08:30

Just to update this - I've managed to resolve it now.

It was because everything was ticked under UI profile as far as the editor tab goes, however the Media Dialog entries against each role were not.

0 votesVote for this answer Unmark Correct answer

Recent Answers

Brenden Kehren answered on June 19, 2014 10:36

Even though they are assigned to the "CMS Editor" role, does their user profile have the "Is editor" checkbox checked?

0 votesVote for this answer Mark as a Correct answer

Gavin Maxwell answered on June 20, 2014 02:55

Hi Brenden, thank you for getting back to me.

These aren't actually assigned to the CMS Editor role, we actually have several roles set up. However, they all have the 'Is Editor' flag ticked.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.